Autor Tópico: Erro no apt-get upgrade  (Lida 26460 vezes)

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #30 Online: 30 de Outubro de 2013, 16:04 »
reinstalar para mim é a última, da última, da última opção.

Não duvido que se acabe nesta opção, mas ainda quando se tem a impressão que pode se resolver sem recorrer à lá windows, é melhor continuar tentando.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #31 Online: 30 de Outubro de 2013, 16:12 »
Tentando instalar eu tenho o seguinte erro:

anderson@anderson-OptiPlex-780:~$ sudo apt-get install google-chrome-stable
[sudo] password for anderson:
Sorry, try again.
[sudo] password for anderson:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os NOVOS pacotes a seguir serão instalados:
  google-chrome-stable
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 44,5 MB de arquivos.
Depois desta operação, 167 MB adicionais de espaço em disco serão usados.
Obter:1 http://dl.google.com/linux/chrome/deb/ stable/main google-chrome-stable amd64 30.0.1599.114-1 [44,5 MB]
Baixados 315 B em 0s (1.035 B/s)           
Falhou ao buscar http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
anderson@anderson-OptiPlex-780:~$
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #32 Online: 30 de Outubro de 2013, 16:22 »
Tentando instalar eu tenho o seguinte erro:

anderson@anderson-OptiPlex-780:~$ sudo apt-get install google-chrome-stable
[sudo] password for anderson:
Sorry, try again.
[sudo] password for anderson:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Os NOVOS pacotes a seguir serão instalados:
  google-chrome-stable
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 44,5 MB de arquivos.
Depois desta operação, 167 MB adicionais de espaço em disco serão usados.
Obter:1 http://dl.google.com/linux/chrome/deb/ stable/main google-chrome-stable amd64 30.0.1599.114-1 [44,5 MB]
Baixados 315 B em 0s (1.035 B/s)            
Falhou ao buscar http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
anderson@anderson-OptiPlex-780:~$


Qual é a versão do Ubuntu que você usa e se ela é 32bits ou 64 bits, ou melhor no terminal digite:

lsb_release -a


e cole aqui. Vi aí pelo nome do pacote que é amd64,então é 64bits a sua versão do Ubuntu, mas vamos começar bem do começo e devagar.

Você usa repositórios PPA?

Por favor, ajude-nos a te ajudar. Já te fiz algumas perguntas de você passa batido por elas ou até já executou, mas não informa aqui.

Ok vi que editou a mensagem anterior e colocou o que foi pedido por lá.
« Última modificação: 30 de Outubro de 2013, 16:30 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #33 Online: 30 de Outubro de 2013, 16:28 »
Eu tentei baixar o arquivo *.deb manualmente e diz que estou sem espaço disponível.

executando um: df -h

Sist. Arq.               Tam. Usado Disp. Uso% Montado em
/dev/sda1                221G   24G  186G  12% /
udev                     1,9G  4,0K  1,9G   1% /dev
tmpfs                    759M  940K  758M   1% /run
none                     5,0M     0  5,0M   0% /run/lock
none                     1,9G  212K  1,9G   1% /run/shm
/home/anderson/.Private  221G   24G  186G  12% /home/anderson
/dev/sdb                 3,7G  1,7G  2,1G  45% /media/ANDERSON


Muito estranho já que espaço tem de sobra aí.

Como ocorre esse erro de espaço, é no momento do download do pacote de forma manual ou no momento da instalação do pacote?
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #34 Online: 30 de Outubro de 2013, 16:29 »
A versão que utilizo é a 12.04 64 bits e a saída do console é esta:

LSB Version:   core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID:   Ubuntu
Description:   Ubuntu 12.04.3 LTS
Release:   12.04
Codename:   precise


(Sim utilizo os repositorios PPAs quando vou fazer alguma instalação via apt-get). Se eu estiver correto na resposta.



Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #35 Online: 30 de Outubro de 2013, 16:34 »
A versão que utilizo é a 12.04 64 bits e a saída do console é esta:

LSB Version:   core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID:   Ubuntu
Description:   Ubuntu 12.04.3 LTS
Release:   12.04
Codename:   precise


(Sim utilizo os repositorios PPAs quando vou fazer alguma instalação via apt-get). Se eu estiver correto na resposta.





Momentaneamente desabilita esses repositórios ppa. Sabe como fazer isso, certo? Caso não saiba é pelo Canais de software guia Outros programas pelo menu Editar da Central de programas. Depois feche tudo e pelo terminal digite:

sudo apt-get update

depois que terminar digite:

wget -c http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_amd64.deb

deve baixar na sua pasta de usuário, se o comando acima foi dado dentro dela, então digite:

sudo dpkg -i google-chrome-stable_30.0.1599.114-1_amd64.deb

se der erro tente assim:

sudo dpkg -i --force-all google-chrome-stable_30.0.1599.114-1_amd64.deb

veja se instala e funciona o navegador chrome.
« Última modificação: 30 de Outubro de 2013, 16:40 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #36 Online: 30 de Outubro de 2013, 16:46 »
Segue o resultado com o primeiro comando:

anderson@anderson-OptiPlex-780:~$ sudo dpkg -i google-chrome-stable_30.0.1599.114-1_amd64.deb
dpkg-deb: erro: 'google-chrome-stable_30.0.1599.114-1_amd64.deb' não é um formato de arquivo debian
dpkg: erro processando google-chrome-stable_30.0.1599.114-1_amd64.deb (--install):
 sub-processo dpkg-deb --control retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
 google-chrome-stable_30.0.1599.114-1_amd64.deb

Agora com o segundo comando:
anderson@anderson-OptiPlex-780:~$ sudo dpkg -i --force-all google-chrome-stable_30.0.1599.114-1_amd64.deb
dpkg-deb: erro: 'google-chrome-stable_30.0.1599.114-1_amd64.deb' não é um formato de arquivo debian
dpkg: erro processando google-chrome-stable_30.0.1599.114-1_amd64.deb (--install):
 sub-processo dpkg-deb --control retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
 google-chrome-stable_30.0.1599.114-1_amd64.deb

Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #37 Online: 30 de Outubro de 2013, 16:51 »
Tenta com o firefox:

wget -c http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb

wget -c http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-locale-en_25.0+build3-0ubuntu0.12.04.1_amd64.deb

wget -c http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-locale-pt_25.0+build3-0ubuntu0.12.04.1_amd64.deb

deve baixar na sua pasta de usuário, se o comando acima foi dado dentro dela, então digite:

sudo dpkg -i firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb

sudo dpkg -i firefox-locale-en_25.0+build3-0ubuntu0.12.04.1_amd64.deb

sudo dpkg -i firefox-locale-pt_25.0+build3-0ubuntu0.12.04.1_amd64.deb


se der erro tente com o parâmetro --force-all ok.

PS: se der o mesmo erro do chrome "não é um formato de arquivo debian", então seu sistema está muito "bichado" mesmo. Já que como podemos ver tanto um como outro são pacotes .deb, mas no caso do chrome podemos ainda pensar que o pacote .deb poderia ter sido feito fora dos padrões Debian, mas o firefox é direto dos repositórios do Ubuntu.

« Última modificação: 30 de Outubro de 2013, 16:55 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.172
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #38 Online: 30 de Outubro de 2013, 16:56 »
Coloca a saída deste comando:

Código: [Selecionar]
sudo netstat -ntlpu
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #39 Online: 30 de Outubro de 2013, 17:06 »
Se quiser tentar o google chrome outra vez usa este outro link aqui:

wget -c https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

sudo dpkg -i google-chrome-stable_current_amd64.deb

veja se dá o mesmo erro.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #40 Online: 30 de Outubro de 2013, 17:30 »
Tenta com o firefox:

wget -c http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb

wget -c http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-locale-en_25.0+build3-0ubuntu0.12.04.1_amd64.deb

wget -c http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-locale-pt_25.0+build3-0ubuntu0.12.04.1_amd64.deb

deve baixar na sua pasta de usuário, se o comando acima foi dado dentro dela, então digite:

sudo dpkg -i firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb

sudo dpkg -i firefox-locale-en_25.0+build3-0ubuntu0.12.04.1_amd64.deb

sudo dpkg -i firefox-locale-pt_25.0+build3-0ubuntu0.12.04.1_amd64.deb


se der erro tente com o parâmetro --force-all ok.

PS: se der o mesmo erro do chrome "não é um formato de arquivo debian", então seu sistema está muito "bichado" mesmo. Já que como podemos ver tanto um como outro são pacotes .deb, mas no caso do chrome podemos ainda pensar que o pacote .deb poderia ter sido feito fora dos padrões Debian, mas o firefox é direto dos repositórios do Ubuntu.



Não instalou ai eu habilitei o PPA e dei novament eum sudo apt-get udate && sudo apt-get upgrade e ele jogou o problema para agora para o LibreOffice. Acho que vou reinstalar assim que tiver tempo.

Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0