Autor Tópico: Erro no apt-get upgrade  (Lida 26277 vezes)

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Erro no apt-get upgrade
« Online: 30 de Outubro de 2013, 10:12 »
Pessoal estou tentando atualizar os pacotes via apt mas está dando erro. Quando executo o apt-get update não da erro, mas no apt-get upgrade é mostrado o erro a baixo:

anderson@anderson-OptiPlex-780:~$ sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes a seguir serão atualizados:
  apport apport-gtk compiz compiz-core compiz-gnome compiz-plugins-default firefox firefox-globalmenu firefox-locale-en firefox-locale-pt
  gir1.2-upowerglib-1.0 initramfs-tools initramfs-tools-bin libdecoration0 libmysqlclient18 libmysqlclient18:i386 libupower-glib1
  mysql-client mysql-client-5.5 mysql-client-core-5.5 mysql-common python-apport python-problem-report rhythmbox-ubuntuone upower
25 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 29,0 MB/44,2 MB de arquivos.
Depois desta operação, 1.453 kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
Obter:1 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main firefox amd64 25.0+build3-0ubuntu0.12.04.1 [29,0 MB]
Baixados 300 B em 0s (1.259 B/s)
Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
anderson@anderson-OptiPlex-780:~$
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Eliseu Carvalho

  • Visitante
Re: Erro no apt-get upgrade
« Resposta #1 Online: 30 de Outubro de 2013, 10:21 »
Esse pacote pode estar corrompido. Sugiro esperar e ver se sai uma correção.

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #2 Online: 30 de Outubro de 2013, 10:36 »
Esse pacote pode estar corrompido. Sugiro esperar e ver se sai uma correção.

Estava acontecendo no pacote do google-chrome-stable, ai eu removi e agora está dando nele. Acho que o problema está em outra coisa mas está refletindo nele.
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #3 Online: 30 de Outubro de 2013, 10:55 »
atualizei ontem o firefox e foi tudo normal.

Tenta limar o cache do apt-get e mudar o servidor do Brasil para o principal.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #4 Online: 30 de Outubro de 2013, 10:55 »
Como está a conexão com a sua internet, está normal?

Pergunto isso, porque o Firefox aqui no meu notebook foi atualizado ontem a noite e foi normal.

Além disso, acabei de fazer o download [9:56h, aqui na Bahia não tem horário de verão] do arquivo segundo o link postado por você e funcionou normalmente, ou seja, baixou o Firefox 25 normalmente...
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #5 Online: 30 de Outubro de 2013, 10:57 »
atualizei ontem o firefox e foi tudo normal.

Tenta limar o cache do apt-get e mudar o servidor do Brasil para o principal.

Como faz para mudar o cache do apt?
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #6 Online: 30 de Outubro de 2013, 11:01 »
[...]
Como faz para mudar o cache do apt?

No terminal:

Código: [Selecionar]
sudo apt-get clean ; sudo apt-get autoclean ; sudo apt-get autoremove ; sudo apt-get update ; sudo apt-get upgrade
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #7 Online: 30 de Outubro de 2013, 11:06 »
[...]
Como faz para mudar o cache do apt?

No terminal:

Código: [Selecionar]
sudo apt-get clean ; sudo apt-get autoclean ; sudo apt-get autoremove ; sudo apt-get update ; sudo apt-get upgrade

Faz tanto tempo que usei que não lembrava que funcionava para limpar o cache. Utilizei eles mas ainda não funcionou. Acho que tem alguma sujeira nos meus repositórios.
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #8 Online: 30 de Outubro de 2013, 11:15 »
para limpar o cache (arquivos .deb que ficam em /var/cache/apt/archives) só é preciso o comando:

sudo apt-get clean

ao que estava me referindo.

Agora alterar o servidor, graficamente você pode fazer assim, abre a central de programas e vá ao menu Editar > Canais de software e na guia Aplicativos Ubuntu onde tem Baixar de:, escolher servidor principal ao invés de Brasil.

Depois só sair da central de programas, abrir o terminal e digitar os comandos:

sudo apt-get update

sudo apt-get upgrade


e aceitar as possíveis atualizações existentes.


Caso continue com o mesmo problema, tenta isso:

sudo apt-get update --fix-missing

sudo apt-get upgrade
« Última modificação: 30 de Outubro de 2013, 11:21 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.172
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #9 Online: 30 de Outubro de 2013, 11:39 »
Tenta isto:
Código: [Selecionar]
sudo su -c "rm -r /var/lib/apt/lists/* && mkdir /var/lib/apt/lists/partial && apt-get update && apt-get upgrade"
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #10 Online: 30 de Outubro de 2013, 11:50 »
Tenta isto:
Código: [Selecionar]
sudo su -c "rm -r /var/lib/apt/lists/* && mkdir /var/lib/apt/lists/partial && apt-get update && apt-get upgrade"

não funcionou. :(
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #11 Online: 30 de Outubro de 2013, 11:53 »
Tente esse:

Código: ($) [Selecionar]
sudo rm -r /var/cache/apt/archives/*.deb ; sudo apt-get update ; sudo apt-get upgrade ; sudo apt-get dist-uprade

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #12 Online: 30 de Outubro de 2013, 12:01 »
Pode também usar esse comando:

Código: [Selecionar]
sudo rm /var/lib/apt/lists/* ; sudo rm /var/lib/apt/lists/partial/* ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt-get update ; sudo apt-get dist-upgrade : sudo apt-get clean ; sudo apt-get autoclean ; sudo apt-get autoremove
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.172
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #13 Online: 30 de Outubro de 2013, 12:26 »
não funcionou. :(

Seria interessante vc copiar/colar a saída dos comandos executados aqui. Pois esta sua resposta foi muita genérica. Não nos ajuda em nada.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #14 Online: 30 de Outubro de 2013, 14:18 »
A saída é sempre esta:

Obter:23 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-client-5.5 amd64 5.5.34-0ubuntu0.12.04.1 [8.318 kB]                 
Obter:24 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-client-core-5.5 amd64 5.5.34-0ubuntu0.12.04.1 [1.934 kB]           
Obter:25 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main upower amd64 0.9.15-3git1ubuntu0.1 [92,0 kB]                             
Obter:26 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main rhythmbox-ubuntuone all 4.2.0-0ubuntu0.0.1 [6.272 B]                     
Baixados 7.412 kB em 19s (382 kB/s)                                                                                                         
Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 25 não atualizados.
anderson@anderson-OptiPlex-780:~$
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0