Autor Tópico: Erro no apt-get upgrade  (Lida 26278 vezes)

Creto

  • Visitante
Re: Erro no apt-get upgrade
« Resposta #15 Online: 30 de Outubro de 2013, 14:28 »
Copia e cola esse comando no seu terminal, de enter + sua senha:
Código: [Selecionar]
sudo rm /var/lib/apt/lists/* ; sudo tm /var/lib/apt/lists/partial/* ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt-get autoclean
Espere terminar e feche o terminal (depois voltamos a ele)...

Procure o Synaptic se não o tiver será manualmente mesmo.

No Synaptic:
Configurações > Repositórios > na aba "Aplicativos ubuntu" em Baixar de: Mude de "Servidor Brasil para Servidor principal

Feche o Synaptic e abra novamente o terminal e:
Código: [Selecionar]
sudo apt-get update

Poste a saida completa se persistir erros
saida completa = canto superior esquerdo ao canto inferior direito do seu terminal, copiar de lá e colar aqui

T+

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #16 Online: 30 de Outubro de 2013, 14:34 »
A saída é sempre esta:

Obter:23 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-client-5.5 amd64 5.5.34-0ubuntu0.12.04.1 [8.318 kB]                
Obter:24 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main mysql-client-core-5.5 amd64 5.5.34-0ubuntu0.12.04.1 [1.934 kB]            
Obter:25 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main upower amd64 0.9.15-3git1ubuntu0.1 [92,0 kB]                              
Obter:26 http://br.archive.ubuntu.com/ubuntu/ precise-updates/main rhythmbox-ubuntuone all 4.2.0-0ubuntu0.0.1 [6.272 B]                      
Baixados 7.412 kB em 19s (382 kB/s)                                                                                                          
Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 25 não atualizados.
anderson@anderson-OptiPlex-780:~$


Uma pergunta você não executou os passos que havia falado antes, pois estou vendo que ainda está usando o servidor do Brasil.

Veja se em /var/cache/apt/archives/partial tem algum arquivo do firefox dentro dele. A pasta partial é uma pasta que contém o .deb que você ainda está baixando, mas ainda não baixou completamente. Não sei se o sudo apt-get clean limpa esta pasta também, então veja aí antes de tentar o resto, pois pode ser que o pacote parcial esteja com algum problema e o donwload tenta continuar ele ao invés de começar de zero outra vez.

A ultima dica que postei faz uso desta recomendação aqui:
Citar
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing
do erro informado.
« Última modificação: 30 de Outubro de 2013, 14:38 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #17 Online: 30 de Outubro de 2013, 14:46 »
Copia e cola esse comando no seu terminal, de enter + sua senha:
Código: [Selecionar]
sudo rm /var/lib/apt/lists/* ; sudo tm /var/lib/apt/lists/partial/* ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt-get autoclean
Espere terminar e feche o terminal (depois voltamos a ele)...

Procure o Synaptic se não o tiver será manualmente mesmo.

No Synaptic:
Configurações > Repositórios > na aba "Aplicativos ubuntu" em Baixar de: Mude de "Servidor Brasil para Servidor principal

Feche o Synaptic e abra novamente o terminal e:
Código: [Selecionar]
sudo apt-get update

Eu não acho que isto seja a melhor solução mas irei fazer por necessidade.

Grato!


Poste a saida completa se persistir erros
saida completa = canto superior esquerdo ao canto inferior direito do seu terminal, copiar de lá e colar aqui

T+
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #18 Online: 30 de Outubro de 2013, 14:54 »
Obtive o mesmo erro mudando o repositório:

Falhou ao buscar http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
anderson@anderson-OptiPlex-780:~$
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Eliseu Carvalho

  • Visitante
Re: Erro no apt-get upgrade
« Resposta #19 Online: 30 de Outubro de 2013, 14:55 »
Quem sabe vamos pelo caminho mais fácil de reinstalar o sistema e já instalar todas as atualizações também, incluindo o Firefox 25?

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #20 Online: 30 de Outubro de 2013, 14:57 »
Quem sabe vamos pelo caminho mais fácil de reinstalar o sistema e já instalar todas as atualizações também, incluindo o Firefox 25?


Impossível
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #21 Online: 30 de Outubro de 2013, 14:58 »
Obtive o mesmo erro mudando o repositório:

Falhou ao buscar http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
anderson@anderson-OptiPlex-780:~$


Ok não é problema com o repositório espelho.

Verificou se em

/var/cache/apt/archives/partial

não existe nada com firefox no nome e se em

/var/cache/apt/archives/

não existe nenhum pacote .deb com firefox no nome também?

Já tentou executar:

sudo apt-get update --fix-missing

qual é o resultado desse comando?
« Última modificação: 30 de Outubro de 2013, 15:00 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #22 Online: 30 de Outubro de 2013, 15:09 »
Obtive o mesmo erro mudando o repositório:

Falhou ao buscar http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_25.0+build3-0ubuntu0.12.04.1_amd64.deb  Tamanho incorreto
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?
anderson@anderson-OptiPlex-780:~$


Ok não é problema com o repositório espelho.

Verificou se em

/var/cache/apt/archives/partial

não existe nada com firefox no nome e se em

/var/cache/apt/archives/

não existe nenhum pacote .deb com firefox no nome também?

Já tentou executar:

sudo apt-get update --fix-missing

qual é o resultado desse comando?


Já sim, ele reponde com o mesmo erro, porém eu executei

sudo apt-get upgrade --fix-missing

Ele atualizou tudo menos o firefox, agora eu removi o repositório do firefox do meu ubuntu e sumiu o problema porém não consigo reeinstalar. Tanto o firefox quanto o chrome.
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #23 Online: 30 de Outubro de 2013, 15:11 »

Já sim, ele reponde com o mesmo erro, porém eu executei

sudo apt-get upgrade --fix-missing

Ele atualizou tudo menos o firefox, agora eu removi o repositório do firefox do meu ubuntu e sumiu o problema porém não consigo reeinstalar. Tanto o firefox quanto o chrome.


deixe os repositórios da forma que é para ser, o padrão, e execute mais esses dois comandos e veja o que é relatado:

sudo dpkg --configure -a

sudo apt-get install -f
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #24 Online: 30 de Outubro de 2013, 15:20 »
Um detalhe o comando que pedi, inicialmente, para você rodar foi:

sudo apt-get update --fix-missing

e não:

sudo apt-get upgrade --fix-missing
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #25 Online: 30 de Outubro de 2013, 15:22 »

Já sim, ele reponde com o mesmo erro, porém eu executei

sudo apt-get upgrade --fix-missing

Ele atualizou tudo menos o firefox, agora eu removi o repositório do firefox do meu ubuntu e sumiu o problema porém não consigo reeinstalar. Tanto o firefox quanto o chrome.


Estou utilizando o konkeror, removi ambos os repositórios quanto os programas para tentar instalar novamente, mas infelizmente não consigo mais instalar. Vou baixar o *.deb do chrome para ver se consigo instalar.

deixe os repositórios da forma que é para ser, o padrão, e execute mais esses dois comandos e veja o que é relatado:

sudo dpkg --configure -a

sudo apt-get install -f

Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #26 Online: 30 de Outubro de 2013, 15:25 »
Estou utilizando o konkeror, removi ambos os repositórios quanto os programas para tentar instalar novamente, mas infelizmente não consigo mais instalar. Vou baixar o *.deb do chrome para ver se consigo instalar.

deixe os repositórios da forma que é para ser, o padrão, e execute mais esses dois comandos e veja o que é relatado:

sudo dpkg --configure -a

sudo apt-get install -f



O último passo, caso nada desse certo, que ia sugerir seria baixar os .deb para instalação manual, mas somente no fim de tentar tudo.

Agora fico sem entender isso que você fala em retirar os repositórios dos navegadores, então você está usando ppa deles para instalar esses navegadores no seu Ubuntu e não, no caso do firefox, os repositórios padrões do Ubuntu?
« Última modificação: 30 de Outubro de 2013, 15:43 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline andersonbonavides

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #27 Online: 30 de Outubro de 2013, 15:48 »
Eu tentei baixar o arquivo *.deb manualmente e diz que estou sem espaço disponível.

executando um: df -h

Sist. Arq.               Tam. Usado Disp. Uso% Montado em
/dev/sda1                221G   24G  186G  12% /
udev                     1,9G  4,0K  1,9G   1% /dev
tmpfs                    759M  940K  758M   1% /run
none                     5,0M     0  5,0M   0% /run/lock
none                     1,9G  212K  1,9G   1% /run/shm
/home/anderson/.Private  221G   24G  186G  12% /home/anderson
/dev/sdb                 3,7G  1,7G  2,1G  45% /media/ANDERSON
« Última modificação: 30 de Outubro de 2013, 16:07 por andersonbonavides »
Ánderson Matos Bonavides      
Bacharel em Ciência da Computação
SCJP - Sun Certified Java Programmer 5.0

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Erro no apt-get upgrade
« Resposta #28 Online: 30 de Outubro de 2013, 15:53 »
Eu tentei baixar o arquivo *.deb manualmente e diz que estou sem espaço disponível.

qual é o resultado do comando:

df -BG

Como está particionado seu sistema a home é numa partição a parte da raiz?

Se você instalou coisas aí pelo apt-get então o cache tem arquivos .deb recentemente baixados.

sudo apt-get clean

limpa eles.
« Última modificação: 30 de Outubro de 2013, 15:54 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Eliseu Carvalho

  • Visitante
Re: Erro no apt-get upgrade
« Resposta #29 Online: 30 de Outubro de 2013, 15:53 »
Você disse que era "impossível" reinstalar o sistema, mas a essa altura, devido a isso:

sem espaço disponível.

essa é a melhor coisa a se fazer. Se tiver arquivos importantes aí, tenta fazer um backup em pen drives, SD, HD externo ou qualquer outra coisa que seja.
Ao meu ver, tentar corrigir isso aí é como querer costurar um travesseiro rasgado e esfiapado pelas garras de um leão. Pensa nisso.