Autor Tópico: (resolvido) Problema com placa wireless Broadcom Device 4727  (Lida 3863 vezes)

Offline antonio_ctba

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
(resolvido) Problema com placa wireless Broadcom Device 4727
« Online: 21 de Setembro de 2011, 20:56 »
Eu tenho um notebook Dell n4030, rodando Ubuntu 10.04 LTS  64 bits - Lucid Lynx..
Minha placa broadcom está instalada e conectando na rede Wi-Fi, porém em poucos segundos ela desconecta e fica procurando rede. Após um minuto tentando conectar, o icone da rede Wi-fi, na barra superior próximo ao relógio, simplesmente desaparece. Já tentei instalar o driver que o Ubuntu sugeri, tentei compilar o driver existente na página da broadcom e segui um tutorial para debian. Ambos sem surtir efeito.

sudo lshw -C network

*-network              
       description: Wireless interface
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       logical name: eth1
       version: 01
       serial: c0:cb:38:5b:7e:81
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl1 driverversion=5.60.48.36 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:fbb00000-fbb03fff
  *-network
       description: Ethernet interface
       product: AR8152 v2.0 Fast Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: eth0
       version: c1
       serial: f0:4d:a2:d6:bc:41
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=7.7.7.4 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:30 memory:fba00000-fba3ffff ioport:e000(size=128)

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11  Access Point: Not-Associated  
          Link Quality:5  Signal level:238  Noise level:163
          Rx invalid nwid:0  invalid crypt:4  invalid misc:0

ifconfig -a

eth0      Link encap:Ethernet  HWaddr f0:4d:a2:d6:bc:41  
          inet addr:7.7.7.4  Bcast:7.7.7.255  Mask:255.255.255.0
          inet6 addr: fe80::f24d:a2ff:fed6:bc41/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12538 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11002 errors:0 dropped:0 overruns:0 carrier:3
          collisions:0 txqueuelen:1000
          RX bytes:12187191 (12.1 MB)  TX bytes:2110687 (2.1 MB)
          Interrupt:30

eth1      Link encap:Ethernet  HWaddr c0:cb:38:5b:7e:81  
          inet6 addr: fe80::c2cb:38ff:fe5b:7e81/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17 errors:0 dropped:0 overruns:0 frame:4
          TX packets:3 errors:6 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5779 (5.7 KB)  TX bytes:407 (407.0 B)
          Interrupt:17

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:32365 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32365 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8924804 (8.9 MB)  TX bytes:8924804 (8.9 MB)

nm-tool

NetworkManager Tool

State: connected

- Device: eth1  [Auto Tonheira] ------------------------------------------------
  Type:              802.11 WiFi
  Driver:            wl
  State:             connected
  Default:           yes
  HW Address:        C0:CB:38:5B:7E:81

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *Tonheira:       Infra, 74:EA:3A:EC:D0:BC, Freq 2412 MHz, Rate 0 Mb/s, Strength 100 WPA WPA2
    dlink:           Infra, 00:1B:11:A3:B2:4E, Freq 2437 MHz, Rate 0 Mb/s, Strength 20 WPA WPA2

  IPv4 Settings:
    Address:         7.7.7.3
    Prefix:          24 (255.255.255.0)
    Gateway:         7.7.7.10

    DNS:             8.8.8.8
    DNS:             200.250.77.87


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unmanaged
  Default:           no
  HW Address:        F0:4D:A2:D6:BC:41

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on
« Última modificação: 23 de Setembro de 2011, 22:15 por antonio_ctba »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com placa wireless Broadcom Device 4727
« Resposta #1 Online: 22 de Setembro de 2011, 08:59 »
Olá antonio,

As informações que você passou não estão consistentes. Um dos comandos acusa que você está conectado por cabo, o outro informa que você está conectado via wireless. Outra coisa, quem configurou esse IP 7.7.7.x no seu roteador? Esse endereço não é de uso livre, isso pode te causar problemas de conexão, caso você tenha o azar de precisar acessar algum site dentro da rede 7.0.0.0/8.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline antonio_ctba

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Problema com placa wireless Broadcom Device 4727
« Resposta #2 Online: 22 de Setembro de 2011, 19:27 »
Segue novo relatório

sudo lshw -C network

  *-network               
       description: Wireless interface
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       logical name: eth1
       version: 01
       serial: c0:cb:38:5b:7e:81
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=5.60.48.36 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:fbb00000-fbb03fff
  *-network
       description: Ethernet interface
       product: AR8152 v2.0 Fast Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: eth0
       version: c1
       serial: f0:4d:a2:d6:bc:41
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI firmware=N/A ip=10.0.0.2 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:30 memory:fba00000-fba3ffff ioport:e000(size=128)

iwconfig

lo        no wireless extensions.

eth1      IEEE 802.11  Access Point: Not-Associated   
          Link Quality:5  Signal level:240  Noise level:164
          Rx invalid nwid:0  invalid crypt:17  invalid misc:0

eth0      no wireless extensions.

ifconfig -a

eth0      Link encap:Ethernet  HWaddr f0:4d:a2:d6:bc:41 
          inet addr:10.0.0.2  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f24d:a2ff:fed6:bc41/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:3276 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3889 errors:0 dropped:0 overruns:0 carrier:14
          collisions:0 txqueuelen:1000
          RX bytes:1836262 (1.8 MB)  TX bytes:504169 (504.1 KB)
          Interrupt:30

eth1      Link encap:Ethernet  HWaddr c0:cb:38:5b:7e:81 
          inet6 addr: fe80::c2cb:38ff:fe5b:7e81/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2382 errors:0 dropped:0 overruns:0 frame:164
          TX packets:2418 errors:920 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2046775 (2.0 MB)  TX bytes:475588 (475.5 KB)
          Interrupt:17

eth1:avahi Link encap:Ethernet  HWaddr c0:cb:38:5b:7e:81 
          inet addr:169.254.7.202  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:17

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12272 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12272 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2910755 (2.9 MB)  TX bytes:2910755 (2.9 MB)

nm-tool

NetworkManager Tool

State: connected


** (process:3117): WARNING **: error: failed to read connections from org.freedesktop.NetworkManagerUserSettings:
    The name org.freedesktop.NetworkManagerUserSettings was not provided by any .service files
- Device: eth1 -----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            wl
  State:             disconnected
  Default:           no
  HW Address:        C0:CB:38:5B:7E:81

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    Tonheira:        Infra, 74:EA:3A:EC:D0:BC, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
    dlink:           Infra, 00:1B:11:A3:B2:4E, Freq 2437 MHz, Rate 0 Mb/s, Strength 20 WPA WPA2


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unmanaged
  Default:           no
  HW Address:        F0:4D:A2:D6:BC:41

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com placa wireless Broadcom Device 4727
« Resposta #3 Online: 22 de Setembro de 2011, 23:35 »
Certo. Vejo que você está usando o driver proprietário da interface Broadcomm. Há vários colegas que fizeram o mesmo recentemente e tiveram problemas, em todos os casos eu recomendei instalar o pacote de firmware da Broadcomm e voltar ao driver nativo.

Pra isso, então, você vai se conectar à internet por cabo, e instalar o pacote "firmware-b43-installer".

sudo apt-get install firmware-b43-installer

Depois que esse pacote estiver instalado, você vai voltar ao gerenciador de drivers proprietários e vai remover o driver da placa de rede.

Quando fizer isso e reiniciar a máquina, a placa não vai mais carregar driver automaticamente; você vai confirmar que o driver nativo está funcionando carregando o driver manualmente:

sudo modprobe -v b43

Se nesse momento você conseguir conectar manualmente, é só editar o arquivo "/etc/modules" e adicionar uma linha com o nome do módulo (no caso, "b43") ao final do arquivo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline antonio_ctba

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Problema com placa wireless Broadcom Device 4727
« Resposta #4 Online: 23 de Setembro de 2011, 22:12 »
Consegui resolver o problema.
Segui os passos que você passou, porém ainda não tinha funcionado o wireless. Verifiquei os arquivos do /etc/modprobe e comentei uma linha do arquivo
broadcom-sta-common.conf..

#blacklist b43


tentei recarregar o módulo e não funcionou. Fiz uma nova busca no google usando o módulo b43 e encontrei esse link
 
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

Segui os passos 1 e 2. Instalei o pacote bcmwl-kernel-source :

sudo apt-get update
sudo apt-get install bcmwl-kernel-source


e reinstalei o driver proprietário através do menu System -> Administration -> Hardware Drivers.

Quando reiniciei o wireless voltou a funcionar.

Agradeço a ajuda...