Autor Tópico: (Resolvido) [wireless] Conecta ao roteador mas não à internet  (Lida 29456 vezes)

libonati

  • Visitante
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #30 Online: 29 de Agosto de 2010, 22:12 »
Nunca vi esse roteador na minha frente. Será que "Europe" só vai funcionar na Europa? ;D Vamos continuar. :)

passe os comandos como root

route add default gw 192.168.1.1 wlan0
ifconfig wlan0 down
ifconfig wlan0 192.168.1.6 netmask 255.255.255.0
ifconfig wlan0 up

Offline rodrigoma

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #31 Online: 29 de Agosto de 2010, 22:26 »
Vou passar aqui é já te dou a resposta

-=-=-=-=-=-

Depois de eu gastar minutos rindo de nervoso/raiva/felicidade/desapontamento, a internet conectou

AOSIHaoishAOISHaoishaOISHAoishAOISHaosihaOSIHaosihaOSIHOI *-*


E logo em seguida eu voltei a rir mas, agora, de tristeza.
A internet ficou 1 minuto conectada e caiu em seguida  :D
Quando tava conectada eu dei ifconfig e apareceu lá inet end.: 192.168.1.6 Bcast:192.168.1.255 Masc:255.255.255.0
Logo vi que tava tudo certo...
Aí a net caiu... desconectei e tentei conectar novamente.. aí volto ao antes... não conecta nem ao roteador.

Disparei as linhas novamente. Conectou novamente. Após 1minuto +- caiu.
Disparei ifconfig e o que apareceu foi o endereço de configuração do roteador inet end.: 192.168.1.3 Bcast:192.168.1.255 Masc:255.255.255.0
« Última modificação: 29 de Agosto de 2010, 22:43 por rodrigoma »

libonati

  • Visitante
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #32 Online: 29 de Agosto de 2010, 22:50 »
Vai no teu arquivo /etc/resolv,conf (sempre como o poderoso root) e deixa ele assim:

# Generated by NetworkManager
nameserver 8.8.8.8
nameserver 8.8.4.4


Faz uma cópia do teu arquivo antes de mexer.
Volta com os comandos e observa se cai.

Offline rodrigoma

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #33 Online: 29 de Agosto de 2010, 23:06 »
Eu fiz o bkp mas nem precisou.
dei sudo gedit /etc/resolv.conf fiz o bkp, claro. tirei a única linha que tinha depois do "# Generated ..." que era: nameserver 192.168.1.1
botei as que você pediu.
Conectou! \o/ yey... por menos de 1 minuto. ahhhhh =/
quando fui olhar o resolv.conf de novo, ele tava com quele ip novamente..
tipo que reescreveu o que eu reescrevi

libonati

  • Visitante
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #34 Online: 29 de Agosto de 2010, 23:19 »
Estou começando a acreditar que seu computador tem vontade própria ;D  O passo agora é você postar as 20 últimas linhas do comando dmesg, só as 20 últimas linhas e logo que a internet cair.  Antes me faça um favor. Aí na sua conexão de rede, bem na sua telinha, acima e a direita ao lado do auto-falante, você vai clicar com o direito do mouse /editar conexões / sem fio / adicionar / desmarque conectar automaticamente. De novo altere o arquivo /etc/resolv.conf e volte os comandos. Observe se cai e me dê um retorno.

Offline rodrigoma

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #35 Online: 29 de Agosto de 2010, 23:36 »
OK!
Eu não entendi se era pra disparar antes ou depois de conectar à internet.
Então fiz os dois

antes de conectar à internet
Citar
[  149.505779] FW Scan long time without stop, stop hw scan
[  149.506778] <-----------rtl8192se_check_hw_scan()
[  229.391977] ----------->rtl8192se_check_hw_scan()
[  229.391981] FW Scan long time without stop, stop hw scan
[  229.392982] <-----------rtl8192se_check_hw_scan()
[  329.249621] ----------->rtl8192se_check_hw_scan()
[  329.249625] FW Scan long time without stop, stop hw scan
[  329.250626] <-----------rtl8192se_check_hw_scan()
[  449.078844] ----------->rtl8192se_check_hw_scan()
[  449.078848] FW Scan long time without stop, stop hw scan
[  449.079848] <-----------rtl8192se_check_hw_scan()
[  568.908082] ----------->rtl8192se_check_hw_scan()
[  568.908086] FW Scan long time without stop, stop hw scan
[  568.909085] <-----------rtl8192se_check_hw_scan()
[  688.705833] ----------->rtl8192se_check_hw_scan()
[  688.705840] FW Scan long time without stop, stop hw scan
[  688.706845] <-----------rtl8192se_check_hw_scan()
[  808.475138] ----------->rtl8192se_check_hw_scan()
[  808.475141] FW Scan long time without stop, stop hw scan
[  808.476141] <-----------rtl8192se_check_hw_scan()

depois que a internet caiu
Citar
[ 1142.356045] ----------->rtl8192se_check_hw_scan()
[ 1142.356049] FW Scan long time without stop, stop hw scan
[ 1142.357050] <-----------rtl8192se_check_hw_scan()
[ 1142.357285] Linking with NETGEAR,channel:1, qos:1, myHT:0, networkHT:0, mode:6 cur_net.flags:0x40e
[ 1142.357298] Linking with NETGEAR,channel:1, qos:1, myHT:0, networkHT:0, mode:6 cur_net.flags:0x40e
[ 1142.357735] ===>rtllib_associate_procedure_wq(), chan:1
[ 1142.357739] HTSetConnectBwMode():pHTInfo->bCurBW40MHz:0
[ 1142.367708] rtllib_authentication_req():auth->algorithm is OPEN
[ 1142.370132] rtl8192_SetWirelessMode(), wireless_mode:4, bEnableHT = 0
[ 1142.373025] Associated successfully
[ 1142.373028] normal associate
[ 1142.373037] Using G rates:108
[ 1142.373040] Successfully associated, ht not enabled(0, 0)
[ 1142.374313] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1142.386264] alg name:TKIP
[ 1142.394919] alg name:TKIP
[ 1142.830460] DHCP pkt src port:68, dest port:67!!
[ 1153.152453] wlan0: no IPv6 routers present
[ 1167.820144] ----------->rtl8192se_check_hw_scan()
[ 1167.820148] FW Scan long time without stop, stop hw scan
[ 1167.821149] <-----------rtl8192se_check_hw_scan()

-=-=-=-=-

Lembrando que eu tive que disparar aqueles comandos para configurar o ip manualmente...
« Última modificação: 29 de Agosto de 2010, 23:38 por rodrigoma »

libonati

  • Visitante
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #36 Online: 29 de Agosto de 2010, 23:44 »
Ok amigo. Vamos dar um tempinho para descansar o corpo e a mente (são 23;42).
Amanhã continuaremos e estarei aqui cedo, des de a parte da manhã.
Assim que você conectar vamos tentar resolver esse abacaxi. Um abraço e boa noite. :o

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #37 Online: 30 de Agosto de 2010, 01:14 »
Cadê a rota?
Ela vai aparecer quando ele tiver um ip na interface. Esse "169.254.x.x." é um endereço "AVAHI", que é o equivalente do APIPA usado no Windows. Aparecem quando a interface está funcionando, configurada pra receber IP dinâmico, mas este IP não chega.

Citar
Será que um
route add defult gw <endereço ip do roteador> wlan0
não resolveria o problema?
Não, não resolve, pois ele precisa de um IP pra navegar. Só a rota não resolve.

ifconfig wlan0 192.168.1.6 netmask 255.255.255.0
Ah, agora sim: como eu disse, só a rota não resolve. ;)
« Última modificação: 30 de Agosto de 2010, 02:00 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #38 Online: 30 de Agosto de 2010, 02:11 »
Vou passar aqui é já te dou a resposta

-=-=-=-=-=-

Depois de eu gastar minutos rindo de nervoso/raiva/felicidade/desapontamento, a internet conectou

AOSIHaoishAOISHaoishaOISHAoishAOISHaosihaOSIHaosihaOSIHOI *-*


E logo em seguida eu voltei a rir mas, agora, de tristeza.
A internet ficou 1 minuto conectada e caiu em seguida  :D
Quando tava conectada eu dei ifconfig e apareceu lá inet end.: 192.168.1.6 Bcast:192.168.1.255 Masc:255.255.255.0
Logo vi que tava tudo certo...
Aí a net caiu... desconectei e tentei conectar novamente.. aí volto ao antes... não conecta nem ao roteador.

Disparei as linhas novamente. Conectou novamente. Após 1minuto +- caiu.
Disparei ifconfig e o que apareceu foi o endereço de configuração do roteador inet end.: 192.168.1.3 Bcast:192.168.1.255 Masc:255.255.255.0

rodrigoma, o teu problema é que você não está conseguindo pegar um IP com o roteador. Isso fica claro, quando você coloca o IP fixo e consegue navegar por algum tempo (até o wireless renovar a chave e tentar novamente pegar IP por dhcp).

A solução, por enquanto, é usar um IP fixo. Só que pra isso, você tem que ir ao Gerenciador de Redes (NetworkManager) e apagar a conexão "auto wlan0".

Depois, você deve configurar uma nova conexão (no próprio Gerenciador de Redes), passando o nome da rede (ou "SSID"), o tipo de criptografia e a senha. Há uma aba "Configuração de IPv4", onde você vai selecionar a opção "especificar um IP manualmente" (é essa mesmo? Me ajuda gente, eu uso Kubuntu e as janelas são diferentes), passando o IP que vc vai usar (192.168.1.6 tá bom), máscara (255.255.255.0), gateway (192.168.1.1) e servidores DNS (8.8.8.8, 8.8.4.4).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

libonati

  • Visitante
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #39 Online: 30 de Agosto de 2010, 07:38 »
Recebemos o reforço de um dos feras rodrigoma. Segue as orientações do zekkerj.
Minha conclusão também foi essa.
rodrigoma, o teu problema é que você não está conseguindo pegar um IP com o roteador. Isso fica claro, quando você coloca o IP fixo e consegue navegar por algum tempo (até o wireless renovar a chave e tentar novamente pegar IP por dhcp).
A solução, por enquanto, é usar um IP fixo. Só que pra isso, você tem que ir ao Gerenciador de Redes (NetworkManager) e apagar a conexão "auto wlan0".
Depois, você deve configurar uma nova conexão (no próprio Gerenciador de Redes), passando o nome da rede (ou "SSID"), o tipo de criptografia e a senha. Há uma aba "Configuração de IPv4", onde você vai selecionar a opção "especificar um IP manualmente" (é essa mesmo? Me ajuda gente, eu uso Kubuntu e as janelas são diferentes), passando o IP que vc vai usar (192.168.1.6 tá bom), máscara (255.255.255.0), gateway (192.168.1.1) e servidores DNS (8.8.8.8, 8.8.4.4).
Minha única dúvida era onde eu iria atuar para que o roteador não solicitasse mais a renovação de IP ou se deveria atuar no próprio roteador para aumentar o tempo de solicitação.
Há uma aba "Configuração de IPv4", onde você vai selecionar a opção "especificar um IP manualmente" (é essa mesmo? Me ajuda gente, eu uso Kubuntu e as janelas são diferentes)...
É assim mesmo amigo zekkerj.

(Encontrei uma página onde alguém diz ter encontrado uma solução baixando diretamente o driver da Realtek)




« Última modificação: 30 de Agosto de 2010, 08:27 por libonati »

Offline rodrigoma

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #40 Online: 31 de Agosto de 2010, 15:56 »
Depois de dar muitas risadas de nervoso e raiva, a rede wireless está funcionando perfeitamente.
Gostaria de agradecer a todo que me ajudaram.
Ao libonati, agradecimentos especiais por ter dedicado grande parte de seu tempo.
Ao zekkerj também agradeço de coração por tentar solucionar meu problema.
Apesar de sua dica, dekkerj, ser a que eu achava que seria a que resolveria o problema mesmo que local, não resolveu.

A dica do libonati do post que ele encontrou foi o que levou ao sucesso.
Instalando o driver da Realtek o problema foi solucionado na hora.
Eu ri demais xD
Eu tive que procurar outro formato.
O arquivo que eu baixei foi esse: rtl8192se-dkms_2.6.0015.0127.2010_all.deb
Versão diferente da que tem no site da Realtek, porém foi de primeira.

Obrigado a todos!
Não sei como que se faz, mas o tópico já pode ser fechado ^^v

libonati

  • Visitante
Re: [wireless] Conecta ao roteador mas não à internet
« Resposta #41 Online: 31 de Agosto de 2010, 16:14 »
Obrigado rodrigoma e não só o libonati, que aínda está aprendendo, mas também o zekkerj e todas as féras do fórum estarão aqui para ajudar a quem possa. Coloque por gentileza aquele famoso "Resolvido" na sua primeira postagem deste tópico para ajudar quem estiver com o mesmo problema. Abraços.