Autor Tópico: Activar placas de rede no Ubuntu  (Lida 20288 vezes)

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Activar placas de rede no Ubuntu
« Online: 09 de MAR?O de 2010, 15:38 »
Boas

Começo por dizer que não percebo nada de linux! No entanto um amigo convenceu-me a experimentar e eu lá tentei...

A situação é que eu queria experimentar o Ubuntu, mas tanto com o CD Live como instalado (versões de 32 e 64 bits) não activa nenhuma placa de rede (com ou sem fios). Já experimentei também o Mandriva One e o Caixa Mágica 14, e tanto um como outro ligam as placas de rede sem nenhum problema.

Em Sistema-> Administração-> Teste de Sistema-> Network Tests, aparece Marvell Technology Group Ltd. 88E8040T PCI-E Fast Ethernet Controller (rev 12) e Intel Corporation Wireless WiFi Link 5100.

Em Sistema-> Administração-> Ferramentas de Rede-> Dispositivos-> Dispositivos de Rede aparece Interface Loopback (lo) sem outra opção.

Em Sistema-> Preferências-> Ligações de Rede, não aparece nada.

O computador em questão é um Toshiba Satellite U400-17B (core2 duo 2,53Ghz - 4Gb RAM - 320 Gb disco - Ethernet Marvell Yukon - WiFi Intel Link 5100)

Qualquer ajuda seria bem vinda.

Obrigado

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Activar placas de rede no Ubuntu
« Resposta #1 Online: 09 de MAR?O de 2010, 16:13 »
Execute os comandos abaixo e copie-os para cá:

lspci

lsusb

ifconfig

sudo lshw -C network
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #2 Online: 09 de MAR?O de 2010, 17:40 »
Boas

Obrigado pela disponibilidade.

Então é assim, corri esses comandos e gravei. Voltei ao windows e abriu isto, não sei se terá algum erro...

xxx@xxx-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
07:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast Ethernet Controller (rev 12)
08:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
0a:01.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
0a:01.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
0a:01.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 04f2:b008 Chicony Electronics Co., Ltd USB 2.0 Camera
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ sudo lshw -C network
  *-network UNCLAIMED     
       description: Ethernet controller
       product: 88E8040T PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       version: 12
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b6000000-b6003fff ioport:2000(size=256)
  *-network UNCLAIMED
       description: Network controller
       product: Wireless WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b6100000-b6101fff
xxx@xxx-laptop:~$

Mais uma vez obrigado.

Offline igtukra

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #3 Online: 09 de MAR?O de 2010, 17:52 »
O lspci achou as duas placas, mas o ifconfig não.
Não sei bem, mas acho que dá pra configurar elas pelo ethtool e dar um "up" pelo ifconfig depois.
Dá uma olhada no manual do ethtool "man ethtool" no terminal.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Activar placas de rede no Ubuntu
« Resposta #4 Online: 09 de MAR?O de 2010, 18:20 »
A wireless é mole, é a mesma que eu uso no notebook.

sudo modprobe iwlagn

Mas a ethernet eu estou apanhando um pouquinho pra identificar o driver.

Achei alguns tópicos do fórum Ubuntu em inglês, que indicam que o módulo de sua placa seria o "sky2".
http://ubuntuforums.org/archive/index.php/t-934755.html

Mas o que vi de lá, me chamou a atenção: quem teve problema (aliás, com um note Toshiba Satellite U405), teve no Ubuntu 8.04. E você não disse qual versão está usando.

Executa então os comandos abaixo e cola o resultado aqui, por favor.

sudo modprobe iwlagn

sudo modprobe sky2

ifconfig

uname -a


Nota: se os dois primeiros não derem nenhuma saída, é normal. Qualquer saída que eles deem é sinal de erro.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #5 Online: 09 de MAR?O de 2010, 19:08 »
Boas

Estou a usar a versão 9.10. É a minha primeira incursão pelo Linux. Vamos ver se não desisto... ;D

O resultado é este:

xxx@xxx-laptop:~$ sudo modprobe iwlagn
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ sudo modprobe sky2
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ ifconfig
lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)
 
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ uname -a
Linux xxx-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux
xxx@xxx-laptop:~$

o que para mim é ainda parecido com chinês ::)

Obrigado

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Activar placas de rede no Ubuntu
« Resposta #6 Online: 09 de MAR?O de 2010, 19:17 »
Hmmm. Os módulos foram encontrados, mas mesmo assim as interfaces não foram criadas.

executa de novo o comando "sudo lshw -C network".

PS: Se a gente recomendasse instalar novamente o Ubuntu, vc ficaria muito chateado?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #7 Online: 09 de MAR?O de 2010, 19:23 »
Boas

Vou já executar esse comando e já volto...

Não fico chateado em instalar de novo, mas posso dizer que já instalei mais de 5 vezes e deu sempre igual. Já instalei o de 32 bits, o de 64 bits, as versões em CD e DVD e o Netbook remix, já instalei com e sem o cabo de rede ligado e com e sem o interruptor wireless ligado, e infelizmente o resultado é sempre o mesmo.

Até já...

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #8 Online: 09 de MAR?O de 2010, 19:40 »
Boas

Cá estou eu de novo...

o resultado foi este:

xxx@xxx-laptop:~$ sudo lshw -C network
[sudo] password for xxx: 
  *-network UNCLAIMED     
       description: Ethernet controller
       product: 88E8040T PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       version: 12
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b6000000-b6003fff ioport:2000(size=256)
  *-network UNCLAIMED
       description: Network controller
       product: Wireless WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b6100000-b6101fff
xxx@xxx-laptop:~$

Já agora qual será a versão mais adequada para um iniciante como eu, confesso que adorei o aspecto do Netbook Remix... ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Activar placas de rede no Ubuntu
« Resposta #9 Online: 09 de MAR?O de 2010, 20:28 »
"UNCLAIMED", ainda???  ???

Rapaz, que estranho. O módulo da wireless, pelo menos, tinha que subir...

Veja só a saída do mesmo comando em minha máquina:

Código: [Selecionar]
  *-network
       description: Wireless interface
       product:[b] Wireless WiFi Link 5100[/b]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       logical name: wmaster0
       version: 00
       serial: 00:22:fb:c2:18:c8
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes [b]driver=iwlagn[/b] ip=192.168.0.252 latency=0 multicast=yes wireless=IEEE 802.11abgn
       resources: irq:29 memory:f69fe000-f69fffff
  *-network
       description: Ethernet interface
       product: NetXtreme BCM5761e Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 10
       serial: 00:22:19:fe:7e:ec
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.99 firmware=5761e-v3.60 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:30 memory:f68e0000-f68effff memory:f68f0000-f68fffff

Mesmo não configuradas, elas tinham que aparecer com o driver carregado. A menos... a menos que algo esteja impedindo a carga dos módulos.
Vamos analisar por esse caminho então.

lsmod | egrep "iwlagn|sky2"

sudo modprobe -r iwlagn
sudo modprobe -v iwlagn
dmesg | tail -n 20
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #10 Online: 09 de MAR?O de 2010, 20:52 »
Boas

Os resultados são os seguintes:

xxx@xxx-laptop:~$ lsmod | egrep "iwlagn|sky2"
iwlagn                109052  0 
iwlcore               112508  1 iwlagn
mac80211              181236  2 iwlagn,iwlcore
cfg80211               93052  3 iwlagn,iwlcore,mac80211
sky2                   46560  0 
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ sudo modprobe -r iwlagn
[sudo] password for xxx: 
xxx@xxx-laptop:~$

xxx@xxx-laptop:~$ sudo modprobe -v iwlagn
insmod /lib/modules/2.6.31-14-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.31-14-generic/kernel/net/mac80211/mac80211.ko 
insmod /lib/modules/2.6.31-14-generic/kernel/drivers/net/wireless/iwlwifi/iwlcore.ko 
insmod /lib/modules/2.6.31-14-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko 
xxx@xxx-laptop:~$ 

xxx@xxx-laptop:~$ dmesg | tail -n 20
[  324.547788] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.562950] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.578113] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.593300] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.608451] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.623606] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.638759] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.653914] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.669074] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.684242] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.699405] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.714576] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.729739] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.744904] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.760059] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.775233] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.790426] iwlagn 0000:08:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x0000100C
[  324.801642] iwlagn 0000:08:00.0: Failed to init APMG
[  324.801659] iwlagn 0000:08:00.0: PCI INT A disabled
[  324.802178] iwlagn: probe of 0000:08:00.0 failed with error -110
xxx@xxx-laptop:~$


Agora por ver isto, lembro-me que quando começavam todas as instalações que fiz até agora aparecia sempre uma grande listagem de linhas com algo desse género ...MAC is in deep sleep!...

Obrigado pela ajuda

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Activar placas de rede no Ubuntu
« Resposta #11 Online: 09 de MAR?O de 2010, 21:45 »
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/463316

Tente essa solução sugerida nesse bug report.

Citar
Hi!
Can you try this solution:

Add pci=use_crs at the end of the line

linux /boot/vmlinuz-2.6.31-19-generic root=UUID=8a7ca0ae-ec6e-4df9-9661-edccf300d223 ro quiet splash

in the file /boot/grub/grub.cfg and reboot
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #12 Online: 09 de MAR?O de 2010, 21:59 »
Boas

Muito obrigado pela atenção, mas acho que isso já é demasiado para um principiante como eu...

Acho que por enquanto vou desistir do Ubuntu e aguardar por alguma versão sem esse bug.

Definitivamente o Linux ainda não está preparado para uma utilização em massa... quem sabe um dia!

Obrigado por tudo!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Activar placas de rede no Ubuntu
« Resposta #13 Online: 09 de MAR?O de 2010, 22:30 »
Ou você pode pegar um notebook que não tenha a BIOS bugada, da próxima vez. É o que está causando o problema.

(Nota mental: não comprar notebooks Toshiba enquanto essa BIOS não for corrigida)
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline XPT

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Activar placas de rede no Ubuntu
« Resposta #14 Online: 09 de MAR?O de 2010, 23:27 »
Ou você pode pegar um notebook que não tenha a BIOS bugada, da próxima vez. É o que está causando o problema.

(Nota mental: não comprar notebooks Toshiba enquanto essa BIOS não for corrigida)

Boas

Não me parece que o BUG seja da BIOS, mas sim do Ubuntu 9.10, durante o dia de hoje instalei o Mandriva 2010 e o Caixa Mágica 14, e detectaram as placas de rede sem nenhum problema. Pena o Ubuntu ter esse problema, gostei muito do Netbook Remix.

Falta mais ou menos 1 mês para sair uma nova versão, vamos ver se já vem com esse bug corrigido e depois tento de novo.

Só para informar que no Toshiba L40 da minha filha o CD Live do Ubuntu activou as placas de rede sem problema nenhum.

Abraço e obrigado pela disponibilidade.