Autor Tópico: Downgrade do amarok 2 para o amarok 1.4  (Lida 12119 vezes)

Offline maneiresco

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
    • Meu perfil completo
Downgrade do amarok 2 para o amarok 1.4
« Online: 30 de Abril de 2009, 14:10 »
Não sei vocês, mas eu após atualizar meu Ubuntu para o 9.04 fiquei decepcionado com o novo amarok 2. Estava cheio de espectativa de que seria melhor (o amarok), mas ao abrir vi que minhas listas haviam sumido assim como varias outras funcionalidades!

A intenção foi boa, mas eu prefiro ficar com o amarok 1.4, e tendo em vista que não sou o único a pensar assim criei esse tópico para ajduar os que também querem fazer um downgrade para o 1.4:

__________
Primeiro desinstale o amarok atual (amarok 2)
Código: [Selecionar]
sudo aptitude purge amarok
Agora baixe os pacotes que disponibilizei em meu servidor do plus10.com.br:
!Importante: Instale na ordem apresentada abaixo por causa de dependências.
amarok-engine-xine_1.4.10-0ubuntu3_i386.deb
libgpod3_0.6.0-5ubuntu2_i386.deb
amarok-common_1.4.10-0ubuntu3_all.deb
amarok_1.4.10-0ubuntu3_i386.deb


Agora para garantir que o amarok que você instalou fique protegido contra atualizações, apenas digite o comando:
Código: [Selecionar]
sudo aptitude hold amarok
:D simples assim! :D

Boa sorte!
« Última modificação: 30 de Abril de 2009, 14:22 por maneiresco »
___________
Twitter: @mauricionero
Perfil: http://mauricionero.com/

Offline Becker

  • Usuário Ubuntu
  • *
  • Mensagens: 309
  • Por tanto tempo quanto dura a eternidade
    • Ver perfil
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #1 Online: 30 de Abril de 2009, 20:45 »
Legal , instalei e tá funcionando bem.
Recomendo.
Seria recomendável, também salvar os arquivos numa pasta, e colar as dicas num editor de texto e salvar, para posterior instalação em até outro micro, para saber a ordem certa da instalação.

Obrigado!
Valeu!

Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #2 Online: 01 de Maio de 2009, 18:37 »
Vim nessa seção do fórum pra postar algo assim. e vc alem de postar resolveu o que eu queria....
E como compartilho da mesma opinião sobre o amarok 2 irei baixar e testar.. se tudo for OK aviso aqui.

Podia ter em algum repositorio né?


Obrigado pela dica...
Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando

Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #3 Online: 01 de Maio de 2009, 19:39 »
Segui os passos na ordem mas o pacote amarok-common tá pedindo pra instalar um pacote chamado ruby, e as dependencias ficam qubradas...
Aconteceu com vcs tambem?

Citar
orlando@orlando-desktop:~/Downloads$ sudo dpkg -i amarok-engine-xine_1.4.10-0ubuntu3_i386.deb
Selecionando pacote previamente não selecionado amarok-engine-xine.
(Lendo banco de dados ... 121074 arquivos e diretórios atualmente instalados).
Desempacotando amarok-engine-xine (de amarok-engine-xine_1.4.10-0ubuntu3_i386.deb) ...
Configurando amarok-engine-xine (2:1.4.10-0ubuntu3) ...
orlando@orlando-desktop:~/Downloads$ sudo dpkg -i libgpod3_0.6.0-5ubuntu2_i386.deb
Selecionando pacote previamente não selecionado libgpod3.
(Lendo banco de dados ... 121082 arquivos e diretórios atualmente instalados).
Desempacotando libgpod3 (de libgpod3_0.6.0-5ubuntu2_i386.deb) ...
Configurando libgpod3 (0.6.0-5ubuntu2) ...

Processando gatilhos para libc6 ...
ldconfig deferred processing now taking place
orlando@orlando-desktop:~/Downloads$ sudo dpkg -i amarok-common_1.4.10-0ubuntu3_all.deb
Selecionando pacote previamente não selecionado amarok-common.
(Lendo banco de dados ... 121091 arquivos e diretórios atualmente instalados).
Desempacotando amarok-common (de amarok-common_1.4.10-0ubuntu3_all.deb) ...
dpkg: problemas de dependência impedem a configuração de amarok-common:
 amarok-common depende de ruby; porém:
  Pacote ruby não está instalado.
dpkg: erro processando amarok-common (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 amarok-common
orlando@orlando-desktop:~/Downloads$
Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando

Offline maneiresco

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
    • Meu perfil completo
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #4 Online: 04 de Maio de 2009, 15:43 »
O Ruby é uma dependencia, estranho ele não ter instalado automaticamente. Em todo caso instale o Ruby assim:

Código: [Selecionar]
sudo apt-get install ruby
sudo apt-get install ruby1.8

As dependencias do Ruby certamente serão satisfeitas assim que instalar. Caso não seja poste aqui novamente que daremos um jeito!
___________
Twitter: @mauricionero
Perfil: http://mauricionero.com/

Offline DimeDesign

  • Usuário Ubuntu
  • *
  • Mensagens: 43
  • Ubuntusaurus Iniciantis
    • Ver perfil
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #5 Online: 08 de Maio de 2009, 11:24 »
Sem chance para o Amarok 2
Confuso, lento e muito inferior ao 1.4
A primeira coisa que faço é remover o 2 e instalar o 1.4 que por enquanto é imbatível, uso Gnome e não tem nenhum player a altura do Amarok 1.4 para Gnome (nem o Exaile) infelizmente.

Outra coisa que logo mudo é o pulse -audio para Alsa, infelizmente este pulse é uma droga e tem muita gente tendo dificuldades com o pulse-áudio, inclusive com outras distribuições que andei vendo em outros foruns. Eu mesmo testei o LiveCD do Mandriva 2009.1 One e o som não funcionou no pulse, tive que mudar para Alsa.

Espero que resolvam esses problemas para lançamentos futuros.

Fui....

- Tentando evoluir para Ubuntusaurus Rex -
Semprom 3000+ ECS 741 - 1.5 gb - Barracuda 80 gb -X1650pro 512mb/128bits - - DVD LG - SBLive+ - LCD 17".

Offline felipe.cintra

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #6 Online: 11 de Junho de 2009, 14:21 »
excelente post..

recentemente passei a utilizar o gnome e como alternativa ao amarok testei o rythmbox..
ele é tao bom quanto o amarok (1.4.x) porque é bem funcional mas o problema que tive foi quanto a listagem das musicas
eu particularmente coloco tudo em uma única playlist e uso os mecanismos de busca para achar a musica que quero
o rythmbox consumia muito do processador principalmente se utilizasse a barra de rolagem e se estivessem abertos alguns programas
que geralmente utilizo, como leitores pdf, uma ide, e firefox .. o resultado era o caos..
as musicas davam umas "engasgadas"

instalei o amarok2 .. veio com muita coisa que para as minha utilizacao é desnecessária entao instalei o amarok 1.4.10
atraves do sourcelist do intrepid (eu estou utilizando o jaunty)

o ganho de performance no momento de concorrencia é notavel

parabens pelo post cara ...

forte abraco

Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #7 Online: 13 de Junho de 2009, 18:12 »
Puxa vida porque será que essas cosas só acontecem comigo!!!  ??? ??? ???

Agora na instalação está aparecendo esse erro:

Citar
orlando@orlando-desktop:~/Downloads/Amarok1.4$ sudo dpkg -i amarok_1.4.10-0ubuntu3_i386.deb
Selecionando pacote previamente não selecionado amarok.
(Lendo banco de dados ... 158116 arquivos e diretórios atualmente instalados).
Desempacotando amarok (de amarok_1.4.10-0ubuntu3_i386.deb) ...
dpkg: problemas de dependência impedem a configuração de amarok:
 amarok depende de libifp4; porém:
  Pacote libifp4 não está instalado.
 amarok depende de libnjb5; porém:
  Pacote libnjb5 não está instalado.
dpkg: erro processando amarok (--install):
 problemas de dependência - deixando desconfigurado
Processando gatilhos para man-db ...
Processando gatilhos para menu ...
Erros foram encontrados durante o processamento de:
 amarok
orlando@orlando-desktop:~/Downloads/Amarok1.4$

Os outros instalam normalmente...Há algum pacote q eu esqueci de desinstalar?


Editando =====>> Consegui instalar, fui no sinaptic e desinstalei tudo referente ao amarok por lá.. e depois instalei seguindo os passou e funcionou, até q enfim vou ter meu player preferido com todas as sua funcionalidades.
« Última modificação: 13 de Junho de 2009, 18:34 por MadOrL »
Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando

Offline GuiH

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #8 Online: 15 de Junho de 2009, 22:08 »
Simplesmente, não dá para acreditar que tanta gente tenha desprezado a evolução do Amarok (que é sem dúvidas um dos melhores audio players do mundo). A versão 2.1 está muito melhor, embora possa ter descuidado em algum detalhe que vc gosta.
Amarok 1.4 é muito antigo. Eu hein, distro nenhuma merece continuar com apps tão obsoletas.
Só te lembrando, já basta a teimosia dos fabricantes em colocar o openoffice 2.x ao invés do 3.0 (o o 3.0 já está antigo também)
AMAROK é 2.x ou superior, powxa!!!!!!!!!!!!!!!!!!!

Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #9 Online: 16 de Junho de 2009, 17:28 »
Cara até sei que é questão de opinião mas para mim só é superior no numero.

Só pelo fato do Amarok 1 organizar suas musicas junto com as id3-tag, e o vizual mais enxuto, e menos bugado, pra mim ainda é o melhor.

E ainda tem aquela janelinha separada do play list com o vizualizador/analisadores dos picos da musica é nota 100!

O Amarok 2.1 é bom, mas acho q falta melhorar muita coisa nele, exemplo crashes (ele fecha sozinho direto) um editor de id3 tag melhorado (igual o do amarok1) e um vizul melhor, acho q se colocarem um suporte a skin podem melhorar. Fora os plugins plasma q ele tem, adorei um do discogs que ele puxa a capa do disco de lá, pois ouço muita musica eletronica e o discog é o melhor lugar pra achar capa de disco. Acredito que numa versão 2.5 ele ja melhore.

Ah voltando ao topico mesmo eu tendo dado o comando o Kubuntu ainda quer atualiza-lo, tem outra forma para barrar essa atualização?

Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando

Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #10 Online: 28 de Junho de 2009, 15:51 »
Olá, alguem sabe como bloquear essa atualização?

Mesmo com o comando "sudo aptitude hold amarok" o KDE quer atualiza-lo....




Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #11 Online: 28 de Junho de 2009, 18:05 »
Olá, alguem sabe como bloquear essa atualização?

Mesmo com o comando "sudo aptitude hold amarok" o KDE quer atualiza-lo....

http://img25.imageshack.us/i/atualizaoamarok2.png


No final do texto (do wiki) Gerenciamento de pacotes com o APT explica como "Prender versão do pacote".

Acho que isso pode te ajudar.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #12 Online: 28 de Junho de 2009, 21:18 »
Deu certo...

E pela maneira mais facil encontrada nesse site mesmo:

DICA: Podemos facilmente fazer isso também usando a interface gráfica do Synaptic. Basta com o mesmo aberto, selecionar o pacote desejado e clicar na opção de menu Pacote > Prender Versão.
Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando

Offline Bruno Gothic

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #13 Online: 01 de Julho de 2009, 10:12 »
Alguem poderia me ajudar, porque eu fiz o Downgrade para o amarok 1.4, porem os icones e as capas dos cds não aparecem. Alguem sabe me dizer qual o tema de icones a ser baixado... ou algum pacote... porque toda a dependências estão instaladas. Uso o Ubuntu Jaunty praticamente no padrão. ???



Offline MadOrL

  • Usuário Ubuntu
  • *
  • Mensagens: 146
  • Vc Sabia que Amanha hoje vira Ontem?
    • Ver perfil
    • Twitter
Re: Downgrade do amarok 2 para o amarok 1.4
« Resposta #14 Online: 15 de Julho de 2009, 16:43 »
Mesmo apos ler esse artigo, ainda continuo preferindo o Amarok 1.4. O 2.1 até dá vontade de usar mas sinto falta principalmente da forma que o antigo organizava as musicas, renomeando o arquivo e ja copiando/movendo para as pastas que eu quero...

Como eles disseram quem sabe na versão 2.3 ou 2.4 ja valha a pena a troca.

A ruim é que o Kapckage insiste em querer atualiza-lo, mas no problem faço o downgrade conforme acima e pronto...

Link do Artigo: http://www.guiadohardware.net/artigos/amarok2/
Kubuntu 15.04, amd64 e sempre atualizando
http://twitter.com/madorlando