Autor Tópico: Problema no grub e agora só entra no prompt do grub!!  (Lida 27314 vezes)

Offline sparklingthing

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #30 Online: 04 de Dezembro de 2008, 16:32 »
Bah, nada feito.... a única diferença é que aparecem só três opções de boot, no entanto, qualquer uma das três que eu seleciono dá o Error 15.

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #31 Online: 04 de Dezembro de 2008, 16:48 »
Bah, nada feito.... a única diferença é que aparecem só três opções de boot, no entanto, qualquer uma das três que eu seleciono dá o Error 15.

Mesmo na vez anterior era para aparecer somente 3 opções no boot.

Bem, apelando já faça um teste pra mim, e retorne aqui e diga se alguma das opções do boot no final ira funcionar, e funcionando a gente acerta de vez o problema:

1o. Inicie com o LiveCD
2o. Monta a partição do boot:

Código: [Selecionar]
sudo   mount    /dev/sda3    /mnt
3o. Edite o arquivo menu.lst

Código: [Selecionar]
sudo   gedit   /mnt/grub/menu.lst
4o. Substitua seu conteúdo pelo abaixo:

Citar
title      HDA02
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-16-generic
quiet

title      HDA03
root      (hd0,3)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-16-generic
quiet

title      HDA04
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-16-generic
quiet

title      HDA05
root      (hd0,5)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-16-generic
quiet

title      HDA06
root      (hd0,6)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-16-generic
quiet

Mesmo assim vou continuar pesquisando aqui...
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline sparklingthing

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #32 Online: 04 de Dezembro de 2008, 16:57 »
Nenhuma funciona, todas dão o Error 15...

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #33 Online: 04 de Dezembro de 2008, 17:03 »
Nenhuma funciona, todas dão o Error 15...

Sabe que até imaginei que sua resposta seria essa.

Vamos reiniciar... Deixa eu acertar aqui o que já sei, então vou pedir de novo algumas informações.

Vamos lá...

1o. Monte a partição /dev/sda3 (que é a /boot), e liste os conteúdos:

Código: [Selecionar]
sudo   mount   /dev/sda3   /mnt
Código: [Selecionar]
ls -l   /mnt
Código: [Selecionar]
ls -l   /mnt/grub
2o. Monte a partição /dev/sda6 (que é a /), e liste os conteúdos:

Código: [Selecionar]
sudo   mount   /dev/sda6   /media
Código: [Selecionar]
ls -l   /media
Código: [Selecionar]
ls -l   /media/boot
3o. Outra pergunta, você tentou instalar um kernel mais novo por conta própria?

4o. Cade o povo que tava ajudando? Alarcon? Mais alguém tem alguma idéia?
« Última modificação: 04 de Dezembro de 2008, 17:05 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline sparklingthing

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #34 Online: 04 de Dezembro de 2008, 17:11 »
Não tentei instalar nenhuma kernel por conta própria, tanto porque eu evito fazer  essas coisas pra evitar estrago, heheeh

Bom, aqui vão as respostas:

ubuntu@ubuntu:~$ ls -l /mnt
total 68436
-rw-r--r-- 1 root root  414274 2007-09-23 20:28 abi-2.6.20-16-generic
-rw-r--r-- 1 root root  424317 2008-02-12 10:39 abi-2.6.22-14-generic
-rw-r--r-- 1 root root  424374 2008-10-22 03:04 abi-2.6.22-15-generic
-rw-r--r-- 1 root root  424374 2008-11-24 21:46 abi-2.6.22-16-generic
drwxr-xr-x 3 root root    1024 2008-12-02 17:40 boot
-rw-r--r-- 1 root root   83217 2007-09-23 17:47 config-2.6.20-16-generic
-rw-r--r-- 1 root root   75311 2008-02-12 10:39 config-2.6.22-14-generic
-rw-r--r-- 1 root root   75300 2008-10-22 03:04 config-2.6.22-15-generic
-rw-r--r-- 1 root root   75300 2008-11-24 21:46 config-2.6.22-16-generic
drwxr-xr-x 2 root root    1024 2008-12-04 18:50 grub
-rw-r--r-- 1 root root 6908083 2007-11-06 00:10 initrd.img-2.6.20-16-generic
-rw-r--r-- 1 root root 6906873 2007-11-05 18:35 initrd.img-2.6.20-16-generic.bak
-rw-r--r-- 1 root root 7251434 2008-05-28 04:42 initrd.img-2.6.22-14-generic
-rw-r--r-- 1 root root 7251354 2008-05-28 04:41 initrd.img-2.6.22-14-generic.bak
-rw-r--r-- 1 root root 7251414 2008-11-07 15:34 initrd.img-2.6.22-15-generic
-rw-r--r-- 1 root root 7251302 2008-10-28 16:17 initrd.img-2.6.22-15-generic.bak
-rw-r--r-- 1 root root 7251284 2008-12-01 19:04 initrd.img-2.6.22-16-generic
-rw-r--r-- 1 root root 7251288 2008-12-01 19:03 initrd.img-2.6.22-16-generic.bak
drwx------ 2 root root   12288 2007-10-22 18:05 lost+found
-rw-r--r-- 1 root root  103204 2007-09-28 10:06 memtest86+.bin
-rw-r--r-- 1 root root  807071 2007-09-23 20:30 System.map-2.6.20-16-generic
-rw-r--r-- 1 root root  823535 2008-02-12 10:39 System.map-2.6.22-14-generic
-rw-r--r-- 1 root root  823860 2008-10-22 03:04 System.map-2.6.22-15-generic
-rw-r--r-- 1 root root  823860 2008-11-24 21:46 System.map-2.6.22-16-generic
-rw-r--r-- 1 root root 1747372 2007-09-23 20:28 vmlinuz-2.6.20-16-generic
-rw-r--r-- 1 root root 1764536 2008-02-12 10:39 vmlinuz-2.6.22-14-generic
-rw-r--r-- 1 root root 1765144 2008-10-22 03:04 vmlinuz-2.6.22-15-generic
-rw-r--r-- 1 root root 1765592 2008-11-24 21:46 vmlinuz-2.6.22-16-generic


 ls -l /mnt/grub
total 185
-rw-r--r-- 1 root root    197 2008-12-04 18:24 default
-rw-r--r-- 1 root root     15 2007-10-22 18:11 device.map
-rw-r--r-- 1 root root   8660 2008-12-04 18:24 e2fs_stage1_5
-rw-r--r-- 1 root root   8452 2008-12-04 18:24 fat_stage1_5
-rw-r--r-- 1 root root     15 2008-12-04 18:24 installed-version
-rw-r--r-- 1 root root   9152 2008-12-04 18:24 jfs_stage1_5
-rw-r--r-- 1 root root   4548 2008-12-04 18:50 menu.lst
-rw-r--r-- 1 root root   5609 2008-12-04 18:09 menu.lst~
-rw-r--r-- 1 root root   5740 2008-12-04 17:37 menu.lst.bkp.20081204
-rw-r--r-- 1 root root   7860 2008-12-04 18:24 minix_stage1_5
-rw-r--r-- 1 root root  10132 2008-12-04 18:24 reiserfs_stage1_5
-rw-r--r-- 1 root root    512 2008-12-04 18:24 stage1
-rw-r--r-- 1 root root 110292 2008-12-04 18:24 stage2
-rw-r--r-- 1 root root   9980 2008-12-04 18:24 xfs_stage1_5

ls -l /media
total 76
drwxr-xr-x   2 root root  3072 2008-11-14 08:05 bin
drwxr-xr-x   2 root root  1024 2007-10-22 18:05 boot
lrwxrwxrwx   1 root root    11 2007-10-22 18:05 cdrom -> media/cdrom
drwxr-xr-x  12 root root 30720 2007-11-07 00:57 dev
drwxr-xr-x 143 root root  5120 2008-12-04 17:41 etc
drwxr-xr-x   6 root root  1024 2008-03-31 01:59 home
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 initrd
lrwxrwxrwx   1 root root    33 2008-12-01 19:03 initrd.img -> boot/initrd.img-2.6.22-16-generic
lrwxrwxrwx   1 root root    33 2008-06-20 16:56 initrd.img.old -> boot/initrd.img-2.6.22-15-generic
drwxr-xr-x  17 root root  5120 2008-03-31 01:53 lib
drwx------   2 root root 12288 2007-06-21 14:10 lost+found
drwxr-xr-x   3 root root  1024 2008-12-01 14:53 media
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 mnt
drwxr-xr-x   4 root root  1024 2008-03-02 23:21 opt
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 proc
drwxr-xr-x  16 root root  1024 2008-11-09 22:42 root
drwxr-xr-x   2 root root  4096 2008-12-01 19:00 sbin
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 srv
drwxr-xr-x   2 root root  1024 2007-06-21 14:12 sys
drwxrwxrwt  15 root root  4096 2008-12-04 18:24 tmp
drwxr-xr-x  12 root root  1024 2008-01-05 12:34 usr
drwxr-xr-x  15 root root  1024 2007-11-06 19:01 var
lrwxrwxrwx   1 root root    30 2008-12-01 19:03 vmlinuz -> boot/vmlinuz-2.6.22-16-generic
lrwxrwxrwx   1 root root    30 2008-06-20 16:56 vmlinuz.old -> boot/vmlinuz-2.6.22-15-generic

ls- l /media/boot
abi-2.6.27-7-generic     System.map-2.6.27-7-generic
config-2.6.27-7-generic  vmcoreinfo-2.6.27-7-generic
memtest86+.bin

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #35 Online: 04 de Dezembro de 2008, 17:18 »
Bem, vamos as minhas dúvidas:

...

ubuntu@ubuntu:~$ ls -l /mnt
total 68436
-rw-r--r-- 1 root root  414274 2007-09-23 20:28 abi-2.6.20-16-generic
-rw-r--r-- 1 root root  424317 2008-02-12 10:39 abi-2.6.22-14-generic
-rw-r--r-- 1 root root  424374 2008-10-22 03:04 abi-2.6.22-15-generic
-rw-r--r-- 1 root root  424374 2008-11-24 21:46 abi-2.6.22-16-generic
drwxr-xr-x 3 root root    1024 2008-12-02 17:40 boot
-rw-r--r-- 1 root root   83217 2007-09-23 17:47 config-2.6.20-16-generic
-rw-r--r-- 1 root root   75311 2008-02-12 10:39 config-2.6.22-14-generic
-rw-r--r-- 1 root root   75300 2008-10-22 03:04 config-2.6.22-15-generic
-rw-r--r-- 1 root root   75300 2008-11-24 21:46 config-2.6.22-16-generic
drwxr-xr-x 2 root root    1024 2008-12-04 18:50 grub
-rw-r--r-- 1 root root 6908083 2007-11-06 00:10 initrd.img-2.6.20-16-generic
-rw-r--r-- 1 root root 6906873 2007-11-05 18:35 initrd.img-2.6.20-16-generic.bak
-rw-r--r-- 1 root root 7251434 2008-05-28 04:42 initrd.img-2.6.22-14-generic
-rw-r--r-- 1 root root 7251354 2008-05-28 04:41 initrd.img-2.6.22-14-generic.bak
-rw-r--r-- 1 root root 7251414 2008-11-07 15:34 initrd.img-2.6.22-15-generic
-rw-r--r-- 1 root root 7251302 2008-10-28 16:17 initrd.img-2.6.22-15-generic.bak
-rw-r--r-- 1 root root 7251284 2008-12-01 19:04 initrd.img-2.6.22-16-generic
-rw-r--r-- 1 root root 7251288 2008-12-01 19:03 initrd.img-2.6.22-16-generic.bak
drwx------ 2 root root   12288 2007-10-22 18:05 lost+found
-rw-r--r-- 1 root root  103204 2007-09-28 10:06 memtest86+.bin
-rw-r--r-- 1 root root  807071 2007-09-23 20:30 System.map-2.6.20-16-generic
-rw-r--r-- 1 root root  823535 2008-02-12 10:39 System.map-2.6.22-14-generic
-rw-r--r-- 1 root root  823860 2008-10-22 03:04 System.map-2.6.22-15-generic
-rw-r--r-- 1 root root  823860 2008-11-24 21:46 System.map-2.6.22-16-generic
-rw-r--r-- 1 root root 1747372 2007-09-23 20:28 vmlinuz-2.6.20-16-generic
-rw-r--r-- 1 root root 1764536 2008-02-12 10:39 vmlinuz-2.6.22-14-generic
-rw-r--r-- 1 root root 1765144 2008-10-22 03:04 vmlinuz-2.6.22-15-generic
-rw-r--r-- 1 root root 1765592 2008-11-24 21:46 vmlinuz-2.6.22-16-generic

Esse diretório marcado em negrito não deveria existir, o que tem nele?

Execute o comando ls -l /mnt/boot para sabermos.


Citar
ls -l /mnt/grub
total 185
-rw-r--r-- 1 root root    197 2008-12-04 18:24 default
-rw-r--r-- 1 root root     15 2007-10-22 18:11 device.map
-rw-r--r-- 1 root root   8660 2008-12-04 18:24 e2fs_stage1_5
-rw-r--r-- 1 root root   8452 2008-12-04 18:24 fat_stage1_5
-rw-r--r-- 1 root root     15 2008-12-04 18:24 installed-version
-rw-r--r-- 1 root root   9152 2008-12-04 18:24 jfs_stage1_5
-rw-r--r-- 1 root root   4548 2008-12-04 18:50 menu.lst
-rw-r--r-- 1 root root   5609 2008-12-04 18:09 menu.lst~
-rw-r--r-- 1 root root   5740 2008-12-04 17:37 menu.lst.bkp.20081204
-rw-r--r-- 1 root root   7860 2008-12-04 18:24 minix_stage1_5
-rw-r--r-- 1 root root  10132 2008-12-04 18:24 reiserfs_stage1_5
-rw-r--r-- 1 root root    512 2008-12-04 18:24 stage1
-rw-r--r-- 1 root root 110292 2008-12-04 18:24 stage2
-rw-r--r-- 1 root root   9980 2008-12-04 18:24 xfs_stage1_5

Aqui parece estar tudo ok.

Citar
ls -l /media
total 76
drwxr-xr-x   2 root root  3072 2008-11-14 08:05 bin
drwxr-xr-x   2 root root  1024 2007-10-22 18:05 boot
lrwxrwxrwx   1 root root    11 2007-10-22 18:05 cdrom -> media/cdrom
drwxr-xr-x  12 root root 30720 2007-11-07 00:57 dev
drwxr-xr-x 143 root root  5120 2008-12-04 17:41 etc
drwxr-xr-x   6 root root  1024 2008-03-31 01:59 home
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 initrd
lrwxrwxrwx   1 root root    33 2008-12-01 19:03 initrd.img -> boot/initrd.img-2.6.22-16-generic
lrwxrwxrwx   1 root root    33 2008-06-20 16:56 initrd.img.old -> boot/initrd.img-2.6.22-15-generic
drwxr-xr-x  17 root root  5120 2008-03-31 01:53 lib
drwx------   2 root root 12288 2007-06-21 14:10 lost+found
drwxr-xr-x   3 root root  1024 2008-12-01 14:53 media
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 mnt
drwxr-xr-x   4 root root  1024 2008-03-02 23:21 opt
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 proc
drwxr-xr-x  16 root root  1024 2008-11-09 22:42 root
drwxr-xr-x   2 root root  4096 2008-12-01 19:00 sbin
drwxr-xr-x   2 root root  1024 2007-06-21 14:10 srv
drwxr-xr-x   2 root root  1024 2007-06-21 14:12 sys
drwxrwxrwt  15 root root  4096 2008-12-04 18:24 tmp
drwxr-xr-x  12 root root  1024 2008-01-05 12:34 usr
drwxr-xr-x  15 root root  1024 2007-11-06 19:01 var
lrwxrwxrwx   1 root root    30 2008-12-01 19:03 vmlinuz -> boot/vmlinuz-2.6.22-16-generic
lrwxrwxrwx   1 root root    30 2008-06-20 16:56 vmlinuz.old -> boot/vmlinuz-2.6.22-15-generic

Aqui tbem parece estar tudo ok.

Citar
ls- l /media/boot
abi-2.6.27-7-generic     System.map-2.6.27-7-generic
config-2.6.27-7-generic  vmcoreinfo-2.6.27-7-generic
memtest86+.bin


Teoricamente aqui não deveria ter nada, já que o diretório é apenas um ponto de montagem para a partição /dev/sda3, e também não entendi isso.
« Última modificação: 04 de Dezembro de 2008, 17:20 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline sparklingthing

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #36 Online: 04 de Dezembro de 2008, 17:27 »
ubuntu@ubuntu:/$ ls -l /mnt/boot
total 1
drwxr-xr-x 2 root root 1024 2008-12-02 17:40 grub


Agora tá dando isso:
ubuntu@ubuntu:/$ ls -l /media/boot
total 0

alarcon

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #37 Online: 04 de Dezembro de 2008, 18:42 »
Uma pergunta a quem possa responder (quem entende bem as funcionalidades do comando chroot), neste caso não se poderia usar o comando chroot via LiveCD e na partição do HD e por lá mandar instalar novamente dos repositórios via apt-get, na partição Ubuntu do HD, os pacotes grub e do kernel (linux-image-2.6.22-16-generic) da versão do Ubuntu em questão?
« Última modificação: 04 de Dezembro de 2008, 18:50 por alarcon »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #38 Online: 04 de Dezembro de 2008, 19:16 »
Uma pergunta a quem possa responder (quem entende bem as funcionalidades do comando chroot), neste caso não se poderia usar o comando chroot via LiveCD e na partição do HD e por lá mandar instalar novamente dos repositórios via apt-get, na partição Ubuntu do HD, os pacotes grub e do kernel (linux-image-2.6.22-16-generic) da versão do Ubuntu em questão?

Eu nunca tentei, mas já indiquei isso duas vezes, só que nas duas alarcon o usuário do tópico sumiu!

Mas acho que pode dar certo!
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

alarcon

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #39 Online: 04 de Dezembro de 2008, 21:58 »
Vou tentar explicar como imagino que seria o uso do chroot e você, clcampos ou outro usuário que entenda este comando, pode fazer a correção que achar necessária, pois eu ainda não entendo muito bem este comando.

1. - Dar o boot pelo LiveCD e lá abrir um terminal (menu Aplicações > Acessórios > Consola ou Terminal) e digitar:

sudo su  (para virar root)

mkdir /media/sda?

mount -t ext3 /dev/sda?  /media/sda?

chroot /media/sda?

OBS: os valores /dev/sda? e /media/sda? mude para a sua verdeira partição do Ubuntu. Se sua partição Ubuntu não for ext3 e sim reiserfs, por favor mude isso também no comando acima.

2. - Para ter acesso completo via linha de comando

mount -t proc /proc proc

3. - Agora é que vem a dúvida, como conectar a internet

pon dsl-provider (apenas, considerando que os arquivos de configuração já estão feitos no HD, partição Ubuntu)

ou ainda

pppoeconf (para fazer a configuração da conexão para só depois usar o comando anterior e isso se for conexão ADSL)

4. - Agora instalar os pacotes:

apt-get clean

apt-get update

apt-get install -f

apt-get --assume-yes grub

apt-get --assume-yes linux-image-2.6.22-16-generic


5. - Finalizando

umout /proc

CTRL+D (para fechar o chroot)
« Última modificação: 04 de Dezembro de 2008, 22:20 por alarcon »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #40 Online: 05 de Dezembro de 2008, 00:12 »
Alarcon eu ainda não entendi exatamente qual é o arquivo que falta para apresentar o erro, nem tenho certeza que instalar o GRUB resolveria, mas não custa tentar.

Porém temos que atentar para algo engraçado. Primeiro os comandos relativos ao GRUB (como grub-install) funcionam, além do que ele é apresentado... Com isso cheguei a pensar que o problema poderia ser com o kernel, mas também não tenho certeza.

Antes de realizar seu teste (e eu acho que a parte de instalação do kernel bem que deve resolver) eu gostaria que ela tentasse o boot com outras opções de kernel, e assim o grub ficaria assim:

1o. Inicie com o LiveCD
2o. Monta a partição do boot:

Código: [Selecionar]
sudo   mount    /dev/sda3    /mnt
3o. Edite o arquivo menu.lst

Código: [Selecionar]
sudo   gedit   /mnt/grub/menu.lst
4o. Substitua seu conteúdo pelo abaixo:

Citar
title      Ubuntu 7.10, 2.6.22-16
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-16-generic
quiet

title      Ubuntu 7.10, kernel 2.6.22-16-generic (recovery mode)
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-16-generic root=/dev/sda6 ro single
initrd      /boot/initrd.img-2.6.22-16-generic

title      Ubuntu 7.10, kernel 2.6.22-15-generic
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-15-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-15-generic
quiet

title      Ubuntu 7.10, kernel 2.6.22-15-generic (recovery mode)
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-15-generic root=/dev/sda6 ro single
initrd      /boot/initrd.img-2.6.22-15-generic

title      Ubuntu 7.10, kernel 2.6.22-14-generic
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.22-14-generic
quiet

title      Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda6 ro single
initrd      /boot/initrd.img-2.6.22-14-generic

title      Ubuntu 7.10, kernel 2.6.20-16-generic
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.20-16-generic root=/dev/sda6 ro quiet splash
initrd      /boot/initrd.img-2.6.20-16-generic
quiet

title      Ubuntu 7.10, kernel 2.6.20-16-generic (recovery mode)
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.20-16-generic root=/dev/sda6 ro single
initrd      /boot/initrd.img-2.6.20-16-generic

title      Ubuntu 7.10, memtest86+
root      (hd0,2)
kernel      /boot/memtest86+.bin
quiet
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

alarcon

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #41 Online: 05 de Dezembro de 2008, 10:26 »
Ok Clcampos, agora uma coisa que também não entendi bem e talvez você possa me explicar, já que está acompanhando de perto este caso, é o por quê de se afirmar que ela tem uma partição em separado /boot.

Pelo que eu pude verificar, eu fiquei com a sensação de que o conteúdo da pasta /boot está é solto na partição raiz / e não que se tenha uma partição isolada/boot, ou seja os arquivos relativos ao kernel e a pasta grub está na partição raiz, por isso ela fala em /mnt/grub e não em /mnt/sda?/boot/grub (ou /mnt/sda?/grub) que acho que deveria ser a correta, sei lá estou confuso com relação a divisão do HD da usuária em questão, mas como disse não estou acompanho de perto tudo que já foi dito aqui e possa está me equivocando.
« Última modificação: 05 de Dezembro de 2008, 11:04 por alarcon »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #42 Online: 05 de Dezembro de 2008, 10:31 »
Ok Clcampos, agora uma coisa que também não entendi bem e talvez você possa me explicar, já que está acompanhando de perto este caso, é o por quê de se afirmar que ela tem uma partição em separado /boot.

Pelo que eu pude verificar, eu fiquei com a sensação de que o conteúdo da pasta /boot está é solto na partição raiz / e não que se tenha uma partição isolada/boot, ou seja os arquivos relativos ao kernel e a pasta grub está na partição raiz, por isso ela fala em /mnt/grub e não em /mnt/sda?/boot/grub (ou /mnt/sda?/grub) que acho que deveria ser a correta, sei lá estou confuso com relação a divisão do HD da usuária em questão, mas como disse não estou acompanho de perto tudo que já foi dito aqui e possa está me equivocando.

Vamos lá... bem, se você observar o conteúdo do seu diretório /boot, com o conteúdo da partição /dev/sda3 dela verá que são iguais (descontadas logicamente as diferenças entre as versões do Ubuntu, e portanto do kernel).

Além disto na partição /dev/sda6 tem toda a estrutura de diretórios do sistema raiz do Linux, inclusive o diretório /boot, que serve de ponto de montagem para a partição /dev/sda3.

Para confirmar minha suspeita eu solicitei que montasse a partição /dev/sda6 (para mim a partição raiz) no diretório /media, e que achasse o arquivo /media/etc/fstab, e nele tem a linha de montagem da partição sda3 em /boot, o que confirmava minhas suspeitas.

Sei que sou complicado com as palavras, mas conseguiu entender?
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

alarcon

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #43 Online: 05 de Dezembro de 2008, 10:54 »

Vamos lá... bem, se você observar o conteúdo do seu diretório /boot, com o conteúdo da partição /dev/sda3 dela verá que são iguais (descontadas logicamente as diferenças entre as versões do Ubuntu, e portanto do kernel).

Além disto na partição /dev/sda6 tem toda a estrutura de diretórios do sistema raiz do Linux, inclusive o diretório /boot, que serve de ponto de montagem para a partição /dev/sda3.

Para confirmar minha suspeita eu solicitei que montasse a partição /dev/sda6 (para mim a partição raiz) no diretório /media, e que achasse o arquivo /media/etc/fstab, e nele tem a linha de montagem da partição sda3 em /boot, o que confirmava minhas suspeitas.

Sei que sou complicado com as palavras, mas conseguiu entender?


Para mim ainda está muito confuso, não suas explicações, pois pelos comandos que vc pediu (sudo   fdisk   -l e blkid) ela tem o HD assim:

/dev/sda1 e /dev/sda2 parições primárias vfat (formatção tipo windows)

/dev/sda3 primária do linux

/dev/sda5 partição extendida e de swap

/dev/sda6 partição extendida do linux


vi que vc mandou montar a partição /dev/sda6 em /media e pediu para ver o fstab dela, mas ela retornou isso de início:

Citar
cat /media/etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=88ce1cfa-38c9-4181-9567-ee8fbaed5b96 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=c5d534d4-6af5-421f-8947-e1bcd7afaeee none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
UUID=abb1ece2-0504-4be8-a9e4-ce570575fe57  /boot ext3 defaults 0 0root@ubuntu:/#

não vi nada que demonstrasse existir uma partição separada /boot, por esse resultado.


Mas a frete eu vi que você fez um novo fstab para ela e aí sim foi sugerido por você a partição /boot em /dev/sda3:

Citar
Substitua seu conteúdo pelo abaixo (ou você pode fazer apenas as alterações, que estão em negrito)


# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1 (Partição Raiz)
/dev/sda6 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda3 (Partição para /boot)
/dev/sda3  /boot ext3 defaults 0 0
# /dev/sda5 (swap)

UUID=c5d534d4-6af5-421f-8947-e1bcd7afaeee none            swap    sw              0       0
# Unidade CD
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0


Agora quero dizer que vendo com mais calma os textos, entendi por que o grub é mostrado em /mnt, pois foi assim que foi sugerido a montagem (sudo mount  /dev/sda3  /mnt) e realmente suas suspeitas de que tem uma partição de boot em /dev/sda3 faz todo o sentido, mas pelo fstab que ela apresentou não havia isso e nem sequer a partição /dev/sda6 tinha, o que é muito estranho isso.

Possivelmente deva ser isso mesmo, um kernel com problemas.

E sim eu entendi o que você quis dizer no seu último texto. ;D
« Última modificação: 05 de Dezembro de 2008, 11:03 por alarcon »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #44 Online: 05 de Dezembro de 2008, 11:04 »
Observe os resultados dos comandos apresentados por ela:

sudo  blkid:
Citar
/dev/sda1: SEC_TYPE="msdos" LABEL="DellUtility" UUID="07D7-0A16" TYPE="vfat"
/dev/sda2: LABEL="OS" UUID="88E8-105A" TYPE="vfat"
/dev/sda3: LABEL="os_part" UUID="abb1ece2-0504-4be8-a9e4-ce570575fe57" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: UUID="c5d534d4-6af5-421f-8947-e1bcd7afaeee" TYPE="swsuspend"
/dev/sda6: LABEL="os_part" UUID="88ce1cfa-38c9-4181-9567-ee8fbaed5b96" SEC_TYPE="ext2" TYPE="ext3"
/dev/loop0: TYPE="squashfs"

fstab:
Citar
cat /media/etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=88ce1cfa-38c9-4181-9567-ee8fbaed5b96 /               ext3    defaults,errors=remount-ro 0       1  Montagem em / (ou seja raiz)
# /dev/sda5
UUID=c5d534d4-6af5-421f-8947-e1bcd7afaeee none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
UUID=abb1ece2-0504-4be8-a9e4-ce570575fe57  /boot ext3 defaults 0 0  <-Montagem  em /boot
root@ubuntu:/#

Ainda restam dúvidas? Essa discussão é ótima, pois podemos achar onde esta o erro...

Que tópico! Me desculpe sparklingthing, pois sei que esta com problemas, mas é um tópico ótimo, bem técnico e desafiador... espero não perder para ele.... hehehe
« Última modificação: 05 de Dezembro de 2008, 11:08 por clcampos »
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!