Autor Tópico: Problema no grub e agora só entra no prompt do grub!!  (Lida 21529 vezes)

alarcon

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #60 Online: 17 de Dezembro de 2008, 18:13 »
Bom, então, eu tentei o que foi indicado pelo clcampos e nada... todas as opções dão erro.
Se alguém tiver mais alguma idéia.....

Quando você informa: "eu tentei o que foi indicado pelo clcampos e nada... todas as opções dão erro.", está incluído o que foi dito aqui:

http://ubuntuforum-br.org/index.php/topic,43713.msg259564.html#msg259564

Offline sparklingthing

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #61 Online: 17 de Dezembro de 2008, 18:41 »
Bom, então, eu tentei o que foi indicado pelo clcampos e nada... todas as opções dão erro.
Se alguém tiver mais alguma idéia.....

Quando você informa: "eu tentei o que foi indicado pelo clcampos e nada... todas as opções dão erro.", está incluído o que foi dito aqui:

http://ubuntuforum-br.org/index.php/topic,43713.msg259564.html#msg259564

Então alacorn, essa idéia empaca no chroot: chroot: cannot run command `/bin/bash': No such file or directory

alarcon

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #62 Online: 20 de Dezembro de 2008, 18:23 »
Então alacorn, essa idéia empaca no chroot: chroot: cannot run command `/bin/bash': No such file or directory

OI, fui testar o que havia proposto no link e o chroot funcionou aqui. Veja o que fiz:

Vou tentar explicar como imagino que seria o uso do chroot e você, clcampos ou outro usuário que entenda este comando, pode fazer a correção que achar necessária, pois eu ainda não entendo muito bem este comando.

1. - Dar o boot pelo LiveCD e lá abrir um terminal (menu Aplicações > Acessórios > Consola ou Terminal) e digitar:

sudo su  (para virar root)

mkdir /media/sda?

mount -t ext3 /dev/sda?  /media/sda?

chroot /media/sda?

OBS: os valores /dev/sda? e /media/sda? mude para a sua verdeira partição do Ubuntu. Se sua partição Ubuntu não for ext3 e sim reiserfs, por favor mude isso também no comando acima.

2. - Para ter acesso completo via linha de comando

mount -t proc /proc proc

3. - Agora é que vem a dúvida, como conectar a internet

pon dsl-provider (apenas, considerando que os arquivos de configuração já estão feitos no HD, partição Ubuntu)

ou ainda

pppoeconf (para fazer a configuração da conexão para só depois usar o comando anterior e isso se for conexão ADSL)

ATENÇÃO: o passo 3 é que foi diferente, pois eu fiz a conexão no liveCD antes, para dar certo, portanto a conexão tem de ser feita no LiveCD.

4. - Agora instalar os pacotes:

apt-get clean

apt-get update

apt-get install -f

apt-get --assume-yes grub

apt-get --assume-yes linux-image-2.6.22-16-generic


Aqui eu só executei o comando apt-get update para testar, já que no meu caso não tenho problemas no meu Ubuntu.

5. - Finalizando

umout /proc

CTRL+D (para fechar o chroot)
« Última modificação: 20 de Dezembro de 2008, 18:31 por alarcon »

Offline sparklingthing

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #63 Online: 20 de Dezembro de 2008, 21:21 »
Dá o mesmo problema ao dar chroot que eu tinha mencionado anteriormente...
Eu tinha achado alguma vez um jeito de não dar esse erro mas não acho mais.....

Rodrigo Henrique

  • Visitante
Re: Problema no grub e agora só entra no prompt do grub!!
« Resposta #64 Online: 22 de Dezembro de 2008, 14:33 »
Eu andei relendo e eu acho que não mandei o código certo.
Ao invés de ser fdisk -f o certo seria fdsk -f
Tenta agora. e posta o que acontece.