Autor Tópico: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!  (Lida 204095 vezes)

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #45 Online: 11 de Novembro de 2008, 23:04 »
Neste tópico está sendo tratado sobre a inicialização do LiveCD/LiveUSB do Intrepid no Note Itautec W7635, com dicas de como configurar o xorg:
http://ubuntuforum-br.org/index.php/topic,42636.0.html

Até o momento, somente com aceleração 2D (OpenChrome ou Vesa).   :-\




...
« Última modificação: 11 de Novembro de 2008, 23:06 por rodrigo.miguel »

Offline heudson

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #46 Online: 15 de Novembro de 2008, 03:55 »
Em tese acho eu que segui o tutorial corretamente... Bem, reiniciei o sistema e a resolução da tela ficou maior, e ao ativar os efeitos visuais, a tela fica preta e volta pro LOGON. O que devo fazer quanto a isso, seguir do 1 passo o tutorial ?

Abraço!

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #47 Online: 15 de Novembro de 2008, 23:05 »
Em tese acho eu que segui o tutorial corretamente... Bem, reiniciei o sistema e a resolução da tela ficou maior, e ao ativar os efeitos visuais, a tela fica preta e volta pro LOGON. O que devo fazer quanto a isso, seguir do 1 passo o tutorial ?

Abraço!

lspci? Modelo, marca?

Offline heudson

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #48 Online: 16 de Novembro de 2008, 19:34 »
00:00.0 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. P4M900 I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. P4M900 Security Device
00:00.7 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:02.0 PCI bridge: VIA Technologies, Inc. P4M900 PCI to PCI Bridge Controller (rev 80)
00:03.0 PCI bridge: VIA Technologies, Inc. P4M900 PCI to PCI Bridge Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. Unknown device 5372
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev b0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev b0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev b0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev b0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237S PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 Host bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. Chrome9 HC IGP (rev 01)
80:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)

Placa mãe GigaByte VM900m HD samsung 160gb, 2gb memória.

Tipo, estou tentando fazer o tutorial NOVAMENTE a partir do segundo passo, mas, fica sempre dando problema. As vezes vai pro Login, as vezes reinicia, acho que baguncei meu sistema.

Como devo proceder ?

Abraço!

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #49 Online: 17 de Novembro de 2008, 09:03 »
heudson

Edite o arquivo /usr/bin/compiz, deixando-o com sua configuração original. No Terminal, ou Consola, digite:
Código: [Selecionar]
sudo gedit /usr/bin/compiz
Procure pela linha WHITELIST="nvidia intel ati radeon i810 via" ou WHITELIST="nvidia intel ati radeon i810 via fglrx" e altere para o original:

WHITELIST="nvidia intel ati radeon i810" (ou para WHITELIST="nvidia intel ati radeon i810 fglrx").


ATENÇÃO: o que estamos fazendo aqui é removendo o parâmetro "via". Portanto, nem tente ativar o Compiz, pois não irá funcionar.

Assim será mais fácil identificar o problema. Saberemos se o erro está acontecendo na instalação do driver, na configuração do xorg ou na ativação do Compiz.

Agora ATENÇÃO: após remover o parâmetro "via" do arquivo "/usr/bin/compiz", você deverá tentar iniciar o modo gráfico e, se iniciar normalmente, verificar se a aceleração gráfica está ativada, com o seguinte comando:

glxinfo | grep direct


Se a linha "direct rendering" estiver como "Yes" a aceleração 3D está habilitada.

Caso o mesmo problema continue ocorrendo, teremos que verificar a configuração do xorg, isso se você tiver CERTEZA que seguiu corretamente todos os passos do tutorial.

Lembrando que o xorg que passei é para o meu Notebook especificamente e similares. No seu caso pode ser justamente esta a causa do problema.


...
« Última modificação: 17 de Novembro de 2008, 09:21 por rodrigo.miguel »

Offline heudson

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #50 Online: 17 de Novembro de 2008, 12:01 »
Hum... Acabei de ver que fiz uma derma então... Eu uso um desktop. Placa mão ON BOARD GibaByte VM900 (VN896/Chrome9 HC IGP). Mesmo assim ainda posso seguir o tutorial ?

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #51 Online: 17 de Novembro de 2008, 22:21 »
Pode...


Mas deixe o seu xorg.conf assim:

Código: [Selecionar]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Driver "via"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Configured Video Device"
    Monitor        "Monitor"
    DefaultDepth    24
    SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "Module"
Load  "glx"
Load  "dri"
Load  "extmod"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection


MAS ANTES, SIGA AS ORIENTAÇÕES DA MINHA POSTAGEM ANTERIOR!

Offline heudson

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #52 Online: 17 de Novembro de 2008, 23:32 »
hum... Muito obrigado pela atenção. Vou seguir como você recomendou. Só uma outra dúvida, como faço para alterar o Xorg por esse que você citou ?

Abraço!

Offline heudson

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #53 Online: 18 de Novembro de 2008, 01:01 »
Eu segui o processo que você citou na mensagem anterior, só não consegui executar os comandos glxinfo | grep direct. Ao executá-los sou redirecionado para tela de Login. Bem, mas consegui remover o parâmetro "via". Enfim, já tinha baixado os arquivos expostos para download no tutorial e comecei a seguir o mesmo a partir,

"cd   ./chrome9.83-242-u804
sudo ./vinstall"

Após eu "dar" sudo ./vinstall sou novamente redirecionado para tela de Login ? O que estou fazendo de errado ? Por favor, tenha paciência comigo... Tô tentando.

Obrigado e um grande Abraço!

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #54 Online: 18 de Novembro de 2008, 10:08 »
Você está instalando no Ubuntu 8.04?

Tente desinstalar o driver via e restaurar o backup do xorg original (usando o openchrome ou o vesa). Reiniciar, e tentar instalar novamente.

Se o erro persistir não poderei ajudá-lo.



Offline 666porcondissaum

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #55 Online: 22 de Novembro de 2008, 19:44 »
Aí beleza rodrigo!? Meu notebook é um Positivo Mobile V56, durante o tutorial tudo ocorreu bem com excessão nos comandos:

patch -p0 < via-chrome9-drm.patch-2.6.24
patch -p0 < via-agp.patch-2.6.24

... que aparecem mensagens seguidas de Patching...  assume -R [n]

Apply anyway [n]

... aí não soube o quê fazer mas continuei, tudo iniciou legal mas a configuração ficou um pouco fora do padrão... com umas linhas no centro da tela, mas efeitos 3d funcionando. Aí fui mudando a configuração do xorg.conf na Section "screen" e subsection e cada vez qeu iniciava a configuração mudava mas não alcançava a padrão... do jeito liso... aí num post vi um '@' seguido de '60' e apliquei no xorg nesta parte. Agora fu... tudo e nem inicia. Utilizando o LiveCD modifico o xorg, já restaurei as configurações iniciais mas nada. Any help???

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #56 Online: 22 de Novembro de 2008, 21:41 »
Você tem que reverter a sua última ação...

Apague o xorg failsafe, ou safemode..., ou algo semelhante...

Enquanto este xorg estiver lá na pasta, o xorg.conf padrão não é carregado.

Deve ser isto. Se funcionou antes, mesmo com os tais problemas, deve funcionar novamente.

Aí você terá que procurar uma solução para a resolução.
« Última modificação: 07 de Dezembro de 2008, 22:04 por rodrigo.miguel »

Offline 666porcondissaum

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #57 Online: 23 de Novembro de 2008, 02:02 »
Tá perfeito mestre valew por mais uma.
« Última modificação: 23 de Novembro de 2008, 04:03 por 666porcondissaum »

Offline la_de_longe

  • Usuário Ubuntu
  • *
  • Mensagens: 198
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #58 Online: 23 de Novembro de 2008, 15:11 »
Aqui na hora de atvar o compiza ou dar o glxinfo ele volta pra tela de login, ae eu atualizei meu kernel pelas atualizaç~oes do ubuntu mesmo e no novo kernel o glxinfo funciona normalmente e aceleraç~ao 3d tg, mas o sistema trava qd teto iniciar o compiz, eu vejo que ele foi iniciado mas tudo trava.


Edit: trava também na hora de rodaralgum aplicativo 3d como google earth.
« Última modificação: 23 de Novembro de 2008, 15:22 por la_de_longe »

Offline 666porcondissaum

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!
« Resposta #59 Online: 23 de Novembro de 2008, 20:38 »
Qual sua máquina??