Autor Tópico: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]  (Lida 13184 vezes)

kErNeL_sCrIpT

  • Visitante
Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Online: 13 de Janeiro de 2008, 19:24 »
Bom galera, to com esse problema de depois que eu instalo o Driver ATI proprietário pelo Envy ou mesmo o Driver restrito, o X não inicia mais, tipo, da boot, carrega, e começa a iniciar, mas não vai, para, fica uma tela preta, dai tenho que entrar com LiveCD e consertar o xorg.conf na unha, pondo o backup que fiz, dai entra o X normal, mas com o driver desativado, usando somente o Driver genérico Mesa. A impressão que tenho é que preciso configurar alguma coisa do xorg.conf para "aceitar" o Driver, mas não sei... se alguém souber como resolver, ou mesmo puder dar dicas e ou links.
Estou usando o Linux Mint 4.0 Daryna (repositório Gutsy incluso).
Desde já, muito obrigado pela atenção.

Editado:

Bom, tentei novamente e dessa vez entrou o X, mas não "pega" o Driver, não reconhece, então fica em baixa resolução, daí tenho que desabilitar o Driver Restrito e ficar sem aceleração...

Editado #2:

Resolvi o problema, compilei manualmente e está funcionando normalmente agora.

« Última modificação: 15 de Janeiro de 2008, 23:04 por kErNeL_sCrIpT »

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #1 Online: 13 de MAR?O de 2008, 14:50 »
blz chefe, como foi que vc fez (como foi que vc compilou manualmente) para solucionar esse problema??
PQ eu sequi esse método:http://ubuntuforum-pt.org/index.php?topic=27077.0
mas só o compiz funciona, mas outros programas que pedem 3D não funcionam e quando eu vou no terminal ver dá isso:
Citar
root@ubuntu-desktop:/home/josephdiniz# glxinfo | grep "direct rendering"
Xlib: extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
root@ubuntu-desktop:/home/josephdiniz#

será que poderia dizer como fez  :) (ou onde eu acho, pq já fiz tantas coisas que deram errado que to perdendo as esperanças)

minha placa é uma ATI Radeon X300
« Última modificação: 13 de MAR?O de 2008, 15:17 por dom diniz »
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

kErNeL_sCrIpT

  • Visitante
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #2 Online: 13 de MAR?O de 2008, 19:56 »
blz chefe, como foi que vc fez (como foi que vc compilou manualmente) para solucionar esse problema??
PQ eu sequi esse método:http://ubuntuforum-pt.org/index.php?topic=27077.0
mas só o compiz funciona, mas outros programas que pedem 3D não funcionam e quando eu vou no terminal ver dá isso:
Citar
root@ubuntu-desktop:/home/josephdiniz# glxinfo | grep "direct rendering"
Xlib: extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
root@ubuntu-desktop:/home/josephdiniz#

será que poderia dizer como fez  :) (ou onde eu acho, pq já fiz tantas coisas que deram errado que to perdendo as esperanças)

minha placa é uma ATI Radeon X300


O comando mais "preciso" pra isso é: glxinfo | grep direct
Cara, o que parece é que falta alguma configuração no seu xorg.conf, que é realizada através de um comando (pode ser o aticonfig ou outro, não tenho certeza), que está, entre outras coisas, nestes tutoriais:

http://www.guiaubuntupt.org/wiki/index.php?title=ATI_fglrx_8.42.3

http://kernel-script.blogspot.com/2008/01/instalar-o-driver-ati-fglrx-no-debian.html

O primeiro é para o Ubuntu e pode estar desatualizado, o segundo foi eu que fiz pra instalar esse Driver no Debian, mas são úteis em geral pra compilar esse Driver pro Ubuntu, ajuda bastante.

Eu voltei a usar Ubuntu já faz tempo, e uso o Envy e acabaram as dores de cabeça (ufa!)

Lembrando que não me responsabilizo pela dica, use por sua conta e risco.

Abraço e até mais. Boa sorte
« Última modificação: 13 de MAR?O de 2008, 20:17 por kErNeL_sCrIpT »

Offline barinho

  • Usuário Ubuntu
  • *
  • Mensagens: 218
  • Linux na veia!
    • Ver perfil
    • Barinho's Flickr!
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #3 Online: 14 de MAR?O de 2008, 13:59 »
Estou para adquirir a placa mae GA-MA69VM-S2, no qual o video onboard e uma ATI :D
To na duvida de adquirir essa placa pelo problema de colocar a ATI para funcionar... Dai estou na duvida dessa placa ou de outra q possui a NVIDIA, no qual nunca tive problemas de colocar o video para funcionar o 3D.

Ai vai a pergunta ? Seria tao dificil ou chato colocar essa ATI para funcionar ?

[ ]s
:: Twitter | Last.fm
:: Ubuntu user #1453
:: Powered by Ubuntu

Offline Ioca100

  • Usuário Ubuntu
  • *
  • Mensagens: 2.848
  • Rio,Brasil
    • Ver perfil
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #4 Online: 14 de MAR?O de 2008, 14:27 »
É colega, também tenho uma Ati 9600 xt e, até hoje,uso o Ubuntu num VMware Player,mas li que o catalyst 8.3 já está bem melhor,acho que vou instalar o 8.04 no HD físico.
Dá uma olhada:    http://www.forumpcs.com.br/noticia.php?b=232855
Usuário Linux- 449417

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #5 Online: 14 de MAR?O de 2008, 14:34 »
bem. a ultima vez que eu usei o envy dizia que eu tinha rendering (renderinn yes) mas eu não conseguia fazer funcionar o fusion, quando eu mandei reistalar os pacotes do fusion o sistema travou que nem mexendo no xorg deu jeito (posso ter errado tambem mas pois meu conhecimento é limitado)

sobre a outra dica fiquei uma dúvida:
Citar
Agora vamos instalar os Drivers utilizando o repositório (No Debian testing Lenny são os Drivers mais recentes :^)
Após instalados os linux-headers, vá novamente na caixa de pesquisa e procure por fglrx e instale o seguinte:

fglrx-amdcccle
fglrx-control
fglrx-driver
fglrx-kernel-2.6.22-3-686
fglrx-kernel-src
xserver-xorg-video-ati

esse "fglrx-amdcccle" é referente ao processador amd??? pq o meu processador é um P4 HT.

muito obrigado pela atenção. ;D
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

kErNeL_sCrIpT

  • Visitante
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #6 Online: 14 de MAR?O de 2008, 14:45 »
barinho

Estou para adquirir a placa mae GA-MA69VM-S2, no qual o video onboard e uma ATI :D
To na duvida de adquirir essa placa pelo problema de colocar a ATI para funcionar... Dai estou na duvida dessa placa ou de outra q possui a NVIDIA, no qual nunca tive problemas de colocar o video para funcionar o 3D.

Ai vai a pergunta ? Seria tao dificil ou chato colocar essa ATI para funcionar ?

[ ]s

Cara, essa pergunta é muito difícil. Na minha opinião, eu não quero ATI™ nunca mais, a placa é excepcional sim, mas só para Windows™©® e quando funciona direito no Linux. Além disso, o Driver do Windows™©® é muito mais competente, já o da NVIDIA™ não vi nada que deixasse a desejar no Linux (Porém usei muito pouco pra te dar uma opinião mais plausível). Mas é minha opinião, pergunte a mais pessoas. Mas no geral, provavelmente você terá muito menos problemas com uma NVIDIA™, visto que o suporte desta para o Linux é muito superior ao da ATI™. Essa minha placa de vídeo Offboard ATI™ sempre me deu muita dor de cabeça pra instalar no Linux. Porém, não se pode ignorar que o Envy vem melhorando a cada dia, e o suporte da ATI™ também, mas mesmo assim, atualmente, se o Linux e ou Linux Ubuntu é seu principal SO, recomendo a NVIDIA™. Mas ressalto, não tome como decisão final a minha opinião somente, pergunte a mais pessoas. Se quiser, delete esta sua mensagem acima e poste-a na sessão Iniciantes, Café com Ubuntu, ou outra que você julgue apropriada, para pedir ajuda e conselhos de diferentes usuários.
Boa sorte barinho :)

Abraço e até mais.



dom diniz

bem. a ultima vez que eu usei o envy dizia que eu tinha rendering (renderinn yes) mas eu não conseguia fazer funcionar o fusion, quando eu mandei reistalar os pacotes do fusion o sistema travou que nem mexendo no xorg deu jeito (posso ter errado tambem mas pois meu conhecimento é limitado)

sobre a outra dica fiquei uma dúvida:
Citar
Agora vamos instalar os Drivers utilizando o repositório (No Debian testing Lenny são os Drivers mais recentes :^)
Após instalados os linux-headers, vá novamente na caixa de pesquisa e procure por fglrx e instale o seguinte:

fglrx-amdcccle
fglrx-control
fglrx-driver
fglrx-kernel-2.6.22-3-686
fglrx-kernel-src
xserver-xorg-video-ati

esse "fglrx-amdcccle" é referente ao processador amd??? pq o meu processador é um P4 HT.

muito obrigado pela atenção. ;D

Não, "fglrx-amdcccle" significa: "fglrx(referente ao Driver ATI™)-amd(referente a empresa AMD™/ATI™)ccc(Catalyst™ Control Center), o "le" eu não sei o que significa :P
Esse pacote é o pacote da Interface Gráfica do Driver ATI™.

Abraço e até mais.
« Última modificação: 14 de MAR?O de 2008, 14:52 por kErNeL_sCrIpT »

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #7 Online: 14 de MAR?O de 2008, 15:03 »
obrigado pela resposta tão rapida  ;D

só uma coisa que eu esqueci o primeiro link não está funcionando
http://www.guiaubuntupt.org/wiki/index.php?title=ATI_fglrx_8.42.3

vou tentar o primeiro link ( a menos que alguém tenha alguma resalva)  já que o envy parece que aqui não dá certo

valeu
« Última modificação: 14 de MAR?O de 2008, 15:07 por dom diniz »
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

kErNeL_sCrIpT

  • Visitante
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #8 Online: 14 de MAR?O de 2008, 15:41 »
obrigado pela resposta tão rapida  ;D

só uma coisa que eu esqueci o primeiro link não está funcionando
http://www.guiaubuntupt.org/wiki/index.php?title=ATI_fglrx_8.42.3

vou tentar o primeiro link ( a menos que alguém tenha alguma resalva)  já que o envy parece que aqui não dá certo

valeu

dom diniz, como o Ioca100 postou, parece que saiu um novo Driver ATI™ com correção de Bugs, então você pode tentar instalar um Envy recente (tem que ver se ele pega o Driver recente) e baixar esse novo Driver. Os dois tutos podem lhe ser útil, geralmente pra usar o Envy, é necessário instalar o os linux-headers referentes ao seu processador, o resto o Envy da conta, se for compilar na mão, vai precisar seguir mais detalhadamente as dependências, também citadas nos tutoriais.

Boa sorte, abraço e até mais.
« Última modificação: 14 de MAR?O de 2008, 15:45 por kErNeL_sCrIpT »

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #9 Online: 14 de MAR?O de 2008, 16:38 »
blz, amigo. Brigado pela ajuda e desculpa o trabalho.
Fou procurar os readers porém não achei nenhum dos que vc listou
dei uma olhada pelo apt e olha quais são os headers


Citar
ubuntu@ubuntu-desktop:~$ apt-cache search linux-headers
linux-headers-386 - Linux kernel headers on 386
linux-headers-generic - Generic Linux kernel headers
linux-headers-server - Linux kernel headers on Server Equipment.
linux-headers-virtual - Linux kernel headers for the virtual flavour
linux-headers-rt - Linux kernel headers on realtime kernel
linux-headers-ume - Linux kernel headers on 386 Embedded/Mobile
linux-headers-xen - Linux kernel headers on Xen
rt2400-source - source for rt2400 wireless network driver
rt2500-source - source for rt2500 wireless network driver
xen-headers-2.6.19-4 - Common header files for Linux 2.6.19
xen-headers-2.6.19-4-generic - Common header files for Linux 2.6.19
xen-headers-2.6.19-4-server - Common header files for Linux 2.6.19
xen-source-2.6.16 - Linux kernel source for version 2.6.17 with Ubuntu patches
linux-headers-2.6.22-14 - Header files related to Linux kernel version 2.6.22
linux-headers-2.6.22-14-386 - Linux kernel headers for version 2.6.22 on i386
linux-headers-2.6.22-14-generic - Linux kernel headers for version 2.6.22 on x86/x86_64
linux-headers-2.6.22-14-rt - Linux kernel headers for version 2.6.22 on RT kernel
linux-headers-2.6.22-14-server - Linux kernel headers for version 2.6.22 on x86/x86_64
linux-headers-2.6.22-14-ume - Linux kernel headers for version 2.6.22 on Ubuntu Moblie and Embedded
linux-headers-2.6.22-14-virtual - Linux kernel headers for version 2.6.22 on x86
linux-headers-2.6.22-14-xen - Linux kernel headers for version 2.6.22 on This kernel can be used for Xen dom0 and domU
linux-source-2.6.22 - Linux kernel source for version 2.6.22 with Ubuntu patches
ubuntu@ubuntu-desktop:~$


Agora não sei qual eu uso.
desses só estão instalado os:

linux-headers-2.6.22-14
linux-headers-2.6.22-14-generic
linux-headers-generic

e agora, devo instalar mais algum???

(acho que vc já deve desconfiar que eu uso o ubuntu 7.10 é que eu esqueci de dizer antes)
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

kErNeL_sCrIpT

  • Visitante
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #10 Online: 14 de MAR?O de 2008, 17:20 »
Beleza dom diniz, na verdade eu não tinha percebido que você usava o 7.10 não. Mas foi bom falar, e você já disse que usa um P4 não é isso?
Então, instale mais esses:

linux-headers-386

linux-headers-2.6.22-14-386

Agora você está pronto para o Envy :)
Se for compilar na unha vai precisar de muito mais coisas, mas nada que os tutoriais não de indiquem :)
Não é trabalho algum amigo, é um prazer ajudar :)

Abraço e até mais. Boa sorte.

Offline barinho

  • Usuário Ubuntu
  • *
  • Mensagens: 218
  • Linux na veia!
    • Ver perfil
    • Barinho's Flickr!
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #11 Online: 14 de MAR?O de 2008, 17:24 »
Eu ja estava cabreiro mesmo !
Andei leno por ai q vou mesmo de Nvidia !
Nao quero problemas com video ...
Ja vi diversos topicos em diversos foruns, falando de problemas com ati no linux.
Eu so uso linux e como ja disse, com a nvidia nunca tive problemas. Smpre foi facil colocar o video para funcionar :D
Mas valeu ai pela ajuda .. Ja me decidi do q quero !

[ ]s
:: Twitter | Last.fm
:: Ubuntu user #1453
:: Powered by Ubuntu

kErNeL_sCrIpT

  • Visitante
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #12 Online: 14 de MAR?O de 2008, 17:29 »
Eu ja estava cabreiro mesmo !
Andei leno por ai q vou mesmo de Nvidia !
Nao quero problemas com video ...
Ja vi diversos topicos em diversos foruns, falando de problemas com ati no linux.
Eu so uso linux e como ja disse, com a nvidia nunca tive problemas. Smpre foi facil colocar o video para funcionar :D
Mas valeu ai pela ajuda .. Ja me decidi do q quero !

[ ]s


Opa, beleza barinho, boa sorte e felicidades com sua nova placa :D

Abraço e até mais.

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #13 Online: 14 de MAR?O de 2008, 22:45 »
espero não está sendo chato mas agora estou com achando que vai dar certo  ;D( to brigando desde junho do ano passado e ja mudei três vezes de distribuição mas eu sou brasileiro e não desisto nunca  ;D)
bem, instalei os headers que vc recomendou mas fiquei curioso com uma coisa que vc disse:

dom diniz, como o Ioca100 postou, parece que saiu um novo Driver ATI™ com correção de Bugs, então você pode tentar instalar um Envy recente (tem que ver se ele pega o Driver recente) e baixar esse novo Driver.

como é que eu fasso para verificar isso?? ???


edit: só uma coisinha, depois que eu instalo pelo envy eu ainda tenho que ir em Sistemas => Administração => Gerenciador de Driver Restrito????

muitissimo obrigado
« Última modificação: 15 de MAR?O de 2008, 07:32 por dom diniz »
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

Offline barinho

  • Usuário Ubuntu
  • *
  • Mensagens: 218
  • Linux na veia!
    • Ver perfil
    • Barinho's Flickr!
Re: Driver ATI ou Restrito não "pega" depois de instalado [Resolvido]
« Resposta #14 Online: 15 de MAR?O de 2008, 05:48 »
Agora fiquei na espectativa também :D
O jeito e esperar alguem q tenha placa ati e testar esse novo driver ...

[ ]s
:: Twitter | Last.fm
:: Ubuntu user #1453
:: Powered by Ubuntu