Autor Tópico: Problemas com o Anki  (Lida 4915 vezes)

Offline paiakan

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Problemas com o Anki
« Online: 29 de Julho de 2017, 17:16 »
Boa tarde,

Estou com problemas para executar o ANKI no Ubuntu 17.04 32 bits.
Tentei pelo ubuntu software e o problema ocorreu. Removi e tentei pelo site:
https://apps.ankiweb.net
Porém o mesmo problema ocorreu ao executar, novamente o removi.

Também tentei versões antigas:
https://apps.ankiweb.net/downloads/archive/

Ele instala normalmente, porém não executa (não inicia).
Alguém com problemas similares que tenha resolvido?  Ou mesmo sugestões?
« Última modificação: 29 de Julho de 2017, 23:37 por paiakan »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.677
    • Ver perfil
Re:Problemas com o Anki
« Resposta #1 Online: 29 de Julho de 2017, 18:39 »
Bug já reportado e solução já apresentada: https://bugs.launchpad.net/ubuntu/+source/anki/+bug/1633737

É a versão do Python que faz ele não funcionar!

Tenha os repositórios universe e updates universe ativos e instale os seguintes pacotes:

python-qt4=4.11.4+dfsg-1build4

python-qt4-sql=4.11.4+dfsg-1build4


Reinstale a versão mais nova que você baixou e tente abrí-lo novamente!
Linux Mint 19.3 XFCE

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Problemas com o Anki
« Resposta #2 Online: 29 de Julho de 2017, 19:14 »
Bug já reportado e solução já apresentada: https://bugs.launchpad.net/ubuntu/+source/anki/+bug/1633737
É a versão do Python que faz ele não funcionar!
Tenha os repositórios universe e updates universe ativos e instale os seguintes pacotes:
python-qt4=4.11.4+dfsg-1build4
python-qt4-sql=4.11.4+dfsg-1build4

Reinstale a versão mais nova que você baixou e tente abrí-lo novamente!

Lá no relato do bug há quem fale afetando também o Zesty, 17.04.  :-\

Curioso, então a questão é hardware dependente, pois instalei aqui num live-iso 32-bit e também num 64-bit e em ambos instalou, sem nenhum erro na instalação pré-compilada e foi só chamar que funcionou de primeira.

Descompactou, entrou na pasta:

Código: [Selecionar]
cd anki-2.0.45/
Código: [Selecionar]
sudo make install
foi só fazer no terminal:

Código: [Selecionar]
anki
e partir pro abraço, funcionou de primeira, também na 32-bit

Embora não instale automaticamente, ele vem até com um arquivo de ícone de brinde anki.desktop.

É só copiar pra dentro do sistema e também funciona chamando pelo Dash

Código: [Selecionar]
sudo cp anki.desktop /usr/share/applications/
Bem, se não está indo mesmo então é experimentar essa alternativa de instalar o python conforme muito bem pesquisado e levantado pelo @galactus no post anterior, questão de ver.
« Última modificação: 29 de Julho de 2017, 23:22 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Problemas com o Anki
« Resposta #3 Online: 29 de Julho de 2017, 19:25 »
Na verdade fiz a conclusão eventualmente errada.  :-[

A versão do python pode ter se alterado entre a existente no live-iso e atualizações posteriores, também poderia ser isso.

No live-iso do 17.04 Zesty 32-bit o python propriamente dito é esse:

apt-cache policy python

python:
  Installed: 2.7.13-2
  Candidate: 2.7.13-2
  Version table:
 *** 2.7.13-2 500
        500 http://archive.ubuntu.com/ubuntu zesty/main i386 Packages
        100 /var/lib/dpkg/status

A biblioteca python-qt4 não vem instalada, apresenta isso:

apt-cache policy python-qt4

python-qt4:
  Installed: (none)
  Candidate: 4.11.4+dfsg-2
  Version table:
     4.11.4+dfsg-2 500
        500 http://archive.ubuntu.com/ubuntu zesty/universe i386 Packages

A python-qt4-sql igualmente não vem instalada:

apt-cache policy python-qt4-sql

python-qt4-sql:
  Installed: (none)
  Candidate: 4.11.4+dfsg-2
  Version table:
     4.11.4+dfsg-2 500
        500 http://archive.ubuntu.com/ubuntu zesty/universe i386 Packages




« Última modificação: 29 de Julho de 2017, 20:54 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline paiakan

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re:Problemas com o Anki
« Resposta #4 Online: 29 de Julho de 2017, 22:30 »
Obrigado pelas respostas, porém continua da mesma forma ao executar o ANKI depois de instalado conforme procedimento citado.

apt-cache policy python
python:
  Instalado: 2.7.13-2
  Candidato: 2.7.13-2
  Tabela de versão:
 *** 2.7.13-2 500
        500 http://br.archive.ubuntu.com/ubuntu zesty/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy python-qt4
python-qt4:
  Instalado: 4.11.4+dfsg-2
  Candidato: 4.11.4+dfsg-2
  Tabela de versão:
 *** 4.11.4+dfsg-2 500
        500 http://br.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status


apt-cache policy python-qt4-sql
python-qt4-sql:
  Instalado: 4.11.4+dfsg-2
  Candidato: 4.11.4+dfsg-2
  Tabela de versão:
 *** 4.11.4+dfsg-2 500
        500 http://br.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status


apt-cache policy anki
anki:
  Instalado: 2.0.45
  Candidato: 2.0.45
  Tabela de versão:
 *** 2.0.45 100
        100 /var/lib/dpkg/status
     2.0.32+dfsg-1 500
        500 http://br.archive.ubuntu.com/ubuntu zesty/universe i386 Packages


Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Problemas com o Anki
« Resposta #5 Online: 29 de Julho de 2017, 22:42 »
Obrigado pelas respostas, porém continua da mesma forma ao executar o ANKI depois de instalado conforme procedimento citado.

Então, @paiakan,

Quando fez a instalação pré-compilada usando o "make install", notou se retornou algum erro na execução da instalação?

Se o caso, faça novamente, não há incoveniente em reinstalar por cima, depois role a tela do terminal, com o mouse ou usando a tecla SHIFT + PageUP para ver o registro da instalação e se há alguma indicação de erro.

Como disse, aqui num live iso da versão 17.04 do Ubuntu 32-bit padrão (=Unity), funcionou de primeira.

Também, quando chama o programa a partir do terminal, dá alguma mensagem de retorno?
Se sim, copie e cole ela aqui no tópico.

« Última modificação: 29 de Julho de 2017, 23:19 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Problemas com o Anki
« Resposta #6 Online: 29 de Julho de 2017, 22:52 »
Apenas para termos certeza de que estamos fazendo a mesma coisa, baixando o mesmo arquivo (na verdade se está baixando o arquivo já pré-compilado), use essa forma para baixar e instalar:

Código: [Selecionar]
cd ~/Downloads
Código: [Selecionar]
wget -c https://apps.ankiweb.net/downloads/current/anki-2.0.45-i386.tar.bz2
Código: [Selecionar]
tar -jxvf anki-2.0.45-i386.tar.bz2
Depois siga exatamente os passos mencionados lá no post #2 para reinstalar o pacote pré-compilado.

Código: [Selecionar]
cd ~/Downloads/anki-2.0.45/
Código: [Selecionar]
sudo make install
Feita a reinstalação chame a partir do terminal:

Código: [Selecionar]
anki
Quaisquer mensagens de alerta ou erro são importantes, seja na instalação ou quando for chamar o programa depois de instalado.
« Última modificação: 29 de Julho de 2017, 23:21 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline paiakan

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re:Problemas com o Anki
« Resposta #7 Online: 29 de Julho de 2017, 23:37 »
Apenas para termos certeza de que estamos fazendo a mesma coisa, baixando o mesmo arquivo (na verdade se está baixando o arquivo já pré-compilado), use essa forma para baixar e instalar:

Código: [Selecionar]
cd ~/Downloads
Código: [Selecionar]
wget -c https://apps.ankiweb.net/downloads/current/anki-2.0.45-i386.tar.bz2
Código: [Selecionar]
tar -jxvf anki-2.0.45-i386.tar.bz2
Depois siga exatamente os passos mencionados lá no post #2 para reinstalar o pacote pré-compilado.

Código: [Selecionar]
cd ~/Downloads/anki-2.0.45/
Código: [Selecionar]
sudo make install
Feita a reinstalação chame a partir do terminal:

Código: [Selecionar]
anki
Quaisquer mensagens de alerta ou erro são importantes, seja na instalação ou quando for chamar o programa depois de instalado.


Funcionou! Obrigado!

Offline erisondutra

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re:Problemas com o Anki
« Resposta #8 Online: 28 de Julho de 2020, 11:57 »
Não estou conseguindo executar o áudio nos cartões. Diz que devo instalar e mp ou mpv player mas, quando instalo mesmo assim não funciona.

Offline creto

  • User BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 462
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Problemas com o Anki
« Resposta #9 Online: 28 de Julho de 2020, 19:49 »
Não estou conseguindo executar o áudio nos cartões. Diz que devo instalar e mp ou mpv player mas, quando instalo mesmo assim não funciona.

Você está usando o Anki?

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto