Autor Tópico: Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu [Resolvido]  (Lida 20592 vezes)

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #30 Online: 14 de Fevereiro de 2017, 23:41 »
Compare essas duas informações:

/dev/sda1: LABEL="Swap" UUID="8406bf11-70e0-47e4-8d51-62d3e2c12819" TYPE="swap" PARTUUID="0005ff15-01"

UUID=056f8c4e-385e-49a4-86b0-e40d1a53a10d none            swap    sw              0       0

A primeira é o blkid dizendo qual é o UUID da partição sda1 a qual corresponde à partição swap, que é o arquivo de troca.

Na segunda é como você disse (post #25) que está o seu arquivo assinalado no seu arquivo /etc/fstab essa mesma partição swap.

Desse modo não dá certo.

O seu arquivo /etc/fstab precisa ficar com aquele UUID da partição swap, então precisa ficar assim naquela linha:


UUID=8406bf11-70e0-47e4-8d51-62d3e2c12819 none            swap    sw              0       0


Faça a alteração, reinicie o sistema e verifique novamente.
« Última modificação: 14 de Fevereiro de 2017, 23:44 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Marciel Diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
    • www.alemblog.com.br
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #31 Online: 15 de Fevereiro de 2017, 00:03 »
Compare essas duas informações:

/dev/sda1: LABEL="Swap" UUID="8406bf11-70e0-47e4-8d51-62d3e2c12819" TYPE="swap" PARTUUID="0005ff15-01"

UUID=056f8c4e-385e-49a4-86b0-e40d1a53a10d none            swap    sw              0       0

A primeira é o blkid dizendo qual é o UUID da partição sda1 a qual corresponde à partição swap, que é o arquivo de troca.

Na segunda é como você disse (post #25) que está o seu arquivo assinalado no seu arquivo /etc/fstab essa mesma partição swap.


Desse modo não dá certo.

O seu arquivo /etc/fstab precisa ficar com aquele UUID da partição swap, então precisa ficar assim naquela linha:


UUID=8406bf11-70e0-47e4-8d51-62d3e2c12819 none            swap    sw              0       0


Faça a alteração, reinicie o sistema e verifique novamente.


Problema da Swap ficou ok, maravilha, editei agora corretamente com as suas informações o arquivo fstab, quando ligo a máquina a swap já está ativa....... muito obrigado... pena que o problema do religamento continua, e é algo muito dificil pois já fiz de tudo sabe, pesquisei na net, tentei varios comandos de desligamento, e mexi na bios também.... engraçado que ao deixar um pen drive espetado (com uma iso qualquer nele) ele desliga normal.... muito estranho
"A  mensagem digna de ser Lida é a que procede de uma Vida com propósito"
Marciel Diniz

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #32 Online: 15 de Fevereiro de 2017, 00:19 »
[...] .. pena que o problema do religamento continua, e é algo muito dificil pois já fiz de tudo sabe, pesquisei na net, tentei varios comandos de desligamento, e mexi na bios também.... engraçado que ao deixar um pen drive espetado (com uma iso qualquer nele) ele desliga normal.... muito estranho

Então, "Marciel Diniz",

Como disse antes, essa questão no Acer Aspire v5-571 e não apenas nele é mesmo complicada.
Já conhecia o caso, mas faz muito tempo que não acompanho esse específico problema e não saberia dizer de antemão o estado da arte sobre esse assunto.

Vamos tentar examinar o caso, se assegure que o sistema esteja atualizado, depois traga algumas informações adicionais sobre o seu computador, instale o pacote inxi, caso já não esteja instalado:

Código: [Selecionar]
sudo apt install inxi
Depois faça o comando abaixo, com o mouse copie a saída e então cole o  resultado aqui no seu tópico:

Código: [Selecionar]
inxi -FxZ
Traga também o resultado para:

Código: [Selecionar]
lspci -nn
Código: [Selecionar]
lsusb
(Faça esse comando acima lsusb sem aquele pendrive espetado)

Código: [Selecionar]
cat /proc/cmdline


www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Marciel Diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
    • www.alemblog.com.br
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #33 Online: 15 de Fevereiro de 2017, 00:37 »
[...] .. pena que o problema do religamento continua, e é algo muito dificil pois já fiz de tudo sabe, pesquisei na net, tentei varios comandos de desligamento, e mexi na bios também.... engraçado que ao deixar um pen drive espetado (com uma iso qualquer nele) ele desliga normal.... muito estranho

Então, "Marciel Diniz",

Como disse antes, essa questão no Acer Aspire v5-571 e não apenas nele é mesmo complicada.
Já conhecia o caso, mas faz muito tempo que não acompanho esse específico problema e não saberia dizer de antemão o estado da arte sobre esse assunto.

Vamos tentar examinar o caso, se assegure que o sistema esteja atualizado, depois traga algumas informações adicionais sobre o seu computador, instale o pacote inxi, caso já não esteja instalado:

Código: [Selecionar]
sudo apt install inxi
Depois faça o comando abaixo, com o mouse copie a saída e então cole o  resultado aqui no seu tópico:

Código: [Selecionar]
inxi -FxZ
Traga também o resultado para:

Código: [Selecionar]
lspci -nn
Código: [Selecionar]
lsusb
(Faça esse comando acima lsusb sem aquele pendrive espetado)

Código: [Selecionar]
cat /proc/cmdline

Blz ai vai então o primeiro resultado:
@MarcielDiniz:~$ inxi -FxZ
System:    Host: MarcielDiniz Kernel: 4.9.0-040900-generic x86_64 (64 bit gcc: 6.2.0)
           Desktop: Unity 7.4.0 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Ubuntu 16.04 xenial
Machine:   System: Acer (portable) product: Aspire V5-571 v: V2.15
           Mobo: Acer model: Aspire V5-571 v: V2.15
           Bios: Phoenix v: V2.15 date: 12/21/2012
CPU:       Dual core Intel Core i5-3337U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7183
           clock speeds: max: 2700 MHz 1: 801 MHz 2: 804 MHz 3: 802 MHz
           4: 804 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.9.0-040900-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 02:00.2
           IF: enp2s0f2 state: down mac: 20:6a:8a:f7:be:50
           Card-2: Qualcomm Atheros AR9462 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: b8:76:3f:0a:e6:93
Drives:    HDD Total Size: 500.1GB (22.6% used)
           ID-1: /dev/sda model: Hitachi_HTS54505 size: 500.1GB temp: 39C
Partition: ID-1: / size: 455G used: 102G (24%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 4.22GB used: 0.00GB (0%) fs: swap dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.0C mobo: 49.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 257 Uptime: 19 min Memory: 1052.4/3748.7MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35

O SEGUNDO RESULTADO:

@MarcielDiniz:~$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.2 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 [8086:1e14] (rev c4)
00:1c.3 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 [8086:1e16] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM77 Express Chipset LPC Controller [8086:1e57] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411 PCI Express Card Reader [10ec:5289] (rev 01)
02:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0a)
03:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adapter [168c:0034] (rev 01)

O TERCEIRO RESULTADO:

lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0489:e04e Foxconn / Hon Hai
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 064e:e330 Suyin Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

O QUARTO RESULTADO

 cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.9.0-040900-generic root=UUID=e9c86fb7-ce29-482d-a810-61bae3eb7374 ro quiet splash vt.handoff=7

tA AI...

Olha amigão tem um camarada da comunidade que sugeriu um Script para desligar os usbs antes de desligar o sistema... olha só:
criei esse documento gedit na area de trabalho com o nome poweroff: dentro dele:
#! /bin/bash

for i in /sys/bus/usb/devices/*/power/control;
    do echo on > $i
done

Pelo terminal executei esse arquivo... e desliguei... cara não ligou mais incrível: só que agora estou tentando achar um jeito de executar o script automaticamente, o que você acha brother dessa informação unida a essas ai de cima?


« Última modificação: 15 de Fevereiro de 2017, 01:23 por Marciel Diniz »
"A  mensagem digna de ser Lida é a que procede de uma Vida com propósito"
Marciel Diniz

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #34 Online: 15 de Fevereiro de 2017, 02:02 »
Olha amigão tem um camarada da comunidade que sugeriu um Script para desligar os usbs antes de desligar o sistema... olha só:
criei esse documento gedit na area de trabalho com o nome poweroff: dentro dele:
#! /bin/bash

for i in /sys/bus/usb/devices/*/power/control;
    do echo on > $i
done

Pelo terminal executei esse arquivo... e desliguei... cara não ligou mais incrível: só que agora estou tentando achar um jeito de executar o script automaticamente, o que você acha brother dessa informação unida a essas ai de cima?

Muito bom, bastante interessante, ia sugerir que desligasse o wireless antes de fazer o shutdown, o que seria uma outra hipótese, mas se esse aí funcionou, melhor ainda, importa é que resolva de uma forma razoavelmente prática.  :)

Já que criou o script, então para ficar mais fácil crie um ícone no desktop que clicado faça o desligamento.
Também pode pensar em colocar no próprio script, acrescentando uma linha, a chamada para desligar.

Código: [Selecionar]
shutdown -h now
Como o shutdown também precisa do sudo e o sudo não pode ser colocado dentro do script, caso funcione vai precisar autorizar a execução no sudoers.
Lembre-se sempre que o sudoers não pode ser editado diretamente, um erro pode tornar seu sistema inacessível.

De toda forma melhore o script e faça o teste chamando inicialmente por linha de comando, se funcionar (e não vejo porque não deveria funcionar) aí é só aperfeiçoar o restante.

Isso quer dizer que nesse pŕimeiro momento precisa chamar o script no terminal usando o sudo, certo?

sudo ./nome_do_script

 (um ponto antes da barra)

ou então:

/bin/bash nome_do_script

Funcionou autoriza no sudoers

Funcionou faz um ícone para o desktop, na área de trabalho.

Depois pode se pensar em voos mais altos.



« Última modificação: 15 de Fevereiro de 2017, 02:38 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Marciel Diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
    • www.alemblog.com.br
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #35 Online: 15 de Fevereiro de 2017, 07:56 »
Olha amigão tem um camarada da comunidade que sugeriu um Script para desligar os usbs antes de desligar o sistema... olha só:
criei esse documento gedit na area de trabalho com o nome poweroff: dentro dele:
#! /bin/bash

for i in /sys/bus/usb/devices/*/power/control;
    do echo on > $i
done

Pelo terminal executei esse arquivo... e desliguei... cara não ligou mais incrível: só que agora estou tentando achar um jeito de executar o script automaticamente, o que você acha brother dessa informação unida a essas ai de cima?

Muito bom, bastante interessante, ia sugerir que desligasse o wireless antes de fazer o shutdown, o que seria uma outra hipótese, mas se esse aí funcionou, melhor ainda, importa é que resolva de uma forma razoavelmente prática.  :)

Já que criou o script, então para ficar mais fácil crie um ícone no desktop que clicado faça o desligamento.
Também pode pensar em colocar no próprio script, acrescentando uma linha, a chamada para desligar.

Código: [Selecionar]
shutdown -h now
Como o shutdown também precisa do sudo e o sudo não pode ser colocado dentro do script, caso funcione vai precisar autorizar a execução no sudoers.
Lembre-se sempre que o sudoers não pode ser editado diretamente, um erro pode tornar seu sistema inacessível.

De toda forma melhore o script e faça o teste chamando inicialmente por linha de comando, se funcionar (e não vejo porque não deveria funcionar) aí é só aperfeiçoar o restante.

Isso quer dizer que nesse pŕimeiro momento precisa chamar o script no terminal usando o sudo, certo?

sudo ./nome_do_script

 (um ponto antes da barra)

ou então:

/bin/bash nome_do_script

Funcionou autoriza no sudoers

Funcionou faz um ícone para o desktop, na área de trabalho.

Depois pode se pensar em voos mais altos.

Verdade dá pra fazer um ícone. Quando eu chamo pelo terminal funciona blz.... Mas como eu posso criar um ícone que var executar o script e dar shutdown ao mesmo tempo, você poderia me explicar??? Obrigado pela grande força...
"A  mensagem digna de ser Lida é a que procede de uma Vida com propósito"
Marciel Diniz

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu [Resolvido]
« Resposta #36 Online: 17 de Fevereiro de 2017, 00:00 »
Tirando uma dúvida, como #root, traga o resultado do comando abaixo:

sudo su    #fica root

Código: [Selecionar]
for f in /sys/bus/usb/devices/*/power/control; do ls $f&&cat $f; done
e ainda:

Código: [Selecionar]
ls /sys/bus/usb/devices


Como sempre, para evitar-se erros de retranscrição, ao invés de digitar, melhor copiar com o mouse, colar no terminal e <enter>
« Última modificação: 17 de Fevereiro de 2017, 00:04 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mario Limão

  • Usuário Ubuntu
  • *
  • Mensagens: 128
  • Gremista, Arquiteto, Monarquista-Absolutista
    • Ver perfil
Re:Removi WIndows e deixei somente o Ubuntu mas o Grub Sumiu e já tentei de Tudo
« Resposta #37 Online: 22 de Fevereiro de 2017, 12:35 »

Muito bom, bastante interessante, ia sugerir que desligasse o wireless antes de fazer o shutdown, o que seria uma outra hipótese,
mas se esse aí funcionou, melhor ainda, importa é que resolva de uma forma razoavelmente prática.  :)

Quando eu chamo pelo terminal funciona blz ... ??? ... Obrigado pela grande força...

Marciel Diniz, cadê vc?
Conclua, por favor.
Até.
Ubuntu 14.04.5-LTS;  Desktop Amazon; Intel Core 2 Duo CPU E4500 @ 2.20 GHz x2; 4 GB; Intel 945Gx86/MM/SSE2; 32-Bit; 160GB.

Offline Marciel Diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
    • www.alemblog.com.br
Re:Problema do Grub [Resolvido] - Problema do Religamento do Acer V5 Ok Leiam
« Resposta #38 Online: 22 de Fevereiro de 2017, 13:09 »
  :D

Muito bom, bastante interessante, ia sugerir que desligasse o wireless antes de fazer o shutdown, o que seria uma outra hipótese,
mas se esse aí funcionou, melhor ainda, importa é que resolva de uma forma razoavelmente prática.  :)

Quando eu chamo pelo terminal funciona blz ... ??? ... Obrigado pela grande força...

Marciel Diniz, cadê vc?
Conclua, por favor.
Até.

O problema do grub resolvemos mais fácil, porém o religamento após o shutdown, sempre recorria. Tentei por dias e dias junto a comunidade em seguida mostro como resolvemos... penso que vale  a pena alguém fazer um totorial sobre isso pois essas dicas foram criadas pela comunidade, e deu certo!!! segue:


Então eu resolvi o problema com os scripts que criamos junto com os meninos da comunidade Ubuntu Brasil (grupo Telegram).... Como disse para o "druidaobelix":

#! /bin/sh

for i in /sys/bus/usb/devices/*/power/control;
    do echo on > $i
done


Esses dados dentro do gedit salvo dentro da pasta  /usr/bin salvo como usbpoweroff (porque descobrimos que o problema era o usb, o segundo para ser específico,Um problema que está recorrente neste modelo de notebook Acer V5,  precisávamos desligar a porta usb antes do sistema executar Shutdowne esse script faz isso)
Deu certo o pc desligou e não acordou sozinho, porém quando eu voltei e desliguei ele voltou a religar o que deduzimos o sistema não executava o script automaticamente - criamos um meio de ele executar automaticamente sempre, com esse arquivo gedit salvo em etc/systemd/system: (com o nome de usbpoweroff.device)

[Unit]
Description=USB Poweroff
DefaultDependencies=no
Before=shutdown.target

[Service]
ExecStart=/usr/bin/usbpoweroff
Type=oneshot

RemainAfterExit=yes

[Install]
WantedBy=shutdown.target

Assim conseguimos manter o processo reexecutando sempre.
Problema resolvido!
Obrigado participe desse grupo pessoal muito prestativo e fera:

https://t.me/UbuntuBrasilOficial

Um Grupo dedicado a resolver os conflitos e trocar ideias sobre o Ubuntu!
Valew

« Última modificação: 22 de Fevereiro de 2017, 13:15 por Marciel Diniz »
"A  mensagem digna de ser Lida é a que procede de uma Vida com propósito"
Marciel Diniz