Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 1210782 vezes)

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #765 Online: 16 de Dezembro de 2008, 19:25 »
Ok Alarcon, segue o que apareceu via terminal:

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root     10241  2.6  0.6   3180  3180 ?        SL   21:11   0:16 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0
root     10569  0.0  0.1   3020   752 pts/0    D+   21:22   0:00 grep slmodemd

e o meu modem é o smartlink motorola...

 ;)
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #766 Online: 16 de Dezembro de 2008, 21:28 »
Ok Alarcon, segue o que apareceu via terminal:

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root     10241  2.6  0.6   3180  3180 ?        SL   21:11   0:16 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0
root     10569  0.0  0.1   3020   752 pts/0    D+   21:22   0:00 grep slmodemd

e o meu modem é o smartlink motorola...

 ;)

Bem pelo relatado por você era para funcionar também, pois seu modem é o mesmo que o do colega que relatou sucesso e no seu caso o driver Smartlink é usado da forma padrão como posso ver por essa linha:

Citar
root     10241  2.6  0.6   3180  3180 ?        SL   21:11   0:16 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0

Veja se você instalou direito o Ubuntu 8.10 que tem de ser o 32bits e se depois o último pacote v27 foi usado corretamente. É necessário reiniciar o PC para só então tentar a conexão.

Também gostaria de saber se você checou a integridade da ISO, se vc baixou da internet e não recebeu o CD do Ubuntu, pois pode ser que sua cópia do Ubuntu 8.10 Intrepid Ibex 32bits esteja com algum problema.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #767 Online: 16 de Dezembro de 2008, 21:40 »
Fiz tudo direitinho mas deu um erro aki.
Alguém sabe me dizer o que é isso??

" root@gabriel-desktop:/home/gabriel/modem-arquivos-v27# ./install-modem_Gnome
No protocol specified

(zenity:8742): Gtk-WARNING **: cannot open display: :0.0
 A instalação foi Abortada! "

Aguardo  ;D

É o seguinte, eu criei um script (roteiro) que fizesse os passos necessários para a ativação do modem, que usa o driver smartlink, de uma forma automática, mas esse script precisa interagir com o usuário no momento da instalação por que alguns dados somente o usuário é quem pode fornecer. Como sei que os usuários, iniciante principalmente, são aversos ao uso do terminal, eu elaborei o script de uma forma que apresentasse janelas gráficas para esta interação com o usuário, só que elas são feitas com o zenity e pelo que vejo pela sua resposta algo não está aceitando abrir as janelas gráficas do zenity chamadas pelo terminal. Nunca houve este tipo de erro relatado por você durante todo o tempo que elaboro o script para ativação do modem no Ubuntu e isso já faz algum tempo.

Veja também que outros usuários acabaram de usar o mesmo pacote que você e nenhum deles relatou tal erro, sendo que um fez o modem funcionar e o outro ainda não.

Tudo está me levando a crer que o problema seria com sua instalação do Ubuntu, já que você diz ter feito tudo conforme explicado no meu pacote, então te pergunto como você obteve sua versão do Ubuntu?

Você baixou a ISO do Ubuntu da internet, mas antes de gravar num CD teve o cuidado de checar o md5sum da cópia baixada para ver se ele não chegou corrompida? Isso é muito importante de se fazer por que  caso a mesma tenha chegado com algum tipo de problema, seu sistema pode falhar em algum ponto.

Offline gabriel_leitzke

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #768 Online: 17 de Dezembro de 2008, 09:00 »
como que eu posso checar a iso?
posso reinstalar n tem problema...

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #769 Online: 17 de Dezembro de 2008, 09:57 »
Alarcon, eu recebi o cd do ubuntu da canonical, fiz o pedido e eles enviaram-me pelo correio...creio que seja o de 32 bits, chegando em casa vou verificar...ontém eu fiz a instalação padrão e após isso instalei o drive do modem do jeito que vc orienta e também reiniciei a máquina... ???
Apenas como informação: ao instalar o 8.04 via live-cd eu instalo o drive do modem e não preciso reiniciar a máquina, ele funciona direto... :-\
To ficando desiludido do 8.10...hahaha, enquanto isso o 8.04 roda tranquilo.
« Última modificação: 17 de Dezembro de 2008, 11:03 por cris.tom »
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #770 Online: 17 de Dezembro de 2008, 10:47 »
como que eu posso checar a iso?
posso reinstalar n tem problema...

Quando você baixa a ISO do Ubuntu, no mesmo local tem um arquivo de texto com a palavra md5sum alguma coisa no nome (não lembro de cabeça agora exatamente o nome desse arquivo de texto) que contém uns códigos de todas as versões do Ubuntu disponível para downloads naquela página.

Depois de baixado você usa um comando via terminal, no linux, ou um programa, via windows, que chega a ISO e retorna um código aí vc comparar com esse que você baixou junto com a ISO. Se forem iguais, ótimo, seu download chegou perfeito, ou seja, sem nenhum corrompimento e você poderá gravar no CD.

Sugiro que quando você for fazer o download da ISO pelo windows não utilize aqueles programas de aceleração de downloads que dividem o mesmo em várias partes, pois isso geralmente pode ocasionar corrompimento. Se possível baixe por torrent que é melhor.

Se você realmente baixou a ISO do Ubuntu 8.10 e tem ela na sua partição do windows, transfira para a partição do Ubuntu colocando na sua pasta de usuário, dentro da pasta home, depois abra um terminal (menu Aplicações > Acessórios > Consola ou Terminal) e digite:

md5sum ubuntu-8.10-rc-desktop-i386.iso (o nome da ISO mostrado aqui é só um exemplo, portanto mude para o adequado)

aguarde uns segundos que este comando retornará o código da ISO, por exemplo:

cc3942020f4ff88a0fadc648a7368354  ubuntu-8.10-rc-desktop-i386.iso

aí vc compara com o do arquivo de texto presente no mesmo local de onde vc baixou a ISO.


A questão do reinstalar é só para o caso de ter ocorrido alguma falha durante o processo de instalação do CD para o HD que possa ter corrompido algum arquivo, mas se sua ISO realmente estiver com o md5sum alterado, esta reinstalação não irá alterar nada, entretanto não custa tentar a reinstalação já que como vc não tem nada ainda instalado no seu Ubuntu, não perderá muita coisa além do que aquilo que se instala pelo próprio CD de instalação.
« Última modificação: 17 de Dezembro de 2008, 11:00 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #771 Online: 17 de Dezembro de 2008, 11:03 »
Alarcon, eu recebi o cd do ubuntu da canonical, fiz o pedido e ele enviaram-em pelo correio...creio que seja o de 32 bits, chegando em casa vou verificar...ontém eu fiz a instalação padrão e após isso instalei o drive do modem do jeito que vc orienta e também reiniciei a máquina... ???
Apenas como informação: ao instalar o 8.04 via live-cd eu instalo o drive do modem e não preciso reiniciar a máquina, ele funciona direto... :-\
To ficando desiludido do 8.10...hahaha, enquanto isso o 8.04 roda tranquilo.

Ok, só é muito estranho que o mesmo modem funcione para uns e para outros não, se fossem modens diferentes eu nem dizia nada.

Para não lhe dar trabalho vou deixar quieto ;), mas quando deu o erro e antes de você voltar para o Ubuntu que funciona eu queria ter sabido de alguma informações tipo o resultado dos comandos:

ps -aux | grep slmodemd

dmesg | grep slamr

lsmod

sudo /etc/initd.d/sl-modem-daemon restart


e etc.

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #772 Online: 17 de Dezembro de 2008, 11:09 »
Hoje à tarde em casa vou fazer a verificação via terminal usando os comando deixados por ti...

Uma obs.: Após ter instalado os drivers no 8.10 apareceu uma mensagem dizendo que não havia sido possível encontrar o modem...isso quando eu clicava no Gnome-ppp...inclusive eu digitei via terminal o último comando postado por ti "sudo /etc/initd.d/sl-modem-daemon restart" e não houve mudança.
« Última modificação: 17 de Dezembro de 2008, 11:11 por cris.tom »
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #773 Online: 17 de Dezembro de 2008, 11:15 »
Hoje à tarde em casa vou fazer a verificação via terminal usando os comando deixados por ti...

Uma obs.: Após ter instalado os drivers no 8.10 apareceu uma mensagem dizendo que não havia sido possível encontrar o modem...isso quando eu clicava no Gnome-ppp...inclusive eu digitei via terminal o último comando postado por ti "sudo /etc/initd.d/sl-modem-daemon restart" e não houve mudança.

Ok, caso continuasse a dar os mesmos erros, gostaria que vc fizesse isso:

sudo /etc/init.d/sl-modem-daemon stop

sudo mknod -m 600 /dev/slamr0 c 242 0

sudo modprobe ungrab-winmodem

sudo modprobe slamr

sudo /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0


e depois tentasse usar o discador gnome-ppp.

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #774 Online: 17 de Dezembro de 2008, 17:45 »
Reinstalei o 8.10 e instalei o seu pacote modem-arquivos-v27...no final da instalação apareceu a seguinte mensagem:

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... none found.
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080817|Sl-Modem-Daemon|Dialup

e quando fui tentar conectar apareceu novamente dizendo que o modem não fora encontrado...

Fico no aguardo...brigadão!   :)
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #775 Online: 17 de Dezembro de 2008, 17:50 »
Depois vou apagar...é muita coisa:

root@linux:/home/alvins# sudo /etc/init.d/sl-modem-daemon stop
Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... snd_atiixp_modem.
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins# sudo mknod -m 600 /dev/slamr0 c 242 0
mknod: `/dev/slamr0': O arquivo já existe
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins# sudo modprobe ungrab-winmodem
FATAL: Module ungrab_winmodem not found.
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins# sudo modprobe slamr
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins#
root@linux:/home/alvins# sudo /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0


Você está tentando ativar o modem com o meu pacote modem-arquivos-v27.tar.gz no Ubuntu 8.10 Intrepid Ibex 32bits na forma LiveCD ou com ele instalado no HD?

Pergunto isso por que pelo que estou vendo nos seus resultados o pacote não foi instalado, pois veja:

pelo comando lsmod (listar módulos) não é apresentado os módulos:

- slamr
- ungrab_winmodem

então após instalar o pacote modem-arquivos-v27.tar.gz, gostaria que você verificasse se em:

/lib/modules/2.6.27-7-generic/extra existem os arquivos slmar.ko e ungrab-winmodem.ko

/usr/sbin existe o arquivo slmodemd

/etc/init.d/ existe o script sl-modem-daemon


por esse erro aqui:

Citar
root@linux:/home/alvins# sudo mknod -m 600 /dev/slamr0 c 242 0
mknod: `/dev/slamr0': O arquivo já existe

deu para saber que o slamr0 em /dev já havia sido criado não sendo necessário a sua criação.


por esse erro aqui:

Citar
root@linux:/home/alvins# sudo /etc/initd.d/sl-modem-daemon restart
sudo: /etc/initd.d/sl-modem-daemon: command not found

dá a entender que o script sl-modemd-daemon não foi instalado, indicando que o meu pacote não foi instalado corretamente.


Outra dúvida é que pelo comando lsmod, é apresentado isso aqui (dentre outras coisas):

Citar
snd_atiixp_modem       20360  0
snd_via82xx_modem      19464  0
snd_intel8x0m          22412  0

mas para usar o driver do modem da forma tradicional (não a forma ALSA) não era para estes módulos estarem carregados, pois eles são necessários somente para o caso de se usar o driver smartlink na forma ALSA e o que é mais estanho você tem os 3 ativos quando deveria se ter só um deles e qual seria ia depender de sua placa de som.


Há uma grande inconsistência/incoerência nos dados apresentados por você.



Driver Smartlink na forma padrão de uso:

Cria o módulo slmar.ko e o executável slmodemd que são usados e a verificação dele ativo e funcionando pelo comando ps -aux | grep slmodemd seria + ou - assim:
Citar
4255 ?        SL     7:31 /usr/sbin/slmodemd --perm=0666 --country=BRAZIL /dev/slamr0



Driver Smartlink na forma ALSA de uso:

Cria somente o executável slmodemd mas usa um dos seguintes módulos, presente no seu Ubuntu: snd_atiixp_modem ou snd_via82xx_modem ou snd_intel8x0m e não os 3 e isso dependendo da sua placa de som.

A verificação dele ativo e funcionando pelo comando ps -aux | grep slmodemd seria + ou - assim:

Citar
3944 ?        SLs    0:00 /usr/sbin/slmodemd --alsa --perm=0666 -c BRAZIL modem:0

ou

3944 ?        SLs    0:00 /usr/sbin/slmodemd --alsa --perm=0666 -c BRAZIL modem:1

ou

3944 ?        SLs    0:00 /usr/sbin/slmodemd --alsa --perm=0666 -c BRAZIL hw:0

ou

3944 ?        SLs    0:00 /usr/sbin/slmodemd --alsa --perm=0666 -c BRAZIL hw:1
« Última modificação: 17 de Dezembro de 2008, 18:22 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #776 Online: 17 de Dezembro de 2008, 18:00 »
Reinstalei o 8.10 e instalei o seu pacote modem-arquivos-v27...no final da instalação apareceu a seguinte mensagem:

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... none found.
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080817|Sl-Modem-Daemon|Dialup

e quando fui tentar conectar apareceu novamente dizendo que o modem não fora encontrado...

Fico no aguardo...brigadão!   :)

Só vi este seu texto depois que escrevi meu último texto, portanto peço para que veja esta informações aqui para mim:

então após instalar o pacote modem-arquivos-v27.tar.gz, gostaria que você verificasse se em:

/lib/modules/2.6.27-7-generic/extra existem os arquivos slmar.ko e ungrab-winmodem.ko

/usr/sbin existe o arquivo slmodemd

/etc/init.d/ existe o script sl-modem-daemon
« Última modificação: 17 de Dezembro de 2008, 18:21 por alarcon »

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #777 Online: 17 de Dezembro de 2008, 21:17 »
Resultado dos códigos:

alvins@linux1:~$ /lib/modules/2.6.27-7-generic/extra existem os arquivos slmar.ko e ungrab-winmodem.ko
bash: /lib/modules/2.6.27-7-generic/extra: Permissão negada
alvins@linux1:~$
alvins@linux1:~$ /usr/sbin existe o arquivo slmodemd
bash: /usr/sbin: é um diretório
alvins@linux1:~$
alvins@linux1:~$ /etc/init.d/ existe o script sl-modem-daemon
bash: /etc/init.d/: é um diretório


ESSES ABAIXO SURGIRAM ASSIM QUE DEI O COMANDO PARA RESTARTAR O DISCADOR:



root@linux1:/home/alvins# sudo /etc/init.d/sl-modem-daemon restart
Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... snd_atiixp_modem.
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

Eu estou com o 8.10 instalado...e através do live-CD conecto na internet...sempre que tenho que conectar faço todo o processo de instalação do drive...rs
« Última modificação: 17 de Dezembro de 2008, 21:32 por cris.tom »
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #778 Online: 17 de Dezembro de 2008, 21:34 »
Resultado dos códigos:

alvins@linux1:~$ /lib/modules/2.6.27-7-generic/extra existem os arquivos slmar.ko e ungrab-winmodem.ko
bash: /lib/modules/2.6.27-7-generic/extra: Permissão negada
alvins@linux1:~$
alvins@linux1:~$ /usr/sbin existe o arquivo slmodemd
bash: /usr/sbin: é um diretório
alvins@linux1:~$
alvins@linux1:~$ /etc/init.d/ existe o script sl-modem-daemon
bash: /etc/init.d/: é um diretório


ESSES ABAIXO SURGIRAM ASSIM QUE DEI O COMANDO PARA RESTARTAR O DISCADOR:



root@linux1:/home/alvins# sudo /etc/init.d/sl-modem-daemon restart
Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... snd_atiixp_modem.
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

faz o seguinte, abre o terminal e digita:

sudo gedit /etc/modprobe.d/blacklist-modem

quando abrir o arquivo blacklist-modem você descomenta as linhas:

Citar
# blacklist snd-atiixp-modem
# blacklist snd-intel8x0m
# blacklist snd-via82xx-modem

Descomentar é retirar o símbolo # do início de cada linha ok.

O resultado final do arquivo blacklist-modem seria esse:

Citar
# Uncomment these entries in order to blacklist unwanted modem drivers
blacklist snd-atiixp-modem
blacklist snd-intel8x0m
blacklist snd-via82xx-modem

Estou pedindo isso para que este módulos (snd-atiixp-modem, snd-intel8x0m e snd-via82xx-modem) não sejam mais carregados no boot.

Aí depois vc faz o seguinte:

- reinicia o PC
- sudo /etc/init.d/sl-modem-daemon stop
- sudo modprobe -r slamr
- sudo modprobe -r ungrab-winmodem

e depois reinstala o pacote modem-arquivos-v27.tar.gz e reinicia o PC e só então tenta a conexão pelo gnome-ppp. Esses procedimentos para o Ubuntu 8.10 instalado no HD.

Não se preocupe com qualquer mensagem de erro dos comandos acima ok.

« Última modificação: 17 de Dezembro de 2008, 21:39 por alarcon »

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #779 Online: 17 de Dezembro de 2008, 22:10 »
Fiz o que vc falou, mas ainda naum deu certo...

verifiquei os arquivos,

/lib/modules/2.6.27-7-generic/extra existem os arquivos slmar.ko e ungrab-winmodem.ko  (NÃO EXITEM) - Na verdade o extra é uma espécie de arquivo texto.

/usr/sbin existe o arquivo slmodemd (EXISTE)

/etc/init.d/ existe o script sl-modem-daemon (EXISTE)
Linux, uma questão de filosofia!