Autor Tópico: Instalando driver ATI com suporte ao AIGLX  (Lida 84366 vezes)

Offline odrande

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #30 Online: 13 de Novembro de 2007, 00:52 »
faco exatamente conforme o artigo, porem olha a resposta qdo digito o ultimo comando


$ SKIP_CHECKS=yes compiz
Checking for Xgl: not present.
No whitelisted driver found
SKIP_CHECKS is yes, so continuing despite problems.
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1024x768) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format


oq isso ker dizer ?

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #31 Online: 16 de Novembro de 2007, 22:14 »
Segui estrita/ os passos dessa dica p/ o Ubuntu Gusty Gibbon, encontrada no fórum internacional do Ubuntu:

Citar
Well, let's try here and see if I can help you... If yes, I will create a Wiki page.

Before we begin -- supported hardware list

Taken from fglrx driver description for Gutsy.

This version of the ATI driver officially supports:

* FireGL: V7350, V7300, V7200, V7100, V5200, V5100, V5000, V3400,
V3300, V3200, V3100, X3-256, X3, X2-256, Z1-128, T2-128,
X1-128, X1-256p
* FireMV: 2200 (Single card PCI-e configuration)
* Mobility FireGL: V5000, T2
* Mobility Radeon: X1800, X1600, X1400, X1300, X800, X700, X600, X300,
9800, 9600, 9550, 9500
* Radeon Xpress: 200M series, 1250 IGP, 200 series
* Radeon: X1900, X1800, X1600, X1300, X850, X800, X700, X600, X550,
X300, 9800, 9700, 9600, 9550, 9500

ATI All-in-Wonder variants of the above cards/chips are also supported,
but video capture is not.

If you are doing fresh install of Gutsy

   1. Enable fgrlx driver.

      Install linux-restricted-modules and restricted-manager provied in the restricted repositories:
      Code:

      sudo apt-get update
      sudo apt-get install linux-restricted-modules-generic restricted-manager

      Open the restricted drivers manager in "System -> Administration -> Restricted Drivers Manager" and select "ATI accelerated graphics driver".
   2. Install xserver-xgl package
      Code:

      sudo apt-get install xserver-xgl

   3. Install compiz
      Code:

      sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0

   4. Reboot
   5. Log in. 3D effects should be enabled!
   6. Customize Compiz Fusion.
      Select System → Preferences → Advanced Desktop Effects Settings
      In the new window, General Options → Desktop Size → Horizontal Virtual Size. Set it to 4.
      The other two options have to be left at 1.

      Continue customization per Forlong's guide at http://forlong.blogage.de/article/20...-Compiz-Fusion

Fonte: http://ubuntuforums.org/showthread.php?t=569654&highlight=x300+gutsy

Final/ a minha ATI Radeon x300 PCIE passou a ter o 3d e também o famoso Compiz Fusion.
A única coisa que está pegando é a tela do login que está vindo em 1920x1080, e eu uso um monitor LCD 17'' c/ a resolução 11280x1024 c/ taxa de resolução de 60 Hz
Linux User #440843 | Ubuntu User #11469

kErNeL_sCrIpT

  • Visitante
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #32 Online: 17 de Novembro de 2007, 10:42 »
Acabei de ver que o kernel não foi compilado corretamente... acho que vou ter que instalar o driver manualmente... :'(
« Última modificação: 17 de Novembro de 2007, 10:49 por kErNeL_sCrIpT »

Offline technojeff

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #33 Online: 17 de Novembro de 2007, 15:02 »
Segui estrita/ os passos dessa dica p/ o Ubuntu Gusty Gibbon, encontrada no fórum internacional do Ubuntu:

Citar
Well, let's try here and see if I can help you... If yes, I will create a Wiki page.

Before we begin -- supported hardware list

Taken from fglrx driver description for Gutsy.

This version of the ATI driver officially supports:

* FireGL: V7350, V7300, V7200, V7100, V5200, V5100, V5000, V3400,
V3300, V3200, V3100, X3-256, X3, X2-256, Z1-128, T2-128,
X1-128, X1-256p
* FireMV: 2200 (Single card PCI-e configuration)
* Mobility FireGL: V5000, T2
* Mobility Radeon: X1800, X1600, X1400, X1300, X800, X700, X600, X300,
9800, 9600, 9550, 9500
* Radeon Xpress: 200M series, 1250 IGP, 200 series
* Radeon: X1900, X1800, X1600, X1300, X850, X800, X700, X600, X550,
X300, 9800, 9700, 9600, 9550, 9500

ATI All-in-Wonder variants of the above cards/chips are also supported,
but video capture is not.

If you are doing fresh install of Gutsy

   1. Enable fgrlx driver.

      Install linux-restricted-modules and restricted-manager provied in the restricted repositories:
      Code:

      sudo apt-get update
      sudo apt-get install linux-restricted-modules-generic restricted-manager

      Open the restricted drivers manager in "System -> Administration -> Restricted Drivers Manager" and select "ATI accelerated graphics driver".
   2. Install xserver-xgl package
      Code:

      sudo apt-get install xserver-xgl

   3. Install compiz
      Code:

      sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0

   4. Reboot
   5. Log in. 3D effects should be enabled!
   6. Customize Compiz Fusion.
      Select System → Preferences → Advanced Desktop Effects Settings
      In the new window, General Options → Desktop Size → Horizontal Virtual Size. Set it to 4.
      The other two options have to be left at 1.

      Continue customization per Forlong's guide at http://forlong.blogage.de/article/20...-Compiz-Fusion

Fonte: http://ubuntuforums.org/showthread.php?t=569654&highlight=x300+gutsy

Final/ a minha ATI Radeon x300 PCIE passou a ter o 3d e também o famoso Compiz Fusion.
A única coisa que está pegando é a tela do login que está vindo em 1920x1080, e eu uso um monitor LCD 17'' c/ a resolução 11280x1024 c/ taxa de resolução de 60 Hz

show de bola... com esses poucos passos consegui o compiz fusion no meu Micro...

muito obrigado pela dica...

Offline niltonpess

  • Usuário Ubuntu
  • *
  • Mensagens: 70
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #34 Online: 22 de Novembro de 2007, 08:49 »
Eu tenho o Ubuntu Studio instalado na minha máquina. Com o 7.04 eu usava o driver opensource sem problemas com aceleração 3D ativada. Atualizei ontem para o 7.10 e instalei o driver ATI sem problemas. Mas não consegui ativar a aceleração 3D nem ativar os efeitos do desktop. Simplesmente vem a mensagem em inglês "Não pode usar efeitos".

Tentei reinstalar o driver open source e deu a mensagem:

niltonpess@ubuntu:~$ glxinfo | grep "direct rendering"
Xlib:  extension "ATIFGLRXDRI" missing on display ":0.0".
Error: couldn't find RGB GLX visual
niltonpess@ubuntu:~$ sudo modprobe radeon
niltonpess@ubuntu:~$ sudo rmmod fglrx
ERROR: Module fglrx does not exist in /proc/modules
niltonpess@ubuntu:~$ sudo modprobe radeon
niltonpess@ubuntu:~$ lsmod | grep "radeon"
radeon                125472  2
drm                    83348  3 radeon
niltonpess@ubuntu:~$ sudo gedit /etc/modules
niltonpess@ubuntu:~$ sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
niltonpess@ubuntu:~$ sudo gedit /etc/X11/xorg.conf
niltonpess@ubuntu:~$ glxinfo | grep "direct rendering"
Xlib:  extension "ATIFGLRXDRI" missing on display ":0.0".
Error: couldn't find RGB GLX visual
niltonpess@ubuntu:~$

O que faço? Reinstalo o driver ATI e fico sem aceleração 3D ou tem como ativar? Reisntalo o driver opensource, mas como se faz para funcionar?

kErNeL_sCrIpT

  • Visitante
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #35 Online: 22 de Novembro de 2007, 10:09 »
Eu tenho o Ubuntu Studio instalado na minha máquina. Com o 7.04 eu usava o driver opensource sem problemas com aceleração 3D ativada. Atualizei ontem para o 7.10 e instalei o driver ATI sem problemas. Mas não consegui ativar a aceleração 3D nem ativar os efeitos do desktop. Simplesmente vem a mensagem em inglês "Não pode usar efeitos".

niltonpess, eu também uso o Ubuntu Studio 7.10, e cara, eu tive a maior dor de cabeça com isso também... quando eu usava o Ubuntu 7.04 o Driver proprietário funfava normal... mas quando fui tentar no Ubuntu Studio 7.10 não teve jeito, tentei pelo Envy, Tentei na "Raça" seguindo o Tuto desse tópico, mas sempre dava o mesmo erro e eu ficava sem o AIXGL e sem Compiz Fusion consequentemente... daí eu formatei umas duas vezes só pra tentar instalar esse Driver, mas não deu, daí eu instalei o Driver Restrito mesmo e sou feliz agora, mas eu não gosto muito do Compiz Fusion... então pra mim o suporte a AIXGL num faz diferença, o negócio é ter aceleração 3D pra que eu possa jogar e assistir meus vídeos com qualidade. Mas se você de tudo não conseguir resolver seu problema, então formate tudo, instale o Driver Restrito, e se você quiser o Compiz Fusion,vai ter que instalar o xserver-xgl, pra que o Compiz Fusion funcione, eu testei isso também, mas o sistema fica muito lerdo sem o Compiz Fusion, e já vi casos parecidos com o meu, então se pretende usar ele permanentemente, faça isso, se não, instale só o Driver restrito mesmo, ou continue tentanto o Driver proprietário, se conseguir poste aqui por favor :)

Cara, só mais uma coisa, o teu Ubuntu Studio 7.10 por acaso da uma Bug de vez em quando que você entra no sistema e ele não "Carrega" o GNOME? Tipo, da uma massagem de erro e você tem que encerrar o X pra tentar iniciar com o GNOME?

Abraço e até mais.
« Última modificação: 22 de Novembro de 2007, 10:18 por kErNeL_sCrIpT »

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #36 Online: 22 de Novembro de 2007, 10:18 »
niltonpess, dependendo de seu modelo de placa de vídeo ATI, siga estrita/ o tuto postado ai acima - http://ubuntuforum-br.org/index.php/topic,27077.msg162082.html#msg162082

Fiz o seguinte, por aqui, depois do Reboot, apliquei a última opção da tela Efeitos Visuais
Clique c/ botão direito no desktop > Alterar plano de fundo > Efeitos Visuais

Faça outro reboot.

Aqui veio uma msg de erro do GTK (Gnome), dei OK. O Sistema entrou mas c/ os icones de outro padrão. Dei novo Reboot e tudo voltou ao normal. Depois foi só brincar c/ o tal 3D e o Compiz Fusion.  ;D

Só veio um erro na tala de login - http://ubuntuforum-br.org/index.php?topic=28233.new;topicseen#new

Ontem dei uma executada na tela gráfica, na hora ñ funcionou

Código: [Selecionar]
sudo dpkg-reconfigure -phigh xserver-xorg
Hj, estranha/ a tela de login reapareceu normal  ::)

também apareceu o erro do GTK e que o drive proprietário ñ estava acionado. O ativei e repeti todos os reboot como citei acima e agora tá funcionando normal/, mas ainda estou vendo se real/ isso também se normalizou.
Linux User #440843 | Ubuntu User #11469

Offline niltonpess

  • Usuário Ubuntu
  • *
  • Mensagens: 70
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #37 Online: 22 de Novembro de 2007, 10:18 »
Para mim mais importante é a aceleração 3D. Posso dispensar o Fusion. Mas qual é a diferença entre o driver restrito e o proprietário? Para mim era a mesma coisa, diferente do opensource!
Como você resolveu o problema da aceleração 3D?

Não tive nenhum problema com o X até agora. Tudo inicia e roda tranqüilo, só falta a aceleração 3D.

Outra coisa: notei que esta nova versão do UbuntuStudio não traz o Scribus, tive de instalar depois da atualização. Como pode uma distro voltada para designers dispensar o Scribus, único programa de paginação no universo Linux?

kErNeL_sCrIpT

  • Visitante
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #38 Online: 22 de Novembro de 2007, 10:29 »
Para mim mais importante é a aceleração 3D. Posso dispensar o Fusion. Mas qual é a diferença entre o driver restrito e o proprietário? Para mim era a mesma coisa, diferente do opensource!
Como você resolveu o problema da aceleração 3D?

Não tive nenhum problema com o X até agora. Tudo inicia e roda tranqüilo, só falta a aceleração 3D.

Outra coisa: notei que esta nova versão do UbuntuStudio não traz o Scribus, tive de instalar depois da atualização. Como pode uma distro voltada para designers dispensar o Scribus, único programa de paginação no universo Linux?

Sério cara ??? O meu Ubuntu Studio 7.10 já vem com Scribus sim! O único trabalho que tive foi ter que instalar o openoffice-gtk e o openoffice-gnome que não vem por padrão, para que o OpenOffice se integre ao tema GTK do GNOME... mas fora isso ele veio com quase tudo que um artista tem direito...

niltonpess, o Driver proprietário é o feito pela própria ATI e nos oferece o Catalisty Control Center™ para um total controle da nossa placa ATI no Linux, essa GUI (Graphical User Interface = Interface Gráfica para Usuário) no Linux ainda é meio limitada.
Mas o Driver tem a mesma potência ou melhor que a versão do Windows™.

Já o Driver Open Source é construído pela Comunidade Linux, seguindo algumas especificações de Hardware que a ATI libera para nós, e é muito mais seguro e estável de usar e já vem por padrão no Linux.

Porém a versão do "Driver Restrito" , que é proprietário, (Sistema > Adiministração > Gerenciador de Drivers Restritos) ainda é antiga e não oferece suporte ao AIGLX, coisa que o Driver Proprietário atual oferece e é fundamental para rodar o Compiz Fusion.

Os os dois Drivers deveriam ofererecer aceleração 3D, mas nem sempre o Open Source cumpre bem essa função, aí entra o Driver Proprietário (o atual com o AIGLX) e precisa baixar do site da ATI e compilar, e o "Driver Restrito" (Antigo e sem suporte a AIGLX) que é Proprietário também, porém mais estável e seguro e dá pra instalar pelo Ubuntu mesmo (Sistema > Adiministração > Gerenciador de Drivers Restritos).

Espero ter explicado bem, agora cabe a você decidir o que fazer :)
« Última modificação: 22 de Novembro de 2007, 13:00 por kErNeL_sCrIpT »

Offline niltonpess

  • Usuário Ubuntu
  • *
  • Mensagens: 70
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #39 Online: 22 de Novembro de 2007, 10:37 »
Explicou bem kErNeL_sCrIpT!!!! Muito obrigado, mas...

A sua aceleração 3D está ativada? Quando instalei o Driver da ATI ela não foi ativada, apesar do painel de controle da ATI estar funcionando bem.

kErNeL_sCrIpT

  • Visitante
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #40 Online: 22 de Novembro de 2007, 10:39 »
Explicou bem kErNeL_sCrIpT!!!! Muito obrigado, mas...

A sua aceleração 3D está ativada? Quando instalei o Driver da ATI ela não foi ativada, apesar do painel de controle da ATI estar funcionando bem.

Opa, dei uma editada, te passei informção errada, desculpa, leia denovo por favor. Já já te respondo novamente.

EDIT:

niltonpess, o meu ta acelerando sim, meus vídeos tão incríveis! Eu intalei o sistema do zero denovo e instalei o Driver Restrito, só isso! Não gosto do Compiz Fusion, então o suporte a AIGLX não me faz falta nehuma, o negócio é acelerar hehehehe. E aqui veio o Scribus sim cara, a versão 1.3.3.9
« Última modificação: 22 de Novembro de 2007, 13:00 por kErNeL_sCrIpT »

Offline niltonpess

  • Usuário Ubuntu
  • *
  • Mensagens: 70
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #41 Online: 22 de Novembro de 2007, 12:35 »
Ontem, dia 21, saiu um novo driver da ATI, o 7.11. vou baixar e tentar com este e ver se há melhoras.

http://ati.amd.com/support/drivers/pt/linux/linux-radeon.html

O site fala:
Citar
1 - O driver de vídeo requer que a memória compartilhada POSIX esteja ativada no sistema.
2 - O pacote Kernel Source (código do kernel) não será mais necessário se o pacote Kernel Header (cabeçalho do kernel) estiver instalado.

O POSIX é ativado por default no Gibson?



kErNeL_sCrIpT

  • Visitante
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #42 Online: 22 de Novembro de 2007, 12:49 »
Ontem, dia 21, saiu um novo driver da ATI, o 7.11. vou baixar e tentar com este e ver se há melhoras.

http://ati.amd.com/support/drivers/pt/linux/linux-radeon.html

O site fala:
Citar
1 - O driver de vídeo requer que a memória compartilhada POSIX esteja ativada no sistema.
2 - O pacote Kernel Source (código do kernel) não será mais necessário se o pacote Kernel Header (cabeçalho do kernel) estiver instalado.

O POSIX é ativado por default no Gibson?


Opa que boa notícia niltonpess! Aqui esse maldito kernel source é que num compilava... quem sabe agora funfa. Ha, o nome é Gibbon X^D
Cara, eu também quero saber isso do POSIX :-\



EDIT:
Corrigindo, eu estava falando AIXGL quando o correto é AIGLX, peço desculpas pelo erro X^D Já corrigi.
« Última modificação: 22 de Novembro de 2007, 13:03 por kErNeL_sCrIpT »

Offline niltonpess

  • Usuário Ubuntu
  • *
  • Mensagens: 70
    • Ver perfil
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #43 Online: 29 de Novembro de 2007, 10:17 »
Instalei o novo driver 7.11 da ATI para minha Radeon 9600 e ele esta funcionando bem, mas a aceleração 3D não está ativada. Como faço para ativar a aceleração 3D neste driver?



kErNeL_sCrIpT

  • Visitante
Re: Instalando driver ATI com suporte ao AIGLX
« Resposta #44 Online: 29 de Novembro de 2007, 10:48 »
Instalei o novo driver 7.11 da ATI para minha Radeon 9600 e ele esta funcionando bem, mas a aceleração 3D não está ativada. Como faço para ativar a aceleração 3D neste driver?

niltonpess, instalei o mesmo Driver que você, esse 7.11, instalei pelo Envy, mas eu tinha esquecido de instalar os linux-headers, então não completou a instalação, após instalar os linux-headers, eu tentei novamente pelo Envy, agora sim, funcionou normalmente, instalou certinho e aceleração funfando beleza.

Você colocou o fglrx na blacklist? Instalou os linux-headers?
« Última modificação: 29 de Novembro de 2007, 11:58 por kErNeL_sCrIpT »