Autor Tópico: problema ao determinar "server's fully qualified domain name" [RESOLVIDO]  (Lida 4046 vezes)

Offline gtludwig

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Isso não é normal, é?

Acho que é por isso que eu só consigo acessar essa máquina pelo ip dela, não? Como resolvo isso?

Código: [Selecionar]
Failed to start apache : Apache does not appear to be running :

 * Starting apache 2.0 web server...
apache2: Could not determine the server's fully qualified domain name, using 10.0.0.160 for ServerName
   ...done.

Obrigado,

Gustavo
« Última modificação: 30 de Agosto de 2006, 10:51 por gtludwig »
|AMD64 3500+ 939p| |ASUS A8V| |ATI RADEON 9600 PRO| |2x 512 Mb DDR400| |SATA 120 Gb|

Offline gtludwig

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: problema ao determinar "server's fully qualified domain name"
« Resposta #1 Online: 30 de Agosto de 2006, 10:50 »
Procurei um pouco e vi num outro forum que deveria colocar no /etc/apache2/apache2.conf a seguinte linha
Código: [Selecionar]
ServerName rx160
Onde rx160 é, obviamente, o nome do servidor. E no /etc/hosts tenho que especificar o nome do servidor.

Depois, via ssh (que está funcinando maravilhosamente bem ;D), parei o apache usando o seguinte comando:
Código: [Selecionar]
$ sudo /usr/sbin/apache2ctl stop
Depois, pelo Webmin, reiniciei o apache e retornou o seguinte:

Código: [Selecionar]
Failed to start apache : Apache does not appear to be running :

 * Starting apache 2.0 web server...
   ...done.

Parece estar tudo certo, não?
|AMD64 3500+ 939p| |ASUS A8V| |ATI RADEON 9600 PRO| |2x 512 Mb DDR400| |SATA 120 Gb|