Autor Tópico: Como instalar o Oracle JavaSE 6 no Ubuntu  (Lida 5001 vezes)

Offline MayconCancini

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Como instalar o Oracle JavaSE 6 no Ubuntu
« Online: 21 de Agosto de 2012, 18:47 »
Este artigo explica passo-a-passo uma solução para instalar a JVM da Oracle no Ubuntu.

Originalmente aplicado ao Java 6, pode ser aplicado a Oracle Java 7 com as devidas adaptações.

Leia em: http://java-bytecode.blogspot.com.br/2012/08/como-instalar-oracle-javase6-ubuntu.html


eliseu_carvalho

  • Visitante
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #1 Online: 21 de Agosto de 2012, 21:00 »
Aqui tem uma forma muito mais fácil de instalar o Java:

http://diolinux.blogspot.com.br/2012/04/instalando-o-oracle-java-7-no-ubuntu.html

Offline Beto Pinheiro

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Agora com avatar! he he!
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #2 Online: 22 de Agosto de 2012, 08:11 »
Instalações complexas eu estou fora! Estou sempre instalando por PPA, conforme mencionou o colega Elizeu!

Abs
"O problema com o mundo é que as pessoas inteligentes estão cheias de dúvidas, enquanto os estúpidos estão cheios de confiança."

Charles Bukowski

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #3 Online: 23 de Agosto de 2012, 20:23 »
Frescura da Oracle em mudar a licença...

Mas não sei se eles fizeram isso para que as pessoas utilizem o openjdk e o openjre no lugar do outro, pq me parece que a partir da versão 7 da plataforma a versão "oficial" seria a open, e não a da própria Oracle. Tanto é que já consegui entrar em site de banco com o openjre 7.

Alguém pode me explicar melhor toda essa confusão? Pq ainda não entendi a diferença do openjdk 7 e o Java SE 7 da Oracle. Na plataforma 6 me parece que o melhor suporte era o da Oracle (ou Sun, antigamente), por conta de algumas bibliotecas (ou algo do genero) não ser totalmente implementado. Mas agora na 7 parece que mudou, mas não tenho certeza.

Edit: O Firefox tá reclamando mesmo de atualização do Java. Não gosto de fazer as coisas na mão...  :P
« Última modificação: 23 de Agosto de 2012, 20:26 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #4 Online: 24 de Agosto de 2012, 00:42 »
Este artigo explica passo-a-passo uma solução para instalar a JVM da Oracle no Ubuntu.

Originalmente aplicado ao Java 6, pode ser aplicado a Oracle Java 7 com as devidas adaptações.

Leia em: http://java-bytecode.blogspot.com.br/2012/08/como-instalar-oracle-javase6-ubuntu.html

Tentei instalar desse modo no Ubuntu 10.04.4, mas tá dando pau no alien:

Citar
error: incorrect format: unknown tag

...

dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
...

dpkg-shlibdeps: aviso: couldn't find library libjvm.so needed by debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/libj2pkcs11.so (ELF format: 'elf64-x86-64'; RPATH: '/usr/java/jdk1.6.0_34/jre/lib/amd64').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjava.so'

...

dpkg-shlibdeps: aviso: couldn't find library libjvm.so needed by debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/libj2gss.so (ELF format: 'elf64-x86-64'; RPATH: '/usr/java/jdk1.6.0_34/jre/lib/amd64').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjava.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjava.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
dpkg-shlibdeps: aviso: Não foi possível extrair o nome e a versão da biblioteca chamada 'libjli.so'
dpkg-shlibdeps: aviso: dependency on libnsl.so.1 could be avoided if "debian/jdk/usr/java/jdk1.6.0_34/jre/bin/javaws debian/jdk/usr/java/jdk1.6.0_34/bin/javaws debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/native_threads/libhpi.so debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/libnet.so debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/libjava.so debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/libhprof.so debian/jdk/usr/java/jdk1.6.0_34/jre/lib/amd64/libdt_socket.so" were not uselessly linked against it (they use none of its symbols).
dh_gencontrol
dh_gencontrol: Compatibility levels before 5 are deprecated.
dh_md5sums
dh_md5sums: Compatibility levels before 5 are deprecated.
dh_builddeb
dh_builddeb: Compatibility levels before 5 are deprecated.
dpkg-deb - erro: versão (upstream) ('unknown') não contém nenhum dígito
dpkg-deb: 1 erros no arquivo de controle
dh_builddeb: dpkg-deb --build debian/jdk .. returned exit code 2
make: ** [binary-arch] Erro 9
find: `jdk-1.6.0_34': Arquivo ou diretório não encontrado
sergio3@sergio3-laptop:~/Download/java 6u34$

Não deu para copiar tudo.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #5 Online: 24 de Agosto de 2012, 01:07 »
Aqui tem uma forma muito mais fácil de instalar o Java:

http://diolinux.blogspot.com.br/2012/04/instalando-o-oracle-java-7-no-ubuntu.html

Achei informação útil nesse link. Parece que tem um falha de segurança grotesca que atinge versões anteriores à 7u5:

Citar
WARNING: A severe security vulnerability has been found that will allow processes (including web applets and some applications) to "escape" from the Java sandbox and operate in the user context when using Java versions prior to Oracle Java 7 Update 5. This may allow malicious code to deliver harmful payloads. The use of Oracle Java 6 is no longer recommended.

Portanto, é mais fácil seguir o que está no link que o eliseu passou.

Edit: esses PPA's do WebUpd8 são confiáveis?

Edit 2: Pelo site do WebUpd8, o processo de instalação do java é semelhante ao do flash: não há o programa propriamente no repositório, o que há é apenas um script que baixa o binário do java lá do site oficial da Oracle e instala na sua máquina. Pq raios a Canonical não fez isso? Pq pode ter o flash-plugin-instaler na Central de programas e para o Java não?

Edit 3: Instalei o java 7 da Oracle pelo PPA, e instalou o plugin para os navegadores numa boa. Mas ao tentar abrir um aplicativo em Java, o Arduino, o menu ficou todo desconfigurado. Consegui deixar como default do sistema o java 6u34 instalado em /opt/java/64/, da seguinte forma:

sudo update-alternatives --install "/usr/bin/java" "java" "/opt/java/64/jdk1.6.0_34/bin/java" 1
sudo update-alternatives --install "/usr/bin/javac" "javac" "/opt/java/64/jdk1.6.0_34/bin/javac" 1
sudo update-alternatives --config java
sudo update-alternatives --config javac

Após iniciar o Arduino novamente, o problema do menu foi embora (agora ele está usando a versão 6u34). E os navegadores estão usando a versão + recente, 7u6.

Que trabalhão deixar tudo funcionando!!!  :P
« Última modificação: 24 de Agosto de 2012, 02:03 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline MayconCancini

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #6 Online: 29 de Agosto de 2012, 14:51 »
Ola Sergio Benjamim,

Realmente, saudoso tempo em que o Oracle Java vinha empacotado prontinho pra usar na Central de Programas ou Synaptic.

Quanto ao erro mencionado, eu passei por um erro semalhante, quando o local onde eu fiz o download era um drive do Windows (NTFS). Pode ser alguma questão de permissão também.

As instalações via PPA são mais simples, com certeza. Eu também utilizava assim. O problema é que as vezes esses PPAs são extintos, ou demoram para sincronizar com a versão mais atual da JVM.

Quanto a diferença entre o OpenJDK e o Oracle JDK é o seguinte: a partir da versão 6, a Sun abriu o código-fonte do Java. Com isto, a Sun continuou seu projeto (que hoje é o Oracle JDK), enquanto a comunidade iniciou um novo projeto: o OpenJDK.

Na minha opnião, na versão 6, o OpenJDK deixa muito a desejar. No meu ambiente (Ubuntu 12.04), aplicações que utilizam a JVM, tal como o Eclipse ou o JBoss, ficaram mais lentos. Porém, dizem (nunca testei) que na versão 7, a situação é invertida. Um dia que tiver tempo e paciência, faço um teste.

Offline advi

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #7 Online: 08 de Setembro de 2012, 11:44 »
Edit: esses PPA's do WebUpd8 são confiáveis?

Sim. A própria Oracle recomenda instalar. Veja: http://java.com/pt_BR/download/help/linux_install.xml

Nesta página, tem um link para instalar no Ubuntu. A opção 1 para instalação manual instrui colocar este PPA. ;)

Citar
Após iniciar o Arduino novamente, o problema do menu foi embora (agora ele está usando a versão 6u34). E os navegadores estão usando a versão + recente, 7u6.

Que trabalhão deixar tudo funcionando!!!  :P
Por aqui, tudo funcionou direitinho, sem problemas, automaticamente. Tanto na versão 12.04 como na 10.04.

Fui!
Ezcreve herrado é coiza de quem uza o IE6. Eu uso Firefox com dicionário de português! 8)

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Como instalar o Oracle JavaSE 6 no Ubuntu
« Resposta #8 Online: 08 de Setembro de 2012, 23:32 »
Edit: esses PPA's do WebUpd8 são confiáveis?

Sim. A própria Oracle recomenda instalar. Veja: http://java.com/pt_BR/download/help/linux_install.xml

Nesta página, tem um link para instalar no Ubuntu. A opção 1 para instalação manual instrui colocar este PPA. ;)

Citar
Após iniciar o Arduino novamente, o problema do menu foi embora (agora ele está usando a versão 6u34). E os navegadores estão usando a versão + recente, 7u6.

Que trabalhão deixar tudo funcionando!!!  :P

Por aqui, tudo funcionou direitinho, sem problemas, automaticamente. Tanto na versão 12.04 como na 10.04.

Fui!

Mas vc usa o Arduino?

***

Só uma sugestão para o MayconCancini, o tópico acabou descambando para o Java 7, não seria melhor atualizar o título?
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !