Autor Tópico: Não consigo fazer o Samba funcionar!!!!!!!!  (Lida 11874 vezes)

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Não consigo fazer o Samba funcionar!!!!!!!!
« Online: 12 de Agosto de 2006, 21:26 »
 ???

estou com o ubuntu server instalado e também o ambiente grafico, não consigo de maneira nenhuma fazer funcionar o Samba, o ubuntu nao consegue enxergar as maquinas windows, ja tentei de tudo, o ubuntu pinga para as maquinas windows, o windows acessa via ssh e vnc o linux , mais ao contrario não consigo nada.....

ja configurei tudo de acordo com as dicas, o grupo de trabalho esta o mesmo do windows, as permissãos e tal estão certa.... o que pode estar errado?

Ubuntu  Server 6.06
« Última modificação: 12 de Agosto de 2006, 21:31 por lueneberg »

Offline rafasnn

  • Usuário Ubuntu
  • *
  • Mensagens: 611
    • Ver perfil
Re: Não consigo fazer o Samba funcionar11111
« Resposta #1 Online: 12 de Agosto de 2006, 21:30 »
Macbook Pro 2,33 4GB 250GB
iPhone 8GB

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar11111
« Resposta #2 Online: 12 de Agosto de 2006, 21:34 »
Sugiro dar uma lida
http://www.guiadohardware.net/tutoriais/115/

ja passei por ai,,, mais vou rever o passo a passo quem sabe algum erro besta,,, ( que acredito)

valeu!!

Offline rafasnn

  • Usuário Ubuntu
  • *
  • Mensagens: 611
    • Ver perfil
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #3 Online: 12 de Agosto de 2006, 21:43 »
posta o arquivo /etc/samba/smb.conf assim é mais fácil ajudar, provavelmente deve ser as permissões das pastas
Macbook Pro 2,33 4GB 250GB
iPhone 8GB

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #4 Online: 12 de Agosto de 2006, 22:14 »
posta o arquivo /etc/samba/smb.conf assim é mais fácil ajudar, provavelmente deve ser as permissões das pastas

http://geocities.yahoo.com.br/lueneberg68/smb.html

renomeie para smb.conf, devido a restrições do yahoo tive que mudar,,,,


Offline rafasnn

  • Usuário Ubuntu
  • *
  • Mensagens: 611
    • Ver perfil
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #5 Online: 12 de Agosto de 2006, 22:40 »
vixi cara

abre o arquivo, seleciona tudo, copia clique no simbolo ( # ) nos botões do fórum, e colo entre as opções [code.] que vai aparecer, ai fica mais fácil.
Macbook Pro 2,33 4GB 250GB
iPhone 8GB

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #6 Online: 13 de Agosto de 2006, 08:49 »
vixi cara

abre o arquivo, seleciona tudo, copia clique no simbolo ( # ) nos botões do fórum, e colo entre as opções [code.] que vai aparecer, ai fica mais fácil.

segue smb.conf

Código: [Selecionar]
#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentary and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.
#

#======================= Global Settings =======================

[global]
log file = /var/log/samba/log.%m
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
obey pam restrictions = yes
socket options = TCP_NODELAY
encrypt passwords = yes
passdb backend = tdbsam
passwd program = /usr/bin/passwd %u
wins support = no
dns proxy = no
server string = %h server (Samba, Ubuntu)
invalid users = root
message command = /bin/sh -c '/usr/bin/linpopup
workgroup = CASADASCORES
        netbios name = Ubuntu
os level = 20
syslog = 0
panic action = /usr/share/samba/panic-action %d
max log size = 1000

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of

# server string is the equivalent of the NT Description field

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
;   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth1

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = true



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects

# Put a capping on the size of the log files (in Kb).

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
;   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.

# Do something sensible when Samba crashes: mail the admin a backtrace


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba-HOWTO-Collection/ServerType.html
# in the samba-doc package for details.
;   security = share

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using. 


;   guest account = nobody

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
;   unix password sync = no

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
;   pam password change = no

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
;   domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
;   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
;   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
;   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

# When using [print$], root is implicitly a 'printer admin', but you can
# also give this right to other users to add drivers and set printer
# properties
;   printer admin = @lpadmin


############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
;   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares.  This will share each
# user's home directory as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = no

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.  Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
;   valid users = %S

# By default, the home directories are exported read-only. Change next
# parameter to 'yes' if you want to be able to write to them.
;   writable = no

# File creation mask is set to 0600 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0664.
;   create mask = 0600

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   writable = no
;   share modes = no

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /tmp
   printable = yes
   public = no
   writable = no
   create mode = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# Replace 'ntadmin' with the name of the group your admin users are
# members of.
;   write list = root, @ntadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   writable = no
;   locking = no
;   path = /cdrom
;   public = yes

# The next two parameters show how to auto-mount a CD-ROM when the
# cdrom share is accesed. For this to work /etc/fstab must contain
# an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
# is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom


[Ubuntu-Server]
path = /home/ccores
available = yes
browseable = yes
public = yes
writable = yes

Offline rafasnn

  • Usuário Ubuntu
  • *
  • Mensagens: 611
    • Ver perfil
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #7 Online: 13 de Agosto de 2006, 09:02 »
lueneberg,

caso queira que todos os usuários da rede tenham acesso a pasta /home/ccores faça assim

descomente a linha tire o " ; " do inicio da linha
Código: [Selecionar]
;   security = share
adicione as linhas no final do compartinhamento [Ubuntu-Server]
Código: [Selecionar]
force user = nobody
force group = nogroup

e na pasta home de o comando chdown para trocar o usuário da pasta /home
Código: [Selecionar]
sudo chown nobody ccores
 ;D
Macbook Pro 2,33 4GB 250GB
iPhone 8GB

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #8 Online: 13 de Agosto de 2006, 14:40 »
lueneberg,

caso queira que todos os usuários da rede tenham acesso a pasta /home/ccores faça assim

descomente a linha tire o " ; " do inicio da linha
Código: [Selecionar]
;   security = share
adicione as linhas no final do compartinhamento [Ubuntu-Server]
Código: [Selecionar]
force user = nobody
force group = nogroup

e na pasta home de o comando chdown para trocar o usuário da pasta /home
Código: [Selecionar]
sudo chown nobody ccores
 ;D

ok,, ja fiz a modificação, como estou em casa fiz pelo ssh, agora testar somente amanha qdo as estações windows serão ligadas....

posto aqui resultados....
valeu.......

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #9 Online: 14 de Agosto de 2006, 09:32 »
lueneberg,

caso queira que todos os usuários da rede tenham acesso a pasta /home/ccores faça assim

descomente a linha tire o " ; " do inicio da linha
Código: [Selecionar]
;   security = share
adicione as linhas no final do compartinhamento [Ubuntu-Server]
Código: [Selecionar]
force user = nobody
force group = nogroup

e na pasta home de o comando chdown para trocar o usuário da pasta /home
Código: [Selecionar]
sudo chown nobody ccores
 ;D

foi feito como acima, no ultimo comando ele retorna um erro:
sudo chown ccores nobody
chown: impossível acessar `nobody': No such file or directory

 e ainda nao consigo acessar o windows e nem o windows acessar o servidor

Offline rafasnn

  • Usuário Ubuntu
  • *
  • Mensagens: 611
    • Ver perfil
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #10 Online: 15 de Agosto de 2006, 00:17 »
lueneberg,

caso queira que todos os usuários da rede tenham acesso a pasta /home/ccores faça assim

descomente a linha tire o " ; " do inicio da linha
Código: [Selecionar]
;   security = share
adicione as linhas no final do compartinhamento [Ubuntu-Server]
Código: [Selecionar]
force user = nobody
force group = nogroup

e na pasta home de o comando chdown para trocar o usuário da pasta /home
Código: [Selecionar]
sudo chown nobody ccores
 ;D

foi feito como acima, no ultimo comando ele retorna um erro:
sudo chown ccores nobody
chown: impossível acessar `nobody': No such file or directory

 e ainda nao consigo acessar o windows e nem o windows acessar o servidor

ops, tenta
Código: [Selecionar]
sudo chown nobody ccores
Macbook Pro 2,33 4GB 250GB
iPhone 8GB

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #11 Online: 15 de Agosto de 2006, 16:46 »
lueneberg,

caso queira que todos os usuários da rede tenham acesso a pasta /home/ccores faça assim

descomente a linha tire o " ; " do inicio da linha
Código: [Selecionar]
;   security = share
adicione as linhas no final do compartinhamento [Ubuntu-Server]
Código: [Selecionar]
force user = nobody
force group = nogroup

e na pasta home de o comando chdown para trocar o usuário da pasta /home
Código: [Selecionar]
sudo chown nobody ccores
 ;D

foi feito como acima, no ultimo comando ele retorna um erro:
sudo chown ccores nobody
chown: impossível acessar `nobody': No such file or directory

 e ainda nao consigo acessar o windows e nem o windows acessar o servidor

ops, tenta
Código: [Selecionar]
sudo chown nobody ccores

mesma msg igual... sem acesso  :-[


Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #12 Online: 19 de Agosto de 2006, 10:08 »
sudo chown nobody ccores  ( estava dando este comando dentro do ccores, sai do /ccores e deu certo)

ok resolvido pelo menos 70%, estou fazendo testes, mais ja consigo gravar windows --> linux , ainda não consegui fazer ao contrario, mais acredito que to chegando lá... não posso resetar a maquina agora,,, mais assim  que resetar vejo como ficou o compartilhamento...acredito que agora vai.......

Offline Darcamo

  • Usuário Ubuntu
  • *
  • Mensagens: 1.315
    • Ver perfil
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #13 Online: 19 de Agosto de 2006, 11:28 »
Acredito que não seja necessário resetar o computador. Apenas o samba.

sudo /etc/init.d/samba restart

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: Não consigo fazer o Samba funcionar!!!!!!!!
« Resposta #14 Online: 19 de Agosto de 2006, 20:20 »
Acredito que não seja necessário resetar o computador. Apenas o samba.

sudo /etc/init.d/samba restart

sim amigo sei que um restart no samba resolve, mais como tenho algumas mudanças no firewall que quero testar, dai uma reinicialização ja me faria testar tudo , firewall, samba, etc....

obrigado pelo ajuda