Autor Tópico: [Resolvido]Problemas Enviando E-mail por CLI (Linha de comando)  (Lida 3167 vezes)

Offline darksneasel

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
[Resolvido]Problemas Enviando E-mail por CLI (Linha de comando)
« Online: 12 de MAR?O de 2011, 19:38 »
Pesquisei um pouco como faço pra enviar um e-mail por linha de comando e encontrei 3 programas, os 3 deram o mesmo erro:
mail, sendmail e postfix:

send-mail: fatal: open /etc/postfix/main.cf: No such file or directory
Can't send mail: sendmail process failed with error code 75

alguém sabe o que é isso?

---
edit
pesquisei um pouco, me disseram pra digitar esse comando:
dpkg-reconfigure postfix


aparece uma tela, mas não tenho como prosseguir, está escrito <OK> no fim da mensagem, mas nenhum botão do teclado que eu aperte, continua a configuração.
« Última modificação: 13 de MAR?O de 2011, 19:34 por darksneasel »
Pinguins dominaram o mundo!

Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Problemas Enviando E-mail por CLI (Linha de comando)
« Resposta #1 Online: 12 de MAR?O de 2011, 20:34 »
O postfix precisa ser configurado para você enviar os emails. Depois disso, você pode usar o mail, mutt, etc. para o envio.

Se quer algo simples e prático pode usar o ssmtp.

http://tombuntu.com/index.php/2008/10/21/sending-email-from-your-system-with-ssmtp/

Nesse link ensina como configurar ele para usar o gmail para envio.

Obs. Provavelmente com a tecla <TAB> você vai chegar no "OK".

« Última modificação: 13 de MAR?O de 2011, 19:46 por jeflui »

Offline darksneasel

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Problemas Enviando E-mail por CLI (Linha de comando)
« Resposta #2 Online: 13 de MAR?O de 2011, 19:34 »
 :D era a tecla tab mesmo, resolvi o problema, vlw!
Pinguins dominaram o mundo!