Autor Tópico: [Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona  (Lida 13401 vezes)

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
[Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Online: 16 de Dezembro de 2010, 14:57 »
Caros amigos!

Tenho instalado o scanner HP Deskjet_1050_j410 All-in-One no Ubuntu 9.10 com a última versão do HPlip e o sistema actualizado. Quando executo o Xsane ele dá a seguinte mensagem de erro: "Falha ao abrir o dispositivo: hpaio:/usb/Deskjet_1050_j410_series?serial=CN06R21GBZ05HW: dispositivo ocupado".

Já li quase tudo o que há escrito na Internet sobre este erro e até agora nada me ajudou a resolve-lo.

Quando executo o comando scanimage -L o scanner é corretamente identificado e sem mensagens de erro. O comando "sane-find-scanner" também identifica, mas aqui, este comando também identifica nas linhas a seguir a Webcam. Será que o problema está aqui?

Já experimentei o Xsane, o Simple scan e o Scan2pdf. Todos mencionam o Scanner correctamente mas ele não funciona com nenhum.

Agradeço muito a vossa ajuda porque queria migrar de vez para o Ubuntu e só me falta poder usar o scanner.

A impressora funciona na perfeição, o que me deixa admirado, uma vez que o hplip é o mesmo.


Obrigado

Hernâni
« Última modificação: 19 de Dezembro de 2010, 15:52 por Hernâni »

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #1 Online: 16 de Dezembro de 2010, 17:52 »
Viva!

Parece que a instalação está correcta, mas existe um problema relacionado com "grupos" porque o grupo "scanner" não existe na pasta /etc/group e creio que devia existir.

Se alguém souber como criar e adicionar "users" a um "grupo", por favor ajude.

Obrigado.

Hernâni

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #2 Online: 16 de Dezembro de 2010, 20:33 »
Vocẽ poderia tentar baixar a iso do Ubuntu por exemplo a LTS versão do Ubuntu 10.04 ou a ultima versão estavel.


Porque eu penso que o hplip que vem no Ubuntu 9.10 deve ser antigo.

Existe um pacote chamado hplip-gui se quiser instalar ele.

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #3 Online: 16 de Dezembro de 2010, 21:45 »
Livre1,

Obrigado pela sua resposta e por ter tentado ajudar, no entanto, este não é o problema porque o hplip é o mais recente. É o que agora está disponível para download no site da HP.

O meu problema é que o grupo "scanner" por alguma razão não foi criado e eu também não sei como o criar.

Se alguém poder ajudar, agradeço muito.

Obrigado.

Hernâni

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #4 Online: 16 de Dezembro de 2010, 21:51 »
O meu problema é que o grupo "scanner" por alguma razão não foi criado e eu também não sei como o criar.

Clique em sistema=> administração => usuarios e grupos

Crie o grupo => scanner

Coloque seu usuario nele.

[]'s

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #5 Online: 17 de Dezembro de 2010, 17:33 »
Obrigado, Tota!

Agradeço muito a sua atenção. Já consegui criar o grupo mas mesmo assim o scanner ainda não funciona. Quando executo o comando sudo tail -f /var/log/messages antes de executar o Xsane o resultado é este:

prof@prof-laptop:~$ sudo tail -f /var/log/messages
[sudo] password for prof:
Dec 17 16:00:06 prof-laptop kernel: [   38.416991] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:06 prof-laptop kernel: [   38.558631] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:06 prof-laptop kernel: [   38.655138] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec 17 16:00:06 prof-laptop kernel: [   38.862208] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.006219] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.297354] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.443950] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.680813] ppdev: user-space parallel port driver
Dec 17 16:00:09 prof-laptop kernel: [   41.513951] usb 2-3: usbfs: interface 1 claimed by usblp while 'usb' sets config #1
Dec 17 16:00:19 prof-laptop kernel: [   51.277000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

Portanto, não existem erros. Mas se executar o mesmo comando depois de ter executado o Xsane, aí o erro aparece:

prof@prof-laptop:~$ sudo tail -f /var/log/messages
[sudo] password for prof:
Dec 17 16:00:06 prof-laptop kernel: [   38.655138] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec 17 16:00:06 prof-laptop kernel: [   38.862208] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.006219] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.297354] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.443950] [drm] TV-14: set mode NTSC 480i 0
Dec 17 16:00:07 prof-laptop kernel: [   39.680813] ppdev: user-space parallel port driver
Dec 17 16:00:09 prof-laptop kernel: [   41.513951] usb 2-3: usbfs: interface 1 claimed by usblp while 'usb' sets config #1
Dec 17 16:00:19 prof-laptop kernel: [   51.277000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Dec 17 16:04:54 prof-laptop xsane: failed to open scan channel: scan/sane/hpaio.c 658
Dec 17 16:04:54 prof-laptop kernel: [  326.646039] usblp0: removed


O erro é o que está a bold.

Se alguém tiver uma ideia de como resolvo este erro, eu agradeço imenso a ajuda.

Um abraço.

Hernâni

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #6 Online: 17 de Dezembro de 2010, 22:28 »
Veja essa pagina que fala de um bug no hplip: https://bugs.launchpad.net/hplip/+bug/652963


La tem uma possivel solução que é editar algum arquivo.
« Última modificação: 20 de Dezembro de 2010, 05:48 por livre1 »

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #7 Online: 19 de Dezembro de 2010, 14:07 »
Livre1 e Tota,

Antes de mais queria agradecer-vos pelas ajudas que me deram a resolver este problema. Sem vocês talvez não conseguisse. Um grande obrigado ao Tota porque me ensinou a criar “Grupos” em Linux e um grandíssimo obrigado ao Livre1, porque me indicou o site certo para seguir. A solução do link do Livre1 é perfeita e funcionou em grande.
Obrigado a ambos.

Agora vamos ao tutorial passo-a-passo que me permitiu por este scanner a funcionar:

Este scanner não funciona logo após a instalação porque o hplip contém um bug e vários defeitos que não lhe permitem funcionar.

1 – Quando se instala o hplip, ele não cria o grupo “Scanner”. Então é necessário fazer o seguinte: ir a Sistema=> Administração => Usuários e Grupos, clicar em baixo onde tem as 2 chavinhas e na janela que se abre colocar o nome do seu usuário e palavra pass. Dar OK. Agora o sistema já o deixa criar um novo grupo. Depois do grupo criado, fechar tudo, abrir o Terminal e executar o seguinte comando para juntar “Saned” ao grupo “scanner”: sudo adduser saned scanner

2 – Agora vamos juntar o nosso nome de usuário ao grupo “scanner” executando o seguinte comando: sudo adduser o_seu_nome_de_usuario scanner

3 – Agora já estamos prontos para corrigir a instalação que foi feita pelo hplip, fazendo o seguinte:

a) Garantir que temos instalada a última versão do hplip que vai na versão 3.10.9.

b) Abrir como root o ficheiro /usr/share/hplip/data/models/models.dat executando o seguinte comando: sudo gedit /usr/share/hplip/data/models/models.dat

c) Agora na janela que se abriu vamos editar a secção "deskjet_1050_j410_series"  procurando as seguintes linhas: "io-mfp-mode=3" que tem de ficar assim: "io-mfp-mode=1" e ainda “scan-type=-1" que tem de ficar assim: “scan-type=7" . Em cima clicar em “save” para guardar as alterações. Agora saia do hp-toolbox e do hp-systray se eles estiverem a correr. Execute o xsane a partir do Terminal. Em princípio o scanner já funciona.


Boa sorte.
Hernâni

« Última modificação: 19 de Dezembro de 2010, 14:13 por Hernâni »

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: [Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #8 Online: 19 de Dezembro de 2010, 19:26 »
Otima dica Hernâni, parabens pelo exito e persistencia.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: [Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #9 Online: 20 de Dezembro de 2010, 02:02 »
Para os usuarios que ver este topico lembro que sempre antes de editar algum arquivo do sistema operacional ou de um programa como esse arquivo para a impressora funcionar, é bom fazer uma copia do arquivo antes de editar ele para caso de algo der errado.


Já foi resolvido e segundo o Hernâni agora esta funcionando, mais o que disse acima e principalmente para quem estiver procurando alguma coisa parecida, saber que uma copia do arquivo sem modificação é bom fazer.

Agora eu fico pensando como a HP faz uma coisa dessa (eu sei que erros em software podem ocorrer mais eu acho que eles deviam testar bem antes de liberar o pacote).

Hernâni essa impressora agora funciona bem, ou com o drive para Windows ela funciona melhor?

Você consegue usar todas as funções, e ver os niveis de tinta?

Estou perguntando, porque se um dia eu for comprar uma impressora eu já tenho alguma opnião de qual vai funcionar melhor nas distribuições Linux.

« Última modificação: 11 de Janeiro de 2011, 04:14 por livre1 »

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: [Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #10 Online: 20 de Dezembro de 2010, 11:28 »
Viva Livre!

Respondendo às tuas questões: a impressora ficou a funcionar da mesma forma como funciona no Windows. Ela instala o HP Device Manager que permite todo o tipo de configurações e mostra também os níveis de tinta. A velocidade de funcionamento é a mesma que no Windows. Em comparação com o funcionamento em Windows é exactamente a mesma coisa.

Convém ressalvar que se trata de uma multifunções ( scan, cópia e impressora ) muito barata. É a mais barata do mercado, pelo que não se podem esperar grandes velocidades de impressão tanto em Linux com em Windows.

É conveniente também informar que a HP se disponibilizou de imediato a fornecer suporte para este problema. Recebi hoje mesmo o link com a informação para resolver o problema, mas curiosamente o link é exactamente o mesmo que forneceu o Livre! A HP garantiu que na próxima "release" este problema estará reparado e que será muito brevemente.

Apesar de ter tido este problema continuo a aconselhar a comprar HP, uma vez que o suporte é impecável. Reparem que esta multifunções não é suportada pelo Linux e mesmo assim está a funcionar a 100%.

Um Feliz Natal a todos, e continuem a participar neste fórum, para que ele continue a ajudar muita gente como até aqui.

Um abraço.

Hernâni

 

Offline Ioca100

  • Usuário Ubuntu
  • *
  • Mensagens: 2.848
  • Rio,Brasil
    • Ver perfil
Re: [Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #11 Online: 20 de Dezembro de 2010, 12:34 »
Olá colegas, semana passada comprei uma multifuncional HP deskjet F4480, ela veio defeituosa e me deu trabalho para instalá-la, mas , depois, que a revenda trocou por outra nova, foi só excluir a antiga e ligá-la que o Ubuntu 10.04, com os drivers novos da HP 3.10.9, instalou automaticamente e está a funcionar perfeitamente.
« Última modificação: 20 de Dezembro de 2010, 12:36 por Ioca100 »
Usuário Linux- 449417

Offline Hernâni

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: [Resolvido] Scanner HP Deskjet_1050_j410 All-in-One não funciona
« Resposta #12 Online: 20 de Dezembro de 2010, 13:49 »
Loca100,

O facto da minha impressora não ter funcionado bem, isso não quer dizer que outros modelos também vão ter problemas. Que eu saiba existem várias dezenas de modelos de impressoras HP a funcionar bem com o HPlip 3.10.9. O bug que existe é para os modelos HP Deskjet 1050 e HP deskjet 2050 e poucas mais. As outras, é claro que funcionam bem.

Hernâni