Autor Tópico: wireless não conecta mais  (Lida 13418 vezes)

Offline sandrassg

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
wireless não conecta mais
« Online: 05 de Setembro de 2010, 09:42 »
tenho um note da cce com ubuntu 10.4 usando a rede wireless há um mês e funcionando bem, com um modem speedstream e um roteador tp-link, quando a gente ligava a rede já entrava automaticamente.
ontem pela manhã eu ligo e não aparece o ícone, em conexões de rede parece tudo igual .
olhei em todos os tópicos e não achei nada parecido.
o note conecta por cabo e eu tenho um netbook philco rodando mandriva e com a internet wireless funcionando perfeitamente.

sandra@sandra-Ubuntu:~$ iwconfig wlan0
wlan0     802.11b/g  Mode:Managed  Frequency=2.422 GHz 
          Access Point: Not-Associated   Bit Rate:11 Mb/s   
          Retry:on   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sandra@sandra-Ubuntu:~$ iwlist wlan0 scan
wlan0     No scan results

ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:e0:4c:07:b6:f9 
          inet end.: 192.168.1.102  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::2e0:4cff:fe07:b6f9/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:1247 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:651 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:277386 (277.3 KB) TX bytes:161879 (161.8 KB)
          IRQ:31

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:4 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:4 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

wlan0     Link encap:Ethernet  Endereço de HW 70:f1:a1:6d:64:4b 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:47 excesso:0 quadro:0
          Pacotes TX:336 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:14112 (14.1 KB)
          IRQ:17 Memória:f8530000-f8530100

lsusb
Bus 002 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 002 Device 002: ID 8087:0020 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 062a:0003 Creative Labs
Bus 001 Device 002: ID 8087:0020 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sandra@sandra-Ubuntu:~$ nm-tool

NetworkManager Tool

State: connected


** (process:1767): WARNING **: error: failed to read connections from org.freedesktop.NetworkManagerUserSettings:
    The name org.freedesktop.NetworkManagerUserSettings was not provided by any .service files
- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        00:E0:4C:07:B6:F9

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.102
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             200.175.5.139
    DNS:             200.175.89.139


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            r8180
  State:             disconnected
  Default:           no
  HW Address:        70:F1:A1:6D:64:4B

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points


Obrigada desde já

libonati

  • Visitante
Re: wireless não conecta mais
« Resposta #1 Online: 05 de Setembro de 2010, 13:02 »
Posta os comandos
lspci
ifconfig
Qual sua internet (cabo/adsl)
Qual seu provedor
Modelo do modem
Modelo do roteador

Offline sandrassg

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: wireless não conecta mais
« Resposta #2 Online: 05 de Setembro de 2010, 13:12 »
sandra@sandra-Ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller (rev 22)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
sandra@sandra-Ubuntu:~$ ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:e0:4c:07:b6:f9 
          inet end.: 192.168.1.102  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::2e0:4cff:fe07:b6f9/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:25093 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:15843 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:32216130 (32.2 MB) TX bytes:1530382 (1.5 MB)
          IRQ:32 Endereço de E/S:0xc000

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:4 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:4 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

wlan0     Link encap:Ethernet  Endereço de HW 70:f1:a1:6d:64:4b 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:17 Memória:f8238000-f8238100

sandra@sandra-Ubuntu:~$

internet adsl gvt
modem speedstream 4200
roteador tplink tl wr541g


libonati

  • Visitante
Re: wireless não conecta mais
« Resposta #3 Online: 05 de Setembro de 2010, 13:32 »
Por favor, mais um comando
lspci -v -s 00.0

Offline sandrassg

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: wireless não conecta mais
« Resposta #4 Online: 05 de Setembro de 2010, 13:34 »
sandra@sandra-Ubuntu:~$ lspci -v -s 00.0
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
   Subsystem: Intel Corporation Core Processor DRAM Controller
   Flags: bus master, fast devsel, latency 0
   Capabilities: <access denied>
   Kernel driver in use: agpgart-intel
   Kernel modules: intel-agp

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
   Subsystem: Elitegroup Computer Systems Device 8348
   Flags: bus master, fast devsel, latency 0, IRQ 32
   I/O ports at 2000 [size=256]
   Memory at f0a00000 (64-bit, prefetchable) [size=4K]
   Memory at f0a10000 (64-bit, prefetchable) [size=64K]
   [virtual] Expansion ROM at f0a20000 [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: r8169
   Kernel modules: r8169

06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller (rev 22)
   Subsystem: Realtek Semiconductor Co., Ltd. Device 8181
   Flags: bus master, fast devsel, latency 0, IRQ 17
   I/O ports at 4000 [size=256]
   Memory at f0600000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: r8180
   Kernel modules: rtl8187se

ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
   Subsystem: Intel Corporation Device 8086
   Flags: bus master, fast devsel, latency 0

sandra@sandra-Ubuntu:~$



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: wireless não conecta mais
« Resposta #5 Online: 05 de Setembro de 2010, 13:48 »
Duas sugestões:

1) Desligue o roteador e ligue novamente;

2) Apague a conexão antiga e crie-a novamente, com os mesmos dados.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

libonati

  • Visitante
Re: wireless não conecta mais
« Resposta #6 Online: 05 de Setembro de 2010, 13:53 »
Duas sugestões:

1) Desligue o roteador e ligue novamente;

2) Apague a conexão antiga e crie-a novamente, com os mesmos dados.


Lembra o caso do rodrigoma? que baixou o driver e resolveu o problema?
http://ubuntuforum-br.org/index.php/topic,71612.msg399212.html#msg399212


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: wireless não conecta mais
« Resposta #7 Online: 05 de Setembro de 2010, 13:57 »
O dele não estava funcionando e parou de repente, estava? :-\
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sandrassg

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: wireless não conecta mais
« Resposta #8 Online: 05 de Setembro de 2010, 14:14 »
eu escrevi a resposta e não sei porque não foi. eu fiz todas essas coisas. a primeira coisa que fiz foi desligar roteador, modem, só roteador, só modem, todas as combinações possíveis.
mas como eu disse, a internet com fio tá ótima. eu tô aqui nela.
e o netbook está funcionando com a wireless e mandriva
já refiz a conexão umas trezentas vezes desde ontem, pq não tem um botãozinho de conectar :(
baixei um Wicd e ele não acha rede também.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: wireless não conecta mais
« Resposta #9 Online: 05 de Setembro de 2010, 14:27 »
O adaptador Realtek 8187SE não tem os mesmos problemas do 8187B; se não está funcionando, provavelmente é alguma atualização recente que não entrou bem.

Quanto aos equipamentos, o modem não tem a ver com seu problema, já que vc não se conecta a ele.

Gostaria de confirmar qual módulo vc está usando. Pode postar a saída do comando abaixo?

lsmod | egrep "8187|8180"
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sandrassg

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: wireless não conecta mais
« Resposta #10 Online: 05 de Setembro de 2010, 14:34 »
sandra@sandra-Ubuntu:~$ lsmod | egrep "8187|8180"
rtl8187se             159435  0
sandra@sandra-Ubuntu:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: wireless não conecta mais
« Resposta #11 Online: 05 de Setembro de 2010, 15:11 »
É esse mesmo. Vou pesquisar um pouco e volto. Se alguém tiver alguma idéia pode adiantar as coisas também.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

libonati

  • Visitante
Re: wireless não conecta mais
« Resposta #12 Online: 05 de Setembro de 2010, 16:08 »
sandrassg, enquanto o zekkerj pesquisa vamos pular várias etapas para agilizar.
Instale o  driverRTL8192SE . Vou te dar o passo a passo. Primeiro baixe o driver para o seu pc.

Offline sandrassg

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: wireless não conecta mais
« Resposta #13 Online: 05 de Setembro de 2010, 17:15 »
Baixei ;)

libonati

  • Visitante
Re: wireless não conecta mais
« Resposta #14 Online: 05 de Setembro de 2010, 17:51 »
Siga a sequência com atenção.
Primeiro veja qual o seu kernel com o comando
uname -r (anote)
Agora vá na pasta /usr/src/linux-headers-2.6.32-24-generic (supondo que seu kernel seja este)
cd /usr/src/linux-headers-2.6.32-24-generic
Agora copie o driver para a pasta
cp <caminho/rtl8192se_linux_2.6.0017.0705.2010.tar.gz  rtl8192se_linux_2.6.0017.0705.2010.tar.gz
onde <caminho/rtl8192se_linux_2.6.0017.0705.2010.tar.gz> é o caminho absoluto da pasta que está o driver que você baixou. Ex: /home/emanoel/rtl8192se_linux_2.6.0017.0705.2010.tar.gz
Agora extraia os arquivos
tar -zxvf rtl8192se_linux_2.6.0017.0705.2010.tar.gz
Agora entre na pasta que será criada
cd rtl8192se_linux_2.6.0017.0705.2010
Compile
make
instale
make install
Depois continuamos. Até aqui você tem de chegar.