Autor Tópico: achando o plugin certo para o amsn - gstreamer farsight  (Lida 4418 vezes)

Offline lambona

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
achando o plugin certo para o amsn - gstreamer farsight
« Online: 13 de Junho de 2010, 19:22 »
Olá a todos.
 Bem uso o amsn ,as nunca havia tentado usar a web cam - não tenho- e a video conferencia. Netse findi resolvi brincar um pouco pois vou adquirir uma e peguei a dos meus irmãos para usar: resultado, nada feito.
Li aqui no fórum alguma coisa a respeito mas quem já viu meus posts sabe que ainda estou na fase gugu dadá então as coisas tem que ser bem explicadinhas... achei este tuto http://www.vivaolinux.com.br/artigo/aMSN-0.98-com-suporte-a-audio-e-video-pronto-para-video-e-chamada e tentei fazer o passo a passo ... sim a versão disponibilizado para o karmic  já tem suporte de gravação, eu sei... mas fala serio vou ficar gravando e enviando?

segui as etapas anteriores e tentei instalar os plugins abaixo:

sudo apt-get install build-essential libgstreamer0.10-0 gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-tools gstreamer0.10-alsa
sudo apt-get build-dep gstreamer0.10-plugins-farsight
 mas rolou o seguinte:

pandora@pandora-laptop:~$ sudo apt-get install build-essential libgstreamer0.10-0 gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-tools gstreamer0.10-alsa
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
build-essential já é a versão mais nova.
libgstreamer0.10-0 já é a versão mais nova.
gstreamer0.10-plugins-base já é a versão mais nova.
gstreamer0.10-plugins-good já é a versão mais nova.
gstreamer0.10-plugins-bad já é a versão mais nova.
O pacote gstreamer0.10-plugins-farsight é um pacote virtual fornecido por:
  gstreamer0.10-plugins-bad 0.10.14-4ubuntu1.1
Você deveria selecionar explicitamente um para instalar.
E: O pacote gstreamer0.10-plugins-farsight não tem candidato para instalação

Aí fui pro farsight...pensei vai ver tenho que instalá-lo primeiro e ver os plugins depois....

pandora@pandora-laptop:~$ sudo wget http://slackware.rrhti.com.br/farsight2-0.0.12-i686-1cf.txz
--2010-06-13 18:18:47--  http://slackware.rrhti.com.br/farsight2-0.0.12-i686-1cf.txz
Resolvendo slackware.rrhti.com.br... 74.54.143.66
Conectando-se a slackware.rrhti.com.br|74.54.143.66|:80... conectado!
HTTP requisição enviada, aguardando resposta... 200 OK
Tamanho: 625096 (610K) [text/plain]
Salvando em: `farsight2-0.0.12-i686-1cf.txz'
2010-06-13 18:18:56 (96,8 KB/s) -`farsight2-0.0.12-i686-1cf.txz' salvo [625096/625096]

pandora@pandora-laptop:~$  sudo apt-get install build-essential libgstreamer0.10-0 gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-tools gstreamer0.10-alsa
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
build-essential já é a versão mais nova.
libgstreamer0.10-0 já é a versão mais nova.
gstreamer0.10-plugins-base já é a versão mais nova.
gstreamer0.10-plugins-good já é a versão mais nova.
gstreamer0.10-plugins-bad já é a versão mais nova.
O pacote gstreamer0.10-plugins-farsight é um pacote virtual fornecido por:
  gstreamer0.10-plugins-bad 0.10.14-4ubuntu1.1
Você deveria selecionar explicitamente um para instalar.
E: O pacote gstreamer0.10-plugins-farsight não tem candidato para instalação
pandora@pandora-laptop:~$ sudo apt-get build-dep gstreamer0.10-plugins-farsight
[sudo] password for pandora:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
E: Você deve colocar algumas URIs 'source' em seu sources.list

Após isso dei um sudo apt-get update pois o tuto se pautou na versão 8.10 apesar de dizer que valia para as versões mais recentes.

Enfim, estou mais perdida que cego em tiroteio. perdão pelas edições na msg... mas é que tento de outras formas e a cada avanço algumas coisas se torna desnecessárias.
Ah meu a-msn é o 0.98.3
Ao entrar neste (amsn) e tentar acessar video/audio conferencia ele não acusa a existencia do farsight que imagino que seja pela falta dos plugins... sei lá... o que pode estar errado além de mim?
rsrs

« Última modificação: 13 de Junho de 2010, 21:47 por lambona »

libonati

  • Visitante
Re: achando o plugin certo para o amsn - gstreamer farsight
« Resposta #1 Online: 14 de Junho de 2010, 00:19 »
Oi lambona, tente "farsight" no synaptic que você encontra várias bibliotecas. Leia cada uma delas e instale. Não testei nenhuma delas mas talvez lhe sirva. Se não der certo, é só desinstalar.

Offline Falco90

  • Usuário Ubuntu
  • *
  • Mensagens: 669
  • mais um desocupado à procura de ajudar quase todos
    • Ver perfil
    • Blog de Tecnologia
Re: achando o plugin certo para o amsn - gstreamer farsight
« Resposta #2 Online: 14 de Junho de 2010, 01:08 »
Primeiro veja se a camera está funcinando perfeitamente pelo aplicativo cheese. Você pode instalar ele pela Central de Programas(Aplicativos>Central de Programas).
Se estiver funcionando configure ela no amsn: amsn>conta>preferencias>outros>Editar opções de audio e vídeo

Obs: A versão do amsn no repositório do Karmic é a 0.98.1, e a versão mais recente é a mesma que ta nos repositórios do Lucid: 0.98.3, acho que ambas já tem o suporte chamada de vídeo.
« Última modificação: 14 de Junho de 2010, 01:16 por Falco90 »

Offline lueneberg

  • Usuário Ubuntu
  • *
  • Mensagens: 727
    • Ver perfil
    • BrasilLivre
Re: achando o plugin certo para o amsn - gstreamer farsight
« Resposta #3 Online: 14 de Junho de 2010, 06:46 »
edite seu sources.list e acrescente estas linhas

deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/amsn-daily/ppa/ubuntu lucid main


depois as chaves:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0x07af2e69547ac004b7bcb5971c1e55a728cbc482

enfim a instalação com todos os pacotes, incluindo áudio e voz

sudo apt-get update
sudo apt-get install amsn amsn-extra-plugins amsn-extra-skins



pronto e só usar agora, lembre se usar outra vs do ubuntu apenas troque no repositorio a palavra "lucid" pela correspondente  .  EX:  lucid por karmic ou jaunty