Autor Tópico: CD/DVD Não monta no 10.04  (Lida 16314 vezes)

Offline fabiobianchi

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
CD/DVD Não monta no 10.04
« Online: 15 de Maio de 2010, 04:48 »
Desde que instalei o 10.04, há 2 semanas, o drive de CD/DVD não monta nenhuma mídia. Mas quando estava usando o Karmic Koala, nem precisei fazer nada para reconhecer e montar as mídias.

Ao digitar:  df -h  

aparece isso:
Sist. Arq.            Tam   Usad Disp  Uso% Montado em
/dev/sda1              29G  4,1G   24G  15% /
none                  498M  288K  497M   1% /dev
none                  502M  1,4M  500M   1% /dev/shm
none                  502M  196K  501M   1% /var/run
none                  502M     0  502M   0% /var/lock
none                  502M     0  502M   0% /lib/init/rw
/dev/sda2             241G   26G  203G  12% /home
/dev/sdb1              75G   59G   16G  80% /media/16D85F88D85F6551

E o meu  fstab está assim:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=d86ab621-4f15-4653-8c9e-470da5ebedb7 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda2 during installation
UUID=e67f1226-a199-4e76-ac55-ce89dbefe19f /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=a62a7b4d-c1c4-4d81-8688-3c2a7069aca3 none            swap    sw              0       0
/dev/cdrom       /media/cdrom0 udf,iso9660 rw,user,noauto                         0       0
« Última modificação: 29 de Maio de 2010, 16:07 por fabiobianchi »

Offline dstter

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: CD/DVD Não Monta no 10.04
« Resposta #1 Online: 17 de Maio de 2010, 00:59 »
Seu CDROM é IDE ou SATA? Você sabe informar se você tem uma placa controladora (IDE ou SATA) PCI no computador ou usa a onboard? Caso não saiba, a onboard é a mais provável. Experimente essas tentativas:

Abra o console e digite:

sudo mkdir /mnt/cdrom
sudo mount /dev/sr0 /mnt/cdrom (obviamente com um CD no dispositivo)

se não der certo, tente..

sudo mount /dev/hdc /mnt/cdrom

Se funcionar edite seu fstab:

Na parte que diz /dev/cdrom mude para a sugestão que deu certo (/dev/sr0 ou /dev/hdc)


Acredito que seja só essa linha no seu fstab que tá causando o problema.
Espero ter ajudado





Offline fabiobianchi

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Re: CD/DVD Não Monta no 10.04
« Resposta #2 Online: 17 de Maio de 2010, 03:20 »
Meu CD/DVD é IDE, quanto a controladora eu não sei, mas a placa é uma ASUS A8N SLI

consegui montar com a primeira opção: /dev/sr0

editei meu fstab.

Muito obrigado pela ajuda.

Offline wminhoto

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: CD/DVD Não Monta no 10.04
« Resposta #3 Online: 27 de Maio de 2010, 14:12 »
Estou com o mesmo problema o sistema não reconhece a unidade lógica CD/DVD depois que instalei a versão 10.04, gostaria de saber como montar a unidade?

willians@Willians-Kubuntu:~$ sudo lshw -c disk
  *-disk                 
       description: ATA Disk
       product: WDC WD3200AAJS-9
       vendor: Western Digital
       physical id: 0.0.0
       bus info: scsi@2:0.0.0
       logical name: /dev/sda
       version: 12.0
       serial: WD-WCAPZ3331385
       size: 298GiB (320GB)
       capabilities: partitioned partitioned:dos
       configuration: ansiversion=5 signature=c2bac70c
  *-cdrom
       description: DVD-RAM writer
       physical id: 0.0.0
       bus info: scsi@0:0.0.0
       logical name: /dev/cdrom
       logical name: /dev/cdrw
       logical name: /dev/dvd
       logical name: /dev/dvdrw
       logical name: /dev/scd0
       logical name: /dev/sr0
       capabilities: audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: status=open
  *-disk:0
       description: SCSI Disk
       physical id: 0.0.0
       bus info: scsi@4:0.0.0
       logical name: /dev/sdb
  *-disk:1
       description: SCSI Disk
       physical id: 0.0.1
       bus info: scsi@4:0.0.1
       logical name: /dev/sdc
  *-disk:2
       description: SCSI Disk
       physical id: 0.0.2
       bus info: scsi@4:0.0.2
       logical name: /dev/sdd
  *-disk:3
       description: SCSI Disk
       physical id: 0.0.3
       bus info: scsi@4:0.0.3
       logical name: /dev/sde
willians@Willians-Kubuntu:~$

Offline fabiobianchi

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Re: CD/DVD Não Monta no 10.04
« Resposta #4 Online: 28 de Maio de 2010, 01:05 »
Você já tentou o que o dstter explicou acima? Comigo funcionou perfeitamente.

Boa sorte!!!

Offline pigdin

  • Usuário Ubuntu
  • *
  • Mensagens: 723
  • Terra - Brasill - SP-Capital
    • Ver perfil
Re: CD/DVD Não Monta no 10.04
« Resposta #5 Online: 28 de Maio de 2010, 08:18 »
Para alterar o fstab:

Vá no menu aplicativos->acessórios->terminal

digite:

sudo gedit /etc/fstab
Desk: Phenom X3 2GB DDR II - Win 7 / Ubuntu 10.04 64 Bits
Note MUB: Core2Duo 4GB - Win7 / Ubuntu 10.04 / Bodhi Linux.
@alexpigdin

Offline fabiobianchi

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
CD/DVD Não monta no 10.04
« Resposta #6 Online: 01 de Junho de 2010, 15:57 »
Depois de relatar o mesmo problema aqui no fórum e ter modificado o fstab como proposto
(veja esse tópico:   http://ubuntuforum-pt.org/index.php/topic,66645.msg373194.html#msg373194)

me pareceu que a questão estava resolvida. No entanto fui colocar outro cd no drive há pouco e apareceu o seguinte erro:


Error mounting: mount exited with exit code 1: helper failed with:
mount: mount point /media/cdrom0 does not exist

Alguém pode ajudar???

meu fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=d86ab621-4f15-4653-8c9e-470da5ebedb7 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda2 during installation
UUID=e67f1226-a199-4e76-ac55-ce89dbefe19f /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=a62a7b4d-c1c4-4d81-8688-3c2a7069aca3 none            swap    sw              0       0
/dev/sr0       /media/cdrom0 udf,iso9660 rw,user,noauto                         0       0

Offline rruella

  • Usuário Ubuntu
  • *
  • Mensagens: 1.097
    • Ver perfil
Re: CD/DVD Não monta no 10.04
« Resposta #7 Online: 02 de Junho de 2010, 15:24 »
não sei como resolver seu problema infelizmente, não estou apto para te ajudar, a não ser em dizer que estive para jogar meu cd/dvd fora quando usava o 9.10 e agora no 10.04 voltou a trabalhar normalmente. por isso tente, e tente e tente também.
Dar como resolvido, ou como solucionado um tópico seu:

http://www.youtube.com/watch?v=cW8isbYhR_M

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: CD/DVD Não monta no 10.04
« Resposta #8 Online: 02 de Junho de 2010, 15:42 »
Eu não tenho linha de cdrom no meu fstab e o cd funciona normalmente...

tente apagar a linha
Citar
/dev/sr0       /media/cdrom0 udf,iso9660 rw,user,noauto                         0       0

E dê um boot e veja o que acontece...
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: CD/DVD Não monta no 10.04
« Resposta #9 Online: 02 de Junho de 2010, 15:44 »
Citar
Error mounting: mount exited with exit code 1: helper failed with:
mount: mount point /media/cdrom0 does not exist

Esta informação indica a você:

entre em terminal e digite
Citar
sudo nautilus

Cuidado, nautilus como root é perigoso. se errar, pode apagar o sistema. faça só o descrito aqui.

Com o nautilus aberto, navegue até a pasta /media

Nesta pasta /media crie uma pasta vazia com o nome cdrom0 ( mas verifique o prque de ter posto no seu fstab ele como Sr0 )

depois de criada dê permissão de leitura e escrita para seu usuario

Tente abrir o cd.


a propósito, pelas regras não é permitido tratar de um mesmo assunto em mais de um tópico do mesmo autor, então estou unindo este ao seu outro topico.

[],s
« Última modificação: 02 de Junho de 2010, 15:46 por Tota »

Offline SantiagoPD

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
    • Além do que se vê
Re: CD/DVD Não monta no 10.04
« Resposta #10 Online: 04 de Junho de 2010, 22:17 »
Poxa pessoal também tenho este problema. Não entendo muito, mas saco um pouco da lógica de programação. Meu 9.04 dava este problema e meu 10.04 está dando. Este é o meu fdtab

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=850cdeb1-981f-434b-8964-77d541e4e0ec none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Pelo que entendi no meu caso nem aparece apontamento para a montagem do CD\DVD, ou seia  /dev/sda1? Se for este o caso eu dei uma olhada da na pasta dev e lá aparece um arquivo chamado sda1, mas não é uma pasta e ele também não me deixa criar uma pasta com este nome por causa deste arquivo (e sim, eu abri o Nautilus como Sudo). Não me parece algo extremamente complexo, me parece que está faltando um comando ou está apontando para alguma pasta de montagem que não existe.

Abraços!
"Não tem nada de sadio em adaptar-se a uma sociedade completamente doente"

Offline SantiagoPD

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
    • Além do que se vê
Re: CD/DVD Não monta no 10.04
« Resposta #11 Online: 04 de Junho de 2010, 23:52 »
Uau! Como é bom conseguir resolver um destes problemas com auxílio de algumas dicas do Fórum e um pouco de intuição.

Seguinte, vejam como resolvi o meu problema.
Abri o Nautilus pelo terminal conforme escreveu


entre em terminal e digite
Citar
sudo nautilus


Naveguei até a pasta "media" e criei uma pasta "sda1" dentro dela. Ainda não testei gravações de CDs ou DVDs, mas creio que se isto não funcionar bastará ir até lá novamente e liberar estas ações para o meu usuário. OK, acho que isso resolveu o problema. Valeu pessoal... abraços!
"Não tem nada de sadio em adaptar-se a uma sociedade completamente doente"

Offline SantiagoPD

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
    • Além do que se vê
Re: CD/DVD Não monta no 10.04
« Resposta #12 Online: 12 de Junho de 2010, 16:47 »
Mas que m... achei que havia resolvido, estava todo feliz. Mas adivinhem o que aconteceu quando liguei a maquina hoje? Pois então, não montou os CDs nem os DVDs. Isso que no dia anterior, quando consegui fazer funcionar, cheguei até a gravar DVDs!
"Não tem nada de sadio em adaptar-se a uma sociedade completamente doente"

Offline SantiagoPD

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
    • Além do que se vê
Re: CD/DVD Não monta no 10.04
« Resposta #13 Online: 12 de Junho de 2010, 17:01 »
Fiz outro procedimento que montou automaticamente os CD e DVDs, pelo menos até a próxima vez que eu desligar e ligar o computador.

1. Abri o Nautilus pelo terminal como sudo
2. Naveguei até a pasta /dev e alterei as permissões do arquivo sda1 (para onde apontava a montagem do meu driver)
3. Alterei da seguinte forma: estava permitida a leitura e escrita para o grupo "disk" e eu alterei para "cdrom"

Vou realizar testes para ver o que acontece. Tentarei gravar alguns arquivos.
"Não tem nada de sadio em adaptar-se a uma sociedade completamente doente"

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: CD/DVD Não monta no 10.04
« Resposta #14 Online: 12 de Junho de 2010, 17:07 »
Mas alterar as permissões de sda1 vai influenciar no que a montagem de CD's?

Muito provavelmente sda1 é a partição inicial do seu HD, e além do que esse arquivo existe apenas em tempo de execução, correto?
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!