Autor Tópico: Ubuntu Rescue  (Lida 4957 vezes)

Offline emanoeljulio

  • Usuário Ubuntu
  • *
  • Mensagens: 94
    • Ver perfil
Ubuntu Rescue
« Online: 01 de Abril de 2010, 17:52 »
Ola!!!
Estou editando o live cd do Ubuntu 9.10 para gerar um livecd customizado do ubuntu para automatizar a restauração do windows xp. Já possuo todos os script e o próximo passo é remover o ambiente gráfico do live cd para que ele inicie somente em modo texto. Ja removi o GDM, UBUNTU-DESKTOP( e todos as suas dependências).

Feito isso sempre que inicio o LiveCD personalizado ele passa do logo branco do ubuntu em fundo preto, mas para na mensagem:

Código: [Selecionar]
* Starting early crypto disks...
* Starting remaining crypto disks...
* Starting init crypto disks...                                                [ OK ]

Pesquisei alguns sites e encontrei o seguinte comando para desabilitar o ambiente grafico, mais não funfou!!!

Código: [Selecionar]
sudo update-rc.d gdm remove

Offline emanoeljulio

  • Usuário Ubuntu
  • *
  • Mensagens: 94
    • Ver perfil
Re: Ubuntu Rescue
« Resposta #1 Online: 01 de Abril de 2010, 19:39 »
Existe uma distro, http://ubuntu-rescue-remix.org/, que funciona como eu desejo, somente modo texto, mas ao tentar altera-la segundo o tuto do guto carvalho http://gutocarvalho.net/mediawiki/index.php?title=Customizando_LiveCD_do_Ubuntu_7.04 é retornado esse erro sempre que tento montar o filesystem.squashfs

Código: [Selecionar]
root@laptop:/# mount -t squashfs -o loop /diretorio/mnt/cd/casper/filesystem.squashfs /diretorio/mnt/squashfs
mount: wrong fs type, bad option, bad superblock on /dev/loop1,
       missing codepage or helper program, or other error
       Em alguns casos informações úteis são encontradas no syslog - tente
       "dmesg | tail" ou algo do tipo

Se algem souber como desabilitar o modo gráfico usando o terminal, que não seja o citado acima agradeço.
 

Offline emanoeljulio

  • Usuário Ubuntu
  • *
  • Mensagens: 94
    • Ver perfil
Re: Ubuntu Rescue [ RESOLVIDO ]
« Resposta #2 Online: 10 de Abril de 2010, 19:11 »
O problema esta resolvido. Apaguei tudo e refiz o tramalho, mas dessa vez usei o comando apt-get remove gdm*, ele removeu tudo(gdm, xorg, xserver, gnome, etc) para remover o ambiente gráfico e deu certo.

Agradeço a atenção de todos