Autor Tópico: WebCam Sony Vaio VGP-VCC8 [R5U870] não é detectada... (Ubuntu 9.10)  (Lida 5639 vezes)

Offline Yeeg

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Resolvi criar um topico a parte pq TUDO que eu testei ate agora nao deu certo
Instalei EasyCam,o Drive R5U870 ,Instalei Cheese,reiniciei e  nada!!!
Eu tentei encontrar o diretorio /dev/video0 pelo terminal e fala : "Arquivo ou diretorio nao encontrado"
Eu nao sei mais o que eu faço
Porem quando digito lsusb aparece:

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 3538:0070 Power Quotient International Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05ca:183b Ricoh Co., Ltd Visual Communication Camera VGP-VCC8 [R5U870]

Ou seja,o Ubuntu reconhece que tem uma camera ,mas nao ativa  :-\
o que eu faço???

alarcon

  • Visitante
Re: WebCam Sony Vaio VGP-VCC8 [R5U870] não é detectada... (Ubuntu 9.10)
« Resposta #1 Online: 22 de MAR?O de 2010, 13:58 »
Segue o que falo exatamente aqui:

http://ubuntuforum-br.org/index.php/topic,49371.0.html

PS: Veja que lá tem instruções para as seguintes versões do Ubuntu:

- Ubuntu 9.04 Jaunty 32bits
- Ubuntu 9.10 Karmic Kola 32bits

Entretanto em algum lugar neste tópico eu falo sobre uma versão do driver para sistemas 64bits também.

Se vc já instalou o driver correto veja se o seu problema só é o que falo sobre o cheese lá no tópico. É que é preciso consertar algo nele para ele poder usar o dispositivo correto da câmera.

Offline Yeeg

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: WebCam Sony Vaio VGP-VCC8 [R5U870] não é detectada... (Ubuntu 9.10)
« Resposta #2 Online: 22 de MAR?O de 2010, 15:15 »
eu usei isto tmb...
mas acontece que da



Error! Bad return status
for module build on kernel: 2.6.31-20-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/r5u870/0.11.3/build/ for more information.
0
0
dpkg: erro processando r5u870-dkms (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 10
Erros foram encontrados durante o processamento de:
 r5u870-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)


e da esse erro mesmo eu tentando instalar o r5u070-dkms

alarcon

  • Visitante
Re: WebCam Sony Vaio VGP-VCC8 [R5U870] não é detectada... (Ubuntu 9.10)
« Resposta #3 Online: 22 de MAR?O de 2010, 16:51 »
eu usei isto tmb...
mas acontece que da



Error! Bad return status
for module build on kernel: 2.6.31-20-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/r5u870/0.11.3/build/ for more information.
0
0
dpkg: erro processando r5u870-dkms (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 10
Erros foram encontrados durante o processamento de:
 r5u870-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)


e da esse erro mesmo eu tentando instalar o r5u070-dkms

Talvez seu problema seja a falta de compiladores, principalmente o pacote linux-headers-2.6.31-20-generic que é extremamente necessário no processo de compilação.

Estou assumindo que vc usa o Ubuntu 9.10 32bits e que tem acesso a internet por ele, então siga estes passos aqui:

- Abra um terminal (menu Aplicativos > Acessórios > Terminal)

- com ele aberto digite exatamente isso (copie e cole é melhor):

sudo apt-get update

isso vai atualizar o banco de dados do instalador do Ubuntu. Vai ser pedido uma senha, digite a sua senha e não se preocupe, pois ao digitar a senha no terminal não é mostrado nada nem os ****, mas vc está sim digitando sua senha ok.

Agora digite:

sudo apt-get install build-essential fakeroot gcc make linux-headers-2.6.31-20-generic checkinstall

isso irá instalar alguns pacotes e compiladores necessários para instalar o driver

- Agora baixe o driver com o comando no terminal:

wget http://www.palmix.org/download/r5u870_k2.6.30_i386.tar.bz2

OBS: se já tiver ele aí na sua pasta de usuária, apague-o antes de executar este comando acima no terminal ok.

Agora descompacte ele assim:

tar -jxvf r5u870_k2.6.30_i386.tar.bz2

entre na pasta descompactada assim:

cd r5u870/

- Agora vamos compilar o driver com os comandos:

make

espere o processo acabar e depois digite:

sudo make install

espere o processo acabar e depois digite:

sudo modprobe r5u870


E para finalizar:

sudo gedit /usr/share/hal/fdi/information/20thirdparty/10-r5u870-webcam.fdi

no arquivo vazio que abrir cole exatamente isso aqui:

Código: [Selecionar]
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.subsystem" string="usb">
      <match key="usb.interface.class" int="0x0e">
        <match key="usb.interface.subclass" int="0x02">
          <match key="usb.interface.protocol" int="0x00">
            <merge key="info.category" type="string">video4linux</merge>
   <append key="info.capabilities" type="strlist">video4linux</append>
            <merge key="linux.subsystem" type="string">video4linux</merge>
            <merge key="video4linux.device" type="string">/dev/video0</merge>
            <merge key="video4linux.version" type="string">2</merge>
          </match>
        </match>
      </match>
    </match>
  </device>
</deviceinfo>

Terminando tudo, faça mais isso:

sudo gedit /etc/modprobe.d/blacklist.conf

e coloque no final dele:

blacklist uvcvideo


Seguindo esses procedimentos eu ativei minha câmera:

Bus 001 Device 002: ID 05ca:1839 Ricoh Co., Ltd Visual Communication Camera VGP-VCC6 [R5U870]

no Ubuntu 9.10 32bits com o seguinte kernel: 2.6.31-20-generic
« Última modificação: 22 de MAR?O de 2010, 16:52 por alarcon »

Offline Yeeg

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: WebCam Sony Vaio VGP-VCC8 [R5U870] não é detectada... (Ubuntu 9.10)
« Resposta #4 Online: 24 de MAR?O de 2010, 11:18 »
A camera foi dectada,obrigada ^^
Mas o erro r5u870-dkms continua mesmo depois d ter feito o comando sudo apt-get install build-essential fakeroot gcc make linux-headers-2.6.31-20-generic checkinstall....
la no final aparece a mesma mensagem:
Código: [Selecionar]
linux-headers-2.6.31-20-generic já é a versão mais nova.
checkinstall já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando r5u870-dkms (0.11.3-0ubuntu1~tj~ppa1j) ...
Removing old r5u870-0.11.3 DKMS files...

------------------------------
Deleting module version: 0.11.3
completely from the DKMS tree.
------------------------------
Done.
Loading new r5u870-0.11.3 DKMS files...

Creating symlink /var/lib/dkms/r5u870/0.11.3/source ->
                 /usr/src/r5u870-0.11.3

DKMS: add Completed.
Installing prebuilt kernel module binaries (if any)
Building module...

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
su nobody -c "make KERNELRELEASE=2.6.31-20-generic -C /lib/modules/2.6.31-20-generic/build M=/var/lib/dkms/r5u870/0.11.3/build"....(bad exit status: 2)

Error! Bad return status for module build on kernel: 2.6.31-20-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/r5u870/0.11.3/build/ for more information.
0
0
dpkg: erro processando r5u870-dkms (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 10
Erros foram encontrados durante o processamento de:
 r5u870-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

fora isso o microfone nao funciona tambem.... :-[

o q eu faço pra concertar esses probleminhas???
« Última modificação: 24 de MAR?O de 2010, 11:26 por Yeeg »

alarcon

  • Visitante
Re: WebCam Sony Vaio VGP-VCC8 [R5U870] não é detectada... (Ubuntu 9.10)
« Resposta #5 Online: 24 de MAR?O de 2010, 13:24 »
A camera foi dectada,obrigada ^^
Mas o erro r5u870-dkms continua mesmo depois d ter feito o comando sudo apt-get install build-essential fakeroot gcc make linux-headers-2.6.31-20-generic checkinstall....
la no final aparece a mesma mensagem:
Código: [Selecionar]
linux-headers-2.6.31-20-generic já é a versão mais nova.
checkinstall já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando r5u870-dkms (0.11.3-0ubuntu1~tj~ppa1j) ...
Removing old r5u870-0.11.3 DKMS files...

------------------------------
Deleting module version: 0.11.3
completely from the DKMS tree.
------------------------------
Done.
Loading new r5u870-0.11.3 DKMS files...

Creating symlink /var/lib/dkms/r5u870/0.11.3/source ->
                 /usr/src/r5u870-0.11.3

DKMS: add Completed.
Installing prebuilt kernel module binaries (if any)
Building module...

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
su nobody -c "make KERNELRELEASE=2.6.31-20-generic -C /lib/modules/2.6.31-20-generic/build M=/var/lib/dkms/r5u870/0.11.3/build"....(bad exit status: 2)

Error! Bad return status for module build on kernel: 2.6.31-20-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/r5u870/0.11.3/build/ for more information.
0
0
dpkg: erro processando r5u870-dkms (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 10
Erros foram encontrados durante o processamento de:
 r5u870-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

fora isso o microfone nao funciona tambem.... :-[

o q eu faço pra concertar esses probleminhas???


Humm, olha só, acho que você fez uma tremenda confusão aí e instalou um driver errado para a sua versão do Ubuntu.

Veja, pelo que você relata e estou entendendo, você pegou o pacote .deb de nome r5u870-dkms_0.11.3-0ubuntu1~tj~ppa1j_all.deb que é para ser usado somente no Ubuntu 9.04 32bits e usou o mesmo no Ubuntu 9.10 32bits que é a usada por você.

Pacotes .deb do driver r5u870 são pacotes já compilados e portanto só servem para aquela versão de kernel usada no Ubuntu para o qual ele foi criado (o pacote .deb), portanto não irá funcionar em outras versões do Ubuntu e seu respectivo kernel.

Pacotes do tipo .tar.bz2 (ou .tar.gz) são pacotes para ainda serem compilados e portanto é necessário ter os compiladores aí no seu sistema. A vantagem dele é que independem do kernel usado na grande maioria dos casos, pois você pode compilar no kernel em uso, gerando módulos que se encaixe no respectivo kernel (mais ou menos isso), entretanto processos de compilação podem ser muito complicados e demorados, depende do aplicativo, mas felizmente este driver de câmera de vídeo é muito simples a compilação.

No seu caso você tem que usar o pacote ainda para compilar chamado de r5u870_k2.6.30_i386.tar.bz2 e seguir os procedimentos anteriores.

Para remover o driver que não será usado por vc faça o seguinte, abra o terminal (menu Aplicativos > Acessórios > Terminal) e digite:

sudo dpkg -r --purge r5u870-dkms

que deve resolver, mas aí acho, não tenho certeza, que terá de fazer outra vez todo o procedimento que indiquei a você no meu texto anterior referente ao driver r5u870_k2.6.30_i386.tar.bz2 que é o correto a se usar por você. Na parte de compilação (entrar na pasta r5u870 e usar os comandos make, sudo make install e sudo modprobe r5u870).


Vamos agora ao microfone, clique com o botão direito do mouse sobre o ícone de som no canto superior direito, próximo ao relógio, e na janela que abrir vá em Preferencias de som, na janela que abrir clique na Aba(ou guia) Entrada, veja lá se em volume de entrada o botão Mudo está marcado, se estiver desmarque e teste o som do microfone, fale e veja sem em nível de entrada é mostrado alguma atividade quando você fala por aí. Se não funcionar, ainda neste local vá logo mais abaixo onde tem Conector e troque de Microphone 1 para Microphone 2 e teste o som novamente. Outro local para testar o microfone seria no menu Aplicativos > Multimídia > Gravador de som, isso sem o mic está no mudo ou com volume muito baixo no local onde falei ok.

Caso ainda não funcione, retorne aqui informando que tenho mais alguma coisa para você testar por aí referente ao som ok.
« Última modificação: 24 de MAR?O de 2010, 13:28 por alarcon »