Autor Tópico: [Parcialmente resolvido] gnome-ppp via XP e instalar no Ubuntu 9.10 (erros)  (Lida 3799 vezes)

Offline Adailton_Melo

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
    • Preparando a Hospitalidade para o mundo globalizado
Olá a todos.

Eu sou um completo novato em Linux (menos de 10 dias) e fuçando pela net baixei o ISO do Karmic, instalei sem complicações e gostei de verdade do sistema. Quando fui escutar MP3 e assistir a vídeos, descobri que era necessário fazer atualizações e baixar codecs. Meus problemas começaram aí:

Eu uso a internet Giro da Embratel que usa o celular Nokia 1508i como modem conectado via cabo usb. Depois de fuçar a net inteira e não conseguir resolver a questão, me vi forçado a abrir este tópico: http://ubuntuforum-br.org/index.php/topic,62071.0.html

Ninguém respondeu ainda, mas quebrando muito a cabeça pra tentar resolver, procurei esquecer do Karmic instalado em dual boot e fui fuçar o outro Ubuntu que estava emulado no VMware pelo XP. Tal qual foi a minha surpresa em descobrir que o Karmic emulado "pegava" automaticamente a internet que já estava conectada pelo XP. Fantástico!!!!!

Mexi num monte de coisa pra me ambientar e no repositório busquei pelo gnome-ppp, instalei e fui praticar o que as minhas pesquisas anteriores me indicavam fazer.... não deu outra!!! Consegui conectar o Ubuntu emulado com o Nokia da Embratel e acessei a net numa boa e sem depender do XP.

Feliz da vida fui baixar pelo XP o gnome-ppp no link http://packages.ubuntu.com/karmic/gnome-ppp

Reiniciei a máquina e fui instalar o que havia baixado no Ubuntu e deu xabu.... Dava a mensagem:
Erro! Dependência não satisfeita: wvdial

Deduzi que faltava o software wvdial, reiniciei, fui no XP, baixei o wvdial, reiniciei, rodei o Ubuntu, fui instalar o wvdial e mais um erro:
Erro! Dependêcia não satisfeita: libuniconf4.6

Fui baixar esse libuniconf4.6 e o ciclo foi o mesmo, dando erro sobre outro pacote.

Pergunta:

Como faço pra baixar o gnome-ppp pelo XP e instalar no Ubuntu sem todos esses erros?

Ficarei muito grato a quem possa dar uma força, porque quero migrar do XP definitivamente, mas, sem net não dá.

Abraço a todos!
« Última modificação: 29 de Janeiro de 2010, 14:13 por Adailton_Melo »
Adailton Melo

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #1 Online: 28 de Janeiro de 2010, 10:19 »
O sistema de pacotes do Ubuntu (aliás, do Linux) é ingrato mesmo: sem net, é muito difícil instalar pacotes que tenham dependências.

Não tem nem como evitar isso, a não ser usar algum outro tipo de conexão (por exemplo, um cabo de rede, conectado a outro computador que compartilhe o Giro pra você).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

alarcon

  • Visitante
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #2 Online: 28 de Janeiro de 2010, 10:34 »
Se você não tem acesso a internet e que instalaro discador gnome-ppp e suas dependências, uma alternativa que pode dar certo seria o seguinte, vá no menu Sistema > Administração > Gerenciador de Pacotrs Synaptic lá procure pelos aplicativo gnome-ppp, selecionando-o para instalação, mas não clique no botão Aplicar. Ao invés disso vá ao menu Arquivos do Synaptic e escolha lá a opção Gerar script de download do(s) pacote(s) e depois dê um nome para esse script, por exemplo discador e salve.

Depois vc pode ir ao windows ou qualquer outro PC que vc possa usar a internet abrir esse script (arquivo de texto) e copiar e colar todos os endereços de pacotes e suas dependências para serem baixados em um aplicativo de download.

O bom desse script é que ele já coloca todos os pacotes e suas dependências na sequência de instalação, depois é só vc levar tudo que baixou ao Ubuntu e instalar na sequência indicada no script ou então colocar todos os .deb numa pasta e digitar:

 sudo dpkg -i *.deb

dentro da pasta que contém todos .deb baixados, isso pelo terminal.

Um porém que pode ocorrer nesta solução é que talvez a sua lista de repositórios esteja defasada, o mais provável, e aí os pacotes gerados por esse script seriam de versões mais antigas dos que as realmente existentes neste momento nos repositórios, entretanto para o caso do discador gnome-ppp e suas dependências não creio que isso será um problema por que é um pacote de pouca atualização depois do lançamento, não lembro de alguma atualização dele ou suas dependências após ter instalado e usado determinada versão do Ubuntu por muito tempo.


Exemplificando, aqui no meu Ubuntu 9.10 32 bits fui ao synaptic e procurei pelos programas Opdenjdk e Gnucash e marquei para instalação e depois mandei gerar o script e o resultado foi esse:

Citar
#!/bin/sh
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/openjdk-6-jre-lib_6b16-1.6.1-3ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/c/ca-certificates-java/ca-certificates-java_20090928_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/t/tzdata/tzdata-java_2009s-0ubuntu0.9.10_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/jline/libjline-java_0.9.94-5~ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/r/rhino/rhino_1.7R2-1ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/openjdk-6-jre-headless_6b16-1.6.1-3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/java-access-bridge/libaccess-bridge-java_1.26.2-1ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/java-access-bridge/libaccess-bridge-java-jni_1.26.2-1ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/openjdk-6-jre_6b16-1.6.1-3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/icedtea-6-jre-cacao_6b16-1.6.1-3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libg/libgwenhywfar/libgwenhywfar47_3.10.0-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking-data_4.1.2-1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking29_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqhbci16_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqofxconnect5_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libk/libktoblzcheck/libktoblzcheck1c2a_1.22-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking29-plugins_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/aqbanking-tools_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/libguile-ltdl-1_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/libqthreads-12_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/r/readline5/libreadline5_5.2-6_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/guile-1.6-libs_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/guile-1.6_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/s/slib/slib_3b1-3_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/guile-1.6-slib_1.6.8-6.3ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking-plugins-libgwenhywfar47_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libqbanking8_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking29-plugins-qt_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/c/crypt-ssleay/libcrypt-ssleay-perl_0.57-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/libd/libdate-manip-perl/libdate-manip-perl_5.54-1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libh/libhtml-tableextract-perl/libhtml-tableextract-perl_2.10-3_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libf/libfinance-quote-perl/libfinance-quote-perl_1.16-4_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/g/goffice/libgoffice-0-8-common_0.7.8-1ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/g/goffice/libgoffice-0-8_0.7.8-1ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/opensp/libosp5_1.5.2-7ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libo/libofx/libofx4_0.9.0-3ubuntu2_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnucash/gnucash-common_2.2.9-0ubuntu4_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnucash/gnucash_2.2.9-0ubuntu4_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnucash-docs/gnucash-docs_2.2.0-3_all.deb

isso é um script e se vc tivesse outro linux com acesso a internet, bastava dar permissão de execução ao script e rodar ele que iria baixar na sequencia o aplicativo e todas as suas dependências. Como vc provavelmente irá é usar o Windows basta copiar e colar todos estes links aí num gerenciador de downloads (copiando e colando lá) anotar a sequência e levando ao Ubuntu instalar um por um na sequência (dos primerios links aos últimos) ou como já falei anteriormente.

PS: Isso aí é só um exemplo, para o caso do gnome-ppp suas dependências são poucos arquivos .deb a se baixar.
« Última modificação: 28 de Janeiro de 2010, 19:01 por alarcon »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #3 Online: 28 de Janeiro de 2010, 10:38 »
Citar
Se você não tem acesso a internet e que instalaro discador gnome-ppp e suas dependências, uma alternativa que pode dar certo seria o seguinte, vá no menu Sistema > Administração > Gerenciador de Pacotrs Synaptic lá procure pelos pacots que vc quer instar selecionando-os para instalação, mas não clique no botão Aplicar. Ao invés disso vá no menu Arquivos do Synaptic e escolha lá a opção Gerar script de download do(s) pacote(s) e depois dê um nome para esse script, por exemplo discador e salve.
Taí, essa eu não conhecia... já foi pro caderninho.  :D
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Alyscom

  • Usuário Ubuntu
  • *
  • Mensagens: 774
  • Apenas me dê o feijão!
    • Ver perfil
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #4 Online: 28 de Janeiro de 2010, 11:26 »
Olá___Se querer um modo mais fácil, ao invés de baixar um por um, você poderia baixar direto pelo arquivo shell gerado através do Cygwin!! ;D

Olha só, e vê se ajuda
http://aurelio.net/cygwin/
http://cygwin.com/

ou então, renomear o arquivo e colocar no final a extensão .html, ai é só abrir com o seu navegador e ir clicando nos link's!!! ;)


[]'s


Alyscom
« Última modificação: 28 de Janeiro de 2010, 11:29 por Alyscom »
O álcool é o photoshop da vida real
 

Offline Adailton_Melo

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
    • Preparando a Hospitalidade para o mundo globalizado
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #5 Online: 28 de Janeiro de 2010, 18:39 »
O Alarcon deu uma dica legal, mas quando dei esse comando aqui a única linha de script que foi gerada pelo Sistema > Administração > Gerenciador de Pacotes Synaptic foi: #!/bin/sh Não sei porque não deu certo, apesar de eu ter tentado várias vezes.

Eu agradeço a cooperação mas, agora vou fazer algumas perguntas de leigo:

1 - Como o meu Ubuntu 9.10 emulado tá pegando internet do XP, tem alguma forma de eu transferir o gnome-ppp já instalado nele para algum arquivo de instalação, salvar este arquivo no meu pendrive, reiniciar pelo Ubuntu real e instalar o gnome-ppp?

2 - No Synaptic, as propriedades do gnome-ppp mostram os arquivos de dependência e aí vem minha outra pergunta: essa lista de arquivos mostra eles na ordem em que devem ser instalados? E se eu seguir esta ordem eles serão instalados um a um, sem problemas?

A lista do link http://packages.ubuntu.com/karmic/gnome-ppp também seguiria esta ordem?

Obrigado a quem se pronunciou!!!!! Valeu mesmo.


Adailton Melo

alarcon

  • Visitante
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #6 Online: 28 de Janeiro de 2010, 18:54 »
O Alarcon deu uma dica legal, mas quando dei esse comando aqui a única linha de script que foi gerada pelo Sistema > Administração > Gerenciador de Pacotes Synaptic foi: #!/bin/sh Não sei porque não deu certo, apesar de eu ter tentado várias vezes.

Eu agradeço a cooperação mas, agora vou fazer algumas perguntas de leigo:

1 - Como o meu Ubuntu 9.10 emulado tá pegando internet do XP, tem alguma forma de eu transferir o gnome-ppp já instalado nele para algum arquivo de instalação, salvar este arquivo no meu pendrive, reiniciar pelo Ubuntu real e instalar o gnome-ppp?

2 - No Synaptic, as propriedades do gnome-ppp mostram os arquivos de dependência e aí vem minha outra pergunta: essa lista de arquivos mostra eles na ordem em que devem ser instalados? E se eu seguir esta ordem eles serão instalados um a um, sem problemas?

A lista do link http://packages.ubuntu.com/karmic/gnome-ppp também seguiria esta ordem?

Obrigado a quem se pronunciou!!!!! Valeu mesmo.




Bem se vc não conseguiu aí faça assim, baixe estes pacote:

debconf_1.5.27ubuntu2_all.deb
http://mirrors.kernel.org/ubuntu/pool/main/d/debconf/debconf_1.5.27ubuntu2_all.deb

libwvstreams4.6-base_4.6-2_i386.deb
http://mirrors.kernel.org/ubuntu/pool/main/w/wvstreams/libwvstreams4.6-base_4.6-2_i386.deb

libwvstreams4.6-extras_4.6-2_i386.deb
http://mirrors.kernel.org/ubuntu/pool/main/w/wvstreams/libwvstreams4.6-extras_4.6-2_i386.deb

libuniconf4.6_4.6-2_i386.deb
http://mirrors.kernel.org/ubuntu/pool/main/w/wvstreams/libuniconf4.6_4.6-2_i386.deb
 
wvdial_1.60.1+nmu2ubuntu1_i386.deb
http://mirrors.kernel.org/ubuntu/pool/main/w/wvdial/wvdial_1.60.1+nmu2ubuntu1_i386.deb

gnome-ppp_0.3.23-1ubuntu2_i386.deb
http://mirrors.kernel.org/ubuntu/pool/universe/g/gnome-ppp/gnome-ppp_0.3.23-1ubuntu2_i386.deb

e instale na sequencia do primeiro ao último ou coloque tudo numa pasta, entre nela pelo terminal e digite:

sudo dpkg -i *.deb

PS: estes pacotes são para versão 32bits do Ubuntu 9.10 se a sua for 64bits, são outros pacotes


No Synaptic seria assim vc clica no procurar e digita gnome-ppp, ele vai listar numa área logo abaixo, aí vc clica nele com o botão direito e escolhe marcar para instalação. Se vc clicar no botão Aplicar ele vai informar que dependências precisa instalar e o que precisa ser removido no seu sistema para não ter conflito (isso somente se existir) e basta vc concordar. Se ao invés de vc clicar no botão Aplicar, depois de ter selecionado o discador gnome-ppp para instalação, vc for ao menu Arquivos do Synaptic e escolha lá a opção Gerar script de download do(s) pacote(s) e ele irá gerar o script com suas dependências. Acho que vc não deve ter marcado o discador gnome-ppp para instalação, então ele gerou um script vazio.

Acho que no site mostra as dependências em ordem alfabética e nem sempre é preciso de todas, pois algumas delas já estão instalados no seu sistema por ser dependência de outros aplicativos já instalados aí. Além disso uma dependência do gnome-ppp, pode ter por si só mais uma quantidade X de dependências gerando uma reação em cadeia o que pode tornar o processo muito trabalhoso a instalação de pacotes indo pegar no site http://packages.ubuntu.com/karmic/
« Última modificação: 28 de Janeiro de 2010, 19:09 por alarcon »

Offline Adailton_Melo

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
    • Preparando a Hospitalidade para o mundo globalizado
Re: Baixar o gnome-ppp pelo XP e depois instalar no Ubuntu 9.10 (erros)
« Resposta #7 Online: 29 de Janeiro de 2010, 14:06 »
Grande Alarcon, obrigadíssimo pela ajuda!!!!!!!!

Como novato que sou, estou quebrando a cabeça que só, mas, estou aprendendo. Finalmente consegui instalar o Gnome-ppp através do Aptoncd que instalei no meu Ubuntu emulado. Configurei tudo certinho, o wvdial discou beleza no Nokia da Embratel, no celular até apereceu tráfego de rede, mas internet no pc que é bom, nada!!!!!

Fucei, fucei e fucei. Acabou que não sei porque razão, o XP começou a congelar logo após o login. E deve ter sido alguma coisa com o Nokia. Digo isso porque tive que restaurar o sistema para o dia 1º desse mês. Já estava desesperado e conformado em ter que formatar o XP. Que bom que eu consegui restaurar o sistema!!!!!!

Mas, depois de restaurado, o XP acusava que um dispositivo não estava funcionando corretamente. Deduzi que foi o Nokia. Fui conectar e  nada. Então, desinstalei os Drivers do Nokia, reiniciei pelo XP, reinstalei o Nokia e cá estou eu de volta a net.

Sabe de uma coisa?!!! Vou quietar aí uns dias com a idéia do meu Ubuntu 9.10 concectar com a net da Embratel. Apesar dos sustos e dos sufocos, aprendi mais um pouco sobre Linux. Pra mim já valeu o esforço. Obrigado a quem se pronunciou
Adailton Melo