Autor Tópico: [resolvido] Resolução retorna para 800x600  (Lida 4636 vezes)

Offline cezarpaes

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
    • Insanidade Parcial
[resolvido] Resolução retorna para 800x600
« Online: 22 de Dezembro de 2009, 22:50 »
Tenho uma placa de vídeo Nvidia MX4000 com o driver oficial instalado, quando coloco na resolução 1024x768 ele vai, mas depois que reinicio ele volta pra 800x600.

Já tentei de tudo, vi outros tópicos explicando diretinho... mas nada funciona!

Entro como root, comando nvidia-settings e quando clico em "save to X configuration file" aparece uma caixa escrito: "failed to parse existing X conf file 'etc/X11/Xorg.conf"

E no terminal fica:
"VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Undefined Device "(null)" referenced by Screen "Default Screen"."
 
Já tentei o
Código: [Selecionar]
sudo dpkg-reconfigure -phigh xserver-xorg mas não aconteceu nada!

Aqui vai o meu Xorg.conf

Código: [Selecionar]
Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Se alguém puder me ajudar eu fico muito agradecido.
« Última modificação: 23 de Dezembro de 2009, 02:56 por cezarpaes »

Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Resolução retorna para 800x600
« Resposta #1 Online: 22 de Dezembro de 2009, 23:51 »
Tentou ir em Sistema > Preferências > Resolução ? (Gnome)

Offline cezarpaes

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
    • Insanidade Parcial
Re: Resolução retorna para 800x600
« Resposta #2 Online: 23 de Dezembro de 2009, 00:09 »
Já, e como disse... ele vai pra 1024x768, mas quando reinicio ele volta pra 800x600

Offline niquelnausea

  • Usuário Ubuntu
  • *
  • Mensagens: 967
    • Ver perfil
Re: Resolução retorna para 800x600
« Resposta #3 Online: 23 de Dezembro de 2009, 01:35 »
Eu já tive esse mesmo problema, a solução foi entrar no sistema como root (para isso atribua uma senha para o root digitando no terminal sudo passwd root), depois logado como root va em Sistema>>Preferencias>>NVIDIA X Server Settings, configurei a resolução e pedi para salvar Save to X Configuration File.

Offline cezarpaes

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
    • Insanidade Parcial
Re: Resolução retorna para 800x600
« Resposta #4 Online: 23 de Dezembro de 2009, 02:01 »
Entro como root, comando nvidia-settings e quando clico em "save to X configuration file" aparece uma caixa escrito: "failed to parse existing X conf file 'etc/X11/Xorg.conf"


Offline cezarpaes

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
    • Insanidade Parcial
Re: Resolução retorna para 800x600
« Resposta #6 Online: 23 de Dezembro de 2009, 02:55 »
Uhuuuuuuuuuuuuuuuuuuuuuuuuuuul \o/

funcionou a dica do primeiro link

Valeu, Gui_Flux. o/

Offline erkrijo

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: Resolução retorna para 800x600
« Resposta #7 Online: 28 de Dezembro de 2009, 23:44 »
Tenta essas coisas:
http://johnnydopefish.blogspot.com/2009/05/ubuntu-904-nvidia-failed-to-parse.html
ou
http://ubuntuforums.org/showpost.php?p=7165382&postcount=9

Só pra saberem...

~$ sudo nvidia-settings

VALIDATION ERROR:  Data incomplete in file /etc/X11/xorg.conf.
At least one Device section is required.

Falha de segmentação
~$

Offline dezt

  • Usuário Ubuntu
  • *
  • Mensagens: 17
  • Dezt - Escape From This World!
    • Ver perfil
    • Escape From This World!
Re: [resolvido] Resolução retorna para 800x600
« Resposta #8 Online: 19 de MAR?O de 2010, 23:46 »
Então, eu também fiz isso, aparentemente resolveu tudo, mas após reiniciar a máquina, ficou tudo lento, as bordas das janelas sumiram e o terminal + algumas outras janelas ficaram 100% em branco, sem botões, sem nada, etc.

Só após desativar os efeitos é que voltou ao normal, porém, perco alguns efeitos básicos, como transparência no terminal, etc.

Após reiniciar, volta tudo lentão novamente, sem bordas, sem nada.

GPU: nVidia GeForce 3 Ti 200.

Offline mhkgalvez

  • Usuário Ubuntu
  • *
  • Mensagens: 289
  • Não temas: A Esperança VIVE!!!
    • Ver perfil
    • The Century Truth - Conhecendo a Verdade deste Século.
Re: [resolvido] Resolução retorna para 800x600
« Resposta #9 Online: 19 de Maio de 2010, 15:35 »
Usei a dica do primeiro link mas não deu certo! Alguém pode me ajudar!
"A quem vencer, eu o farei coluna no templo do meu Deus, e dele nunca sairá; e escreverei sobre ele o nome do meu Deus, e o nome da cidade do meu Deus, a nova Jerusalém, que desce do céu, do meu Deus, e também o meu novo nome."