Autor Tópico: Multimídia no Dapper!  (Lida 87534 vezes)

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.677
    • Ver perfil
Multimídia no Dapper!
« Online: 27 de Abril de 2006, 15:37 »
Este tutorial serve para as versões 32bits do Dapper!

O Tutorial foi aprimorado com a ajuda de vocês. As coisas estão mais fáceis. O que eu faço é instalar o Ubuntu e depois o KDE e o XFCE e testar isso tudo. Para mim funciona. Mas para aqueles que instalam apenas o Ubuntu, o Kubuntu ou o Xubuntu, as coisas devem mudar um pouco. Meus agradecimentos a todos que ajudaram nas mudanças: Éderson ( nova lista do Repositório Marillat), José Vitor (dica do Globo Media Center), Agent Orange (teste do Java 1.4 e 1.5), RC2006, Gony64 e Hanover ( repositório do Listen). Espero que o Marcusvinicius e o Gony64 falem pra gente sobre a viabilidade do uso deste tutorial num sistema 64bits!


Problemas já detectados:  Quando instalar o sun-java5-bin (o Java), prefira usar o Synaptic no   Ubuntu/Kubuntu/Xubuntu/Edubuntu!  Depois de ter instalado o Java 1.5 é preciso "dizer" ao sistema para usar o Java 1.5. Para isso vá até o terminal e faça: sudo update-alternatives --config java . Ele deve mostrar que existem duas versões, o Java 1.4 e o Java 1.5. Escolha o Java 1.5.

Por favor leiam todo o tutorial antes de realizar qualquer modificação.

Este tutorial tem o objetivo de dar suporte aos principais arquivos multimídia no Dapper 32bits. Estou assumindo que você está fazendo a instalação desses pacotes após uma instalação nova do Dapper. Foi exatamente o que fiz aqui na minha máquina. Ao final dele o seu Dapper deverá ser capaz de lidar com os seguintes tipos de arquivos multimídia (foram os que consegui testar): mp3, Ogg-Vorbis, m4a (aac), ape (vejam o final do tutorial), XviD, wma,  avi, wmv (os protegidos pela DRM não são suportados), divx, mpeg, pdf, streaming de vídeos (trailers do sites da  Apple, Omelete e Yahoo), animações Flash, Java (para acessar sites de Bancos), assistir DVDs, fontes da Microsoft e etc.
Este tutorial não tem o objetivo de substituir o Script Automatix ou o Guia Easy Ubuntu.  Se quiser suporte a arquivos MIDI sugiro que use o Automatix.

Para os que não quiserem se incomodar com a instalação manual da maioria dos pacotes que são sugeridos aqui, você pode usar o Scripts Bumps do Fórum Americano do Ubuntu:

http://ubuntuforums.org/showthread.php?t=181248&highlight=Bumps

http://www.ubuntuforums.org/showthread.php?t=181251

O Bumps instalará basicamente os mesmo pacotes deste tutorial. Aqui instalaremos mais pacotes que o Bumps, além dele não te dar dica nenhuma. É só dar uma lida no arquivo Readme do Bumps para ver toda a lista de pacotes que ele instala. O desenvolvedor do Bumps promete para logo a inclusão da instalação dos Driver da Nvidia e ATI. Neste tutorial não incluirei esses Drivers, visto que já temos Tópicos excelentes sobre como instalar tais Drivers aqui no Fórum.

Entenda que mesmo com o Codec necessário para execução de um determinado arquivo multimídia instalado, pode acontecer da aplicação escolhida por você para reproduzí-lo, não dar suporte a ele. Por isso é importante que você teste vários programas de sua escolha para tal. Como exemplo vou falar dos arquivos APE ( o formato Monkey Audio ). Mesmo depois de instalada as bibliotecas necessárias para sua reprodução, se você não instalar o suporte à arquivos APE no XMMS ou no BMP, você não conseguirá executar os arquivos APE!





Iremos alterar a lista de repósitórios do Dapper para que você possa baixar todos os pacotes necessários ao suporte multimídia. A lista usada é a seguinte: Obs. ( 10/07/2006): A lista do Bumps foi tirada do ar, no Lugar dela o mantenedor do Bumps colocou outras duas listas, uma do Debian Multimedia, a outra foi a do Issaris que voltou a fazer parte do Bumps. Mas ele avisa que você deve rezar para o Issaris funcionar! Após ter modificado a lista, antes do "recarregar" ou apt-get update, adicione a chave de autenticação do Debian Multimedia. Vá até o terminal e fique logado como usário root:

gpg --keyserver hkp://wwwkeys.eu.pgp.net --recv-keys 1F41B907
gpg --armor --export 1F41B907 | apt-key add -

Obrigado ao kunigas pela dica da chave.


Código: [Selecionar]



#
# deb cdrom:[Ubuntu 6.06 _Dapper Drake_ - Release i386 (20060531)]/ dapper main restricted


# deb cdrom:[Ubuntu 6.06 _Dapper Drake_ - Release i386 (20060531)]/ dapper main restricted

deb-src http://archive.ubuntu.com/ubuntu/ dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu/ dapper universe main restricted multiverse
deb-src http://archive.ubuntu.com/ubuntu/ dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse


deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe


##Bumps - Temporariamente fora do ar.
#   deb http://www.politicalcrossfire.com/ubuntu/dapper dapper main non-free


## Debian Multimedia Repository
     deb http://www.debian-multimedia.org sarge main

## Issaris' ffmpeg repository- cross your fingers and hope it works!
     deb http://issaris.be/breezy ./

## Cristhian Marillat
# deb http://www.debian-multimedia.org sarge main
# deb http://www.debian-multimedia.org etch main
# deb http://www.debian-multimedia.org sid main



Para incluir a lista  acima vá até o terminal e digite:

Código: [Selecionar]
sudo gedit /etc/apt/sources.list 

Copie e cole  a lista acima no lugar da sua lista original. Se quiser manter a sua lista original é só recortar e colar em outro  editor de texto de sua escolha, mais tarde é só repetir esse passo e voltar tudo como era antes.

Se você for usuário do Kubuntu poderá usar o "kate", e se for usuário do Xubuntu poderá usar o "nano" no lugar do "gedit".

Se você preferir o terminal pode continuar nele e digitar:

Código: [Selecionar]
sudo apt-get update
Se não gostar do terminal e for usuário do Ubuntu/Xubuntu vá até o Synaptic e clique em  “Recarregarr”. Se for usário do Kubuntu use o Adept. Ao final da atualização será mostrado um aviso de que alguns repositórios não são autenticados. Você pode desconsiderar isso, já que introduzimos repositórios que não pertencem a lista oficial do Dapper. Fique atento para o fato da lista do Cristian Marillat estar comentada (com o símbolo do jogo da velha  “##” na sua frente, o que faz o Dapper não  “enxergarr” essas linhas). O Real Player 10  e se você preferir um pacote mais atual do w32codecs, serão instalados depois com a lista do Cristian Marillat. Portanto, na primeira etapa a lista do Marillat fica comentada. Depois de algum tempo deve ser mostrado o ícone de atualização disponível do Ubuntu. Desconsidere esse aviso também.

Realizar uma atualização do sistema com repositórios não oficiais ativos representaria um risco enorme a integridade do sistema. Listarei os pacotes que iremos instalar, assim fica fácil para vocês usarem a busca no Synaptic/Adept ou digitar isso tudo no terminal. E é claro, você poderá escolher os pacotes que irão servir para você, coisa que você não poderá fazer ao escolher em usar o Bumps. Se for usar o terminal é só digitar ou copiar e colar os nomes de todos os pacotes com espaço entre os nomes deles depois do comando: sudo apt-get install. Exemplo:

sudo apt-get install sun-java5-bin sun-java5-plugin acroread.... + ENTER ao final da lista.


Instalaremos os seguintes pacotes (não se preocupem com as dependências, o Synaptic (no Ubuntu/Xubuntu/Edubuntu)  ou o Adept (no Kubuntu) cuidarão disso para você. Se preferir o modo texto o  “aptt” também cuidará de tudo:

Pacotes para o Ubuntu/Xubuntu/Edubuntu
sun-java5-bin
sun-java5-plugin
acroread
acroread plugins
mozilla-acroread
cpdvd (para copiar o conteúdo de um DVD para o HD)
faac
faad
ffmpeg
flac
gstreamer0.10-ffmpeg
gstreamer0.10-gl
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly-multiverse
gstreamer0.10-sdl
gstreamer0.8-vorbis  (para decodificar arquivos ogg para CDs de Áudio usando o Gnomebaker)
gstreamer0.8-flac  (para decodificar arquivos mp3 para CDs de Áudio usando o Gnomebaker)
gstreamer0.8-mad (para decodificar arquivos mp3 para CDs de Áudio usando o Gnomebaker)
gstreamer0.8-misc (para decodificar arquivos ogg/mp3 para CDs de Áudio usando o Gnomebaker)
gstreamer0.8-artsd (se você for usuário do Ubuntu mas instalar o Kubuntu-desktop)
lame
libdc1394-13-dev (para câmeras digitais)
mpg123 (para ouvir mp3 no nautilus quando passar o ponteiro do mouse sobre a música)
mpg321 (para ouvir mp3 no nautilus quando passar o ponteiro do mouse sobre a música)
gqmpeg (para ouvir ogg no nautilus quando passar o ponteiro do mouse sobre a música)
libdvdcss2 (para reprodução de DVDs encriptados)
libdvdread3 (para reprodução de DVDs)
regionset (modifica a região de codificação para reprodução de DVDs - uso em modo texto)
xine-ui  (se preferir em continuar com interface gráfica do Totem, mas sem as suas limitações, use o Totem-xine)
libxine-extracodecs
libxine-main1
mjpegtools
msttcorefonts (fontes da Microsoft)
sox
w32codecs (Codecs da Microsoft)
mplayer
mozilla-mplayer
mplayer-fonts
flashplugin-nonfree
vive (encoder de vídeo para o formato do iPod)




Pacotes para o Kubuntu - indicação do Fórum Gringo, por favor testem e me avisem se é necessário alguma mudança
sun-java5-bin
sun-java5-plugin
acroread
cpdvd
faac
faad
ffmpeg
flac
gstreamer0.10-esd
gstreamer0.8-artsd
kdemultimedia
libarts1-dev
lame
libdc1394-13-dev
libdvdcss2
libdvdcss2-dev
libdvdread3
libxine-extracodecs
libxine-main1
mjpegtools
mozilla-acroread
mplayer
mozilla-mplayer
msttcorefonts
sox
totem-xine
w32codecs
flashplugin-nonfree
vive (encoder de vídeo para o formato do iPod)




Aproximadamente 126MB serão baixados e 346MB de espaço extra serão utilizados depois destes    pacotes instalados. Isso pode variar bastante de acordo com os pacotes escolhidos por você.
Aproveite e vá tomar um café enquanto os pacotes são baixados. Isso pode demorar muito dependendo da velocidade de sua conexão. Na hora em que os pacotes começarem a ser instalados fique atento pois serão feitas duas perguntas. Uma sobre você aceitar a licença do Java e outra sobre a instalação do Flash, você deve permitir que ele baixe o Flash-plugin-nonfree direto do site da Macromedia. Sugiro que você não use o Flash opensource presente nos repositórios oficias do Dapper. Ele é responsável por muitas travadas e instabilidades em todos os navegadores que você venha usar no Dapper.
   
:arrow: Realplayer10 (aqui é onde entra a lista do Cristian Marillat). Volte ao começo do tutorial e descomente as linhas do Marillat e comente  a linha do Debian Multimídia e do Issaris. Depois mais um  “recarregarr” ou apt-get update e instale o Realplayer 10. Aproximadamente 6,2MB serão baixados e mais 15MB de espaço extra serão utilizados.

:arrow:Atualização w32codecs Se você preferir com os repositórios Marillat ativados, note que você poderá atualizar o w32codecs para uma versão mais nova que a do repositório Bumps. Você decide! :)

Retorne ao sources.list e comente os repositórios Marillat. Novo apt-get update ou  “Recarregarr”. Pronto! Você estará novamente apenas com uma lista de repositórios oficiais do Dapper. 



No caso deste tutorial eu optei por instalar o Mplayer e o plugin do Mplayer para o FireFox, com isso você poderá assistir trailers dentro da janela do Navegador. Se você não gostar  você pode mudar, você têm mais duas opções. Você pode usar o Totem ou o Kaffeine. É só trocar os pacotes mplayer, mozilla-mplayer e mplayer-fonts por :

Código: [Selecionar]
(Totem)
totem-xine
totem-xine-firefox-plugin


Código: [Selecionar]
(Kaffeine)
kaffeine
kaffeine-mozilla


Eu testei os três.  Se você tiver uma conexão de alta velocidade (falo em mais de 1MB, de preferência de 2MB em diante) pode usar o Totem ou Kafeinne sem problemas. Se não for o seu caso, use o Mplayer. O que acontece é o seguinte, os Trailers estão cada vez maiores, no site da Apple já temos trailers de mais de 150MB! Isso mesmo, tudo isso. O Mplayer é o único dos três que é capaz de baixar o arquivo e depois tocá-lo ao clicarmos em  “atualizarr” no Firefox, assim poderemos assistir ao trailer sem pulos ou travadas. Os outros dois não fazem isso. Mostrarão o trailer de acordo com a velocidade de sua conexão! Se você clicar em atualizar o download começara da estaca zero!  O Kaffeine abre uma janela fora do Navegador.

:arrow:TV Terra no Dapper: Agradecimentos ao Brodock do Fórum do Kurumin. Vou explicar o que vamos fazer, chamaremos o Nautilus/konqueror/Thunar como Root (Muito cuidado nessa parte, você pode detonar o seu sistema se apagar algum arquivo ou pasta importante por engano), para apagarmos ou mudar de lugar os plugins do Mplayer que impedem os do Realplayer de funcionarem corretamente. Vamos fazer isso com o Mozilla e o Firefox. No Firefox o Real Player não está funcionando corretamente.  Abre a página da TV Terra e dá erro quando clicamos em algum vídeo para ser assistido ( se vocês conseguirem usar, fiquem a vontade de contar pra gente o que fizeram).

No terminal:

Código: [Selecionar]
sudo nautilus

ou

sudo konqueror

ou

sudo thunar

Procure pelas seguintes pastas:

Para o Firefox /usr/lib/firefox/plugins

Para o Mozilla  /usr/lib/mozilla/plugins

Dentro destas pastas você deve encontrar 4 plugins que nos interessam. São eles:

Código: [Selecionar]
nphelixz.so
nphelix.xpt
e
mplayerplug-in-rm.so
mplayerplug-in-rm.xpt

Recorte e cole os mplayerplug-in-rm.so e mplayerplug-in-rm.xpt em outra pasta de sua escolha. Você deve fazer isso nas duas pastas indicadas acima.

Reinicie ou Inicie o seu Navegador. Agora você já deve ser capaz de assistir a TV Terra no Mozilla.

http://tv.terra.com.br

Mas Galactus, não uso o Velho Mozillão. É só instalá-lo pelo Synaptic/Adept, procure pelos seguintes pacotes:

Código: [Selecionar]
mozilla-browser e mozilla-psm

Para pré-visualizar (ouvir) os arquivos mp3 e ogg no Nautilus: tenha certeza de ter habilitado essa função nele, pois mesmo com aqueles pacotes instalados você não será capaz de ouvir nada sem ter habilitado o Nautilus. Como fazer isso? Dentro do Nautilus vá até: Editar > Preferências > pré-visualização. Mude as seguintes caixas de diálogo: Outros tipos de arquivos (aqui o principal é mudar o tamanho do arquivo que poderá ser pré-visualizado, escolha o tamanho máximo de arquivo que ele poderá tocar quando você passar o ponteiro do Mouse sobre ele) e Arquivos de Som (deixa na opção  “Sempree”).  Se não quiser nada disso, apenas não instale os três pacotes que listei quanto a esta funcionalidade.

:arrow:Tocador de MP3/Ogg alternativo para o Gnome: Por padrão o Ubuntu tem instalado o Rhythmbox como tocador de mp3/ogg. Se você gosta de um tocador mais ao estilo do Amarok do KDE (que já vem como padrão no Kubuntu) e não gostaria de instalar o mesmo no Ubuntu, seus problemas acabaram! Instale o Listen Gnome. Você pode fazer isso de duas maneiras. Baixando ele do site do desenvolvedor: http://listengnome.free.fr/

Algumas vezes o site encontra-se fora do ar. Ou então adicionar o seguinte repositório para instalar pelo Synaptic:
#Listen
deb http://theli.free.fr/packages/ dapper listen

 E procure por Listen. Infelizmente o desenvolvedor do Listen Gnome só esta trabalhando em versões mais recentes para o Dapper.


:arrow:Arquivos APE (Monkey Audio): Para poder tocar arquivos APE no Dapper teremos algum trabalho. Mas não se preocupe. No final, entre mortos e feridos, todos irão se salvar! :)  Preparado? Então mãos a obra!
   Primeiro certifique-se de ter instalado o XMMS ou o BMP. Eu particularmente prefiro o XMMS, mas como gosto não se discute, faça a sua escolha. Os dois estão presentes nos repositórios oficias do Dapper. É só dar uma busca por eles no Synaptic/Adept.  Depois visite o site Rarewares Debian Unstable ( http://rarewares.soniccompression.com/debian/packages/unstable/ ) e baixe os seguintes pacotes (estão listados em ordem alfabética no site  – para os usuários mais avançados será uma fonte de ótimos pacotes, sei que ficarão contentes):

bmp-mac_0.1.1-0.1_i386.deb - Se preferir o BMP
xmms-mac_0.3.1-0.1_i386.deb - Se preferir o XMMS
monkeys-audio_3.99+update4+build4-0.0_i386.deb
libmac2_3.99+update4+build4-0.0_i386.deb

   Agora abra o Nautilus, vá até a pasta onde você baixou os pacotes acima e clique duas vezes neles para que sejam instalados pelo Gdebi (eu testei no Kubuntu, é preciso ir até o terminal. No Xubuntu eu não testei), eles devem ser instalados na seguinte ordem:
1) libmac2_3.99+update4+build4-0.0_i386.deb
2) monkeys-audio_3.99+update4+build4-0.0_i386.deb
3) xmms-mac_0.3.1-0.1_i386.deb

   
   No passo 3 troque o xmms-mac pelo bmp-mac se tiver preferido instalar o BMP.

Se não puder usar o Gdebi, vá até o terminal e faça:

Código: [Selecionar]
sudo dpkg -i nomedopacote.deb
Na ordem descrita acima.

Para converter o arquivo APE em Cd de Áudio usando o Gnomebaker, instale o pacote gstreamer0.8-monkeysaudio_0.8.2-0rarewares1_i386.deb . Ele está no http://rarewares.soniccompression.com/debian/packages/unstable/


Vou ficando por aqui, espero não ter sido muito cansativo.  Que este tutorial possa ter sido útil para você.

« Última modificação: 17 de Setembro de 2006, 10:48 por galactus »
Linux Mint 19.3 XFCE

Offline hanover

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
    • http://www.sodavirtual.com.br
CLAP CLAP CLAP CLAP CLAP
« Resposta #1 Online: 27 de Abril de 2006, 16:32 »
esse tutorial foi tudo que eu sonhei na vida

Uhuuuuu!

parabens galactus!!!!
GNU/Linux. Viva essa liberdade!

Offline hamtaro

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Multimídia no Dapper!
« Resposta #2 Online: 27 de Abril de 2006, 18:02 »
Sei que escrever sem esclarecer é ocupar o Fórum com "inutilidades"

Mas realmente GALACTUS. esse merece MUITOS APLAUSOS.

Vou tentar no Dapper Beta 64 Bits e posto os resultados.
Quando tiver que optar entre o direito e a justiça, opte pela justiça.
http://counter.li.org/cgi-bin/certificate.cgi/504092

Extremist

  • Visitante
Multimídia no Dapper!
« Resposta #3 Online: 27 de Abril de 2006, 22:13 »
muito bom cara, muito mesmo !  vlws ^^

Offline RC2006

  • Usuário Ubuntu
  • *
  • Mensagens: 822
  • Ubuntu 10.10
    • Ver perfil
Instalei mais alguns...
« Resposta #4 Online: 28 de Abril de 2006, 09:15 »
Reinstalei o Ubuntu Dapper beta e instalei todos aqueles ítens referidos acima.
Fazendo alguns testes, achei que não funcionou legal no meu computador.
Essa foi minha impressão inicial.
Ao colocar um filme de DVD no drive -> O Totem não pode iniciar.
O Mplayer não conseguia ler um arquivo.wma
Fiz a instalação pelo synaptic, procurando pelo nome -> marcar para instalação -> aplicar.
Então resolvi instalar pelo synaptic mais codecs que achava necessário e não constava como instalado pelo synaptic, tipo acidrip, mplayer plugin,mplayer skins, mplayer-586, mencoder-586, xmms-xmmplayer, etc...Acho que instalei mais alguns, mas não registrei pq não sabia se iria ser útil. Alguns são específicos para a  arquitetura do meu micro, portanto quem usa AMD, AMD64 ou outro tipo de arquitetura, o caminho seria outro.
O Totem acabou funcionando.
O Mplayer que após a instalação e solicitado para tocar uma musica.wma
-Could not open/initialize audio device - no sound
Agora está funcionando.
Um fato notado, é que ao fazer um update com estes repositórios multimidia descomentados, aparecem muitos arquivos ignorados além da advertencia de não possuirem assinatura.
HP All-in-one 4GB HD760 - windows7 home premium - Netbook Asus 1005PEB - Windows 7 - Ubuntu 11.04
Macbook branco 13.3" 2gb 160HD - Mac OS X 10.6 - Tablet Asus Eee Pad Transformer com dock - Android 3.2

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.677
    • Ver perfil
Re: Instalei mais alguns...
« Resposta #5 Online: 28 de Abril de 2006, 10:00 »
Citação de: "RC2006"
Reinstalei o Ubuntu Dapper beta e instalei todos aqueles ítens referidos acima.
Fazendo alguns testes, achei que não funcionou legal no meu computador.
Essa foi minha impressão inicial.
Ao colocar um filme de DVD no drive -> O Totem não pode iniciar.
O Mplayer não conseguia ler um arquivo.wma
Fiz a instalação pelo synaptic, procurando pelo nome -> marcar para instalação -> aplicar.
Então resolvi instalar pelo synaptic mais codecs que achava necessário e não constava como instalado pelo synaptic, tipo acidrip, mplayer plugin,mplayer skins, mplayer-586, mencoder-586, xmms-xmmplayer, etc...Acho que instalei mais alguns, mas não registrei pq não sabia se iria ser útil. Alguns são específicos para a  arquitetura do meu micro, portanto quem usa AMD, AMD64 ou outro tipo de arquitetura, o caminho seria outro.
O Totem acabou funcionando.
O Mplayer que após a instalação e solicitado para tocar uma musica.wma
-Could not open/initialize audio device - no sound
Agora está funcionando.
Um fato notado, é que ao fazer um update com estes repositórios multimidia descomentados, aparecem muitos arquivos ignorados além da advertencia de não possuirem assinatura.


Minha máquina é AMD, o Totem abre DVDs normalmente, o que notei é que ele não abre Divx. O Xine e o Mplayer estão tocando DVDs ou Divx normalmente. Garimpa aí pra gente estes pacotes extras que você instalou. Daí eu coloco junto com os outros. O Mplayer, o Xine, o Rhythmbox e o Totem tocaram vários arquivos wma aqui. O xmms não tocou nenhum.

Não entendi o mencoder. Ele serve pra codificar arquivos AVI/ASF/OGG/DVD/VCD/VOB/MPG/MOV/VIV/FLI/RM/NUV/NET.
Linux Mint 19.3 XFCE

Offline RC2006

  • Usuário Ubuntu
  • *
  • Mensagens: 822
  • Ubuntu 10.10
    • Ver perfil
Re: Instalei mais alguns...
« Resposta #6 Online: 28 de Abril de 2006, 11:35 »
Citação de: "galactus"
Minha máquina é AMD, o Totem abre DVDs normalmente, o que notei é que ele não abre Divx. O Xine e o Mplayer estão tocando DVDs ou Divx normalmente. Garimpa aí pra gente estes pacotes extras que você instalou. Daí eu coloco junto com os outros. O Mplayer, o Xine, o Rhythmbox e o Totem tocaram vários arquivos wma aqui. O xmms não tocou nenhum.

Não entendi o mencoder. Ele serve pra codificar arquivos AVI/ASF/OGG/DVD/VCD/VOB/MPG/MOV/VIV/FLI/RM/NUV/NET.

1.Acredito que como vc tem um AMD o mplayer (básico) tenha funcionado melhor. Mas, no meu caso, eu acrescentei o Mplayer-586 e parece que funcionou melhor.
2.Quanto ao mencoder foi só uma tentativa a mais para funcionar com filmes e DVDs. O Totem não estava conseguindo acessar o drive do DVD para rodar filmes.  Como já estava instalado o básico eu acrescentei o 586.
3.Foi uma impressão inicial. Ainda faltam testes.
Eu diria estágio alpha...rsrs
Na realidade, seria necessário para que estas observações se tornassem oficiais, teriamos de ter pelo menos uma dezena de usuários dispostos a fazer testes em máquinas diferentes e fornececer seu depoimento abonador aqui no fórum.
Com tantas atualizações diárias, o que não roda bem hoje pode rodar amanhã e vice-versa.
HP All-in-one 4GB HD760 - windows7 home premium - Netbook Asus 1005PEB - Windows 7 - Ubuntu 11.04
Macbook branco 13.3" 2gb 160HD - Mac OS X 10.6 - Tablet Asus Eee Pad Transformer com dock - Android 3.2

Offline RC2006

  • Usuário Ubuntu
  • *
  • Mensagens: 822
  • Ubuntu 10.10
    • Ver perfil
Avaliação inicial agora usando o Ubuntu Dapper beta2
« Resposta #7 Online: 29 de Abril de 2006, 12:11 »
Instalei seguindo este  tutorial multimídia , o artista foi o Totem, funcionou bem. Já o Mplayer nada.
Teclava num arquivo de vídeo e escolhia o mplayer, nada ocorria.
Resolvi da seguinte forma, desistalei tudo referente ao mplayer incluindo o w32codecs. Habilitei o repositório Marillat e desabilitei os Seveas e Issaris.
E instalei tudo de novo no que se referia a Mplayer. Desta vez, contrariando o que disse em outra mensagem, instalei só o Mplayer genérico (indicado no tutorial) e não o Mplayer-586  e está funcionando bem.
Falta testar sua habilidade na internet com o firefox.

    -Editado-

Testei e funcionou perfeitamente.
Usei este link como referencia para teste:

http://www.ubuntuforum-pt.org/index.php?topic=3674

Usando o synaptic, e com o repositório Marillat habilitado, foram carregados os seguintes ítens mostrados ao procurar a palavra Mplayer:

mplayer
mozilla-mplayer
mplayer-fonts
mplayer-skins
soundkonverter
w32codecs
« Última modificação: 01 de Julho de 2006, 18:39 por KubLin »
HP All-in-one 4GB HD760 - windows7 home premium - Netbook Asus 1005PEB - Windows 7 - Ubuntu 11.04
Macbook branco 13.3" 2gb 160HD - Mac OS X 10.6 - Tablet Asus Eee Pad Transformer com dock - Android 3.2

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Multimídia no Dapper!
« Resposta #8 Online: 29 de Abril de 2006, 17:09 »
Cara, valeu! Será muito útil para muita gente.

Offline marciovinicius

  • Usuário Ubuntu
  • *
  • Mensagens: 111
  • http://peixenarede.blogspot.com
    • Ver perfil
    • Peixe na rede
Deu erro!
« Resposta #9 Online: 30 de Abril de 2006, 12:56 »
Comigo não funcionaou muito bem... quando eu mandei o apt-get update, ele fez tudo normal com os repositórios que já vem com o Ubuntu Dapper, mas no final deu o seguinte erro:

Citar
Err http://users.lichtsnel.nl breezy-seveas/all Packages
  404 Not Found
Ign http://issaris.be ./ Release
Ign http://issaris.be ./ Packages
Atingido http://issaris.be ./ Packages
Obtendo:10 http://archive.ubuntu.com dapper/multiverse Packages [84,2kB]
Obtendo:11 http://archive.ubuntu.com dapper/multiverse Sources [46,2kB]
Baixados 788kB em 18s (43,1kB/s)
Falha ao baixar http://br.archive.ubuntu.com/ubuntu/dists/dapper/main/binary-amd64/Packages.bz2  MD5Sum incorreto
Falha ao baixar http://users.lichtsnel.nl/~seveas/dists/breezy-seveas/all/binary-amd64/Packages.gz  404 Not Found
Lendo Lista de Pacotes... Pronto
W: GPG error: http://users.lichtsnel.nl breezy-seveas Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível : NO_PUBKEY 49A120FD1135D466
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos
E: Alguns arquivos de índice falharam no download, eles foram ignorados ou os antigos foram usados em seu lugar.


Deixei pra lá e continuei com o processo do tutorial, mas alguns pacotes se recuram a ser intalados e outros não apareciam na lista do Synaptic...
<Asus K8U-X><AMD Athlon 64 3000+><1,5Gb>
<NVIDIA GeForce FX 5500 256Mb><HD S-ATA 80Gb><HD S-ATA 250Gb>
Kubuntu 9.04 amd64

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.677
    • Ver perfil
Re: Deu erro!
« Resposta #10 Online: 30 de Abril de 2006, 21:59 »
Citação de: "marciovinicius"
Comigo não funcionaou muito bem... quando eu mandei o apt-get update, ele fez tudo normal com os repositórios que já vem com o Ubuntu Dapper, mas no final deu o seguinte erro:

Citar
Err http://users.lichtsnel.nl breezy-seveas/all Packages
  404 Not Found
Ign http://issaris.be ./ Release
Ign http://issaris.be ./ Packages
Atingido http://issaris.be ./ Packages
Obtendo:10 http://archive.ubuntu.com dapper/multiverse Packages [84,2kB]
Obtendo:11 http://archive.ubuntu.com dapper/multiverse Sources [46,2kB]
Baixados 788kB em 18s (43,1kB/s)
Falha ao baixar http://br.archive.ubuntu.com/ubuntu/dists/dapper/main/binary-amd64/Packages.bz2  MD5Sum incorreto
Falha ao baixar http://users.lichtsnel.nl/~seveas/dists/breezy-seveas/all/binary-amd64/Packages.gz  404 Not Found
Lendo Lista de Pacotes... Pronto
W: GPG error: http://users.lichtsnel.nl breezy-seveas Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível : NO_PUBKEY 49A120FD1135D466
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos
E: Alguns arquivos de índice falharam no download, eles foram ignorados ou os antigos foram usados em seu lugar.


Deixei pra lá e continuei com o processo do tutorial, mas alguns pacotes se recuram a ser intalados e outros não apareciam na lista do Synaptic...


Você usa versão 64bits? E tá aparecendo lista aí que eu não coloquei no repositório deste tutorial!
Linux Mint 19.3 XFCE

Offline marciovinicius

  • Usuário Ubuntu
  • *
  • Mensagens: 111
  • http://peixenarede.blogspot.com
    • Ver perfil
    • Peixe na rede
Re: Re: Deu erro!
« Resposta #11 Online: 30 de Abril de 2006, 22:44 »
Citação de: "galactus"
Você usa versão 64bits?

Sim, eu uso a versão 64bits. Por que? o tutorial não é garantido para essa versão? (se bem que você disse logo de cara que é beta, não deve ser garantido para ninguém! :lol:)

Citação de: "galactus"
E tá aparecendo lista aí que eu não coloquei no repositório deste tutorial!

Pode até ser, mas no source.list está tudo igualzinho (eu copiei e colei).
Fiz de novo e deu uns erros diferentes, mas parece que o problema principal está no "Seveas' Repo's". pois não acha determindos arquivos e em outros diz dá erro... assim:

Código: [Selecionar]
Falha ao baixar http://users.lichtsnel.nl/~seveas/dists/breezy-seveas/all/binary-amd64/Packages.gz  404 Not Found
Falha ao baixar http://users.lichtsnel.nl/~seveas/dists/breezy-seveas/all/binary-amd64/Packages.gz  404 Not Found
Falha ao baixar http://br.archive.ubuntu.com/ubuntu/dists/dapper/universe/source/Sources.bz2  Sub-processo bzip2 retornou um código de erro (2)
Falha ao baixar http://security.ubuntu.com/ubuntu/dists/dapper-security/main/binary-amd64/Packages.bz2  Sub-processo bzip2 retornou um código de erro (2)
Falha ao baixar http://archive.ubuntu.com/ubuntu/dists/dapper/multiverse/binary-amd64/Packages.bz2  Sub-processo bzip2 retornou um código de erro (2)
Lendo Lista de Pacotes... Pronto
W: GPG error: http://users.lichtsnel.nl breezy-seveas Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível : NO_PUBKEY 49A120FD1135D466


Tem também alguns problemas de fontes duplicadas assim, por exemplo:

Código: [Selecionar]
W: Duplicate sources.list entry http://archive.ubuntu.com dapper/multiverse Packages (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_dapper_multiverse_binary-amd64_Packages)
<Asus K8U-X><AMD Athlon 64 3000+><1,5Gb>
<NVIDIA GeForce FX 5500 256Mb><HD S-ATA 80Gb><HD S-ATA 250Gb>
Kubuntu 9.04 amd64

Offline marciovinicius

  • Usuário Ubuntu
  • *
  • Mensagens: 111
  • http://peixenarede.blogspot.com
    • Ver perfil
    • Peixe na rede
Multimídia no Dapper!
« Resposta #12 Online: 30 de Abril de 2006, 23:17 »
Pelo synaptic tentei baixar os pacotes, só não consigo encontrar os seguintes (da primeira etapa do tutorial, os outros não tentei ainda);

acroread (e correlatos)
gpmpeg
libdvdcss2
w32codecs
flashplugin-nonfree

no lugar do flashplugin-nonfree usei um outro (libflash plugin) que não é bem a mesma coisa e também não funciona muito bem, eu agora consigo visualizar algumas animações em flash que antes não conseguia...
<Asus K8U-X><AMD Athlon 64 3000+><1,5Gb>
<NVIDIA GeForce FX 5500 256Mb><HD S-ATA 80Gb><HD S-ATA 250Gb>
Kubuntu 9.04 amd64

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.677
    • Ver perfil
Multimídia no Dapper!
« Resposta #13 Online: 01 de Maio de 2006, 11:51 »
marciovinicius, é importante sabermos a versão do DApper. Realmente deveria ter dito logo no começo que usei uma versão 32bits. Veja o caso do Flash, já sabemos que é problema na plataforma 64bits. Nem sei dizer dos outros codecs. Mas foi extamente por isso que pedi para todos postarem. Vamos porcurar descobrir problemas e soluções para todas as versões.

Estou olhando no Fórum gringo o cara responsável por esta lista de repositórios. E outros usuários, não todos, vem tendo problema para baixar alguns pacotes com essa lista. Uma alternativa é fazer como o RC2006, usar a lista Marillat.

Eu usava o libflash plugin, mas só dava pau com os navegadores e muitas páginas que eu visitava não abriam.
Linux Mint 19.3 XFCE

Offline Éderson

  • Usuário Ubuntu
  • *
  • Mensagens: 203
    • Ver perfil
Multimídia no Dapper!
« Resposta #14 Online: 05 de Maio de 2006, 21:57 »
Os repositórios abaixo não funcionam:
## Cristhian Marillat (NÃO FUNCIONOU)
deb ftp://ftp.nerim.net/debian-marillat/ sarge main
deb ftp://ftp.nerim.net/debian-marillat/ etch main
deb ftp://ftp.nerim.net/debian-marillat/ sid main
#O marillat é para o w32codecs, libdvdcss2, MPlayer, etc.

## Seveas' Repo's  (NÃO FUNCIONOU)
deb http://users.lichtsnel.nl/~seveas breezy-seveas all
deb-src http://users.lichtsnel.nl/~seveas breezy-seveas all

Pode-se acrescentar o repositório abaixo:
deb http://packages.freecontrib.org/ubuntu/plf/ breezy free non-free
#Nessa lista vc encontra o libdvdcss2, w32codecs, sun-j2re1.5, opera, Realplay, skype, etc.
#Caso os arquivos sumam do repositório acima, você pode encontrar a libdvdcss2 e
#w32codecs especialmente criados para o Ubuntu nas seguintes localizações:
#libdvdcss2 : ftp://cipherfunk.org/pub/packages/ubuntu/pool/main/libd/libdvdcss/
#w32codecs : ftp://cipherfunk.org/pub/packages/ubuntu/pool/main/w/w32codec