Autor Tópico: [Resolvido - Aléluia] internet discada no ubuntu 9.04  (Lida 132870 vezes)

Offline Lilian Dias

  • Usuário Ubuntu
  • *
  • Mensagens: 133
  • Eu sou um lixo. Quero morrer [mas não agora].
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #30 Online: 04 de Julho de 2009, 22:27 »
Eu fiz tudo direitinho e deu certo. Porém na hora de conectar, quando eu clico em "conectar" ai aparece este erro: "Não é possível abrir o modem". Clico no "registro" e tem o "Connection Log" que aparece estas informações:

http://img529.imageshack.us/img529/867/errom.png
Editado pela moderação

E também durante a instalação aparece este aviso (que no .pdf não avisa que iria aparecer este aviso):

http://img232.imageshack.us/img232/4642/aviso.png
Editado pela moderação
E agora???  :(
« Última modificação: 05 de Julho de 2009, 18:43 por clcampos »

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #31 Online: 04 de Julho de 2009, 22:32 »
Pronto...segui suas dicas e ja executei o script ScanModem. O arquivo ModemData ja foi gerado!!!
Não sei se interpretei direito, tanto porque tem muitas paginas, 11 ao total. Vou colar aki alguns poucos trechos que talvez sejam parte da solução pra que vc me diga por favor o que realmente resolveria meu problema.

=======================================
The dialer utility package WVDIAL does not appear to be installed on your System.
Please read Modem/DOCs/wvdial.txt

 There are no blacklisted modem drivers in /etc/modprobe*  files
 Potentially useful modem drivers now loaded are:
         snd_hda_intel       

=======================================

--- Bootup diagnostics for card in PCI slot 00:0f.0 ----
[    0.514836] pci 0000:00:0f.0: reg 10 32bit mmio: [0xb0100000-0xb0103fff]
[    0.514879] pci 0000:00:0f.0: PME# supported from D0 D3hot D3cold
[    0.514883] pci 0000:00:0f.0: PME# disabled
[    9.790651] HDA Intel 0000:00:0f.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[    9.790718] HDA Intel 0000:00:0f.0: setting latency timer to 64

 The PCI slot 00:0f.0 of the modem card may be disabled early in
 a bootup process,  but then enabled later.

========================================

The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.18
The modem cards detected by "aplay -l"  are:
placa 0: SIS966 [HDA SIS966], dispositivo 6: Si3054 Modem [Si3054 Modem]

The /proc/asound/pcm file reports:
-----------------------
00-00: ALC662 Analog : ALC662 Analog : playback 1 : capture 1
00-06: Si3054 Modem : Si3054 Modem : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [SIS966         ]: HDA-Intel - HDA SIS966
                      HDA SIS966 at 0xb0100000 irq 18

 PCI slot 00:0f.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.28-11-generic/kernel/sound/pci/hda/snd-hda-intel.ko
 The modem codec file for the HDA card is: /proc/asound/card0/codec#1
--------------------------------------------------------
Codec: Motorola Si3054
Address: 1
Vendor Id: 0x10573055
Subsystem Id: 0x10190000
Revision Id: 0x100700
Modem Function Group: 0x1

 The audio card hosts a softmodem chip:  0x10573055


ME DESCULPEM PELO TAMANHO DO POST


A única conclusão até agora por esta parte do arquivo ModemData.txt é a de que seu modem realmente é um  do tipo HDA.

Só conheço o driver smartlink e o conexant que podem dar suporte para alguns tipos de modem HDA, mas pode ter outros.

Normalmente neste arquivo tem alguma informação com alguns links de driver, tipo o smartlink ou conexant ou outro qualquer, portanto veja aí, pois no que vc mostrou até agora não dá para saber.

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #32 Online: 04 de Julho de 2009, 22:40 »
Eu fiz tudo direitinho e deu certo. Porém na hora de conectar, quando eu clico em "conectar" ai aparece este erro: "Não é possível abrir o modem". Clico no "registro" e tem o "Connection Log" que aparece estas informações:


E também durante a instalação aparece este aviso (que no .pdf não avisa que iria aparecer este aviso):



E agora???  :(



Acho que não foi instalado direito, o problema de usar o liveCD é que tudo fica perdido ao reiniciar, mas queria que você fizesse novamente os procedimentos e no terminal digitasse os seguintes comandos:


dmesg | grep slamr

lsmod | grep slamr

lsmod | grep ungrab*

ps -aux | grep slmodemd

sudo /etc/init.d/sl-modem-daemon restart


e colocasse aqui seus resultados.

Para alguns usuários é necessário executa mais estes comandos:

sudo su

chmod a+x /usr/sbin/pppd

e depois:

gpasswd -a ubuntu dip


mas só que estes dois comandos só teriam efeito após uma reinicialização o que não seria o seu caso que está usando em liveCd e portanto isso não seria possível. Esses comandos são para solucionar alguns problemas  de permissões.

Alternativamente você poderia abrir um terminal e digitar:

sudo su

para virar root e chamar o discador como root digitando no terminal isso:

gnome-ppp

ele irá abrir o terminal como root e portanto não teria problemas com permissões, só que todas as configurações que eu faço conforme suas respostas ao script de instalação seriam zeradas, pois elas foram feitas para o usuário ubuntu e não o root, então vc pode antes verificar como estão as configurações do gnome-ppp aberto como usuário normal e depois ao chamar como root e aplicar as mesmas configurações.


Continuando do mesmo modo, então faça mai isso no terminal:

sudo su

/etc/init.d/sl-modem-daemon stop

modprobe -r ungrab-winmodem

modprobe -r slamr

mknod -m 600 /dev/slamr0 c 242 0

modprobe ungrab-winmodem

modprobe slamr

/etc/init.d/sl-modem-daemon restart


e tente usar outra vez o discador gnome-ppp, tanto com o usuário normal como com o root.

Sobre a mensagem que é mostrada falando do comando:

sudo route add default ppp0

é falado sobre ele sim no .pdf na parte de solucionado os problemas pagina 15 (final da página), mas não é para se preocupar com isso no momento. Este pdf foi feito em pacotes muito antigos v16 e já estamos no v30, então tem algumas pequenas alterações no modo de proceder, dê um desconto ok.
« Última modificação: 04 de Julho de 2009, 22:56 por alarcon »

Offline MLessa

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #33 Online: 04 de Julho de 2009, 22:49 »
For HDA cards with ALC883 chips, an upgrade to ALSA verions 1.0.15 way be necessary. Instructions for Upgrading snd-hda-intel and its dependent driver set are at:
http://linmodems.technion.ac.il/bigarch/archive-eighth/msg00838.html


Achei esse link... Seria apropriado?

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #34 Online: 04 de Julho de 2009, 22:50 »
For HDA cards with ALC883 chips, an upgrade to ALSA verions 1.0.15 way be necessary. Instructions for Upgrading snd-hda-intel and its dependent driver set are at:
http://linmodems.technion.ac.il/bigarch/archive-eighth/msg00838.html


Achei esse link... Seria apropriado?


Não tem nada falando sobre smartlink, conexant, agere ou etc.?

Offline MLessa

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #35 Online: 04 de Julho de 2009, 22:55 »
 Download from http://linmodems.technion.ac.il/packages/smartlink/
 the package SLMODEMD.gcc4.3.tar.gz having a compiled slmodemd. Unpack under Linux with:
    $ tar zxf SLMODEMD.gcc4.3.tar.gz

==========================================

The softmodem chip 0x10573055 is in principle supported by the COMM support of slmodemd
and the joint snd-hda-intel audio+modem driver, begun with ALSA version 1.0.13. 
For HDA cards with ALC883 chips, an upgrade to ALSA verions 1.0.15 way be necessary. Instructions for Upgrading snd-hda-intel and its dependent driver set are at:
http://linmodems.technion.ac.il/bigarch/archive-eighth/msg00838.html

If not a Conexant modem, the driver snd-hda-intel with its dependent drivers:
snd_hda_intel         435636  3
snd_pcm                82948  2 snd_hda_intel,snd_pcm_oss
snd                    62628  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc         16904  2 snd_hda_intel,snd_pcm
----------
=============================================
Ajuda?  Vou terminar postando o arquivo todo :p

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #36 Online: 04 de Julho de 2009, 22:58 »
Download from http://linmodems.technion.ac.il/packages/smartlink/
 the package SLMODEMD.gcc4.3.tar.gz having a compiled slmodemd. Unpack under Linux with:
    $ tar zxf SLMODEMD.gcc4.3.tar.gz

==========================================

The softmodem chip 0x10573055 is in principle supported by the COMM support of slmodemd
and the joint snd-hda-intel audio+modem driver, begun with ALSA version 1.0.13.  
For HDA cards with ALC883 chips, an upgrade to ALSA verions 1.0.15 way be necessary. Instructions for Upgrading snd-hda-intel and its dependent driver set are at:
http://linmodems.technion.ac.il/bigarch/archive-eighth/msg00838.html

If not a Conexant modem, the driver snd-hda-intel with its dependent drivers:
snd_hda_intel         435636  3
snd_pcm                82948  2 snd_hda_intel,snd_pcm_oss
snd                    62628  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc         16904  2 snd_hda_intel,snd_pcm
----------
=============================================
Ajuda?  Vou terminar postando o arquivo todo :p


Já que ele fala em smartlink tente usar isso aqui:

http://ubuntuforum-br.org/index.php/topic,52065.0.html

que acho que seria melhor para o caso de modems HDA.

Se seu modem realmente for suportado pelo driver smartlink, este driver tm de ser usado na forma alsa.

algo do tipo:

/sbin/slmodemd --perm=0666 -c BRAZIL --alsa hw:0,6
« Última modificação: 04 de Julho de 2009, 23:02 por alarcon »

Offline MLessa

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #37 Online: 04 de Julho de 2009, 23:00 »
Ok... vou seguir esse seu ultimo link, porém se vc estiver disposto postei o arquivo completo no rapidShare sob este link:
http://rapidshare.com/files/252048282/ModemData.doc.html

Brigadão!

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #38 Online: 04 de Julho de 2009, 23:08 »
Ok... vou seguir esse seu ultimo link, porém se vc estiver disposto postei o arquivo completo no rapidShare sob este link:
http://rapidshare.com/files/252048282/ModemData.doc.html

Brigadão!

é isso mesmo, pelo seu modemData, veja:

Citar
NAME="Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller"
CLASS=0403
PCIDEV=1039:7502
SUBSYS=1019:5a00
IRQ=18
HDA=1039:7502
SOFT=1039:7502.HDA
HDAchipVendorID=1057
CHIP=0x10573055
IDENT=slmodemd
SLMODEMD_DEVICE=hw:0,6
Driver=snd-hda-intel

slmodemd é um executável criado pela compilação do driver smartlink e  hw:0,6 é usado pelo comando que indiquei no texto logo acima no uso na forma alsa:

/sbin/slmodemd --perm=0666 -c BRAZIL --alsa hw:0,6

por hoje chega, vou ficando por aqui, até a próxima.
« Última modificação: 04 de Julho de 2009, 23:10 por alarcon »

Offline MLessa

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #39 Online: 04 de Julho de 2009, 23:13 »
Ok cara muitissimo obrigado mesmo!!! Vou seguir as indicações a risca e espero em breve postar aki o sucesso da operação ( vocabulario bonite neh?! :p).

Até a proxima, pode contar comigo =D.



Offline Lilian Dias

  • Usuário Ubuntu
  • *
  • Mensagens: 133
  • Eu sou um lixo. Quero morrer [mas não agora].
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #40 Online: 04 de Julho de 2009, 23:38 »
Eu fiz tudo direitinho e deu certo. Porém na hora de conectar, quando eu clico em "conectar" ai aparece este erro: "Não é possível abrir o modem". Clico no "registro" e tem o "Connection Log" que aparece estas informações:


E também durante a instalação aparece este aviso (que no .pdf não avisa que iria aparecer este aviso):



E agora???  :(



Acho que não foi instalado direito, o problema de usar o liveCD é que tudo fica perdido ao reiniciar, mas queria que você fizesse novamente os procedimentos e no terminal digitasse os seguintes comandos:


dmesg | grep slamr

lsmod | grep slamr

lsmod | grep ungrab*

ps -aux | grep slmodemd

sudo /etc/init.d/sl-modem-daemon restart


e colocasse aqui seus resultados.

Para alguns usuários é necessário executa mais estes comandos:

sudo su

chmod a+x /usr/sbin/pppd

e depois:

gpasswd -a ubuntu dip


mas só que estes dois comandos só teriam efeito após uma reinicialização o que não seria o seu caso que está usando em liveCd e portanto isso não seria possível. Esses comandos são para solucionar alguns problemas  de permissões.

Alternativamente você poderia abrir um terminal e digitar:

sudo su

para virar root e chamar o discador como root digitando no terminal isso:

gnome-ppp

ele irá abrir o terminal como root e portanto não teria problemas com permissões, só que todas as configurações que eu faço conforme suas respostas ao script de instalação seriam zeradas, pois elas foram feitas para o usuário ubuntu e não o root, então vc pode antes verificar como estão as configurações do gnome-ppp aberto como usuário normal e depois ao chamar como root e aplicar as mesmas configurações.


Continuando do mesmo modo, então faça mai isso no terminal:

sudo su

/etc/init.d/sl-modem-daemon stop

modprobe -r ungrab-winmodem

modprobe -r slamr

mknod -m 600 /dev/slamr0 c 242 0

modprobe ungrab-winmodem

modprobe slamr

/etc/init.d/sl-modem-daemon restart


e tente usar outra vez o discador gnome-ppp, tanto com o usuário normal como com o root.

Sobre a mensagem que é mostrada falando do comando:

sudo route add default ppp0

é falado sobre ele sim no .pdf na parte de solucionado os problemas pagina 15 (final da página), mas não é para se preocupar com isso no momento. Este pdf foi feito em pacotes muito antigos v16 e já estamos no v30, então tem algumas pequenas alterações no modo de proceder, dê um desconto ok.


[  886.358711] slamr: module license 'Smart Link Ltd.' taints kernel.
[  886.365190] slamr: SmartLink AMRMO modem.
[  886.365226] slamr: device 1057:3052 is grabbed by another driver
[  892.544202] slamr: SmartLink AMRMO modem.
[  892.544236] slamr: device 1057:3052 is grabbed by another driver

slamr                 437544  0

[terceiro comando não apareceu nada]

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
ubuntu   10520  0.0  0.1   3352   816 pts/0    S+   23:18   0:00 grep slmoemd

bash: sudo/etc/init.d/sl-modem-daemon: Arquivo ou diretório inexistente




alternativamente:

WVCONF: /root/.wvdial.conf
GNOME PPP: Conectando...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot open /dev/modem: No such file or directory
GNOME PPP: STDERR: --> Cannot open /dev/modem: No such file or directory
GNOME PPP: STDERR: --> Cannot open /dev/modem: No such file or directory
GNOME PPP: Unable to KILL wvdial process!

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #41 Online: 05 de Julho de 2009, 10:35 »


[  886.358711] slamr: module license 'Smart Link Ltd.' taints kernel.
[  886.365190] slamr: SmartLink AMRMO modem.
[  886.365226] slamr: device 1057:3052 is grabbed by another driver
[  892.544202] slamr: SmartLink AMRMO modem.
[  892.544236] slamr: device 1057:3052 is grabbed by another driver

slamr                 437544  0

[terceiro comando não apareceu nada]

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
ubuntu   10520  0.0  0.1   3352   816 pts/0    S+   23:18   0:00 grep slmoemd

bash: sudo/etc/init.d/sl-modem-daemon: Arquivo ou diretório inexistente




alternativamente:

WVCONF: /root/.wvdial.conf
GNOME PPP: Conectando...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot open /dev/modem: No such file or directory
GNOME PPP: STDERR: --> Cannot open /dev/modem: No such file or directory
GNOME PPP: STDERR: --> Cannot open /dev/modem: No such file or directory
GNOME PPP: Unable to KILL wvdial process!


Como eu estava suspeitando o uso do script de instalação não foi usado direito e algumas coisas não foram instaladas.

Está me parecendo que na janela que tem várias opções marcadas para você, durante o processo de execução do meu script, a opção Ungrab-Winmodem (Driver ungrab-winmodem for modem) e Sl-Modem-Daemon (SmartLink software modem daemon) não estavam marcadas e aí alguns arquivos importantes não foram instalados.

Por favor tente novamente proceder a execução do script e veja onde você pode estar errando aí.

Na janela que tem várias opções, num primeiro uso do script todas elas tem de ficar marcadas. Só numa reinstalação é que não seria necessária todas as opções marcadas (isso no caso do Ubuntu instalado no HD e não em livecd) como eu explico no pdf.

Ah, vc também digitou um comando errado, pois seria assim:

ps -aux | grep slmodemd

e vc digitou assim:

ps -aux | grep slmoemd

pelo menos foi o que pareceu, a não ser que apenas tenha errado na digitação ao postar aqui.
« Última modificação: 05 de Julho de 2009, 10:39 por alarcon »

Offline MLessa

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #42 Online: 05 de Julho de 2009, 10:40 »
Olá,bom dia!
Alarcon, segui a risca todo que devia ser feito porem ainda não consegui fazer esse modem funcionar.
Aqui estam os logs das vezes que fiz o processo:

===== Log 1 ====

Gravando em ./smartlink-v9.04a-200907042354.log
------------------------------------------
Stopping possible modules to avoid crashes
------------------------------------------
--------------------------
Installing: libasound2-dev
--------------------------
--------------------------
Done: libasound2-dev
--------------------------

#Reiniciei o sistema e repeti a operação

===== Log 2 =====

Gravando em ./smartlink-v9.04a-200907050008.log
------------------------------------------
Stopping possible modules to avoid crashes
------------------------------------------
--------------------------
Installing: libasound2-dev
--------------------------
--------------------------
Done: libasound2-dev
--------------------------
--------------------------
Installing ungrab-winmodem
--------------------------
---------------------
Done: ungrab-winmodem
---------------------
-----------------
Installing wvdial
-----------------
and dependencies: libxplc, libwvstreams, libuniconf
---------------------------------------------------

Sorry.  You can retry the autodetection at any time by running "wvdialconf".
   (Or you can create /etc/wvdial.conf yourself.)
------------
Done: wvdial
------------
--------------------
Installing gnome-ppp
--------------------
---------------
Done: gnome-ppp
---------------
----------------
Installing Slink
----------------
rm: imposível remover `/dev/slamr0': Arquivo ou diretório inexistente
dpkg - aviso: ignorando pedido para remover sl-modem-daemon que não está instalado.
--------------------------
Installing sl-modem-daemon
--------------------------
Alerta: O diretório pessoal /var/log/slmodemd  que você especificou não pode ser acessado: Arquivo ou diretório inexistente
Adicionando usuário de sistema `Slmodemd' (UID 113) ...
Adicionando novo grupo `Slmodemd' (GID 124) ...
Adicionando novo usuário `Slmodemd' (UID 113) ao grupo `Slmodemd' ...
Sem criar diretório pessoal `/var/log/slmodemd'.
usermod : nenhuma mudança
SmartLink modem driver not available for this Kernel. Please read README.Debian
or try to install the package sl-modem-modules-2.6.28-11-generic. Exiting...
invoke-rc.d: initscript sl-modem-daemon, action "start" failed.
------------------------------------
Done: sl-modem-daemon ... proceeding
------------------------------------
modem_test.c: In function ‘modem_test_start’:
modem_test.c:110: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result
WARNING: could not find /home/matheus/smartlink-v9.04a-i386-small/slmodem/drivers/.amrlibs.o.cmd for /home/matheus/smartlink-v9.04a-i386-small/slmodem/drivers/amrlibs.o
WARNING: could not find /home/matheus/smartlink-v9.04a-i386-small/slmodem/drivers/.amrlibs.o.cmd for /home/matheus/smartlink-v9.04a-i386-small/slmodem/drivers/amrlibs.o
----------------------------
Done: slmodemd, slamr, slusb
----------------------------
modem_main.c: In function ‘setup_stream’:
modem_main.c:429: warning: ‘snd_pcm_sw_params_set_xfer_align’ is deprecated (declared at /usr/include/alsa/pcm.h:1115)
modem_test.c: In function ‘modem_test_start’:
modem_test.c:110: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result
------------------
ALSA Support added
------------------
-----------
Done: Slink
-----------
--------------------------------
Configuring WvDial and Gnome-PPP
--------------------------------
-------------------------------------------
Ethernet Interface Found.
Use: sudo route add default ppp0
in case you have problems while navigating.
-------------------------------------------
-----------------------------------
Linux username selected: *********
-----------------------------------
------------------------------------------------------------------------------
/home/matheus/.wvdial.conf BACKUP TO /home/matheus/.wvdial.conf.200907050012
------------------------------------------------------------------------------
------------------
State selected: **
------------------
------------------------
Dial format: Local
------------------------
--------------------------
Dial Number: 17001000
--------------------------
---------------------
Dial String: ATM1L1DT
---------------------
------------------------------------------------
Init2 String: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
------------------------------------------------
--------------------------
ISP User: ****************
--------------------------
---------------
ISP Pass: *****
---------------
----------------------------------------------------
Configuration saved: /home/matheus/.wvdial.conf
----------------------------------------------------
Adicionando usuário matheus ao grupo dip
Adicionando usuário matheus ao grupo dialout
Adicionando usuário matheus ao grupo uucp
------------------------------
matheus added to group 'dip'
------------------------------
-------------------------------------------------
/usr/sbin/pppd ownership changed: root:dip
/etc/ppp/pap-secrets ownership changed: root:dip
/etc/ppp/chap-secrets ownership changed: root:dip
-------------------------------------------------
-----------------------------------------------------------
/usr/sbin/pppd permission changed: 4755 (-rwsr-xr-x)
/etc/ppp/pap-secrets permission changed: 0660 (-rw-rw----)
/etc/ppp/chap-secrets permission changed: 0660 (-rw-rw----)
-----------------------------------------------------------
----------------------------------------------------
/home/matheus/.wvdial.conf chown to matheus
----------------------------------------------------
---------------------
[Re]starting slmodemd
---------------------
-------
Finish!
-------

#Repeti de novo o processo mas como também não resolveu de nada resolvi que não seria importante postar esse ultimo log aqui ( caso seja necessario eu posto ).
Percebi que meu diretorio /dev ficou lotado de arquivos soltos e tambem reparei que o diretorio /dev/modem não existe, seria esse o motivo do não funcionamento??

« Última modificação: 05 de Julho de 2009, 10:56 por MLessa »

alarcon

  • Visitante
Re: internet discada no ubuntu 9.04
« Resposta #43 Online: 05 de Julho de 2009, 10:52 »
vc poderia ir no seu Ubuntu e no terminal digitar:

sudo /etc/init.d/sl-modem-daemon restart

e  mais estes comandos aqui:

dmesg | grep slamr

lsmod | grep slamr

lsmod | grep ungrab*

lsmod | grep hda*

ps -aux | grep slmodemd



e verificar se na pasta do sistema /usr/sbin existe o executável slmodemd e se na pasta do sistema /lib/modules/2.6.28-11-generic/extra existe os arquivos slamr.ko e ungrab-wimodem.ko

Se em /etc/init.d/ existe o script sl-modem-daemon

Retire seus dados pessoais aí do que vc postou ok.
« Última modificação: 05 de Julho de 2009, 10:54 por alarcon »

Offline MLessa

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: internet discada no ubuntu 9.04
« Resposta #44 Online: 05 de Julho de 2009, 11:19 »
vc poderia ir no seu Ubuntu e no terminal digitar:

sudo /etc/init.d/sl-modem-daemon restart

e  mais estes comandos aqui:

dmesg | grep slamr

lsmod | grep slamr

lsmod | grep ungrab*

lsmod | grep hda*

ps -aux | grep slmodemd



e verificar se na pasta do sistema /usr/sbin existe o executável slmodemd e se na pasta do sistema /lib/modules/2.6.28-11-generic/extra existe os arquivos slamr.ko e ungrab-wimodem.ko

Se em /etc/init.d/ existe o script sl-modem-daemon

Retire seus dados pessoais aí do que vc postou ok.

Fiz o que foi pedido e os resultados foram o seguinte:

==============================

matheus@matheus-laptop:~$ sudo /etc/init.d/sl-modem-daemon restart
[sudo] password for matheus:
Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... slamr.
Starting SmartLink Modem driver for: slamr0.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
matheus@matheus-laptop:~$ dmesg | grep slamr
[   13.664331] slamr: module license 'Smart Link Ltd.' taints kernel.
[   13.668526] slamr: SmartLink AMRMO modem.
[   93.253388] slamr: SmartLink AMRMO modem.
matheus@matheus-laptop:~$ lsmod | grep slamr
slamr                 437544  0
matheus@matheus-laptop:~$ lsmod | grep ungrab*
ungrab_winmodem        10112  0
matheus@matheus-laptop:~$ lsmod | grep hda*
snd_hda_intel         435636  3
snd_pcm                82948  2 snd_hda_intel,snd_pcm_oss
snd                    62628  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc         16904  2 snd_hda_intel,snd_pcm
matheus@matheus-laptop:~$ ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
]matheus   3310  0.0  0.0   3352   816 pts/0    S+   11:06   0:00 grep slmodemd

/usr/sbin existe o executável slmodemd -> OK, existe!!
sistema /lib/modules/2.6.28-11-generic/extra existe slamr.ko e ungrab-wimodem.ko -> OK, existe!!
Se em /etc/init.d/ existe o script sl-modem-daemon -> Ok, existe!!
=======================================

Estranho que aparentemente esta tudo no lugar e ele num funciona :S