Autor Tópico: [DESAFIO] UBUNTU 8.10 COM DHCP E WIRELES COM DEFEITO  (Lida 2824 vezes)

Offline Appocc

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
[DESAFIO] UBUNTU 8.10 COM DHCP E WIRELES COM DEFEITO
« Online: 19 de MAR?O de 2009, 00:35 »
Ola,
Estou a uma semana tentando resolver um problema na minha instalação do ubuntu e realmente desisti... resolvi pedir ajuda q penso q meus esforços tem sido em vão.... apreciaria muito a ajuda de vcs.

Estou num Laptop HP pavillion ze4900 e um wireless usb Philips SNU6500
Meu routeador e um Philips SNB6500 q esta funcionando com um modem speedstream4200 em bridge.
Gateway 192.168.1.2
Netmask 255.255.255.0
tenho certeza q n e falha de hardware porque tenho mais dois notebooks com vista e xp funcionando perfeitamente, e mais um osx leopard tbm funcionando todos na base do dhcp
meu provedor e a velox


Entao vamos ao problema... Acontece que meu cliente dhcp simplesmente n funciona... (outputs dos testes abaixo) quer dizer, eu tenho q apontar ip, dns, netmask pra qualquer conexão no meu computador.. e um outro problema.. o wireless funciona intermitentemente... a interface esta instalada com o ultimo ndiswrapper e seu driver nativo e esta constando como presente. Ja funcionou varias vezes.. mas sem razao nenhuma para de funcionar... o engraçado e q uma vez q eu preencha os dados de ip, dns, gateway, netmask, ele SEMPRE conecta e bastante rapido... mas não consigo navegar... ja ocorreu de eu estar navegando, eu parar de conseguir acessar paginas, sem q a conexao caisse, e meia hora depois, com a mesma conexao, ele voltar a navegar... n consigo entender... espero q possam ma ajudar.. vou postar o output dos comandos aki embaixo

ps: agora, no desespero eu instalei o dhcpcd q pelo menos faz o dhclient dar sinal de vida... pq senao ele so recebe No DHCPOFFER

ifconfig
Código: [Selecionar]
root@elisah-laptop:/etc/wifidrivers# ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:0b:cd:ec:76:2b
          inet end.: 192.168.1.13  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::20b:cdff:feec:762b/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:19984 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:17284 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:14609512 (14.6 MB) TX bytes:2453439 (2.4 MB)
          IRQ:10 Endereço de E/S:0x3000

lo        Link encap:Loopback Local
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:43 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:43 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:3746 (3.7 KB) TX bytes:3746 (3.7 KB)

pan0      Link encap:Ethernet  Endereço de HW b2:3f:81:a1:a1:cd
          endereço inet6: fe80::b03f:81ff:fea1:a1cd/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:31 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:6595 (6.5 KB)

pan0:avahi Link encap:Ethernet  Endereço de HW b2:3f:81:a1:a1:cd
          inet end.: 169.254.9.170  Bcast:169.254.255.255  Masc:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1

wlan0     Link encap:Ethernet  Endereço de HW 00:12:bf:0f:4f:9b
          endereço inet6: fe80::212:bfff:fe0f:4f9b/64 Escopo:Link
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:854 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:454 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:122465 (122.4 KB) TX bytes:59541 (59.5 KB)
IWCONFIG
Código: [Selecionar]
lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any
          Mode:Managed  Frequency:2.457 GHz  Access Point: Not-Associated 
          Bit Rate:108 Mb/s 
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
DHCLIENT (com dhcpcd)
Código: [Selecionar]
root@elisah-laptop:/etc/wifidrivers# dhclient
There is already a pid file /var/run/dhclient.pid with pid 7311
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:12:bf:0f:4f:9b
Sending on   LPF/wlan0/00:12:bf:0f:4f:9b
Listening on LPF/pan0/b2:3f:81:a1:a1:cd
Sending on   LPF/pan0/b2:3f:81:a1:a1:cd
Listening on LPF/eth0/00:0b:cd:ec:76:2b
Sending on   LPF/eth0/00:0b:cd:ec:76:2b
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPOFFER of 192.168.1.12 from 192.168.1.2
DHCPREQUEST of 192.168.1.12 on eth0 to 255.255.255.255 port 67
DHCPACK of 192.168.1.12 from 192.168.1.2
no expiry time on offered lease.
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPOFFER of 192.168.1.12 from 192.168.1.2
DHCPREQUEST of 192.168.1.12 on eth0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPACK of 192.168.1.12 from 192.168.1.2
no expiry time on offered lease.
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPOFFER of 192.168.1.12 from 192.168.1.2
DHCPREQUEST of 192.168.1.12 on eth0 to 255.255.255.255 port 67
DHCPACK of 192.168.1.12 from 192.168.1.2
no expiry time on offered lease.
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPOFFER of 192.168.1.12 from 192.168.1.2
DHCPREQUEST of 192.168.1.12 on eth0 to 255.255.255.255 port 67
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 7
e fik assim ate eu dar ^C

antes de eu instalar o dhcpcd ele so me dava  "No DHCPOFFERS received"
bo pessoal e isso.. se puderem me ajudar vou agradecer muito...
gosto muito do linux mas infelismente se continuar assim vou ter q tirar.. por favor me ajudem!!!
« Última modificação: 19 de MAR?O de 2009, 00:37 por Appocc »

Offline Appocc

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Quanto ao wireless nao navegar....
« Resposta #1 Online: 19 de MAR?O de 2009, 01:15 »
Descobri uma coisa interessante..  ainda n resolveu meu problema mas pode ajudar alguem a me ajudar a resolver ehehehe

acontece q eu vi nu forum para se adicionar rotas para os gateways
e foi o q eu fiz
eu  fui no console e digite route add default gw 192.168.1.2 netmask 255.255.255.0 wlan0 e de fato eu consegui navegar

dai fui testar se o dhcp tinha voltado e desativei as configurações manuais da conexao e puz pra dhcp... n conectou... dai eu ativei novamente as manuais.. e NADA... quado fui ver a rota q eu tinha adicionado, ele transformou minha netmask de 255.255.255.0 em 0.0.0.0

tem alguma coisa de estranho ai... sera q existe uma maneira de fixar essas rotas???
acho q essa e uma direção boa pra pelo menos o problema do wireless resolver.. se eu conseguir q ele pelo menos navegue sempre, n tem tanta importancia eu ter q digitar os ips nao...  mas preciso q navegue sempre neh!!!

desde ja agradeço moçada!
vlw

Offline Appocc

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Quanto ao wireless nao navegar....
« Resposta #2 Online: 19 de MAR?O de 2009, 01:51 »
Descobri uma coisa interessante..  ainda n resolveu meu problema mas pode ajudar alguem a me ajudar a resolver ehehehe

acontece q eu vi nu forum para se adicionar rotas para os gateways
e foi o q eu fiz
eu  fui no console e digite route add default gw 192.168.1.2 netmask 255.255.255.0 wlan0 e de fato eu consegui navegar

dai fui testar se o dhcp tinha voltado e desativei as configurações manuais da conexao e puz pra dhcp... n conectou... dai eu ativei novamente as manuais.. e NADA... quado fui ver a rota q eu tinha adicionado, ele transformou minha netmask de 255.255.255.0 em 0.0.0.0

tem alguma coisa de estranho ai... sera q existe uma maneira de fixar essas rotas???
acho q essa e uma direção boa pra pelo menos o problema do wireless resolver.. se eu conseguir q ele pelo menos navegue sempre, n tem tanta importancia eu ter q digitar os ips nao...  mas preciso q navegue sempre neh!!!

desde ja agradeço moçada!
vlw

Esqueçam isso a q eu  falei... a conexao ethernet tbm fik com a netmask 0.0.0.0 e nem por isso deixa de navegar...
fora q depois parou de navegar o wireless (sozinho, pra variar, e sem a conexao cair) e mesmo depois de repetidos os procedimentos nada aconteceu...

segue em anexo minha ip table quando estou so com o wireless ligado
Código: [Selecionar]
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
192.168.1.0     *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0
default         192.168.1.2     0.0.0.0         UG    0      0        0 wlan0

Offline Kamei Hyoga

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
  • Ubuntu 11.04
    • Ver perfil
Re: [DESAFIO] UBUNTU 8.10 COM DHCP E WIRELES COM DEFEITO
« Resposta #3 Online: 19 de MAR?O de 2009, 05:51 »
hehe desafio vai ser o tópico não ser trancado hehe

Recomendo bastante que tire a CAIXA ALTA do título, pois isso vai acabar acontecendo

Offline davisouzarj

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: [DESAFIO] UBUNTU 8.10 COM DHCP E WIRELES COM DEFEITO
« Resposta #4 Online: 19 de MAR?O de 2009, 10:46 »
Tive um problema semelhante ao seu, usando um mini modem 3G HUAWEII da VIVO, e um roteador wireless da 3com para compartilhar a conexão.

Até onde eu sei, há duas soluções possíveis para você:

1) Veja se consegue mudar seu modem de modo bridge para router. Essa é a melhor e mais prática maneira de acessar velox, pois você não precisa discar toda vez que ligar qualquer computador que seja atendido pelo roteador - ao ligar o computador, a conexão internet já estará ativa.

2) Caso não queira, e/ou não consiga colocar seu modem em modo router, vai ter que abandonar a idéia do DHCP, e usar IPs fixos para as máquinas. Nesse caso, precisará desativar o serviço de DHCP do seu roteador, e ao configurar a rede em suas máquinas, você precisará ir até o ícone de rede sem fio > botão direito > propriedades, e alterar as configurações do protocolo TCP/IP da seguinte maneira:

IP: Coloque um IP fixo de acordo com a faixa definida nas configurações do seu roteador. Normalmente é um número entre 192.168.0.1 e 192.168.0.255. Cada computador que for acessar sua rede terá que ter um IP diferente, para não gerar conflito de IPs.

Netmask: Coloque 255.255.255.0

Gateway padrão: Coloque o IP definido para o seu roteador wireless. Normalmente é 192.168.0.1, mas confirme se é na página de configurações do roteador.

Servidor DNS preferencial: Coloque o mesmo IP usado no Gateway

Veja aí se funciona e dá um retorno para a gente.

[]'s
Gigabyte G31M-S2L | C2D E7200 @ 3.4GHz by HyperTX2 | ECS 9600GT @ 40oC by Accelero | 2x1Gb Kingston DDR2-800 *Orthos Primed*
Ubuntu 10.10 Maverick Meerkat >>> GREEN AMBIANCE <<<

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: [DESAFIO] UBUNTU 8.10 COM DHCP E WIRELES COM DEFEITO
« Resposta #5 Online: 19 de MAR?O de 2009, 12:16 »
Após envio de MP ao usuário pedindo para que o mesmo corrigisse o título, ele chegou a colocar novas mensagens no tópico sem corrigir o título com problema. Trancado.