Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 1211947 vezes)

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #840 Online: 31 de Dezembro de 2008, 07:34 »
Ontém baixei o arquivo modem-aquivos-v29 e hoje vou testá-lo... ;D
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #841 Online: 31 de Dezembro de 2008, 10:15 »
Primeiramente agradeço a todos que estão se dispondo a ajudar, mas como falei antes o melhor seria somente aqueles que ainda não estão usando os meus dois últimos pacotes por que não quero nenhum tipo de interferência que eles possam ter com esse novo teste e para que tem a instalação limpa do Ubuntu 8.10 Intrepid Ibex 32bits seria melhor.

Caso mesmo assim os colegas que tem seu Ubuntu 8.10 funcionando com os pacotes anteriores e queiram testar, fiquem a vontade. Só quero que observem bem o processo de compilação e anotem qualquer mensagem de erro.

igorhrk, caso este novo pacote não dê certo observe o driver smartlik contido neste pacote e compare com a "gabiarra" que você faz nele para instalar no v25 e se for o caso tente fazer o mesmo neste aí e diga-me depois o que acontece ok.

Boa Sorte a Todos!
« Última modificação: 31 de Dezembro de 2008, 10:26 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #842 Online: 31 de Dezembro de 2008, 10:24 »
Como eu procedo para rodar no Kubuntu 8.10 ?
sou novo no mundo linux :)

Olha só, até o pacote modem-arquivos-v25.tar.gz (somente para o Ubuntu/Kubuntu 8.04 32bits) que faço para ativação de modems, tinha um script de instalação para ser usado no Kubuntu, mas devido ao pouco retorno dos usuários desta versão do linux e também a limitação (frescura mesmo) dele quanto a abrir janelas gráficas pelo superusuário (root) chamadas via terminal, precisando ainda fazer um ajuste ou instalando um pacote chamado de sux dos repositórios do Ubuntu/kbuntu.

Uma forma mais fácil seria seguir exatamente o que o colega 0tacon fala naquele seu texto sobre esse assunto, ou seja, aqui:

http://ubuntuforum-br.org/index.php/topic,44677.msg264777.html#msg264777

Caso esta dica aí não dê certo, retorne aqui que tentaremos algo mais ok.

Offline rrh

  • Usuário Ubuntu
  • *
  • Mensagens: 25
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #843 Online: 31 de Dezembro de 2008, 10:38 »
Estou precisando de ajuda para instalar o modem motorola. Já instalei o drive slmodem-2.9.11-20080401 e ao rodar /etc/init.d/sl-modem-daemon status aparece slmodemd is running, mas o GNOME PPP não detecta o modem. Como resolver isso?

você poderia informar qual é a versão do Ubuntu que está usando e o resultado dos comandos:

lspci

e

lspci -n

dados no terminal do Ubuntu.


lspci

00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:08.0 Modem: Motorola SM56 Data Fax Modem (rev 04)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)


lspci -n

00:00.0 0600: 1106:0314
00:00.1 0600: 1106:1314
00:00.2 0600: 1106:2314
00:00.3 0600: 1106:3208
00:00.4 0600: 1106:4314
00:00.7 0600: 1106:7314
00:01.0 0604: 1106:b198
00:08.0 0703: 1057:3052 (rev 04)
00:0f.0 0101: 1106:3149 (rev 80)
00:0f.1 0101: 1106:0571 (rev 06)
00:10.0 0c03: 1106:3038 (rev 81)
00:10.1 0c03: 1106:3038 (rev 81)
00:10.2 0c03: 1106:3038 (rev 81)
00:10.3 0c03: 1106:3038 (rev 81)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3227
00:11.5 0401: 1106:3059 (rev 60)
00:12.0 0200: 1106:3065 (rev 78)
01:00.0 0300: 1106:3344 (rev 01)

Estou tentando instalar o modem em uma distribuição corporativa derivada do ubuntu kernel  2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008 i686 GNU/Linux

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #844 Online: 31 de Dezembro de 2008, 10:46 »
Estou precisando de ajuda para instalar o modem motorola. Já instalei o drive slmodem-2.9.11-20080401 e ao rodar /etc/init.d/sl-modem-daemon status aparece slmodemd is running, mas o GNOME PPP não detecta o modem. Como resolver isso?

você poderia informar qual é a versão do Ubuntu que está usando e o resultado dos comandos:

lspci

e

lspci -n

dados no terminal do Ubuntu.


lspci

00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:08.0 Modem: Motorola SM56 Data Fax Modem (rev 04)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)


lspci -n

00:00.0 0600: 1106:0314
00:00.1 0600: 1106:1314
00:00.2 0600: 1106:2314
00:00.3 0600: 1106:3208
00:00.4 0600: 1106:4314
00:00.7 0600: 1106:7314
00:01.0 0604: 1106:b198
00:08.0 0703: 1057:3052 (rev 04)
00:0f.0 0101: 1106:3149 (rev 80)
00:0f.1 0101: 1106:0571 (rev 06)
00:10.0 0c03: 1106:3038 (rev 81)
00:10.1 0c03: 1106:3038 (rev 81)
00:10.2 0c03: 1106:3038 (rev 81)
00:10.3 0c03: 1106:3038 (rev 81)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3227
00:11.5 0401: 1106:3059 (rev 60)
00:12.0 0200: 1106:3065 (rev 78)
01:00.0 0300: 1106:3344 (rev 01)

Estou tentando instalar o modem em uma distribuição corporativa derivada do ubuntu kernel  2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008 i686 GNU/Linux


É o seguinte, meus pacotes são feitos para serem usados no Ubuntu original, não em um Ubuntu remasterizado por que alguns pacotes necessários a compilação do driver smartlink que dá suporte ao modem estão no CD e não foram instalados ainda durante o processo de instalação do Ubuntu. Quando você usa uma versão modificada, pode ser que estes arquivos necessários não estejam no CD e aí vi dar erro no processe de instalação por que ele vai procurar no CD algo não não existe por lá.

Outra coisa que você tem de saber é que para cada versão do Ubuntu eu tenho um pacote adequando que só deve ser usado naquela versão e para saber qual usar vc deve sempre visistar o primeiro texto deste link aqui:

http://ubuntuforum-br.org/index.php/topic,4204.0.html

lá vc é orientado para a página que contém o pacote que faço para a versão do Ubuntu em questão.



===EDITADO===

Se você não usou meus pacotes e está tentando ativar o modem de forma manual, então saiba que antes você deve ter no seu sistema estes pacotes:

- make
- gcc
- build-essential
- linux-headers-2.6.24-22-generic

que são necessários para o processo de compilação do driver smartlink. Atenção também que os drivers para modems só funcionam em versões 32bits do Ubuntu e não em 64bits ok.

O driver smartlink mais recente é esse slmodem-2.9.11-20080817 e seu link é:

http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20080817.tar.gz
« Última modificação: 31 de Dezembro de 2008, 10:55 por alarcon »

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #845 Online: 31 de Dezembro de 2008, 13:07 »
Reinstalei o ubuntu 8.10 e usei o pacote modem-arquivos-v29...

Não conectou...no Gnome PPP aparece a mensagem dizendo que o modem não foi encontrado, então fui naquela pasta lib/modules/2.6.27-7-generic/extra e dentro da pasta extra existe apenas o arquivo ungrab-winmodem-ko e o slamr.ko está faltando...

Ps.: só a nível de conhecimento, o meu modem é o Modem: Motorola SM56 Data Fax Modem (rev 04)
1057:3052 (rev 04)
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #846 Online: 31 de Dezembro de 2008, 13:43 »
Reinstalei o ubuntu 8.10 e usei o pacote modem-arquivos-v29...

Não conectou...no Gnome PPP aparece a mensagem dizendo que o modem não foi encontrado, então fui naquela pasta lib/modules/2.6.27-7-generic/extra e dentro da pasta extra existe apenas o arquivo ungrab-winmodem-ko e o slamr.ko está faltando...

Ps.: só a nível de conhecimento, o meu modem é o Modem: Motorola SM56 Data Fax Modem (rev 04)
1057:3052 (rev 04)

Olha só, revisei as mudanças que fiz no driver smartlink e localizei algo que possivelmente é a causa de não ter sido criado o slamr.ko no local indicado, portanto peço para que baixe novamente o pacote modem-arquivos-v29.tar.gz, descartando esse aí que você possui, pois já fiz modificações nele, o link está aqui:

http://ubuntuforum-br.org/index.php/topic,4204.msg264696.html#msg264696

Peço só paciência para quem está testando que os possíveis erros eu irei tentar corrigir e para isso seu retorno dos erros é extremamente importante, por isso observem outros erros ok.

Infelizmente eu não tenho como testar aqui as mudanças que faço no driver smartlink, pois não possuo um modem que é suportado por ele para poder eu mesmo observar o processo de compilação do driver smartlink e ir corrigindo minhas falhas nas alterações feitas por mim.
« Última modificação: 31 de Dezembro de 2008, 13:53 por alarcon »

Offline rrh

  • Usuário Ubuntu
  • *
  • Mensagens: 25
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #847 Online: 31 de Dezembro de 2008, 14:00 »
Ok, como estou iniciando em linux quero te perguntar: O fato do status está aparecendo slmodemd is running não quer dizer que foi instalado o modem e que falta apenas alguns ajustes para que o GNOME PPP o reconheça?

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #848 Online: 31 de Dezembro de 2008, 14:04 »
Ok, como estou iniciando em linux quero te perguntar: O fato do status está aparecendo slmodemd is running não quer dizer que foi instalado o modem e que falta apenas alguns ajustes para que o GNOME PPP o reconheça?

vou te pedir o resultados de alguns comandos.

Lá no Ubuntu e pelo terminal (menu Aplicações > Acessórios > Consola ou Terminal) digita:

dmesg | grep slamr

ps -aux | grep slmodemd

lsmod | grep slamr

lsmod | grep ungrab_winmodem

coloca aqui os resultados destes comandos aí que poderei saber com maior precisão se seu driver está corretamente instalado.

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #849 Online: 31 de Dezembro de 2008, 15:53 »
Estou baixando agora o pacote v29 com as alterações, mas vou aproveitar pra dizer que também notei a falta do sl-modem-daemon, qdo eu dei o comando sudo /etc/init.d/sl-modem-daemon restart simplismente não retornou nada, aí fui verificar se o arquivo estava na pasta init.d e notei que ele não existe lá... ???
Linux, uma questão de filosofia!

Offline rrh

  • Usuário Ubuntu
  • *
  • Mensagens: 25
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #850 Online: 31 de Dezembro de 2008, 16:04 »

vou te pedir o resultados de alguns comandos.

Lá no Ubuntu e pelo terminal (menu Aplicações > Acessórios > Consola ou Terminal) digita:

dmesg | grep slamr

ps -aux | grep slmodemd

lsmod | grep slamr

lsmod | grep ungrab_winmodem

coloca aqui os resultados destes comandos aí que poderei saber com maior precisão se seu driver está corretamente instalado.

dmesg | grep slamr
[   20.970198] slamr: module license 'Smart Link Ltd.' taints kernel.
[   21.024999] slamr: SmartLink AMRMO modem.
[   21.025122] slamr: probe 1057:3052 SL1900 card...
[   21.249180] slamr: slamr0 is SL1900 card.


ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      4793  0.0  1.3   2908  2908 ?        SL   10:29   0:00 /usr/sbin/slmodemd -c USA /dev/slamr0
1000     14497  0.0  0.3   3024   860 pts/2    R+   16:01   0:00 grep --color=auto slmodemd


lsmod | grep slamr
slamr                 433448  2


lsmod | grep ungrab_winmodem
ungrab_winmodem         3584  0

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #851 Online: 31 de Dezembro de 2008, 16:13 »
Estou baixando agora o pacote v29 com as alterações, mas vou aproveitar pra dizer que também notei a falta do sl-modem-daemon, qdo eu dei o comando sudo /etc/init.d/sl-modem-daemon restart simplismente não retornou nada, aí fui verificar se o arquivo estava na pasta init.d e notei que ele não existe lá... ???

verifiquei o meu script de instalação e aparentemente não tem nenhum tipo de erro na parte que instala o pacote sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5ubuntu4_i386.deb que é o responsável por instalar o sl-modem-daemon em /etc/init.d, portanto observe se na instalação deste novo pacote v29 alterado isso ocorre outra vez.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #852 Online: 31 de Dezembro de 2008, 16:19 »

dmesg | grep slamr
[   20.970198] slamr: module license 'Smart Link Ltd.' taints kernel.
[   21.024999] slamr: SmartLink AMRMO modem.
[   21.025122] slamr: probe 1057:3052 SL1900 card...
[   21.249180] slamr: slamr0 is SL1900 card.


ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      4793  0.0  1.3   2908  2908 ?        SL   10:29   0:00 /usr/sbin/slmodemd -c USA /dev/slamr0
1000     14497  0.0  0.3   3024   860 pts/2    R+   16:01   0:00 grep --color=auto slmodemd


lsmod | grep slamr
slamr                 433448  2


lsmod | grep ungrab_winmodem
ungrab_winmodem         3584  0

é o seguinte, tem algumas coisas a se alterar por aí, então abra um terminal e digite:

sudo gedit /etc/default/sl-modem-daemon

e na linha:

SLMODEMD_COUNTRY=USA

altera para:

SLMODEMD_COUNTRY=BRAZIL

e também onde tem:

OPTS=""

altere para:

OPTS="--perm=0666"


salve e saia do arquivo. Ainda no terminal digite:

sudo /etc/init.d/sl-modem-daemon restart

e tente usar o discador gnome-ppp outra vez. Se não funcionar retorne aqui ok.


Sua instalação do driver Smartlink está, aparentemente, perfeita. Acho que é só questão de permissões e configurações do gnome-ppp.
« Última modificação: 31 de Dezembro de 2008, 16:24 por alarcon »

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #853 Online: 31 de Dezembro de 2008, 16:42 »
Reinstalei o seu pacote v29 modificado e não houve alteração...o arquivo slamr.ko não foi instalado na pasta...+ fui ver se o sl-modem-daemon estava na pasta init.d e ele está lá...só que ao dar o comando sudo /etc/init.d/sl-modem-daemon restart ou stop não aparece nenhuma mensagem no terminal...estranho né!
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #854 Online: 31 de Dezembro de 2008, 16:51 »
Reinstalei o seu pacote v29 modificado e não houve alteração...o arquivo slamr.ko não foi instalado na pasta...+ fui ver se o sl-modem-daemon estava na pasta init.d e ele está lá...só que ao dar o comando sudo /etc/init.d/sl-modem-daemon restart ou stop não aparece nenhuma mensagem no terminal...estranho né!

vou revisar mais uma vez a modificação que fiz no driver smartlink para ver isso do slamr.ko, mas antes faz o seguinte para mim, procure em toda sua partição pelo arquivo slamr.ko para ver se pela compilação do driver ele não é colocando em outro local, uma direção é que deve ser em uma das pasta daqui: /lib/modules/2.6.27-7-generic/kernel