Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 968625 vezes)

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #675 Online: 19 de Junho de 2008, 09:24 »
Veja se está certo agora:

lsusb


Bus 002 Device 003: ID 045e:00d2 Microsoft Corp.
Bus 002 Device 002: ID 0483:7554 SGS Thomson Microelectronics 56k SoftModem
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 001: ID 0000:0000 

lsusb -n

lsusb: invalid option -- n

dmesg | grep slusb

nenhuma resposta

ps -aux | grep slmodemd


Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
ixian     6648  0.0  0.0   3020   780 pts/0    R+   18:59   0:00 grep slmodemd


lsmod | grep slusb


nenhuma resposta

Quando você instalou o meu pacote notou algum erro no processo de compilação ou tudo transcorreu bem?

Se vc está com o meu pacote instalado abra um terminal e digite estes comandos:

sudo /etc/init.d/sl-modem-daemon stop

sudo modprobe ungrab-winmodem

sudo modprobe slusb

sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0 &


só então tente usar o discador gnome-ppp no menu Aplicações > Internet > GNOME PPP. Lembrando que na aba Modem nas configurações do gnome-ppp em dispositivo deve estar o /dev/ttySL0.

Se com estes comandos acima seu modem funcionar é por que o script de ativação sl-modem-daemon que tem nele e que serve para ativar o modem no boot não funcionar para modems USB e então teremos que criar um script.
« Última modificação: 19 de Junho de 2008, 09:27 por alarcon »

Offline ixian

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #676 Online: 19 de Junho de 2008, 10:16 »
Obtive as seguintes respostas:

sudo /etc/init.d/sl-modem-daemon stop

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... slamr.

sudo modprobe ungrab-winmodem
nada
sudo modprobe slusb
nada

sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0 &


[1] 6419
ixian@ixian-linux:~$ error: mdm setup: cannot stat `/dev/slusb0': No such file or directory
error: cannot setup device `/dev/slusb0'

[1]+  Exit 255                sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0

Obrigado pela ajuda!


alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #677 Online: 19 de Junho de 2008, 10:34 »
Obtive as seguintes respostas:

sudo /etc/init.d/sl-modem-daemon stop

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... slamr.

sudo modprobe ungrab-winmodem
nada
sudo modprobe slusb
nada

sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0 &


[1] 6419
ixian@ixian-linux:~$ error: mdm setup: cannot stat `/dev/slusb0': No such file or directory
error: cannot setup device `/dev/slusb0'

[1]+  Exit 255                sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0

Obrigado pela ajuda!



O que está me parecendo é que o driver não foi compilado como deveria e por isso o comando modprobe (responsável por carregar os módulos do modem ) não está funcionado por que os módulos não foram criados e tudo o mais falha.

Veja para mim se em /lib/modules/KERNEL_EM_USO/ tem uma pasta chamada de extra ou se em /lib/modules/KERNEL_EM_USO/kernel tem uma pasta chamada de extra e procure por slusb.ko e slamr.ko para saber se os módulos haviam sido criados. Não lembro direito se é neste caminho que deveria estar os módulos, portanto como alternativa use o menu Locais > Pesquisar por Arquivos... > e em todo o sistema procure por slusb.ko ok.

Já vi que em teoria seu modem é suportado pelo driver Smartlink.

Vou pedir que vc faça o seguinte, baixe o driver Smartlink mais novo aqui:

http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20080417.tar.gz


coloque ele na sua pasta de usuário dentro da home e pelo nautilus clique com o botão direito do mouse sobre ele e escolha a opção extrair aqui. Será criada uma pasta chamada de slmodem-2.9.11-20080417, depois pelo terminal entre nela digitando:

cd /home/SEU_USUARIO/slmodem-2.9.11-20080417

e lá digite os seguintes comandos:

make

sudo make install

aguarde o processo de compilação e anote possíveis erros mostrados.

Depois de compilado digite os comandos:

sudo modprobe -r ungrab-winmodem

sudo modprobe slusb

sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0 &


só então tente usar o discador gnome-ppp no menu Aplicações > Internet > GNOME PPP. Lembrando que na aba Modem nas configurações do gnome-ppp em dispositivo deve estar o /dev/ttySL0
« Última modificação: 19 de Junho de 2008, 10:37 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #678 Online: 19 de Junho de 2008, 10:51 »
alternativamente, ou melhor, antes de fazer os procedimentos indicados acima tente isso:

Se vc está com o meu pacote instalado abra um terminal e digite estes comandos:

sudo /etc/init.d/sl-modem-daemon stop

sudo mknod -m 600 /dev/slusb0 c 243 0

sudo modprobe ungrab-winmodem

sudo modprobe slusb

sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0 &


só então tente usar o discador gnome-ppp no menu Aplicações > Internet > GNOME PPP. Lembrando que na aba Modem nas configurações do gnome-ppp em dispositivo deve estar o /dev/ttySL0 ok.

Se com estes comandos acima seu modem funcionar é por que o script de ativação sl-modem-daemon que tem nele e que serve para ativar o modem no boot não funcionar para modems USB e então teremos que criar um script.

OBS: o comando destacada em vermelho foi acrescentado ao que vc já tinha feito anteriormente.

« Última modificação: 19 de Junho de 2008, 10:53 por alarcon »

Offline ixian

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #679 Online: 19 de Junho de 2008, 11:03 »
alternativamente, ou melhor, antes de fazer os procedimentos indicados acima tente isso:

Se vc está com o meu pacote instalado abra um terminal e digite estes comandos:

sudo /etc/init.d/sl-modem-daemon stop

sudo mknod -m 600 /dev/slusb0 c 243 0

sudo modprobe ungrab-winmodem

sudo modprobe slusb

sudo /usr/sbin/slmodemd --country=BRAZIL --perm=0666 /dev/slusb0 &


só então tente usar o discador gnome-ppp no menu Aplicações > Internet > GNOME PPP. Lembrando que na aba Modem nas configurações do gnome-ppp em dispositivo deve estar o /dev/ttySL0 ok.

Se com estes comandos acima seu modem funcionar é por que o script de ativação sl-modem-daemon que tem nele e que serve para ativar o modem no boot não funcionar para modems USB e então teremos que criar um script.

OBS: o comando destacada em vermelho foi acrescentado ao que vc já tinha feito anteriormente.



alarcon,

Desculpe, eu acabei de fazer o outro procedimento que você me falou.

Agora funcionou perfeitamente!!!

Muito obrigado pela ajuda!!!

Até mais



Offline Oswaldo

  • Usuário Ubuntu
  • *
  • Mensagens: 50
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #680 Online: 20 de Junho de 2008, 21:45 »
Saudações!Não sei se já postaram sobre isso antes, pois não li todas as respostas...
Vejo que muitos sofrem no Hardy com a desconexão e posterior bloqueio do modem. Mas não precisa reiniciar o micro, basta fazer o seguinte:
* Digite em um terminal
Código: [Selecionar]
ps ax | grep slmodem
A saída deve ser parecida com isto:

Código: [Selecionar]
12406 ?        SL     1:56 /usr/sbin/slmodemd --alsa -c USA modem:1
13701 pts/2    S+     0:00 grep modem

Aí vc pega o n° do processo do slmodemd e dá um sudo kill nele

Código: [Selecionar]
sudo kill 12406
E depois repete a linha do slmodemd sem a parte do modem:1

Código: [Selecionar]
sudo  /usr/sbin/slmodemd --alsa -c USA
Não feche o terminal.
Pronto, está destravado o seu modem, e quando travar de novo é só teclar Ctrl + C no mesmo terminal e repetir o último comando.
PS. Instalei o meu modem com o pacote sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5build1_i386.deb
Não usei ungrab-winmodem, e quando atualizo o pacote para a atual do repo, fica caindo a conexão toda hora, quando conecta.
Espero ter ajudado, mas no 6.10 nada disso era necessário, e se continuar esse monte de bugs que estão rolando, infelizmente eu vou pular pro Debian ou pro Slack.
A propósito, Alarcon, qual é a função do ungrab? Pois na máquina de um amigo, o modem é o mesmo, mas só funciona com ungrab e o meu com ungrab não funciona de jeito nenhum, a conexão ficava instável e eu tinha de remover tudo e reinstalar só o pacote deb do daemon...

Abraços
« Última modificação: 20 de Junho de 2008, 22:06 por Oswaldo »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #681 Online: 21 de Junho de 2008, 11:59 »
Saudações!Não sei se já postaram sobre isso antes, pois não li todas as respostas...
Vejo que muitos sofrem no Hardy com a desconexão e posterior bloqueio do modem. Mas não precisa reiniciar o micro, basta fazer o seguinte:
* Digite em um terminal
Código: [Selecionar]
ps ax | grep slmodem
A saída deve ser parecida com isto:

Código: [Selecionar]
12406 ?        SL     1:56 /usr/sbin/slmodemd --alsa -c USA modem:1
13701 pts/2    S+     0:00 grep modem

Aí vc pega o n° do processo do slmodemd e dá um sudo kill nele

Código: [Selecionar]
sudo kill 12406
E depois repete a linha do slmodemd sem a parte do modem:1

Código: [Selecionar]
sudo  /usr/sbin/slmodemd --alsa -c USA
Não feche o terminal.
Pronto, está destravado o seu modem, e quando travar de novo é só teclar Ctrl + C no mesmo terminal e repetir o último comando.
PS. Instalei o meu modem com o pacote sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5build1_i386.deb
Não usei ungrab-winmodem, e quando atualizo o pacote para a atual do repo, fica caindo a conexão toda hora, quando conecta.
Espero ter ajudado, mas no 6.10 nada disso era necessário, e se continuar esse monte de bugs que estão rolando, infelizmente eu vou pular pro Debian ou pro Slack.
A propósito, Alarcon, qual é a função do ungrab? Pois na máquina de um amigo, o modem é o mesmo, mas só funciona com ungrab e o meu com ungrab não funciona de jeito nenhum, a conexão ficava instável e eu tinha de remover tudo e reinstalar só o pacote deb do daemon...

Abraços

Rapaz faz tanto tempo que li sobre o ungrab que não lembro mais o que era e nem encontrei informação sobre ele agora no momento, mas foi algo feito para solucionar um problema com alguns modems que alguma informação necessária era interpretada erroneamente e o ungrab foi feito para solucionar isso para alguns tipos de modems.

Isso que você falou acima sobre desbloquear o modem pode ser feito de uma forma mais simples, bastando digitar no terminal isso:

sudo /etc/init.d/sl-modem-daemon restart


o script sl-modem-daemon que vem no pacote sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5build1_i386.deb serve para ativar o modem no boot, para pará-lo e para reiniciar o mesmo quando não foi iniciardo direito, ou seja, /etc/init.d/sl-modem-daemon start, /etc/init.d/sl-modem-daemon stop e /etc/init.d/sl-modem-daemon restart

Offline Antonio Jr.

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #682 Online: 22 de Junho de 2008, 18:59 »
...so pegando uma carona, Alarcon, pq eu nao consigo colocar strings tipo AT*MM12 naquele pacote v.23 para modem motorola q vc me passou??? pois se coloco assim da erro e o modem nao conecta, agora se coloco um Z depois do AT ele funciona normal mas acredito q as strings nao...obrigado, se acharem mais apropriado crio um topico...

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #683 Online: 24 de Junho de 2008, 17:08 »
...so pegando uma carona, Alarcon, pq eu nao consigo colocar strings tipo AT*MM12 naquele pacote v.23 para modem motorola q vc me passou??? pois se coloco assim da erro e o modem nao conecta, agora se coloco um Z depois do AT ele funciona normal mas acredito q as strings nao...obrigado, se acharem mais apropriado crio um topico...

se vc abrir um terminal e digitar:

gedit wvdial.conf

irá abrir o arquivo de configuração do discador gnome-pp e nas linhas:

Citar
Init = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =


são os strings de inicialização. Acho que se você pretende fazer alguma alteração que não seja os valores padrões, então altera do Init2 em diante, creio que o Init principal, o primeiro, deva ser ATZ mesmo. Se quiser pode tentar modificar o Init principal também e por aqui para ver o que acontece.

Offline marinhojeff

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #684 Online: 29 de Junho de 2008, 04:58 »
Olá, Alarcon, muita satisfação postar p falar com vc e com toda a comunidade, via Ubuntu 8.04, graças ao material que vc disponibilizou, parabéns camarada!
Quem dera se em nossos orgãos federais houvessem pessoas como vc mais preoucupadas em compartilhar e colaborar com os demais do que ver seus próprios interesses.
Meu modem hoje é um V.92 chipset motorola sm56 (que troquei, antes era o conexant que não rodava no windows) e agora funciona após eu ter instalado o pacote modem-arquivos-v23.tar.gz.
Nem li se alguém já tinha postado esta informação, fiz questão de voltar ao fórum e reforçar, além de estar postando em outros sites por onde passar. Valeu!
« Última modificação: 29 de Junho de 2008, 05:00 por marinhojeff »

Offline Antonio Jr.

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #685 Online: 29 de Junho de 2008, 08:25 »
Citar
são os strings de inicialização. Acho que se você pretende fazer alguma alteração que não seja os valores padrões, então altera do Init2 em diante, creio que o Init principal, o primeiro, deva ser ATZ mesmo. Se quiser pode tentar modificar o Init principal também e por aqui para ver o que acontece.

....bom eu ja tentei modificar o init 1 mas nao da certo, o init 2 eu deixei padrao e so edito dele em diante, mas meu grilo é nao poder usar as strings como elas sao, tipo AT o modem so inicia se nas strings q eu coloco eu inserir ATZ...mas vlw muito pela ajuda cara...

Offline cfsilva30

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #686 Online: 30 de Junho de 2008, 06:50 »
Olá Amigo!   Tudo bem?   Sou iniciante no linux e instalei em minha maquina o ubuntu 8.04  e agora estou a semanas tentando instalar um modem e não consigo tenho um lucente v90 e um motorola com chipset Smartlink.  vi o  seu tutorial, e gostaria de saber se é possível usalo para instalar o motorola. se não me engano esse é o nome dele (motorola unknown device 3052)

Caso não seja, você pode me ajudar.

                                      Desde já agradeço!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #687 Online: 30 de Junho de 2008, 14:05 »
Olá Amigo!   Tudo bem?   Sou iniciante no linux e instalei em minha maquina o ubuntu 8.04  e agora estou a semanas tentando instalar um modem e não consigo tenho um lucente v90 e um motorola com chipset Smartlink.  vi o  seu tutorial, e gostaria de saber se é possível usalo para instalar o motorola. se não me engano esse é o nome dele (motorola unknown device 3052)

Caso não seja, você pode me ajudar.

                                      Desde já agradeço!

Primeiramente retire do seu PC o modem lucent e coloque somente o motorola.

Depois abra o Ubuntu e use o terminal dele que se encontra no menu Aplicações > Acessórios > Consola (ou Terminal) e digite:

lspci -d 1057:3052

se aparecer como resposta algo referente ao seu modem motorola, por exemplo isso: Motorola SM56 Data Fax Modem (Rev04), então é por que o seu motorola é suportado pelo driver smartlink. Agora se nada aparecer, infelizmente, no momento, seu modem motorola não tem suporte.

Sendo o seu modem suportado siga as várias dicas que já falei aqui neste meu tópico e use o pacote que fiz correspondente a sua versão do Ubuntu.
« Última modificação: 30 de Junho de 2008, 14:11 por alarcon »

Offline cfsilva30

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #688 Online: 02 de Julho de 2008, 01:28 »
Olá Amigo!   Tudo bem?   Sou iniciante no linux e instalei em minha maquina o ubuntu 8.04  e agora estou a semanas tentando instalar um modem e não consigo tenho um lucente v90 e um motorola com chipset Smartlink.  vi o  seu tutorial, e gostaria de saber se é possível usalo para instalar o motorola. se não me engano esse é o nome dele (motorola unknown device 3052)

Caso não seja, você pode me ajudar.

                                      Desde já agradeço!

Primeiramente retire do seu PC o modem lucent e coloque somente o motorola.

Depois abra o Ubuntu e use o terminal dele que se encontra no menu Aplicações > Acessórios > Consola (ou Terminal) e digite:

lspci -d 1057:3052

se aparecer como resposta algo referente ao seu modem motorola, por exemplo isso: Motorola SM56 Data Fax Modem (Rev04), então é por que o seu motorola é suportado pelo driver smartlink. Agora se nada aparecer, infelizmente, no momento, seu modem motorola não tem suporte.

Sendo o seu modem suportado siga as várias dicas que já falei aqui neste meu tópico e use o pacote que fiz correspondente a sua versão do Ubuntu.


Grato pela resposta ,  acabei de baixar o pacote  v24,    vou tentar e posto para vc !

Offline Nielson

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #689 Online: 02 de Julho de 2008, 02:05 »
      Oi  Alarcon.

Já o agradeço daqui por diante.

Sou iniciante no mundo linux e estou com dificuldade para instalar meu modem na distro Ubuntu 8.04. Tenho um modem Motorola sm56, com id 1057:3052, kernel 2.6.24-16-generic.
Testei o comando:
lspci -d 1057:3052
obtive resposta:
01:00.0 Modem: Motorola SM56 Data Fax Modem (rev 04)
Vi em seu Tutorial que  meu modem é suportado pelo novo pacote. Baixei o modem-arquivos-v23.tar.gz, li os arquivos leia-me e outro PDF, testei o seu novo pacote fazendo todos os comandos para poder instalar meu modem. O probrema é que quando dei o comando:
sudo su
para entrar no modo root ele me respondeu:
sudo: unable to resolve host nielson-desktop
após este testei o comando:
su
onde ele responde:
senha:
mas neste ponto não posso digitar nenhum caractere para auténticar minha senha.
Prossegui com a instalação com os comandos:

nielson@nielson-desktop:~/cd modem-arquivos-v23
nielson@nielson-desktop:~/modem-arquivos-v23$ chmod +x install-modem_Gnome
nielson@nielson-desktop:~/modem-arquivos-v23$ ./install-modem_Gnome
Usando ponto de montagem de CD-ROM /cdrom/
Desmontando CD-ROM
Aguardando por disco...
Por favor, insira um Disco no leitor e pressione enter
Montando CD-ROM...
Identificando.. [6c2e1c01c6884ef40fd349693334a953-2]
Procurando por arquivos de índice no disco..
Found 2 package indexes, 0 source indexes, 0 translation indexes and 1 signatures
Esse disco é chamado:
'Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)'
Copiando lista de pacotes...gpgv: Assinatura feita Ter 22 Abr 2008 22:03:24 BRT usando DSA chave ID FBB75451
gpgv: Assinatura correta de "Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>"
E: Não foi possível abrir arquivo /var/lib/apt/lists/Ubuntu%208.04%20%5fHardy%20Heron%5f%20-%20Release%20i386%20(20080423)_dists_hardy_Release - open (13 Permissão negada)
E: Não foi possível abrir arquivo /var/lib/apt/lists/Ubuntu%208.04%20%5fHardy%20Heron%5f%20-%20Release%20i386%20(20080423)_dists_hardy_Release.gpg - open (13 Permissão negada)
./modem_homolog.h:53: erro: expected specifier-qualifier-list before ‘u8’
./modem_homolog.h:103: erro: expected ‘:’, ‘,’, ‘;’, ‘}’ or ‘__attribute__’ before ‘id’
In file included from ./modem.h:51,


     O livecd estava com o CD de instalação do ubuntu 8.04, e apareceram caixas de dialogo semelhantes ao do guia de instalação PDF. Após isto ele começou a ler muitos arquivos onde aqui coloquei apenas o começo mas fique sabendo que todos têm palavras dizendo AVISO, ERRO.
                   from modem_main.c:70:
./modem_dp.h:82: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem_dp.h:83: erro: expected declaration specifiers or ‘...’ before ‘u8’
In file included from modem_main.c:70:
./modem.h:138: erro: expected specifier-qualifier-list before ‘u16’
./modem.h:174: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:175: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:191: erro: expected specifier-qualifier-list before ‘u16’
./modem.h:219: erro: expected specifier-qualifier-list before ‘u8’
./modem.h:263: erro: field ‘termios’ has incomplete type
./modem.h:319: erro: expected specifier-qualifier-list before ‘u8’
./modem.h:340: erro: expected specifier-qualifier-list before ‘u32’
./modem.h:342: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:343: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:354: erro: expected specifier-qualifier-list before ‘u8’
./modem.h:371: erro: expected specifier-qualifier-list before ‘u8’
./modem.h:436: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:437: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:439: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:440: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:442: erro: expected declaration specifiers or ‘...’ before ‘u8’
./modem.h:443: erro: expected declaration specifiers or ‘...’ before ‘u8’
modem_main.c:98: erro: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘modem_perm’
modem_main.c:106: erro: expected specifier-qualifier-list before ‘snd_pcm_t’
modem_main.c:134: erro: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
modem_main.c: Na função ‘alsa_mixer_setup’:
modem_main.c:141: erro: ‘snd_mixer_elem_t’ undeclared (first use in this function)
modem_main.c:141: erro: (Each undeclared identifier is reported only once
modem_main.c:141: erro: for each function it appears in.)
modem_main.c:141: erro: ‘elem’ undeclared (first use in this function)
modem_main.c:144: aviso: implicit declaration of function ‘strchr’