Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 945565 vezes)

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #960 Online: 08 de Fevereiro de 2009, 16:28 »
Alarcon, acabei de perceber que esse problema é mais grave, pois me deixa bem limitado... para ativar tudo, acho que preciso fechar o terminal, para que o sistema não reclame (alguma coisa como E: Unable to lock nãosei oque, algo mais ou menos assim), mas se eu fechar o terminal então o sudo ppp-gnome também será fechado... vou perder a única forma de conexão...

Como resolver o problema das supostas permissões (estou me coçando para tentar aquele comando que vc deixou por aí em algum post) ?

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #961 Online: 08 de Fevereiro de 2009, 16:30 »
Ah, esqueci de dizer, a conexão já está mais normalizada, e o tempo de conexão é de quase 19 minutos... se ficar nesta velocidade sempre já estarei satisfeito, mas vou esperar sua opnião sobre o que falei acima...

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #962 Online: 08 de Fevereiro de 2009, 18:23 »
Por tudo que você falou até o momento presumo que desta vez o pacote v29 não deu erro de compilação, ou seja, ela foi até o fim e você consegue conectar mesmo que de forma precária.

Gostaria de saber se você já tentou a conexão pelo gnome-ppp indo no menu Aplicações > Internet > GNOME PPP , mas testando com a opção verificar portadora marcada e desmarcada na aba Opções nas configurações do discador. Este é a única opção que para alguns tipos de modem deve ficar desmarcada e para outros marcadas. Agora a opção ignorar seqüencias de terminal (modo burro) sempre deve estar marcada, independente do tipo de modem. A opção verificar rota padrão também deve sempre estar marcada.

Peço para que veja se nos arquivos pap-secrets e chap-secrets que fica em /etc/ppp se no final deles tem tal informação:

"usuario@provedor.com.br" * "senha1234"

obviamente mudando os valores entre duas aspas para o seus dados de conexão, ou seja, nome completo de acesso do provedos (com @ e domínio) e sua senha de acesso e na formatação indicada.

Você só pode olhar e editar estes arquivos acima como root ok, portanto abra o nautilus como root assim sudo nautilus, no terminal.

Logo após reiniciar o PC, abra o terminal e digite os seguintes comandos, um de cada vez:

dmesg | grep slamr

ps -aux | grep slmodemd

lsmod | grep slamr

lsmod | grep ungrab_winmodem


cola aqui o resultado dos comandos.

Quanto a instabilidade na conexão eu falei lá no guia_instalação.pdf sobre usar outros Init2 que não o padrão que pode melhorar isso.

Para fazer essa mudança manualmente baste pelo terminal (menu Aplicações > Acessórios > Consola ou Terminal) digitar:

gedit .wvdial.conf

e na linha que tem:

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0  (que é o padrão)

tentar com esses outros Init2:

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

ou

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34

ou

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

e ver qual é o melhor para você.
« Última modificação: 10 de Fevereiro de 2009, 10:38 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #963 Online: 08 de Fevereiro de 2009, 19:23 »
Outras alternativas para fazer o discador acessado pelo menu Aplicações > Internet > GNOME PPP funcionar, adiciona seu usuário ao grupo:

dialout

se mesmo assim estiver sem funcionar, acrescenta ainda neste outro:

dip


se não me falha a memória o comando para adicionar um certo usuário a um grupo seria:


sudo gpasswd -a seu_usuário dialout

ou

sudo gpasswd -a seu_usuário dip

Reinicie o PC e veja se agora o gnome-ppp pelo menu funciona.

Caso ainda assim não esteja funcionando vá no menu Sistema > Administração > Usuários e Grupos e na janela que aparecer clique em desbloquear, depois selecione seu usuário e clique no botão propriedades e na janela que aparecer vá na aba privilégios do usuário e veja se as opções usar modem e conectar à internet usando modem estão marcadas, se não estiverem, então marque as duas opções.

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #964 Online: 08 de Fevereiro de 2009, 22:45 »
Alarcon instalei o kernel do diamondmax 2.6.28.1 e usei o slmodem modificado do hqxriven,

dá uma olhada no log do gnome-ppp  por favor as vezes dá  o erro a seguir , mas depois de algumas

tentativas de reconecção do gnome ele conecta novamente

The PPP daemon has died: A modem hung up the phone (exit code = 16)

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34
OK
--> Modem initialized.
--> Sending: ATM1L1DT44697415
--> Waiting for carrier.
ATM1L1DT44697415
CONNECT 28800
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sun Feb  8 21:51:34 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 5467
--> Using interface ppp0
--> Disconnecting at Sun Feb  8 21:52:05 2009
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.

veja o resultado do comando ls -la  /usr/sbin/pppd

dtomadon@dtomadon-desktop:~$ ls -la /usr/sbin/pppd
-rwSr-xr-- 1 root dip 269256 2007-10-04 16:57 /usr/sbin/pppd

mais uma vez obrigado pela ajuda!!!
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #965 Online: 09 de Fevereiro de 2009, 11:05 »
Alarcon instalei o kernel do diamondmax 2.6.28.1 e usei o slmodem modificado do hqxriven,

dá uma olhada no log do gnome-ppp  por favor as vezes dá  o erro a seguir , mas depois de algumas

tentativas de reconecção do gnome ele conecta novamente

The PPP daemon has died: A modem hung up the phone (exit code = 16)

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34
OK
--> Modem initialized.
--> Sending: ATM1L1DT44697415
--> Waiting for carrier.
ATM1L1DT44697415
CONNECT 28800
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sun Feb  8 21:51:34 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 5467
--> Using interface ppp0
--> Disconnecting at Sun Feb  8 21:52:05 2009
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.

veja o resultado do comando ls -la  /usr/sbin/pppd

dtomadon@dtomadon-desktop:~$ ls -la /usr/sbin/pppd
-rwSr-xr-- 1 root dip 269256 2007-10-04 16:57 /usr/sbin/pppd

mais uma vez obrigado pela ajuda!!!


realmente esta velocidade CONNECT 28800 está muito baixa.


-rwSr-xr-- 1 root dip 269256 2007-10-04 16:57 /usr/sbin/pppd


este S deveria ser s

pelo man do chmod tem esta informação, dentre outras:

 
Citar
The  letters rwxXst select file mode bits for the affected users: read
       (r), write (w), execute (or search for directories) (x), execute/search
       only  if  the file is a directory or already has execute permission for
       some user (X), set user or group ID on execution (s), restricted  dele‐
       tion  flag or sticky bit (t).  Instead of one or more of these letters,
       you can specify exactly one of the letters ugo: the permissions granted
       to  the  user  who  owns the file (u), the permissions granted to other
       users who are members of the file’s  group  (g),  and  the  permissions
       granted  to  users  that are in neither of the two preceding categories
       (o).


pelo log do gome-ppp nesta parte:

Citar
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.


está recomendando que vc veja /var/log/messages e consulte a pagina de manual do pppd e wvdial para maiores informações.

Vendo rapidamente o man pppd, pois é muito grande, este erro 16 representa isso aqui:

Citar
16     The link was terminated by the modem hanging up.


Você usa a opção verificar portadora marcada ou desmarcada?

Isso pode ser mais pelo tipo de conexão, pois você sabe que conexão discada não é lá essas coisas e que o horário que possa estar tentando a conexão esteja concorrido e aí é necessários várias tentativas de conexão até pegar uma boa com estabilidade e velocidade.
« Última modificação: 09 de Fevereiro de 2009, 11:08 por alarcon »

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #966 Online: 09 de Fevereiro de 2009, 17:08 »
Verificar portadora está marcada.!
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #967 Online: 09 de Fevereiro de 2009, 18:05 »
Verificar portadora está marcada.!

E você já tentou sem esta opção de verificar portadora estar marcada para ver se não seria melhor?

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #968 Online: 10 de Fevereiro de 2009, 00:55 »
Ei Alarcon...
Resposta dos comandos que vc falou...
___________________________________________________________


sudo su

dmesg | slamr
bash: slamr: comando não encontrado

ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      4817  0.8  0.1   3000  3000 ?        SL   11:46   0:14 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0
root      6429  0.0  0.0   3256   828 pts/1    S+   12:13   0:00 grep slmodemd

lsmod | grep slamr
slamr                 437672  2

lsmod | grep ungrab_winmodem
ungrab_winmodem        10112  0


___________________________________________________________

Fui lá em Usuários e Grupos, e a opção conectar à internet usando modem estava desmarcada. Mas após marcá-la, testei o gnome-ppp e continua dando o problema da mensagem de permissão de acesso.

Eu adicionei meu usuário ao grupo dialout e dip, e no momento ainda não consigo me conectar, já marquei e desmarquei aquela opção de Verificar portadora e nada ainda... continuo tendo aquela mesma mensagem...


alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #969 Online: 10 de Fevereiro de 2009, 10:47 »
Ei Alarcon...
Resposta dos comandos que vc falou...
___________________________________________________________


sudo su

dmesg | slamr
bash: slamr: comando não encontrado

ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      4817  0.8  0.1   3000  3000 ?        SL   11:46   0:14 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0
root      6429  0.0  0.0   3256   828 pts/1    S+   12:13   0:00 grep slmodemd

lsmod | grep slamr
slamr                 437672  2

lsmod | grep ungrab_winmodem
ungrab_winmodem        10112  0


___________________________________________________________

Fui lá em Usuários e Grupos, e a opção conectar à internet usando modem estava desmarcada. Mas após marcá-la, testei o gnome-ppp e continua dando o problema da mensagem de permissão de acesso.

Eu adicionei meu usuário ao grupo dialout e dip, e no momento ainda não consigo me conectar, já marquei e desmarquei aquela opção de Verificar portadora e nada ainda... continuo tendo aquela mesma mensagem...



Primeiro uma correção, o primeiro comando está errado por culpa minha e já corrigi no texto original, ou seja, ao inés de ser o comando dmesg | slamr o correto seria:

dmesg | grep slmar

portanto cole aqui o resultado do comando acima que ficou faltando, mas que não vai apresentar nenhum erro, pois pelos outros já deu para perceber isso, entretanto gostaria que colocasse aqui o resultado do comando.

Bem, pelo que vejo por esse comando ls -la /usr/sbin/pppd :

-rwsr-xr-- 1 root dip 273064 2008-10-15 22:51 /usr/sbin/pppd

as permissões do pppd estão normais.

Por esse comando aqui ps -aux | grep slmodemd cujo resultado foi isso:

root      4817  0.8  0.1   3000  3000 ?        SL   11:46   0:14 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0

também mostra que o executável slmodemd pode ser usado pelo usuário comum ( --perm=0666), ou seja, não deveria ter problemas de permissão, pois ele está com permissão 666 ok.

Em Usuários e Grupos você verificou as opções usar modem e conectar à internet usando modem. Ambas tem de estar marcadas, agora só queria que vc tentasse a conexão após reiniciar o PC, depois de marcar estas opções.

Como última alternativa tente mais esse comando no terminal:

sudo chmod a+x /usr/sbin/pppd
« Última modificação: 10 de Fevereiro de 2009, 10:51 por alarcon »

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #970 Online: 11 de Fevereiro de 2009, 11:08 »
Alarcon, consegui !!! Finalmente....

Muito obrigado desde já...

Bom, o que fiz foi o seguinte : no terminal dgitei o comando dmesg | grep slamr , que retornou isso :

[   11.609267] slamr: module license 'Smart Link Ltd.' taints kernel.
[   11.634681] slamr: SmartLink AMRMO modem.
[   11.647852] slamr: probe 1057:3052 SL1900 card...
[   11.647868] slamr 0000:01:06.0: PCI INT A -> Link[APC2] -> GSI 17 (level, low) -> IRQ 17
[   11.647884] slamr 0000:01:06.0: setting latency timer to 64
[   11.868249] slamr: slamr0 is SL1900 card.

Vc disse também :

"Em Usuários e Grupos você verificou as opções usar modem e conectar à internet usando modem. Ambas tem de estar marcadas, agora só queria que vc tentasse a conexão após reiniciar o PC, depois de marcar estas opções."

Eu já as tinha marcado na última tentativa... então resolvi ir direto pra seu último conselho...

"Como última alternativa tente mais esse comando no terminal:


sudo chmod a+x /usr/sbin/pppd "

Foi isso, com certeza... assim que fiz isso, tentei conectar normalmente, e consegui (estou postando agora do linux)...

Valeu pela ajuda e esforço... vou tomar coragem para resolver o problema com o meu modem que está agora no outro computador, é aquele Intel 537, não sei se vc lembra, esse aí vou precisar de um Alarcon só para esse modem...

Mas chegou a internet banda larga aqui na vizinhança, talvez eu consiga uma banda larga, e isso seria algo com um Claro 3G da vida... deve facilitar bastante as coisas... Obrigado !!!

Offline morrison

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #971 Online: 11 de Fevereiro de 2009, 11:19 »
Bom andei mei sumido mas vou tentar fazer tudo denovo  pois os problemas que tinha eram o mesmos do Shakmatton  e seguir os ultimos passos desdes que o Alarcon postou o V29 e verei se da´acerto.
Abraços

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #972 Online: 11 de Fevereiro de 2009, 18:08 »
Alarcon, consegui !!! Finalmente....

Muito obrigado desde já...

Bom, o que fiz foi o seguinte : no terminal dgitei o comando dmesg | grep slamr , que retornou isso :

[   11.609267] slamr: module license 'Smart Link Ltd.' taints kernel.
[   11.634681] slamr: SmartLink AMRMO modem.
[   11.647852] slamr: probe 1057:3052 SL1900 card...
[   11.647868] slamr 0000:01:06.0: PCI INT A -> Link[APC2] -> GSI 17 (level, low) -> IRQ 17
[   11.647884] slamr 0000:01:06.0: setting latency timer to 64
[   11.868249] slamr: slamr0 is SL1900 card.

Vc disse também :

"Em Usuários e Grupos você verificou as opções usar modem e conectar à internet usando modem. Ambas tem de estar marcadas, agora só queria que vc tentasse a conexão após reiniciar o PC, depois de marcar estas opções."

Eu já as tinha marcado na última tentativa... então resolvi ir direto pra seu último conselho...

"Como última alternativa tente mais esse comando no terminal:


sudo chmod a+x /usr/sbin/pppd "

Foi isso, com certeza... assim que fiz isso, tentei conectar normalmente, e consegui (estou postando agora do linux)...

Valeu pela ajuda e esforço... vou tomar coragem para resolver o problema com o meu modem que está agora no outro computador, é aquele Intel 537, não sei se vc lembra, esse aí vou precisar de um Alarcon só para esse modem...

Mas chegou a internet banda larga aqui na vizinhança, talvez eu consiga uma banda larga, e isso seria algo com um Claro 3G da vida... deve facilitar bastante as coisas... Obrigado !!!

Poxa, finalmente o sucesso!

Fico satisfeito que tenha contribuído de alguma forma para o seu sucesso no uso do linux.

Lembro, ou melhor, chamo a atenção para as atualizações que devem ser indicadas pelo Ubuntu que tem mudança de kernel e ao fazer as atualizações, seu modem irá para de funcionar com esse novo kernel, mas aí é só usar o v29 outra vez, mas naquela janela do instalador do v29 que tem várias opções marcadas, você só deve deixar marcadas as opções Ungrab-Winmodem e Slmodem-2.9.11-20080629 que são exatamente as opções de compilação do driver ungrab-winmodem e do driver smartlink que devem ser feitas outra vez para este novo kernel. Tudo isso está explicado no guia_instalação.pdf presente no v29 ok.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #973 Online: 11 de Fevereiro de 2009, 18:09 »
Bom andei mei sumido mas vou tentar fazer tudo denovo  pois os problemas que tinha eram o mesmos do Shakmatton  e seguir os ultimos passos desdes que o Alarcon postou o V29 e verei se da´acerto.
Abraços

Ok, veja o pacote v29 que acho que agora vai, hehehe.

Offline morrison

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #974 Online: 12 de Fevereiro de 2009, 14:10 »
Alarcon obrigado agora foiiiii só precisei adicionar o meu usuario no dialout e dip e colocar pra conectar usando um modem e ai funcionou normal estoy a um bom tempo conectado nele. agora posso deixar o windons e voltar a usar linus obrigado.