Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 991444 vezes)

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #45 Online: 01 de Abril de 2006, 00:52 »
Citação de: "Bode"
Alarcon, cara estou mto grato pela sua ajuda, sem vc não teria consegido compilar o driver da SmartLink, vlw msm!  Por acaso vc é o alarcon do fórum do Kurumin também???



Carlos, vc! É, vc msm!


VC SALVOU MEU PC!


Meu modem, igual ao seu, tá funfano agora msm! Nesse instante! Vlw cara, vlw msm!


Sim sou eu mesmo, mas agora com o Ubuntu :-)

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Té q enfim cheguei lá
« Resposta #46 Online: 01 de Abril de 2006, 03:46 »
Caro alarcom,


                              obrigado pela forca ja estou digitando do mozilla e agora tenho mais flexibilidade para aprender as coisas no linux pois naum tenho q reiniciar. vlw msm
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Fixo
« Resposta #47 Online: 01 de Abril de 2006, 12:59 »
O q eh necessário para um tópico ficar fixo pq
Bem q esse topico poderia ser fixo,
pois pelo q vi naum fui o unico a ter problemas com o modem!!!!!!!!!!!!!!!!!
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

alarcon

  • Visitante
Re: Fixo
« Resposta #48 Online: 01 de Abril de 2006, 18:24 »
Citação de: "eng_ividal"
O q eh necessário para um tópico ficar fixo pq
Bem q esse topico poderia ser fixo,
pois pelo q vi naum fui o unico a ter problemas com o modem!!!!!!!!!!!!!!!!!


Valeu eng ividal pelas suas palavras e até que enfim vc colocou seu modem para funcionar, fico satistfeito com isso. Que deixem de usar o Linux por achar difícil, não atender as suas necessidades e etc, mas não por que seu modem não funciona e consequentemente não navega na net :-)

Agora com relação ao tópico ficar fixo isso é com os moderadores, creio eu, conforme os critérios adotados por eles na hora de se fixar um tópico, tá bom.

Offline Agaporn

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #49 Online: 01 de Abril de 2006, 22:27 »
Eai chef blz? Vc caprichou mesmo no tutorial, ficou bom pra karamba...
Então cara só tive um problema muito vagabundo, eu consegui instalar o drive do modem sem problemas, mas na hora de conectar o modem até ameaça a discar, mas não disca; no registro aparece a seguinte mensagem "No dial tone". Já testei tanto com o kppp, quanto com o gnome-ppp. Esse problema parece ser muito bobo, pois no kppp tem uma opção de chamar o sinal do modem e lá o modem responde certinho!!!

O meu modem é um LG NetoDragon PCI
Ah...Já olhei o seu outro tópico de como configurar o gnome-ppp e continuo com  esse probleminha

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #50 Online: 01 de Abril de 2006, 22:45 »
Citação de: "Agaporn"
Eai chef blz? Vc caprichou mesmo no tutorial, ficou bom pra karamba...
Então cara só tive um problema muito vagabundo, eu consegui instalar o drive do modem sem problemas, mas na hora de conectar o modem até ameaça a discar, mas não disca; no registro aparece a seguinte mensagem "No dial tone". Já testei tanto com o kppp, quanto com o gnome-ppp. Esse problema parece ser muito bobo, pois no kppp tem uma opção de chamar o sinal do modem e lá o modem responde certinho!!!

O meu modem é um LG NetoDragon PCI
Ah...Já olhei o seu outro tópico de como configurar o gnome-ppp e continuo com  esse probleminha


como vc fez utilizou o meu texto e fez manualmente os passo, pq criei um pacote para fazer isso.

Vc pode mostrar aqui como tá o seu .wvdial, lembrando de apagar os seus dados confidenciais ok.


me mostra o conteúdo do seu ativar-modem e do comando dmseg |grep slamr

Agora não entendi direito o seu problema.

qual provedor vc usa e tem de configurar DNS?

Tenta usar AT X3 +MS=34 ou ATZX3 ao invés de  ATZ lá nas configurações do modem pra ver.

PsYkHe

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #51 Online: 01 de Abril de 2006, 22:57 »
valeeuu alarcon....muito bom...estou navegando no linux finalmente. o programa de instalação q visseste funcionou q uma beleza....valeu mesmo....agora é ir apreendendo a mexer no power linux....faloww..ate.

Offline Agaporn

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #52 Online: 02 de Abril de 2006, 02:49 »
Olha parceiro foi assim: eu peguei uma parte do seu tutorial (não usei o pacote) e outra parte foi o que o Carlos Costa postou, pois eu estava com a mesma dificuldade dele, o driver da SmartLink precisou de uma forcinha pra funcionar.

Aki tá o meu .wvdial.conf


Código: [Selecionar]
[Dialer Defaults]
Modem = /dev/modem
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone =
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L3DT
Ask Password = off
Password =
Username =
Auto Reconnect = off
Abort on Busy = on
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = on
;Do NOT edit this file by hand!


O conteúdo pra ativar o modem é esse:

Código: [Selecionar]
#!/bin/sh
modprobe -r slamr
modprobe ungrab-winmodem
modprobe slamr
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0&
ln -sf /dev/ttySL0 /dev/modem


O modem parece estar funcionando certinho, olha a ativação e o dmeg dele

Código: [Selecionar]
root@ubuntu:/home/felipe/Desktop# ./ativar_modem.sh
SmartLink Soft Modem: version 2.9.11 Apr  1 2006 19:37:12
symbolic link `/dev/ttySL0' -> `/dev/pts/1' created.
modem `slamr0' created. TTY is `/dev/pts/1'
root@ubuntu:/home/felipe/Desktop# Use `/dev/ttySL0' as modem device, Ctrl+C for termination.

root@ubuntu:/home/felipe/Desktop# dmesg | grep slamr
[4295738.248000] slamr: SmartLink AMRMO modem.
[4295738.252000] slamr: probe 10b9:5459 SL1800 card...
[4295739.253000] slamr: mc97 codec is SIL26
[4295739.253000] slamr: slamr0 is SL1800 card.


Eu uso o Ibest, não preciso configurar DNS.

Willesmar

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #53 Online: 02 de Abril de 2006, 03:02 »
Caro amigo, posto aki o sucesso deste teu tuto, ficou bom e conectando mais rápido q pelo win, e com o som funcionando beleza, tanks.

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #54 Online: 02 de Abril de 2006, 11:25 »
Citação de: "Agaporn"
Olha parceiro foi assim: eu peguei uma parte do seu tutorial (não usei o pacote) e outra parte foi o que o Carlos Costa postou, pois eu estava com a mesma dificuldade dele, o driver da SmartLink precisou de uma forcinha pra funcionar.

Aki tá o meu .wvdial.conf


Código: [Selecionar]
[Dialer Defaults]
Modem = /dev/modem
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone =
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L3DT
Ask Password = off
Password =
Username =
Auto Reconnect = off
Abort on Busy = on
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = on
;Do NOT edit this file by hand!


O conteúdo pra ativar o modem é esse:

Código: [Selecionar]
#!/bin/sh
modprobe -r slamr
modprobe ungrab-winmodem
modprobe slamr
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0&
ln -sf /dev/ttySL0 /dev/modem


O modem parece estar funcionando certinho, olha a ativação e o dmeg dele

Código: [Selecionar]
root@ubuntu:/home/felipe/Desktop# ./ativar_modem.sh
SmartLink Soft Modem: version 2.9.11 Apr  1 2006 19:37:12
symbolic link `/dev/ttySL0' -> `/dev/pts/1' created.
modem `slamr0' created. TTY is `/dev/pts/1'
root@ubuntu:/home/felipe/Desktop# Use `/dev/ttySL0' as modem device, Ctrl+C for termination.

root@ubuntu:/home/felipe/Desktop# dmesg | grep slamr
[4295738.248000] slamr: SmartLink AMRMO modem.
[4295738.252000] slamr: probe 10b9:5459 SL1800 card...
[4295739.253000] slamr: mc97 codec is SIL26
[4295739.253000] slamr: slamr0 is SL1800 card.


Eu uso o Ibest, não preciso configurar DNS.


Olá...

É aparentemente está tudo ok mesmo, agora vc não me falou se tentou usar AT X3 +MS=34 ou ATZX3 ao invés de  ATZ lá nas configurações do .wvdial pra ver se assim funciona.

é a linha do .Wvdial que tem Init = ATZ então vc deve mudar para Init = AT X3 +MS=34 ou  Init = ATZX3

também uso o Ibest como provedor e é sem problemas a conexão com o gnome-ppp.

Para verificar se está ativo o driver de modem dê o comando:

ps -aux | grep slmodemd

e se sair algo assim:

Citar
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      7193  5.1  1.3   3012  3012 ?        SL   11:05   1:16 slmodemd --country=BRAZIL --perm=0666 /dev/slamr0
alarcon   8661  0.0  0.3   3068   764 pts/1    S+   11:30   0:00 grep slmodemd


então realmente seu driver foi ativado na hora do boot corretamente.

Atenção: Antes de tentar s mudanças que eu falei aí em cima com relação a configuração do .wvdial.conf primeiro tente isso:

abra o gnome-ppp  e clique em Configuração > aba (ou guia) Opções e desmarque a opção verificar portadora e veja se o seu gnome-ppp funciona desta vez e caso continue dando erro aí vc tenta o que falei sobre mudar de ATZ para outras opções aí.

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #55 Online: 02 de Abril de 2006, 11:37 »
Citação de: "Willesmar"
Caro amigo, posto aki o sucesso deste teu tuto, ficou bom e conectando mais rápido q pelo win, e com o som funcionando beleza, tanks.


MAIS UM... MAIS UM.... MAIS UM....  :lol:

É isso aí galera, botem estes softmodems aí pra funcionarem!!!

Que os softmodems não sejam obstáculos ao uso do linux.

[]bWillesmar[/b] que bom que seu modem funiona. Agora espalhe o conhecimento com todos que possuem um modem igual ao seu ok.

Valeu e Obrigado.

Offline botinha

  • Usuário Ubuntu
  • *
  • Mensagens: 106
  • Debian7 Brasil
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #56 Online: 04 de Abril de 2006, 21:13 »
Citar

Olha só pelo que pude ver não aparece nada do que relatei até agora, então no seu cado o passo modprobe -r nome_do_módulo não é para ser feito, pois vc não tem nenhum destes que podem atrapalhar no modem, pelo menos como disse nesta lista que vc colou aqui não aparece nada.


Caro Alarcon então seu pular o modprobe -r irá funcionar aqui ou vc recomenda outro procedimento.


Valeu.......
"o suor poupa o sangue"

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #57 Online: 05 de Abril de 2006, 10:04 »
Citação de: "botinha"
Citar

Olha só pelo que pude ver não aparece nada do que relatei até agora, então no seu cado o passo modprobe -r nome_do_módulo não é para ser feito, pois vc não tem nenhum destes que podem atrapalhar no modem, pelo menos como disse nesta lista que vc colou aqui não aparece nada.


Caro Alarcon então seu pular o modprobe -r irá funcionar aqui ou vc recomenda outro procedimento.


Valeu.......


Faz o seguinte lê este texto aqui:

http://ubuntuforum-pt.org/index.php?topic=4204&postdays=0&postorder=asc&start=20

onde eu criei uma forma de instalação automática que previne possíveis dúvidas e tente por ele ok.

deividfoggi

  • Visitante
Erro logo no passo 1
« Resposta #58 Online: 08 de Abril de 2006, 14:48 »
Ao descompactar ocorre o seguite erro:

root@servidor:/home/deividfoggi/Desktop# tar -zxvf modem-arquivos-v2.tar.gz
modem-arquivos-v2/smartlink-ubuntu.deb
modem-arquivos-v2/gcc-3.4_3.4.4-6ubuntu8_i386.deb
modem-arquivos-v2/cpp-3.4_3.4.4-6ubuntu8_i386.deb

gzip: stdin: unexpected end of file
tar: Final-de-arquivo inesperado no arquivo-tar
tar: Final-de-arquivo inesperado no arquivo-tar
tar: Erro não é recuperável: saindo agora

Não estou aguentando mais esse modem, essa é a ultima tentaiva...

alarcon

  • Visitante
Re: Erro logo no passo 1
« Resposta #59 Online: 08 de Abril de 2006, 15:09 »
Citação de: "deividfoggi"
Ao descompactar ocorre o seguite erro:

root@servidor:/home/deividfoggi/Desktop# tar -zxvf modem-arquivos-v2.tar.gz
modem-arquivos-v2/smartlink-ubuntu.deb
modem-arquivos-v2/gcc-3.4_3.4.4-6ubuntu8_i386.deb
modem-arquivos-v2/cpp-3.4_3.4.4-6ubuntu8_i386.deb

gzip: stdin: unexpected end of file
tar: Final-de-arquivo inesperado no arquivo-tar
tar: Final-de-arquivo inesperado no arquivo-tar
tar: Erro não é recuperável: saindo agora

Não estou aguentando mais esse modem, essa é a ultima tentaiva...


olha só, ou vc teve um problema no download deste arquivo ou o seu ubuntu não tá legal pq um usuário já usou este arquivo aí sem problemas então tente novamente o downloads ou reinstale o seu ubuntu, mais atenção que estas dicas aí são para o ubuntu 5.10 Ok.