Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 968551 vezes)

Offline clebãoo

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #1245 Online: 30 de Maio de 2010, 18:51 »
eai é q eu fui instalar o modem-arquivos-v32.tar e ele deu o msm poblema do Rodrigo-live(ate q vc arrumou a versão do ubuntu no etc...) msm vc atualizando este poblema ai eu queria saber o pq ????
falow

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1246 Online: 07 de Junho de 2010, 17:02 »
eai é q eu fui instalar o modem-arquivos-v32.tar e ele deu o msm poblema do Rodrigo-live(ate q vc arrumou a versão do ubuntu no etc...) msm vc atualizando este poblema ai eu queria saber o pq ????
falow

Abra um terminal (menu  Aplicativos > Acessórios > Terminal) e digite o seguinte comando:

cat /etc/lsb-release


cole aqui o resultado do comando anterior.


Veja também o conteúdo do seguinte comando (copie e cole é melhor) no terminal:

cat /etc/lsb-release | grep "Ubuntu 10.04 LTS" | cut -d= -f2- | cut -d'"' -f2- | cut -d'"' -f1

poste aqui o resultado ok.

Offline João Gabriel

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #1247 Online: 09 de Junho de 2010, 22:20 »
Saudações  :D
Alarcon, baixei e instalei o novo pacote modem-arquivos-v32, a instalação terminou sem erros, depois de reiniciar o PC e discar, meu Ubuntu conecta e cai logo em seguida, ficando apenas um ou dois segundos conectado.
Depois disso o meu modem não é mais reconhecido pelo Ubuntu, abro o terminal e digito o comando
sudo /etc/init.d/sl-modem-daemon restart, depois tento conectar outra vez e acontece o mesmo problema.
Esta tudo ok com o meu cd, e já formatei e instalei o Ubuntu do zero e mesmo assim continua.
Quando instalei o Ubuntu 10.04 pela primeira vez aconteceu um erro e não terminou a instalação do pacote modem-arquivos-v32, na notificação dizia que já existia alguns pacotes instalados e tinha a opção de reinstalar.
Abri o  Synaptic e já estavam marcados e instalados os pacotes, Make;Gcc;Linux-Headers-Libasound 2, então desmarquei quando adicionei o Live-CD, deixando marcado todo o resto, ai consegui completar a instalação.
Obrigado.

Offline clebãoo

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1248 Online: 10 de Junho de 2010, 15:20 »
eae
blz alarcon
eu fiz o q vc pediu...

o primeiro comando:
cat /etc/lsb-release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu lucid (development branch)"

o segundo comando:

cat /etc/lsb-release | grep "Ubuntu 10.04 LTS" | cut -d= -f2- | cut -d'"' -f2- | cut -d'"' -f1

não deu em nada
blz
falow
   


alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1249 Online: 10 de Junho de 2010, 16:12 »
eae
blz alarcon
eu fiz o q vc pediu...

o primeiro comando:
cat /etc/lsb-release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu lucid (development branch)"

o segundo comando:

cat /etc/lsb-release | grep "Ubuntu 10.04 LTS" | cut -d= -f2- | cut -d'"' -f2- | cut -d'"' -f1

não deu em nada
blz
falow
   



É o seguinte, aqui o comando cat /etc/lsb-release dá como resposta isso:

Citar
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"

e o comando cat /etc/lsb-release | grep "Ubuntu 10.04 LTS" | cut -d= -f2- | cut -d'"' -f2- | cut -d'"' -f1 aqui retorna isso:

Citar
Ubuntu 10.04 LTS

Ou seja, exatamente a versão do Ubuntu, portanto o script confere se é essa versão que o meu pacote dá suporte e segue em frente.

No meu script de instalação tive que colocar uma espécie de trava, pois apesar de sempre colocar em letras vermelhas para qual versão do Ubuntu aquela versão do meu pacote era adequada, sempre tinha usuário teimoso que usava para a versão do Ubuntu errada.

Pelo que você postou do comando cat /etc/lsb-release, no seu caso deu diferente do meu, veja:

Citar
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu lucid (development branch)"

O que destaquei em negrito é exatamente a diferença entre o meu e o seu, portanto o meu script vai procurar pela informação DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS", mas no seu caso a informação seria DISTRIB_DESCRIPTION="Ubuntu lucid (development branch)"

A solução mais simples, abra um terminal e digite:

sudo gedit /etc/lsb-release

quando o arquivo lsb-release abrir, edite a linha:

DISTRIB_DESCRIPTION="Ubuntu lucid (development branch)"

para

DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"

salve e saia do arquivo.

Depois instale o meu pacote outra vez.
« Última modificação: 10 de Junho de 2010, 16:18 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1250 Online: 10 de Junho de 2010, 16:24 »
Saudações  :D
Alarcon, baixei e instalei o novo pacote modem-arquivos-v32, a instalação terminou sem erros, depois de reiniciar o PC e discar, meu Ubuntu conecta e cai logo em seguida, ficando apenas um ou dois segundos conectado.
Depois disso o meu modem não é mais reconhecido pelo Ubuntu, abro o terminal e digito o comando
sudo /etc/init.d/sl-modem-daemon restart, depois tento conectar outra vez e acontece o mesmo problema.
Esta tudo ok com o meu cd, e já formatei e instalei o Ubuntu do zero e mesmo assim continua.
Quando instalei o Ubuntu 10.04 pela primeira vez aconteceu um erro e não terminou a instalação do pacote modem-arquivos-v32, na notificação dizia que já existia alguns pacotes instalados e tinha a opção de reinstalar.
Abri o  Synaptic e já estavam marcados e instalados os pacotes, Make;Gcc;Linux-Headers-Libasound 2, então desmarquei quando adicionei o Live-CD, deixando marcado todo o resto, ai consegui completar a instalação.
Obrigado.


Não se preocupe com pacotes que já estão instalados, isso no meu script é só para o caso de não estarem instalados, não influencia em nada o processo de instalação.

Quanto ao problema de desconexão logo ao se conectar, você tem de tentar os outros strings de inicialização como falo no guai_instalação.pdf, ou até mesmo em algum lugar deste meu tópico sobre modem, portanto procure em textos anteriores algo sobre Init2. Desculpe não falar aqui, mas é que já falei sobre isso inúmeras vezes e confesso a você que já estou ficando cansado de falar quase sempre a mesma coisa, mas se não encontrar ou não entender, depois eu explico melhor.

===Editado===

Veja este link que fala sobre o Init2 ( string de inicialização):

http://ubuntuforum-br.org/index.php/topic,4204.msg357091.html#msg357091

Offline João Gabriel

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1251 Online: 12 de Junho de 2010, 23:21 »
Saudações  :D
Alarcon, baixei e instalei o novo pacote modem-arquivos-v32, a instalação terminou sem erros, depois de reiniciar o PC e discar, meu Ubuntu conecta e cai logo em seguida, ficando apenas um ou dois segundos conectado.
Depois disso o meu modem não é mais reconhecido pelo Ubuntu, abro o terminal e digito o comando
sudo /etc/init.d/sl-modem-daemon restart, depois tento conectar outra vez e acontece o mesmo problema.
Esta tudo ok com o meu cd, e já formatei e instalei o Ubuntu do zero e mesmo assim continua.
Quando instalei o Ubuntu 10.04 pela primeira vez aconteceu um erro e não terminou a instalação do pacote modem-arquivos-v32, na notificação dizia que já existia alguns pacotes instalados e tinha a opção de reinstalar.
Abri o  Synaptic e já estavam marcados e instalados os pacotes, Make;Gcc;Linux-Headers-Libasound 2, então desmarquei quando adicionei o Live-CD, deixando marcado todo o resto, ai consegui completar a instalação.
Obrigado.


Não se preocupe com pacotes que já estão instalados, isso no meu script é só para o caso de não estarem instalados, não influencia em nada o processo de instalação.

Quanto ao problema de desconexão logo ao se conectar, você tem de tentar os outros strings de inicialização como falo no guai_instalação.pdf, ou até mesmo em algum lugar deste meu tópico sobre modem, portanto procure em textos anteriores algo sobre Init2. Desculpe não falar aqui, mas é que já falei sobre isso inúmeras vezes e confesso a você que já estou ficando cansado de falar quase sempre a mesma coisa, mas se não encontrar ou não entender, depois eu explico melhor.

===Editado===

Veja este link que fala sobre o Init2 ( string de inicialização):

http://ubuntuforum-br.org/index.php/topic,4204.msg357091.html#msg357091
Saudações
bom me lembrei que você tinha me pedido pra desmarcar isso há um tempo atrás http://ubuntuforum-br.org/index.php/topic,4204.msg299747.html#msg299747, e como aconteceu o mesmo erro :) não ia fazer a mesma  pergunta.
Como esqueci de mencionar(desculpa ::)) testei outras strings revisei todo o tópico antes de postar, porém como não tive sucesso foi por isso que postei  ;) all right.
Muito obrigado.

Offline clebãoo

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1252 Online: 15 de Junho de 2010, 13:53 »
valeu alarcon pela ajuda, funcionou bem sem eu precisar colocar o codigo para entrar na internet...
eu estou escrevendo por ele ate...
muito obrigado pela ajuda...
falow

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1253 Online: 19 de Junho de 2010, 20:51 »
Alarcon a internet está funcionando aqui com o Ubuntu 10.04 com seu pacote.





Mais toda vez que abro o Firefox ele ta offline ae tenho que desmarcar toda vez.




No 9.10 isto não acontecia.



Eu sei que não deve ter nada a ver com seu pacote, mais você ou outro usuario podia me ajudar?



Obrigado.


Offline J-P

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Tutorial para driver da conexant
« Resposta #1254 Online: 30 de Junho de 2010, 18:32 »
Olá pessoal, tudo bem?
acho que estou muito perto de conseguir instalar meu fax modem da conexant. No Cd de instalação havia uma pasta "hsfmodem-7.60.00.00oem.tar. Segui as instruções de um outro tutorial para instalar arquivos com esta extensão, descompactei, entrei no terminal como root, entrei no diretório da pasta e apliquei os seguintes comandos:
./configure
make
sudo make install

Então, apareceu a seguinte mensagem no terminal:

complete the installation and configuration of your modem,
please run "hsfconfig" (or "/usr/sbin/hsfconfig")


Digitei no terminal "hsfconfig". Apareceu então a seguinte mensagem no terminal:

Conexant HSF softmodem driver, version 7.60.00.00oem

If you need assistance or more information, please go to:
   http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Ubuntu-10.04 linux-2.6.32-21-generic i686-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?
[/lib/modules/2.6.32-21-generic/build]


Aqui eu não sabia o que fazer, então dei "Enter" no terminal. Apareceu então a seguinte mensagem:

Building modules for kernel 2.6.32-21-generic, using source directory
/lib/modules/2.6.32-21-generic/build. Please wait...

ERROR: Module build failed!
Please examine the log file "/tmp/hsfconfig-buildlog.txt" to determine why."


Dentro do Cd de instalação do modem havia um arquivo "Leia-me" alertando para a necessidade de rodar o "hsfconfig" no final, mas como sou iniciante não entendo bem o que significa. Acredito que foi por causa disso que ainda não consegui instalar o modem. Alguém poderia me orientar a resolver esse problema?

Offline mauricio_luciano

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1255 Online: 05 de Julho de 2010, 17:42 »
Saudações  :D
Alarcon, baixei e instalei o novo pacote modem-arquivos-v32, a instalação terminou sem erros, depois de reiniciar o PC e discar, meu Ubuntu conecta e cai logo em seguida, ficando apenas um ou dois segundos conectado..


Mais você está se conectando como root? Pode ser problema de permissão... Veja um exemplo de tentativa de conexão como usuário comum:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT35251999
--> Waiting for carrier.
ATM1L3DT35251999
CONNECT 46667
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Mon Jul  5 17:35:35 2010
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 5663
--> Using interface ppp0
--> Disconnecting at Mon Jul  5 17:36:24 2010
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds

Depois disso o meu modem não é mais reconhecido pelo Ubuntu, abro o terminal e digito o comando
sudo /etc/init.d/sl-modem-daemon restart, depois tento conectar outra vez e acontece o mesmo problema.


Você pode criar um arquivo de script com esse comando e colocar na pasta {/etc/ppp/ip-down.d} pra ele fazer isso automaticamente toda vez que a conexão cair.

Alarcon a internet está funcionando aqui com o Ubuntu 10.04 com seu pacote.
Mais toda vez que abro o Firefox ele ta offline ae tenho que desmarcar toda vez.
No 9.10 isto não acontecia.


Comigo isso também acontece. Para resolver tem que digitar na barra de endereços --> about:config <-- procurar pela linha {toolkit.networkmanager.disable;false} e dar dois cliques em cima para deixar como {true}.

8)
« Última modificação: 05 de Julho de 2010, 17:46 por mauricio_luciano »

Offline sandro.serra.ap

  • Usuário Ubuntu
  • *
  • Mensagens: 111
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1256 Online: 07 de Julho de 2010, 13:29 »
Olá a todos,

Não quero ser inconveniente mas já sendo, gostaria de saber se alguém já consegue acessar internet discada com o Fax Modem da Motorola(e como ?) no ubuntu 10.04 LTS, estou pensando adquirir um, pois o meu da conexant tá difícil. (Já pesquisei no fórum mas ninguem tem uma resposta se já conecta)
« Última modificação: 07 de Julho de 2010, 13:31 por sandro.serra.ap »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1257 Online: 09 de Julho de 2010, 21:02 »
Olá a todos,

Não quero ser inconveniente mas já sendo, gostaria de saber se alguém já consegue acessar internet discada com o Fax Modem da Motorola(e como ?) no ubuntu 10.04 LTS, estou pensando adquirir um, pois o meu da conexant tá difícil. (Já pesquisei no fórum mas ninguem tem uma resposta se já conecta)

Se seu modem é o Motorola sm56 com ID 1057:3052, ele tem suporte no Ubuntu sim com o drive smartlink que uso nos meus pacotes aqui deste tópico (Tutorial para HSP56 MR driver Smartlink) é só procurar no primeiro texto deste tópico o link dos pacotes que faço para a versão do Ubuntu em uso, em 32bits, e se não me falha a memória já foi testado e aprovado com esse modem no Ubuntu 10.04 é só vc verificar nos posts anteriores.

alarcon

  • Visitante
Re: Tutorial para driver da conexant
« Resposta #1258 Online: 09 de Julho de 2010, 21:10 »
Olá pessoal, tudo bem?
acho que estou muito perto de conseguir instalar meu fax modem da conexant. No Cd de instalação havia uma pasta "hsfmodem-7.60.00.00oem.tar. Segui as instruções de um outro tutorial para instalar arquivos com esta extensão, descompactei, entrei no terminal como root, entrei no diretório da pasta e apliquei os seguintes comandos:
./configure
make
sudo make install

Então, apareceu a seguinte mensagem no terminal:

complete the installation and configuration of your modem,
please run "hsfconfig" (or "/usr/sbin/hsfconfig")


Digitei no terminal "hsfconfig". Apareceu então a seguinte mensagem no terminal:

Conexant HSF softmodem driver, version 7.60.00.00oem

If you need assistance or more information, please go to:
   http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Ubuntu-10.04 linux-2.6.32-21-generic i686-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?
[/lib/modules/2.6.32-21-generic/build]


Aqui eu não sabia o que fazer, então dei "Enter" no terminal. Apareceu então a seguinte mensagem:

Building modules for kernel 2.6.32-21-generic, using source directory
/lib/modules/2.6.32-21-generic/build. Please wait...

ERROR: Module build failed!
Please examine the log file "/tmp/hsfconfig-buildlog.txt" to determine why."


Dentro do Cd de instalação do modem havia um arquivo "Leia-me" alertando para a necessidade de rodar o "hsfconfig" no final, mas como sou iniciante não entendo bem o que significa. Acredito que foi por causa disso que ainda não consegui instalar o modem. Alguém poderia me orientar a resolver esse problema?

Com relação ao driver conexant o que sei sobre ele já falei aqui:

http://ubuntuforum-br.org/index.php/topic,52862.0.html

portanto leia todos os textos deste tópico e adapte a sua versão do Ubuntu, pois o texto se refere a outra versão do Ubuntu, mais antiga.

O que sei é que você tem de usar o driver conexant para a versão do seu kernel e ele pode ser baixado do site:

http://www.linuxant.com/drivers/hsf/full/downloads.php

Agora não é um driver livre, tem de pagar por uma licença.

Offline sandro.serra.ap

  • Usuário Ubuntu
  • *
  • Mensagens: 111
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1259 Online: 10 de Julho de 2010, 11:09 »
Olá a todos,

Não quero ser inconveniente mas já sendo, gostaria de saber se alguém já consegue acessar internet discada com o Fax Modem da Motorola(e como ?) no ubuntu 10.04 LTS, estou pensando adquirir um, pois o meu da conexant tá difícil. (Já pesquisei no fórum mas ninguem tem uma resposta se já conecta)

Se seu modem é o Motorola sm56 com ID 1057:3052, ele tem suporte no Ubuntu sim com o drive smartlink que uso nos meus pacotes aqui deste tópico (Tutorial para HSP56 MR driver Smartlink) é só procurar no primeiro texto deste tópico o link dos pacotes que faço para a versão do Ubuntu em uso, em 32bits, e se não me falha a memória já foi testado e aprovado com esse modem no Ubuntu 10.04 é só vc verificar nos posts anteriores.

Olá alarcon,

Na verdade ainda não comprei, estou pensando em comprar um que seja compatível com o Ubuntu 10.04. Por isso estou a procura de marca e modelo de um. Se não for pedir muito me indique um!