Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 1004526 vezes)

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1095 Online: 11 de Junho de 2009, 11:34 »


Fix tudo isso, mas continua a conectar e não navegar, a única coisa que fz éacessar o pidgin, e nada mais. É mesmo o fim.

Não creio que seja problema de portadora por que se fosse você nem conectava e vicê está afirmando que conecta e só navega pelo pidgin, então está parecendo problema típico de DNS (primário e secundário), o famoso conecta mas não navega.

O discador gnome-ppp está configurado para receber estes dados automaticamente do provedor, mas há casos que esses valores devem ser fornecidos manualmente.

Se você fez tudo que já falei e verificou o caso do verificar portadora que o RenatoMN comentou e não funcionou, parta para isso que falei do DNS. Procure informações sobre o openDNS (algo assim) para usar outros DNS que não o do provedor.

Que provedor vc usa?

Talvez ele seja um daqueles provedores chatos que tem algum tipo de autenticação que é fornecido pelos discadores que eles criam, limitando o uso assim a sistemas windows que são os que podem usar tal discadores.
« Última modificação: 11 de Junho de 2009, 16:33 por alarcon »

Offline andre_eofim

  • Usuário Ubuntu
  • *
  • Mensagens: 34
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1096 Online: 11 de Junho de 2009, 14:36 »


Fix tudo isso, mas continua a conectar e não navegar, a única coisa que fz éacessar o pidgin, e nada mais. É mesmo o fim.

Não creio que seja problema de portora por que se fosse você nem conectava e vicê está afirmando que conecta e só navega pelo pidgin, então está parecendo problema típico de DNS (primário e secundário), o famoso conecta mas não navega.

O discador gnome-ppp está configurado para receber estes dados automaticamente do provedor, mas há casos que esses valores devem ser fornecidos manualmente.

Não sei que tipo de provedor uso,
Se você fez tudo que já falei e verificou o caso do verificar portadora que o RenatoMN comentou e não funcionou, parta para isso que falei do DNS. Procure informações sobre o openDNS (algo assim) para usar outros DNS que não o do provedor.

Que provedor vc usa?

Talvez ele seja um daqueles provedores chatos que tem algum tipo de autenticação que é fornecido pelos discadores que eles criam, limitando o uso assim a sistemas windows que são os que podem usar tal discadores.


Minha internet é a discada da oi, um plano de 30 reais que me permite usar em qualquer hora do dia. Além disso a única coisa que sei é o número que uso para discar, 17003131 ou 17001000. Nunca tive que configurar algo com DNS antes.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1097 Online: 11 de Junho de 2009, 16:34 »

Minha internet é a discada da oi, um plano de 30 reais que me permite usar em qualquer hora do dia. Além disso a única coisa que sei é o número que uso para discar, 17003131 ou 17001000. Nunca tive que configurar algo com DNS antes.

Você está usando como nome de acesso do provedor o seu endereço de email da oi e como senha, a senha do email da oi?

E verificou isso:

se ao digitar ( no terminal):

sudo gedit /etc/ppp/pap-secrets

e depois:

sudo gedit /etc/ppp/chap-secrets

no final de cada um destes dois arquivos há uma informação do tipo:

"usuario@provedor.com.br" * "senha1234"

obviamente que os valores entre duas aspas " " devem ser seu nome de acesso do provedor de forma completa (com o @ e domínio) e sua senha de acesso do provedor, respectivamente e na formatação indicada acima.
« Última modificação: 11 de Junho de 2009, 16:36 por alarcon »

Offline andre_eofim

  • Usuário Ubuntu
  • *
  • Mensagens: 34
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1098 Online: 11 de Junho de 2009, 20:41 »

Minha internet é a discada da oi, um plano de 30 reais que me permite usar em qualquer hora do dia. Além disso a única coisa que sei é o número que uso para discar, 17003131 ou 17001000. Nunca tive que configurar algo com DNS antes.

Você está usando como nome de acesso do provedor o seu endereço de email da oi e como senha, a senha do email da oi?

E verificou isso:

se ao digitar ( no terminal):

Na verdade esse e-mail não existe, a única coisa que a oi da é o número para discar, o e-mail e a senha é apenas para completar os campos.

o que é esse 13 permissão negada?
Tentei o ubuntu 7.10, mas também não obtive sucesso. Percebi que em todos as vezes que instalei o pacote apareceu no terminal falando em 13 permissão negada, e depois erro 1, erro 2 , e assim por diante, mas mesmo assim a inatalação continua até o fim.

Sim, e estava tudo correto, o nome de usuario e a senha. Hoje tentei uma versão mais antiga, instalei o ubuntu 7.10, consegui conectar, navegar, mas não consigo instalar nada nele, e ele não atualiza para o 8.10 através do CD.

sudo gedit /etc/ppp/pap-secrets

e depois:

sudo gedit /etc/ppp/chap-secrets

no final de cada um destes dois arquivos há uma informação do tipo:

"usuario@provedor.com.br" * "senha1234"

obviamente que os valores entre duas aspas " " devem ser seu nome de acesso do provedor de forma completa (com o @ e domínio) e sua senha de acesso do provedor, respectivamente e na formatação indicada acima.
« Última modificação: 11 de Junho de 2009, 21:58 por andre_eofim »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1099 Online: 12 de Junho de 2009, 10:59 »
andre_eofim você usa algum firewall, proxy ou rede aí que esteja impedindo o tráfego?

Seu navegador não está em modo offline? ( já aconteceu problema deste tipo no fórum, portanto não se ofenda)

Com relação ao modem está tudo instalado.

No gnome-ppp nas suas Configurações > Aba Rede, altere de DNS automático, para DNS manual e forneça os dados do seu provedor. Aqui uso velox com provedor Oi e os DNS são:

Primário: 200.165.132.155
Secundário: 200.149.55.140

Aqui minha conexão está ok. Muitos dos problemas de conectar e não navegar é culpa do DNS.

Acho que também vc tem que fazer:

teclar Alt+F2 e na janela que aparecer digitar: gksu nautilus /etc/peers

forneça sua senha e quando abrir o nautilus veja os arquivos lá e comenta a linha:

usepeerdns

OBS: comentar é colocar o # no início da linha, ou seja, #usepeerdns

em cada um dos arquivos que vc encontrar nesta pasta. Acho que o que comanda a sua conexão discada deve ser um com nome wvdial, mas não tenho certeza.

Offline RenatoMN

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1100 Online: 14 de Junho de 2009, 19:07 »
alarcon,

terminei meu script:

http://ubuntuforum-pt.org/index.php/topic,52065.0.html

;)

Abraços,
Renato

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1101 Online: 15 de Junho de 2009, 16:39 »
Fiz 3 pequenas alterações no script que uso no pacote modem-arquivos-v30.tar.gz, mas elas não mudam em nada a forma com que já havia trabalhando com estes meus pacotes. A mudança foi feita mais para se evitar alguns equívocos que ando vendo na indicação e/ou uso dos meus pacotes.

Mudança 1:

Acrescentei um verificador de sudo, ou seja, o script verifica se ele está sendo executado como superusuário ou não. Isso para os mais desavisados que não lêem o que escrevo nos arquivos Leia-me e gui_instalação.pdf dos meus pacotes ou aqui no fórum. Não muda em nada a forma do script, mas aborta a execução se não for executado como root.

Mudança 2:

Vejo aqui muitos indicando meus pacotes para usuários que tem modems que são suportados por outro tipo de driver, por exemplo, Conexant e etc., aí para evitar isso de o usuário instalar o meu pacote e não conseguir configurar seu modem e desistir de tentar outras soluções, também coloquei um verificador de modem com um cadastro que tenho aqui, assim, caso o modem não esteja no cadastro, a execução do script também vai ser abortada indicando que o modem do usuário não é suportado pelo driver smartlink.

Mudança 3:

Outro erro muito comum é que apesar de colocar no primeiro texto deste tópico aqui, o link de cada pacote que faço para a respectiva versão do Ubuntu, de colocar em letras destacadas em vermelho do texto do referido link, bem no início informando qual versão do Ubuntu aquele pacote é adequado, mesmo assim ainda tem usuário usando o pacote de uma versão do Ubuntu em outra versão, então, mais uma vez coloquei um verificador de versão do Ubuntu, para o caso de se não for a adequada para aquele pacote, o script irá abortar a sua execução.


São pequenas mudanças que não afetam em nada o que já havia sendo feito, mas que poem ordem nas coisas para os mais desavisados. Como não tenho mais modem suportado pelo driver smartlink e nem conexão discada, fiz alguns pequenos testes e funcionou, mas caso haja algum erro neste novo script, por favor relatem aqui para futuras correções.

Para quem usa o Ubuntu 9.04 32bits e quer usar o pacote modem-arquivos-v30.tar.gz (já modificado) vejam este link:

http://ubuntuforum-br.org/index.php/topic,4204.msg287645.html#msg287645
« Última modificação: 16 de Junho de 2009, 17:12 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1102 Online: 16 de Junho de 2009, 10:18 »
Olá alarcom, pessoal do fórum como estão vocês ? :D
Bom,venho até aqui dar meu relato sobre a ativação do meu modem um  Motorola SM56 Data Fax Modem,o mesmo que consegui ativar nas outras versões do Ubuntu,mais ainda não consegui no Jaunty Jackalope 32bits,não tem erro nenhum o problema é que meu pc trava completamente (precisando ser resetado) quando esta descompactando o arquivo wvdial,após ter colocado o livecd,para ser adicionado ao Sources.list do apt­get.
Quero frisar que sempre consegui a ativação do modem nas antigas versões do Ubuntu,e estou com o mais novo pacote modem-arquivos-v30.tar.gz com as novas alterações, já verifiquei meu hardware e meu cd que pedi pelo ShipIt que chegou na última sexta-feira,e está ok.
Obrigado.

 

Como você acha que o travamento tem alguma coisa haver com o adicionar o liveCD no sources.list, então faça um teste.

Vá no menu Sistema > Administração > Gerenciador de Pacotes Synaptic, quando abrir o Synptic procure por cada um destes arquivos:

make
gcc
build-essential
linux-headers-2.6.28-11-generic
libasound2-dev


Se eles estiverem instalados, então ainda na janela do Synaptic vá no menu Configurações > Repositórios e na janela que aparecer, aba Programas do Ubuntu, lá na parte de baixo desmarque a opção que fala no CD-rom do Ubuntu para tirá-lo da lista de repositórios de onde baixar pacotes. Estou pedindo para fazer isso por que já que os arquivos necessários para compilação do driver smartlink (os relatados acima) já estão instalados, então vamos tirar o LiveCD da lista de repositórios e verificar se é ele que estaria causando o problema na hora de instalar o wvdial.

Agora é só executar o script de instalação do meu pacote modem-arquivos-v30.tar.gz, mas preste muita atenção na pergunta que é feita a você sobre Adicionar ou não o LiveCD na lista de repositórios que vc deve dizer NÃO ok.

Quando aparecer a janela com várias opções marcadas, desmarque as seguintes opções:

Make
Gcc
Build-Essential
Linux-Headers-2.6.28-11-generic
Libasound2


Que são exatamente os pacotes que já estão instalados e que portanto não há mais necessidade de instalar. Deixe todas as outras 5 restantes marcadas para  dar prosseguimento ao processo de ativação do seu modem.

Veja agora se a instalação segue sem problemas ou se quando chega novamente na instalação do wvdial ocorre outra vez o travamento.

Offline andre_eofim

  • Usuário Ubuntu
  • *
  • Mensagens: 34
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1103 Online: 17 de Junho de 2009, 20:29 »
andre_eofim você usa algum firewall, proxy ou rede aí que esteja impedindo o tráfego?

Seu navegador não está em modo offline? ( já aconteceu problema deste tipo no fórum, portanto não se ofenda)

Com relação ao modem está tudo instalado.

No gnome-ppp nas suas Configurações > Aba Rede, altere de DNS automático, para DNS manual e forneça os dados do seu provedor. Aqui uso velox com provedor Oi e os DNS são:

Primário: 200.165.132.155
Secundário: 200.149.55.140


Bem infelizmente não consegui conectar no 9.04 e nem no 8.10, mas consegui sem problemas no 8.04. Agora estou com um novo problema. Sempre que tento instalar algum programa, qualquer um, aparece uma menssagem dizendo que não posso instalar, devido a estrtura do meu computador(i386)
Aqui minha conexão está ok. Muitos dos problemas de conectar e não navegar é culpa do DNS.

Acho que também vc tem que fazer:

teclar Alt+F2 e na janela que aparecer digitar: gksu nautilus /etc/peers

forneça sua senha e quando abrir o nautilus veja os arquivos lá e comenta a linha:

usepeerdns

OBS: comentar é colocar o # no início da linha, ou seja, #usepeerdns

em cada um dos arquivos que vc encontrar nesta pasta. Acho que o que comanda a sua conexão discada deve ser um com nome wvdial, mas não tenho certeza.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1104 Online: 22 de Junho de 2009, 17:24 »

Alarcon,desculpas por não responder antes fiz o que você me pediu e continua travando,a seguir copiei as últimas linhas,após isso o pc trava e não volta ,ai é só resetando mesmo :( .

Desempacotando substituto do wvdial …

Configurando libxplc 0.13.13 (0.13.13-1build) …
Configurando libwvstreams 4.4base (4.4.1-0.2ubuntu2) …
Configurando libwvstreams 4.4extras (4.4.1-0.2ubuntu2) …
Configurando libuniconf 4.4 (4.4.1-0.2ubuntu2) …
Configurando o wvdial (1.60.1+ nmu2) ...

Obrigado.

Nem imagino o que seja o motivo do travamento na hora de instalar o wvdial, já que eu instalei ele aqui e suas dependências como um teste e foi tudo tranqüilo.

Como também vc falou que sua cópia do Ubuntu está ok, ou seja, o md5sum confere e a integridade do CD também, então não tenho mais idéia do que lhe passar para resolver o problema, mas quem sabe se você usar a instalação automática por este outro artigo do fórum possa lhe ser mais útil:

https://ubuntuforum-br.org/index.php/topic,52065.0.html

OBS: Já tentou estar no terminal dentro da pasta que contém os arquivos do meu pacote e executar assim:

sudo dpkg -i --force-all libxplc0.3.13_0.3.13-1build1_i386.deb
sudo dpkg -i --force-all libwvstreams4.4-base_4.4.1-0.2ubuntu2_i386.deb
sudo dpkg -i --force-all libwvstreams4.4-extras_4.4.1-0.2ubuntu2_i386.deb
sudo dpkg -i --force-all libuniconf4.4_4.4.1-0.2ubuntu2_i386.deb
sudo dpkg -i --force-all  wvdial_1.60.1+nmu2_i386.deb


para que force a instalação das dependências e o wvdial?

O comando:

sudo apt-get install -f

retorna o quê?

Offline João Gabriel

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1105 Online: 23 de Junho de 2009, 22:27 »
Alarcon,
tomei uma decisão radical  :P como já tinha feito uma vez no passado ,quando o meu Ubuntu só ficava com resolução 800x600 no monitor,fiz de tudo que você imaginar  >:( ,e mesmo assim não adiantou,porém quando meu Ubuntu já estava todo bagunçado comecei tudo do zero,refiz as partições ,reinstalei o sistema ,e por incrível que pareça voltou  a funcionar perfeitamente. A mesma decisão que tomei agora e mais uma vez deu certo ,já consegui ativar o meu modem outra vez  ;D ;D ;D.
Então ,as vezes o melhor é parar e começar tudo de novo,agradeço a atenção ;) e até a próxima .

Abraços .

Offline victorwpbastos

  • Usuário Ubuntu
  • *
  • Mensagens: 42
    • Ver perfil
    • Vitara Soft
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1106 Online: 07 de Julho de 2009, 14:00 »
A razão que trás aqui é simplesmente agradecer a esse grande cara chamado Alarcon. Tempos atrás precisei de sua ajuda e recebi muita atenção referente a ativação do meu modem. Obtive sucesso nas tentativas graças aos seus scripts...mas, lembrei que nunca tinha vindo aqui para agradecer pela ajuda. Então, antes tarde do que nunca, muito obrigado amigão!

Sucesso!
Apenas mais um aprendiz...

Offline cris.tom

  • Usuário Ubuntu
  • *
  • Mensagens: 97
  • Linux, uma questão de filosofia!
    • Ver perfil
    • Impressões Sem Pressões
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1107 Online: 13 de Julho de 2009, 22:01 »
 ;D Gostaria de deixar aqui registrado que hoje consegui conectar à internet usando o pacote do alarcon modem-arquivos-v30 no Ubuntu 9.04, meu modem é o Motorola SM56 Data Fax Modem (rev 04) e depois de muitas tentativas consegui essa façanha, claro que graças a esse bendito pacote do alarcon a quem sempre agradeço...Eu já não dependo mais da conexão discada, estou com Velox e o Ubuntu quase que automaticamente já se conecta à net, mas gosto de deixar a discada na manga, pois nunca sabemos o dia de amanhã e esse é um meio auxiliar...fica aqui meu testemunho de que com as dicas que o alarcon deixou nos tópicos acima é possível conectar desta forma.  ;)
« Última modificação: 14 de Julho de 2009, 09:47 por cris.tom »
Linux, uma questão de filosofia!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1108 Online: 14 de Julho de 2009, 09:46 »
Agradeço a todos pelos elogios, mas o principal de tudo é que assim recebo um retorno de vocês e fico sabendo que os pacotes que faço realmente estão funcionando, pois como vocês já devem saber eu não possuo mais conexão discada a mais de 2 anos e nem tenho modem, para conexão discada aqui, que tenha suporte pelo driver smartlink que me permita fazer alguns testes, então faço tudo mais pelo retorno que vou recebendo de quem pode testar por mim.

Abraço a todos. ;)

Offline rockmarcus

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1109 Online: 22 de Julho de 2009, 12:22 »
olá alrcon!
quero dizer q baixei seu pacote para instalação deste modem para meu linux 9.04 e segui todos os procedimentos. só q ao tentar instalar o pacote "slmodem" dentro desta pasta com o comando "make" acontece isto:
rockmarcus@rockmarcus-desktop:~/slmodem-2.9.11-20090222$ make
make -C modem all
make[1]: Entrando no diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make[1]: *** Sem regra para processar o alvo `all'.  Pare.
make[1]: Saindo do diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make: ** [modem] Erro 2
rockmarcus@rockmarcus-desktop:~/slmodem-2.9.11-20090222$ sudo make install
[sudo] password for rockmarcus:
make -C modem all
make[1]: Entrando no diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make[1]: *** Sem regra para processar o alvo `all'.  Pare.
make[1]: Saindo do diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make: ** [modem] Erro 2
rockmarcus@rockmarcus-desktop:~/slmodem-2.9.11-20090222$
obtive também esta resposta ao tentar outro procedimento:
rockmarcus@rockmarcus-desktop:~$ sudo ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
1000      3877  0.0  0.1   3352   812 pts/0    S+   22:05   0:00 grep slmodemd
espero q vc possa me ajudar.
desde já obrigado.