Autor Tópico: Latex  (Lida 5924 vezes)

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Latex
« Online: 10 de Setembro de 2008, 01:15 »
Olá a tod@s!
Uso o Ubuntu 8.04 e quero começar agora a trabalhar com o latex no Ubuntu. Já escrevi trabalhos em Latex no passado em Windows usando o Miktex e o WinEdt. Por isso, peguei no código desses trabalhos e tentei compilá-los no Ubuntu para ver o que dava. É claro que já instalei o os pacotes do tex-live, mas deparei-me com dois problemas:

1º problema:
Para escrever/exibir o código fonte o Kile ou o Texmaker não mostram os caracteres com acentos, isto é, abrindo directamente o ficheiro de código com esses programas, ele coloca no lugar desses caracteres um "?". Experimentei apagar alguns desses caracteres e voltar a escrevê-los e ambos os programas exibiram correctamente os caracteres com os acentos. No entanto, quando compilo estes caracteres nunca surgem para ambos os casos em ambos os programas.

O emacs22 exibe estes caracteres, no entanto não consigo compilar porque ele retorna-me um erro. E isto remete-me para o 2º problema.

2º problema:
Ao compilar o código fonte no terminal usando um simples editor de texto como o emacs22 recebo este erro:

LaTeX Warning: Citation `SmithBank1975' on page 5 undefined on input line 269.

Esta é uma das linhas de erro, porque em todos os sítios onde tenho citações ele menciona erro no terminal. Eu tenho um ficheiro à parte com a bibliografia. Tanto o ficheiro de código como o da bibliografia têm o mesmo nome à excepção da extensão: o do código fonte tem extensão .tex e o da bibliografia tem extensão .bbl .

Atenção que este trabalho que estou a tentar compilar aqui, compila perfeitamente no windows com o miktex, por isso, presumo que não seja erro do latex mas sim na configuração do Ubuntu: ou algum comando que falta ou algum pacote que seja necessário compilar em ambiente linux. Cito os pacotes que coloquei no início do meu código fonte:

\documentclass[a4paper,portuges,dvips]{article}
\usepackage[latin1]{inputenc}
\usepackage{babel}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage[dvips]{graphicx}
 
Alguém pode-me ajudar?
***
Ana Luísa

Offline anaves

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Latex
« Resposta #1 Online: 10 de Setembro de 2008, 18:45 »
Oi Ana Luísa, vamos ao primeiro problema...

vou te ajudar com o Kile,
1. Abra o Kile, clique em "Settings"
2. Em seguida, "Configure Kile"
3. Em seguida, "Editor"
4. Agora em "Open/Save"
5. Em "File Format" em "Encoding" marque a opção "Western European (iso 8859-1)"  clique em "OK" e experimente abrir algum arquivo .tex, há vários tópicos que explicam um pouco sobre tais codificações o Kile por default é configurado em "Utf8" se não me engano. Deixando em iso 8859-1 resolve este problema que vc teve.

Quanto ao segundo problema você cita desta forma?  \cite{SmithBank1975}

Tenta compilar no Kile pelo botão PDFLaTeX que gera o arquivo em .pdf diretamente. se não resolver escreva novamente...  se possível coloque um trecho do seu código.

Abraços,

Alysson

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Latex
« Resposta #2 Online: 11 de Setembro de 2008, 16:51 »
Olá!
De facto era esse o problema: a codificação do modo de texto! Em relação ao 2º problema também já o consegui resolver. Não estava a compilar todos os ficheiros necessários na mesma directoria. Que parvoíce... $)
Mas ainda tenho um outro problema. As imagens não estão a carregar não sei bem porquê. Eu uso o pacote \usepackage[dvips]{graphicx} e as imagens estão todas na mesma directoria de onde estou a compilar. O formato delas é .eps. No Windows compilavam bem!
***
Ana Luísa

Offline anaves

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Latex
« Resposta #3 Online: 11 de Setembro de 2008, 17:00 »
Oi Ana Luísa, como está compilando? gerando diretamente o arquivo em PDF? Se você passar por .tex -> dvi -> ps -> pdf provavelmente seu problema acaba mas essa não é a melhor alternativa.

Já tive um problema desses há um tempo atrás não lembro bem como resolvi, vou relembrar e volto a escrever.

Vou arriscar algo:  Você utiliza \usepackage[dvips]{graphicx}  observe dvips  então tente passar pelas etapas de compilação e conversão ( .tex -> dvi -> ps -> pdf ) enquanto tento lembrar como resolvi, ou até qua alguém nos fale.

Abraço,

Alysson

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Latex
« Resposta #4 Online: 17 de Setembro de 2008, 21:30 »
Olá!
Desculpa a demora na resposta. No entanto, já tenho a solução do meu problema: modifiquei o pacote

\usepackage[dvips]{graphicx}

para

\usepackage[pdftex]{color,graphicx}

Converti todas as imagens para .pdf e chamo-as no código logo neste formato, compilo (como disseste) com o modo pdflatex no kile e dá bem!

Obrigada pela ajuda.

Ana Luísa

Offline anaves

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Latex
« Resposta #5 Online: 17 de Setembro de 2008, 22:08 »
Está bem!

Estamos aqui para nos ajudar!!!

Abraço,