Autor Tópico: Plugin para GIMP - (UFRAW) - RESOLVIDO  (Lida 4418 vezes)

Offline nicoluis

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Online: 24 de Janeiro de 2006, 19:50 »
Olá.. venho há alguns dias tentando instalar o plugin UFRAW para tratar arquivos RAW no GIMP. Já obtive algum sucesso na hora de rodar o ./configure. Contudo ainda estou tendo problemas. Quando rodo o ./configure a primeira linha que aparece é:

"chmod: changing permissions of `conf16551.sh': Operation not permitted"

Depois ele passa tranquilamente por vários outros cheques e no final recebo:

"Adding pkgconfig/cppflags/ldflags for .
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.4) were not met:

Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix."

Ainda me considero um novato no linux. Como alterar o "PKG_CONFIG_PATH" e qual seria o diretório onde estaria o meu "GTK+"

Agradeço a atenção!!!!!!

Offline LNAS90

  • Usuário Ubuntu
  • *
  • Mensagens: 124
    • Ver perfil
    • http://linux-sem-misterio.blogspot.com/
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #1 Online: 24 de Janeiro de 2006, 20:08 »
tem certeza que vc tem o pacote gtk+-2.0 instalado
Meu blog (reativado a pouco tempo) http://linux-sem-misterio.blogspot.com/

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.285
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #2 Online: 24 de Janeiro de 2006, 20:14 »
sudo apt-get install libgtk2.0-dev

Offline nicoluis

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #3 Online: 24 de Janeiro de 2006, 22:27 »
Obrigado pela atenção. Ao tentar instalar o GTK recebo a mensagema abaixo. Estou usando o Ubuntu 5.10.

"Alguns pacotes não puderam ser instalados. Isso pode significar que
você solicitou uma situação impossível ou se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram tirados do Incoming.

Já que você solicitou uma única operação é bem provável que o pacote
esteja simplesmente não instalável e um relato de erro sobre esse
pacotes deve ser enviado.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
  libgtk2.0-dev: Depende: libglib2.0-dev (>= 2.7.1) mas não está instalável
                 Depende: libpango1.0-dev (>= 1.10.0-2) mas não está instalável
                 Depende: libatk1.0-dev (>= 1.6.1-2) mas não está instalável
                 Depende: libcairo2-dev mas não está instalável
                 Depende: libx11-dev mas não está instalável ou
                          xlibs-dev mas não está instalável
                 Depende: libxext-dev mas não está instalável ou
                          xlibs-dev mas não está instalável
                 Depende: libxinerama-dev mas não está instalável
                 Depende: libxi-dev mas não está instalável
                 Depende: libxrandr-dev mas não está instalável
                 Depende: libxcursor-dev mas não está instalável
                 Depende: libxfixes-dev mas não está instalável"

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.285
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #4 Online: 24 de Janeiro de 2006, 22:37 »
você habilitou os repositórios extras citados em diversas mensagens aqui no fórum universe por exemplo ?
executou um update sudo apt-get update para atualizar a base de dados do apt?

Offline nicoluis

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #5 Online: 24 de Janeiro de 2006, 22:46 »
irei checar os repositórios extras.... o update eu fiz....

Valeu

Offline casainho

  • Usuário Ubuntu
  • *
  • Mensagens: 175
    • Ver perfil
    • www.Casainho.net
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #6 Online: 25 de Janeiro de 2006, 07:39 »
Citação de: "nicoluis"
irei checar os repositórios extras.... o update eu fiz....

Valeu


É assim mesmo..!! Força nisso!!

Eu também uso o Gimp e ele é potente.. olha, eu já usei RAW no Gimp, e se não me falha a memória, instalei a cena para o RAW apartir do APT.. lembro-me que existem 2 conhecidos para o RAW.., o outro é o DCRAW, e o UFRAW, encontro ambos no APT!!


A minha máquina é lenta para gravar em RAW no cartão e as fotos ocupam muito, nos tipos de trabalhos que faço, o RAW não se justifica, mas é o ideal o RAW. Que tipo de trabalho fazes??
Minha página pessoal:
http://www.Casainho.net

Offline nicoluis

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #7 Online: 25 de Janeiro de 2006, 09:58 »
Raramente uso o RAW. Mas gostaria de ter o plugin pois estou aguardando um contato para fazer uma foto para um banner (não sei extamente o tamanho ainda). Ultimamente tenho feito muitas imagens de pizzas, sanduíches, grelhados, artigos de papelaria, etc.. etc... etc...

Abraços

Offline nicoluis

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #8 Online: 27 de Janeiro de 2006, 08:32 »
É assim que deve funcionar a internet... pena daqueles que ainda não descobriram nos fóruns a salvação para suas dúvidas!!!

Consegui instalar o UFRAW pelo apt-get:

sudo apt-get install gimp-ufraw

Porém esta versão (acho que era a 0.4.1) não reconhecia os arquivos gerados pela minha câmera digital. Ontem a noite, alterei o arquivo "source.list" de acordo com indicações aqui do fórum.

sudo apt-get update

E pronto.. alguns segundos depois as atualizações pipocaram na tela e dentre elas, havia uma para o UFRAW. Um clique aqui e outro ali.... abri o GIMP e abri meus arquivos RAW !!!!!

Agora é "correr para o abraço"!!!!

Offline casainho

  • Usuário Ubuntu
  • *
  • Mensagens: 175
    • Ver perfil
    • www.Casainho.net
Plugin para GIMP - (UFRAW) - RESOLVIDO
« Resposta #9 Online: 27 de Janeiro de 2006, 14:07 »
Final feliz :-)

O Gimp é potente!!



Citação de: "nicoluis"
É assim que deve funcionar a internet... pena daqueles que ainda não descobriram nos fóruns a salvação para suas dúvidas!!!

Consegui instalar o UFRAW pelo apt-get:

sudo apt-get install gimp-ufraw

Porém esta versão (acho que era a 0.4.1) não reconhecia os arquivos gerados pela minha câmera digital. Ontem a noite, alterei o arquivo "source.list" de acordo com indicações aqui do fórum.

sudo apt-get update

E pronto.. alguns segundos depois as atualizações pipocaram na tela e dentre elas, havia uma para o UFRAW. Um clique aqui e outro ali.... abri o GIMP e abri meus arquivos RAW !!!!!

Agora é "correr para o abraço"!!!!
Minha página pessoal:
http://www.Casainho.net