Autor Tópico: Depois de instalar o Ubuntu , HD nao da boot, nao acessa o GRUB  (Lida 5427 vezes)

Offline Mongo

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Depois de instalar o Ubuntu , HD nao da boot, nao acessa o GRUB
« Online: 14 de Fevereiro de 2008, 20:11 »
Amigos,

Sou novo na area  :)

Mas estou desesperado, formatei todo o disco e montei MANUALMENTE assim

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *        8355       19260    87592731+   7  HPFS/NTFS
/dev/hda2           10905       21692    86643904   83  Linux
/dev/hda3           13337       22178    71013683   82  Linux swap / Solaris
/dev/hda4           13823       28284   116157982+   7  HPFS/NTFS

Apos entrar algumas vezes normalmente nos 2 OS via GRUB, chega uma hora em que da pau, a BIOS nao consegue acessar o GRUB, jah formatei o disco todo e instalei os dois OS 4 vezes (XP primeiro e Ubuntu depois), agora estou realmente cansado e desanimado   :'(

Soh estou aqui agora pois tenho o Live CD e um roteador, por isso estou na Internet.

O que eu consegui descobrir eh que, ao reiniciar, a BIOS SE CONFUNDE com o HD, nao o identifica adequadamente, aparecem uns nomes estranhos no PRIMARY IDE MASTER, inclusive com o tamanho do HD errado, ai ou da erro, ou tela azul do XP, ou aparece uma mensagem dizendo que eu nao tenho OS.

Nao creio que o HD esteja com defeito pois se eu instalar apenas o XP, funciona bem. Para mim estah claro que a BIOS nao consegue enxergar o HD, nao acessa a GRUB. O pior eh que, sem entender nada de linhas de comando (soh agora aprendi o que eh sudo, sou virgem, calouro nisso, soh uso XP) fui tentar recuperar a GRUB com o Super Grub Disc e tudo o que eu consegui foi piorar tudo, acho que eu apaguei a GRUB, tentei alguns comandos que eu vi aqui no site mas sem sucesso.

Se eu usar 2 HD`s fisicos melhora (interrogacao)

Como dar boot nesse caso (interrogacao)

OK, vou ter que partir do zero pela quinta vez, mas quero fazer certo agora, a sequencia de definicao das particoes estah OK (interrogacao)

Devo definir as particoes em outra ordem (interrogacao)

Para mim, soh serve instalacao manual pois nao quero que o Install CD redimensione minhas particoes.

Obrigado, estou muito desanimado  :'(

Mongo

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Depois de instalar o Ubuntu , HD nao da boot, nao acessa o GRUB
« Resposta #1 Online: 14 de Fevereiro de 2008, 20:54 »
Vc montou o seu disco com qual programa?
O seu disco tem quantos GB?
Pelo que estou vendo só a swap tem 7 GB.
É isso?
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Mongo

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Depois de instalar o Ubuntu , HD nao da boot, nao acessa o GRUB
« Resposta #2 Online: 15 de Fevereiro de 2008, 08:46 »
Oi,

Sim, eu preferi montar a swap bem grande.

O meu HD tem 160 GB divididos assim: 20 GB para cada sistema operacional, 8 GB para a swap e o restante em uma unica partição NTFS, justamente para ser dividida pelos dois OS's.

Primeiro eu usei o CD do Windowspara criar a partição de 20 GB onde ele está instalado, todoo resto eu fiz com o CD do Ubuntu 7.10. A maior partição eu formatei, pelo Ubuntu, como FAT32, e depois usei o Windows para convertê-la em NTFS, já que o CD do Ubuntu não faz isto. Preferi passar para NTFS justamente para usar arquivos maiores que 2 GB.

O problema, como disse, é que até chega a funcionar por algumas vezes, consigo dar seguidos boots na máquina acessando a GRUB, mas depois de algum tempo, inferior a 12 horas, dá pau, a BIOS fala que eu não tenho OS's e identifica ERRADAMENTE o HD  colocado no primary IDE master.   :-[ :'( >:(

POR FAVOR, ME AJUDEM !

Abraço,

Mongo

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Depois de instalar o Ubuntu , HD nao da boot, nao acessa o GRUB
« Resposta #3 Online: 15 de Fevereiro de 2008, 10:58 »
Minha sugestão, já que tá tudo zebrado, é que vc faça o seguinte :

Divida o seu HD em :
1 partição NTFS primária para o XP  = 20 GB
1 partição NTFS primária comum aos 2 SOs = 110 GB
1 partição extendida com:
   1 Ext3 lógica para o Ubuntu = 29 GB
   1 swap = 1GB

ou ainda, incluir nessa extendida mais uma lógica, Ext3, de mais ou menos 9 GB (Ubuntu ficaria com 20 GB) para outras distros que vc queira experimentar.

Use um bom programa para fazer isso : Partition Magic ou gParted.
« Última modificação: 15 de Fevereiro de 2008, 12:50 por pintinho »
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Mongo

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Depois de instalar o Ubuntu , HD nao da boot, nao acessa o GRUB
« Resposta #4 Online: 15 de Fevereiro de 2008, 12:45 »
Pintinho,

Valeu, vou tentar...com o gparted eu posso já de cara formatar as minhas 4 partições. Até então, através do LiveCD eu colocava a partição maior em FAT32 para depois via Windows transformar em NTFS.

Chego a pensar que o problema possa ser este, mas assim eu só estou mexendo na área de dados, longe da MBR   ???

Eu acabei de baixar o Gparted live CD e vou tentar a noite,

Pedro Almeida,

Obrigado, tentei isto mas não consigo achar o grub, dá um erro estranho, acho que eu apaguei a grub usando o SGB  :P :-[ :-\ :'(

Eu tenho a certeza de que está tudo lá no HD, o problema é dar boot  ???...e identificar o porquê do problema estar se repetindo seguidamente  >:(

Outras opiniões são bem vindas !

Obrigado,

Abraço,

Mongo