Autor Tópico: Partição NTFS do hd externo não monta mais.... (Resolvido)  (Lida 8513 vezes)

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Partição NTFS do hd externo não monta mais.... (Resolvido)
« Online: 02 de Janeiro de 2008, 22:28 »
Senhores, estou com um problema daqueles. Eu tenho um hd externo SATA, e este estava sendo montado normalmente, porem não podia modificar, adicionar ou excluir arquivos nele, muito bem, verifiquei no forum e acabei achando o caminho das pedras, instalei o ntfs-3g e ntfs-config, até aí beleza, estava funcionando normalmente. Hoje fui plugar o meu hd externo e o gnome me dá a mensagem que não pode montar o mesmo. Desliguei o note, e de novo a mesma mensagem, fiz isso umas 10 vezes e nada. Desistalei o dito ntfs-3g e o ntfs-config, instalando logo após, e nada. Procurei que nem loco no forum e ninguem teve um problema parecido com o meu. Já verifiquei em Aplicativos/Ferramentas do sistema/Ferramenta de configuração NTFS e está habilitado a escrita para ntfs, mas o dito não monta a partição em /media/diskx, porem aparece o dispositivo em Locais/Computador. Alguem já passou por isso???

Agradeço a ajuda.

Renê
« Última modificação: 13 de Fevereiro de 2008, 14:59 por Rene_Mena »
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #1 Online: 02 de Janeiro de 2008, 23:57 »
Chegou a plugar o HD externo e rodar o aplicativo ntfs-config (se não me engano).

De qualquer forma um HD externo como NTFS não é a melhor pedida né, já que o sistema de arquivos é o mais complicado para ser acessível por todos os sistemas (até mesmo windows mais antigos). Porque não deixa ele como ext3?

[]'s

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #2 Online: 03 de Janeiro de 2008, 19:19 »
Chegou a plugar o HD externo e rodar o aplicativo ntfs-config (se não me engano).

De qualquer forma um HD externo como NTFS não é a melhor pedida né, já que o sistema de arquivos é o mais complicado para ser acessível por todos os sistemas (até mesmo windows mais antigos). Porque não deixa ele como ext3?

[]'s

Cristiano

Sim Cristiano, fiz de tudo cara e não rolou..... o engraçado é que esse HD é sata e pluga normalmente no rwindowns, e estava funcionando perfeitamente no ubuntu 7.04.... acredito eu que foi alguma atualização que fiz que parou de funcionar.... pois agora ele reconhece o hd externo e aparece em /locais/computador no menu grafico, porem não monta, nem como leitura..... bom, mas consegui rodar novamente na mão com os seguintes comandos.

user@ubuntu$ sudo -i
user@ubuntu# mkdir /media/disk
user@ubuntu# mount -t ntfs-3g /dev/sdb1 /media/disk -o force

porem, quando desligo o note ou ejeto o disposito ele vai perder o acesso, se eu quiser montar novamente vou ter que fazer na mão. Ah, mas posso utilizar o fstab.

user@ubuntu# vi /etc/fstab

/dev/sdb1 /media/disk ntfs-3g defaults,force 0 0

legal, fiz e na primeira reinicialização ele montou o dito hd, mas só como leitura, mesmo estando habilitado a escrita para partição ntfs no ntfs-3g.... a mensagem é de que não sou root.... aí vem a utilização do umask na fstab, bom preciso lembrar de como se faz atraves dos meus manuscritos, faz tempo que não uso linux..rs.... vou tentar e depois posto aqui.... mas ainda fica essa dúvida cruel, porque o dito ntfs-3g parou de montar meu hd externo??? ???

Grato pela ajuda até agora.

Renê
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #3 Online: 03 de Janeiro de 2008, 20:36 »
Tenta a linha do fstab assim:

Citar
/dev/sdb1     /media/disk     ntfs-3g     defaults,auto,user,umask=000,gid=46     0 0

Quem sabe não resolve.

[]'s

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #4 Online: 03 de Janeiro de 2008, 21:06 »
Tenta a linha do fstab assim:

Citar
/dev/sdb1     /media/disk     ntfs-3g     defaults,auto,user,umask=000,gid=46     0 0

Quem sabe não resolve.

[]'s

Cristiano

Ok, vou tentar e depois posto aqui se funcionou, mas ainda fica essa dúvida no ar, pq uma coisa que estava funcionando parou derrepente, será que foi alguma atualização???

Abraços e obrigado até aqui.


Renê
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #5 Online: 03 de Janeiro de 2008, 22:00 »
Buenas, tentei, e não funcionou, ele não reconheceu mais, aí eu adicionei na linha do options no fstab o force, e verifiquei que existe um arquivo chamado fstab.pre-ntfs-config e nele meu hd externo estava como hdb1 quando o certo é sdb1, alterei, na inicialização (pois só ela está fazendo o reconhecimento do hd externo) ele reconheceu porem não montou, a falha é porque no gnome eu sou user, e para montar preciso ser root, legal, fui e tentei alterar as permissões dos dir /media/disk e /dev/sdb1 (chmod 777), reiniciei novamente, ele reconheceu e montou, porem mudou o fstab para /dev/sdb1 /media/disk ntfs umask=222,utf8 0 0, ou seja, não tenho acesso a escrita na partição e não montou pelo ntfs-3g..... rsrsrs...... cara isso tá muito sinistro, nunca vi nada igual...rsrsrsr..... tenho que fazer isso com muita calma e pesquisando bastante, o negocio tá meio voodu...rsrsrsr.... mas valeu pela força.

Renê
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #6 Online: 05 de Janeiro de 2008, 13:01 »
Buenas, tentei, e não funcionou, ele não reconheceu mais, aí eu adicionei na linha do options no fstab o force, e verifiquei que existe um arquivo chamado fstab.pre-ntfs-config e nele meu hd externo estava como hdb1 quando o certo é sdb1, alterei, na inicialização (pois só ela está fazendo o reconhecimento do hd externo) ele reconheceu porem não montou, a falha é porque no gnome eu sou user, e para montar preciso ser root, legal, fui e tentei alterar as permissões dos dir /media/disk e /dev/sdb1 (chmod 777), reiniciei novamente, ele reconheceu e montou, porem mudou o fstab para /dev/sdb1 /media/disk ntfs umask=222,utf8 0 0, ou seja, não tenho acesso a escrita na partição e não montou pelo ntfs-3g..... rsrsrs...... cara isso tá muito sinistro, nunca vi nada igual...rsrsrsr..... tenho que fazer isso com muita calma e pesquisando bastante, o negocio tá meio voodu...rsrsrsr.... mas valeu pela força.

Renê

Muito bem senhoras e senhores, estou conseguindo fazer o dito funcionar, porem o único problema é que não consigo criar pastas no hd, mas consigo criar, alterar, mover e excluir arquivos, e pastas consigo mover para dentro ou fora do hd, alterar e excluir, estranho né...rsrsrsr..... joguei esta linha no meu fstab :

/dev/sdb1 /media/disk ntfs-3g auto,rw,exec,users,force,suid 0 2

Outra coisa estranha que tinha esquecido de mencionar foi que no meu menu.lst as entradas para subir outras distros no grub desapareceram. Tenho o slack e o fedora no note também e tinha essa referencia na inicialização destes, agora não mais...... o que parece é que alguns arquivos de sistema foram alterados para o default...... sinistro mesmo...rs..... se alguem já passou por isso poste aqui para podermos debater e talves chegar em um diagnóstico.

Grato.

Renê
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #7 Online: 05 de Janeiro de 2008, 13:32 »
Rene tudo bem?

Só uma coisa, sei que seu HD é externo é por isto não deve estar dando problemas, mas em outro tópico chegou-se a conclusão, junto com o André (pinduvoz), que partições NTFS não deveriam ser testadas pelo Linux no boot, então a sugestão é fazer uma alteração na sua nova linha do arquivo /etc/fstab (em negrito, abaixo):

Citar
/dev/sdb1 /media/disk ntfs-3g auto,rw,exec,users,force,suid 0 0

[]'s

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #8 Online: 05 de Janeiro de 2008, 14:42 »
Rene tudo bem?

Só uma coisa, sei que seu HD é externo é por isto não deve estar dando problemas, mas em outro tópico chegou-se a conclusão, junto com o André (pinduvoz), que partições NTFS não deveriam ser testadas pelo Linux no boot, então a sugestão é fazer uma alteração na sua nova linha do arquivo /etc/fstab (em negrito, abaixo):

Citar
/dev/sdb1 /media/disk ntfs-3g auto,rw,exec,users,force,suid 0 0

[]'s

Cristiano

Opa Cristiano, legal sua contribuição, vou alterar agora mesmo, muito obrigado.

Renê
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline Evaristo

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #9 Online: 09 de Janeiro de 2008, 16:04 »
Pessoal,

vou aproveitar o tópico. Quando mudei do windows pro linux, tinha 3 hd's e todos formatados com ntfs. Na instalação, deixei dois discos com o ntfs e coloquei o sistema em ext3. Busquei meus documentos em um outro hd que tinha ntfs e formatei como ext3, já estou então com dois hd's com ext3. No último, que era o maior, tinha, como tenho, todos meus arquivos de som, fotos e vídeo e ainda algumas iso. Pois bem, este último, ainda mantenho ele porque não tenho espaço prá jogar esses dados e formatá-lo e está problemático. Verifiquei com o gparted e é recomendado passar o chkdsk. Como fazer isso no linux? Tenho o LiveCD Parted Magic, que não consegui muita coisa, tenho LiveRescueCD, que tambe não consegui muita coisa. Pensei em instalar um windows no Virtualbox e de lá fazer isso. Será possível??

Abs.

Editando:

pensei em tirar o hd daqui e levar em alguma instalação windows e colocá-lo lá (é mão de obra mas na falta de outra solução).

Abs.
« Última modificação: 09 de Janeiro de 2008, 16:14 por Evaristo »

Offline prct

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu 8.04 LTS
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #10 Online: 12 de Janeiro de 2008, 09:16 »
No menu principal tens

- Ferramentas de Sistema - Ferramentas de Configuração NTFS

Basta activar a escrita para os discos internos e externos.
Asus T3 Intel 2Duo Core Quad 2.4, 2Gb Ram, 2x 160Gb HDD SataII, Asus EAH2600PRO 512Mb Ram

Offline Rene_Mena

  • Usuário Ubuntu
  • *
  • Mensagens: 39
  • Nous_Triplehandshake
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #11 Online: 12 de Fevereiro de 2008, 11:23 »
Gente, para ficar registrado aqui, eu desisti de tentar fazer funcionar o dito hd externo com o ntfs-3g no automatico, minha solução foi então criar um lançador no desktop com a seguinte instrução de shell:

sudo mount -t ntfs-3g /dev/sdb1 /home/nous/Desktop/HD_Externo -o force

Com isso consigo  montar normalmente meu hd externo ntfs com todos os recursos (rw), e nem precisei inserir a linha no fstab para carregar o mesmo, o reconhecimento é automático.

Abraços

Renê
"..........Algo só é impossível até que alguém duvide e acabe provando o contrário........."
Albert Eistein (1879-1955)  Lingua

Offline prct

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu 8.04 LTS
    • Ver perfil
Re: Partição NTFS do hd externo não monta mais....
« Resposta #12 Online: 12 de Fevereiro de 2008, 19:51 »
Boa. Coloca Como RESOLVIDO.
Asus T3 Intel 2Duo Core Quad 2.4, 2Gb Ram, 2x 160Gb HDD SataII, Asus EAH2600PRO 512Mb Ram