Enquete

Como cofigurar o meu teclado?

[Resolvido]teclado
1 (50%)
[Resolvido]teclado
0 (0%)
[Resolvido]teclado
0 (0%)
[Resolvido]teclado
0 (0%)
[Resolvido]teclado
1 (50%)

Votos Totais: 2

Autor Tópico: [Resolvido]Teclado  (Lida 4325 vezes)

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
[Resolvido]Teclado
« Online: 22 de Dezembro de 2007, 21:40 »
Ola!
Tenho o meu teclado todo desconfigurado!!! Nao sei o que se passou. Instalei alguns pacotes para o Advanced Desktop Effects settings >>>Compiz e depois disso o teclado ficou todo desconfigurado. Nao da acentos, substituindo os por outros caracteres< nao consigo colocar hifens, pontos de interrogacao, nem outros simbolos e em algumas teclas nao funciona o shift. Nao sei o que se passou. Tenho o ubuntu 7.10 e o meu teclado e o Highscreen. Experimentei desactivar as opcoes de efeitos do desktop mas continuou tudo na mesma.
Podem/me ajudar? (afinal o ? esta no lugar do underscore, q confusao!!!!)

Ana Luisa
« Última modificação: 27 de Dezembro de 2007, 02:00 por ana182 »

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Teclado
« Resposta #1 Online: 22 de Dezembro de 2007, 21:52 »
Primeiro digita aí:

Código: [Selecionar]
sudo gedit /etc/X11/xorg.conf
Se o teu teclado tem "Ç" provavelmente deverá estar assim:

Código: [Selecionar]
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection


Depois verifica em Sistema -> Preferencias -> Teclado -> Aba disposições  em "modelo de

teclado" escolher "Brazilian ABNT2"

Isso é o básico, se você tiver alguma configuração de teclado diferente posta aquí.

                                                                    Boa Sorte !
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Teclado
« Resposta #2 Online: 22 de Dezembro de 2007, 22:21 »
Continua tudo na mesma. :( Eu inicialmente tinha configurado o teclado para portugues portugal quando instalei de raiz o ubuntu, pq sou de Portugal. Mas de qualquer forma fiz as alteracoes que indicaste e nada...  :S

Ana Luisa

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Teclado
« Resposta #3 Online: 22 de Dezembro de 2007, 22:25 »
Você reiniciou a parte gráfica ou o computador ?
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Teclado
« Resposta #4 Online: 23 de Dezembro de 2007, 00:35 »
Sim e continua tudo igual. :(

Ana Luisa

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Teclado
« Resposta #5 Online: 23 de Dezembro de 2007, 00:37 »
Ah!, reiniciei o computador.

AnaLu

Offline mikefr

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: Teclado
« Resposta #6 Online: 24 de Dezembro de 2007, 11:15 »
Afinal, ficou resolvido ou nao ?

Offline ana182

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Teclado
« Resposta #7 Online: 26 de Dezembro de 2007, 23:14 »
Olá!
Desculpem a demora na resposta, mas o Natal tem destas coisas.
De facto na altura não resolvi o problema, no entanto já o resolvi agora após ter checkado outro computador com o Ubuntu e com o teclado configurado para Português(Portugal).
Eis a solução:
sudo gedit /etc/X11/xorg.conf
         no ficheiro gedit na seguinte secção ter como configuração:
           Section "InputDevice"
           Identifier    "Generic Keyboard"
           Driver        "kbd"
           Option        "CoreKeyboard"
           Option        "XkbRules"    "xorg"
           Option        "XkbModel"    "pc105"
           Option        "XkbLayout"    "pt"
           EndSection

          de seguida fazer: Sistema -> Preferências -> Teclado -> Disposições
                            Modelo do Teclado: Generic 105-key (Intl) PC
                            Em "Disposição", adicionar ou seleccionar "Portugal" por omissão

Tinha USA por omissão inicialmente. De facto, acho que ao instalar o compiz, isto deve ter-se desconfigurado de alguma forma, porque quando instalei o Ubuntu, seleccionei logo previamente o teclado Português. Não sei como é que isto se desconfigurou... De qualquer forma, obrigadão pela ajuda porque assim soube onde ir ver o problema.
Beijinhos,
Ana Luísa

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Teclado
« Resposta #8 Online: 27 de Dezembro de 2007, 01:09 »
Ana, se você puder alterar o título do tópico e adicionar "[Resolvido]" sem aspas, vai ser muito bom.

P.S.: É engraçado ver alguém mandando "beijinhos" aqui no Fórum. ;D