Autor Tópico: [RESOLVIDO]de em instalar os drivers da impressora HP  (Lida 5604 vezes)

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
[RESOLVIDO]de em instalar os drivers da impressora HP
« Online: 22 de Novembro de 2007, 12:45 »
  Boas, Eu resolvi dar uma nova vida a um portátil que arrumei à uns anos e para o trazer da reforma instalei o Xubuntu 7.10 e correu tudo bem, mas o problema é que não consigo instalar o HPlip e não consigo usar a minha impressora HP Deskjet 2187.
  Ao instalar usando o extractor dá-se um erro no momento de sacar as depêndências dá-me um código que é 108, já tentei instalar manualmente, mas ao sacar as dependências dá erro (não encontra o pacote desejado, mesmo já tendo activado todos os repositórios).
Alguém me pode ajudar?

O PC é um Tsunami Mover com:
Processador: Intel Celeron 1.7 GHz
RAM: 256 Mb
Disco Rígido:20 Gb
Placa Gráfica: Intel 32 MB
« Última modificação: 01 de Dezembro de 2007, 20:23 por masterkorp »

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #1 Online: 22 de Novembro de 2007, 20:39 »
Não é o mesmo modelo de impressora, mas acho que essa dica pode ajudar você também

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #2 Online: 23 de Novembro de 2007, 08:41 »
Não o meu problema é em conseguir instalar dependências do HPlip, a meio da instalação no momento de ir sacar as dependências ele dá-me um erro código 108. E ao usar o comando apt-get install com as dependências que diz no site do HPlip para o Ubuntu ele não encontra algumas e não consegue instalar, será por ser o Xubuntu? Já vi os repositórios e comparei com o Ubuntu e está tudo bem...

Por favor Ajuda

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #3 Online: 23 de Novembro de 2007, 17:19 »
Por favor preciso de ajuda urgentemente

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #4 Online: 23 de Novembro de 2007, 17:30 »
mais detalhes por favor....

quais as depências que ele não encontra?
você já tentou usar o aptitude

quanto mais detalhes mais fácil...

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #5 Online: 26 de Novembro de 2007, 07:01 »
Ao introduzir o seguinte comando:
Código: [Selecionar]
sudo apt-get install libcupsys2 libcupsys2-dev build-essential python-dev python-dev python gs-esp libusb-dev xsane libsane python-reportlab python-qt3 libsnmp9-dev openssl libjpeg62-dev libsane-dev libtool python-imaging
Ele não encontrea o pacote gs-esp e talvez não encontre, mas eu tenho os mesmo repositórios que no ubuntu e nada, se procurar por estes repositórios individualmente dá-me a mensagem:

Citação de: Mensagem
Resolva os seus problemas de dependências


Isto em muitos pacotes

boi

  • Visitante
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #6 Online: 26 de Novembro de 2007, 11:05 »
O gs-esp está no repositório universe. Revise a configuração dos repositórios, pois com certeza o universe não está ativado.
Também é melhor dar preferência aos pacotes instalados diretamente dos repositórios do Ubuntu. A menos que seja mesmo necessário instalar uma versão mais nova do hplip do que aquela que está nos repositórios, o melhor seria instalar com um "sudo apt-get install hplip". O hplip não precisa nem do repositório universe.

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #7 Online: 26 de Novembro de 2007, 19:46 »
Vou tentar depois digo algo...

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #8 Online: 26 de Novembro de 2007, 20:13 »
Já tentei,  já está instaladomas é uma versão muito antiga,onde eu só consigo imprimir e não a consigoconfigurar devidamente. Eu no meu PC de Mesa no Ubuntu tneho o mais recente comum painel de controlo próprio e queria ter o mesmo no portátil...

Ajuda por favor

boi

  • Visitante
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #9 Online: 26 de Novembro de 2007, 22:30 »
A versão 7.10 é a última do Ubuntu, que saiu há um mês. Não acredito que o hplip dela seja tão antigo assim. Já tentou dar um
Código: [Selecionar]
sudo hp-toolboxpelo terminal?

Mas se continuar insistindo em instalar a versão do site do hplip, cole aqui o conteúdo do seu arquivo /etc/apt/sources.list para que vejamos o que está errado nele.

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #10 Online: 27 de Novembro de 2007, 17:42 »
Por acaso não tinha experimentado isso... Falta o PyQT vamos ver como vai ficar depois de o instalar...

alarcon

  • Visitante
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #11 Online: 27 de Novembro de 2007, 17:47 »
Por acaso não tinha experimentado isso... Falta o PyQT vamos ver como vai ficar depois de o instalar...

Tem algum outro modelo de HP próximo ao seu que funciona com a sua impressora, pois não encontrei o seu modelo?

Pergunto isso por que tenho uma idéia de baixar o arquivo  .ppd da sua impressora ou uma próxima para ativar colocando este arquivo aqui: /etc/cups/ppd

e para baixar este arquivo .ppd você iria aqui:
http://www.linuxprinting.org/printer_list.cgi

e digitaria marca e modelo, mas não encontrei a sua.
« Última modificação: 27 de Novembro de 2007, 17:52 por alarcon »

Offline masterkorp

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #12 Online: 27 de Novembro de 2007, 19:21 »
Aqui vai o meu ficheiro dos repositórios:

Código: [Selecionar]
deb cdrom:[APTonCD for ubuntu feisty - i386 (2007-11-19 21:02) DVD1]/ /
deb cdrom:[Xubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/ gutsy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

# Line commented out by installer because it failed to verify:
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy main restricted
# Line commented out by installer because it failed to verify:
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# Line commented out by installer because it failed to verify:
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
# Line commented out by installer because it failed to verify:
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# Line commented out by installer because it failed to verify:
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy universe
# Line commented out by installer because it failed to verify:
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy universe
# Line commented out by installer because it failed to verify:
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy-updates universe
# Line commented out by installer because it failed to verify:
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# Line commented out by installer because it failed to verify:
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy multiverse
# Line commented out by installer because it failed to verify:
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy multiverse
# Line commented out by installer because it failed to verify:
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
# Line commented out by installer because it failed to verify:
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://pt.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
# deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu gutsy partner
deb-src http://archive.canonical.com/ubuntu gutsy partner

# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu gutsy-security universe
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
# Line commented out by installer because it failed to verify:
deb http://pt.archive.ubuntu.com/ubuntu/ gutsy main universe restricted multiverse
deb-src http://pt.archive.ubuntu.com/ubuntu/ gutsy main universe restricted multiverse #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb http://security.ubuntu.com/ubuntu/ gutsy-security universe main multiverse restricted
deb-src http://security.ubuntu.com/ubuntu/ gutsy-security universe main multiverse restricted


Quanto à tua ideia alarcon eu verifiquei no site do HPlip que havia suporte à minha impressora multifunções, mas em versões acima da 2.x.x.x e se não me engano a versão disponínel nos repositórios predefenidos do Xunbuntu 7.10 é a 1.6.x.x.x. Na realidade em consigo imprimir, mas só isso não consigo digitalizar...

Obrigado pela ajuda fornecida até agora, mas infelizmente preciso de mais....

PS: Ainda tenho aqui sceenshot dos repositórios configurados no Gestor de pacotes

« Última modificação: 27 de Novembro de 2007, 19:37 por masterkorp »

boi

  • Visitante
Re: Dificuldade em instalar os drivers da impressora HP
« Resposta #13 Online: 27 de Novembro de 2007, 23:42 »
masterkorp:

No site do hplip consta a HP2187 como suportada desde a versão 1.7.4. A versão do hplip no Gutsy é a 2.7.7. Portanto, deveria funcionar.
Os repositórios também estão configurados corretamente. Não deveria dar nenhum problema de dependências, a não ser que o repositório de Portugal esteja com problemas. Para verificar se o problema é esse seria fácil, só experimentar um repositório de outro país.
Em resumo, não sei mais o que dizer. Só se for mais um bug do Gutsy.