Autor Tópico: Procuro solução para OpenGL no Enemy Territory  (Lida 2702 vezes)

Offline fabiodsp

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
    • http://www.flickr.com/photos/fabio_dsp
Procuro solução para OpenGL no Enemy Territory
« Online: 30 de Dezembro de 2005, 22:27 »
Olá Pessoal,

Acabo de baixar e instalar o Enemy Territory, todavia, ao mandar rodar o jogo eis o q segue:

Citar

root@ibanez:/home/fabio/et# et
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/root/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

root@ibanez:/home/fabio/et#


Tenho os drivers da nvidia instalados do repositório do ubuntu, mas em relação ao OpenGL eu ñ sei como proceder para rodar meu jogo!

Aguardo respostas e futuros convites para uma boa disputa on-line!

Vlw!!!!

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Procuro solução para OpenGL no Enemy Territory
« Resposta #1 Online: 31 de Dezembro de 2005, 00:58 »
o que aparece ao executar glxinfo?
e quanto de FPS aparece quando você executa glxgears -printfps (aparece de 5 em 5 segundos)?

ah, na Section "Module" do /etc/X11/xorg.conf deve ter:
Código: [Selecionar]
Load "dri"
Load "glx"

entre outros, verifique isso :)

ah, qual placa de vídeo você usa? isso pode interferir...
o problema me parece ser relativo ao hardware e não ao jogo, portanto estou movendo de seção ;)
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)