Autor Tópico: Placa USB Wireless do notebook A530  (Lida 8828 vezes)

Offline alan_ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Placa USB Wireless do notebook A530
« Online: 25 de Dezembro de 2005, 13:28 »
ola todos.
Estou tentando configurar minha placa de rede USB do Notebook A530.
Apesar do Led estar sempre aceso, o que indica que alguma coisa deve estar funcionando, não consigo conectar, nem configurar o endereço da rede via pump.
Um ifconfig wlan0
retorna:

wlan0      Encapsulamento do Link: Ethernet  Endereço de HW 00:00:00:00:00:00
          BROADCAST MULTICAST  MTU:1500  Métrica:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

quando tento: pump -i wlan0
retorna:
Operation failed.

Listando os dispositivos usb com: lsusb
retorna:
Bus 004 Device 002: ID 124a:168b AirVast
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 0ea0:2168 Ours Technology, Inc. Transcend JetFlash 2.0 / Astone USB Drive
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Alguem poderia indicar qual o problema ? Porque não consigo usar o pump para pegar um endereço??
Agradeço desde já sua ajuda.
[]s
Alan Gustavo.

Darcamo

  • Visitante
Placa USB Wireless do notebook A530
« Resposta #1 Online: 25 de Dezembro de 2005, 14:46 »
O pump é para configurar a rede obtendo o endereço IP, Gateway, etc, mas a parte "wireless" tem que estar configurada e funcionando antes que vc possa usatr o pump.

Essa parte wireless corresponde a essid, ap, canal, criptografia, etc.
Tem certeza que ela está funcionando?
Posta o resultado do comando iwconfig para ver se está tudo ok.

Offline alan_ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Resultado do iwconfig
« Resposta #2 Online: 26 de Dezembro de 2005, 12:40 »
O resultado do iwconfig é:
lo        no wireless extensions.
eth0      no wireless extensions.
wlan0     no wireless extensions.
sit0      no wireless extensions.

Pesquisando na Internet encontrei uma lista de comandos. Criei um script bash.

#!/bin/sh
sudo wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
sudo wlanctl-ng wlan0 lnxreq_autojoin ssid="alan_michel" authtype=opensystem
sudo iwconfig
sudo dhclient wlan0

quando executo o script pela primeira vez acontece o seguinte:

message=lnxreq_ifstate
  ifstate=enable
  resultcode=implementation_failure
wlanctl-ng: No such device
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     no wireless extensions.

sit0      no wireless extensions.

Internet Systems Consortium DHCP Client V3.0.2
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
SIOCSIFFLAGS: No such device
SIOCSIFFLAGS: No such device
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:00:00:00:00:00
Sending on   LPF/wlan0/00:00:00:00:00:00
Sending on   Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
send_packet: Network is down
receive_packet failed on wlan0: Network is down
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 21
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
send_packet: Network is down
No DHCPOFFERS received.
Trying recorded lease 10.10.0.2
SIOCSIFFLAGS: No such device
connect: Network is unreachable
SIOCSIFFLAGS: No such device
No working leases in persistent database - sleeping.

Quando eu executo novamente o script a rede wireless funciona perfeitamente:
message=lnxreq_ifstate
  ifstate=enable
  resultcode=success
message=lnxreq_autojoin
  ssid='alan_michel'
  authtype=opensystem
  resultcode=success
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11-DS  ESSID:"alan_michel"  Nickname:"alan_michel"
          Mode:Managed  Frequency:2.432 GHz  Access Point: 00:0D:88:9A:8F:26
          Bit Rate:2 Mb/s   Tx-Power:2346 dBm
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=36/92  Signal level=-49 dBm  Noise level=-85 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

There is already a pid file /var/run/dhclient.pid with pid 7437
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.2
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/wlan0/00:0a:e9:01:ec:71
Sending on   LPF/wlan0/00:0a:e9:01:ec:71
Sending on   Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 10.10.0.254
bound to 10.10.0.2 -- renewal in 260911 seconds.

O fato é que não sei bem o  que estou fazendo. Segui o script e funcionou.
Gostaria de entender e deixar a rede funcionando assim que der o boot.
Você pode me ajudar ?
[]s
Alan Gustavo.