Autor Tópico: Ubuntuzilla - Usando sempre a última versão do Firefox  (Lida 83516 vezes)

Offline Alyscom

  • Usuário Ubuntu
  • *
  • Mensagens: 774
  • Apenas me dê o feijão!
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #75 Online: 10 de Janeiro de 2010, 23:18 »
Olá desculpa o desenterro, mas gosto dessa dica e resolvi postar aqui como usar o Ubuntuzilla no 9.10 kk!!! ;)

Adicionando o repositório.
echo -e "\ndeb http://switch.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt all main" | sudo tee -a /etc/apt/sources.list > /dev/null

echo -e "\ndeb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main" | sudo tee -a /etc/apt/sources.list > /dev/null
Importando a chave.
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C1289A29

Instalando.
sudo apt-get update
sudo apt-get install ubuntuzilla

No terminal:
ubuntuzilla.py

Obs: para selecionar o idioma português do Brasil o número é 55 e de portugal é 56.


[]'s


ALyscom
« Última modificação: 15 de MAR?O de 2010, 14:36 por Alyscom »
O álcool é o photoshop da vida real
 

Offline groove

  • Usuário Ubuntu
  • *
  • Mensagens: 469
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #76 Online: 25 de MAR?O de 2010, 19:25 »
Tentei instalar o ubuntuzilla de duas formas e deram errado:
1 - Baixei o pacote para versão 64bits, ao tentar executar existem algumas dependências que impedem a instalação, tentei procurar as mesmas no repositório porém não encontrei;
2 - Tentei adicionar o repositório conforme instruções do site http://sourceforge.net/apps/mediawiki/ubuntuzilla/index.php?title=Ubuntuzilla_Installer_Script e como o Alyscom falou, os dois dão erro quando dou um apt-update, "Falhou ao buscar http://switch.dl.sourceforge.net/project/ubuntuzilla/mozilla/apt/dists/all/Release  Unable to find expected entry  main/binary-amd64/Packages in Meta-index file (malformed Release file?)"
Ubuntu 18.04

Offline Hjik

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #77 Online: 08 de Novembro de 2010, 22:05 »
O link do tópico vai para uma página de Wiki e lá, aparentemente está no idioma inglês, alguém pode me dar uma luz ensinando como instalar o firefox da mozilla com o ubuntuzilla para mim poder usar o firefox sempre atualizado?.

Agraço desde já.
--
ps: Me perdoem pela "ressuscitação" deste tópico, mas estou mesmo precisando de ajuda.
« Última modificação: 08 de Novembro de 2010, 22:09 por Hjik »

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #78 Online: 10 de Novembro de 2010, 00:27 »
O ubuntuzilla.py não existe mais como script, mas existe como repositório.

Para o repo ubuntuzilla vc roda pelo terminal:

echo -e "\ndeb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main" | sudo
 tee -a /etc/apt/sources.list > /dev/null

Depois instala a chave:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C1289A29

Finalmente, atualiza o cache e instala os pacotes, já que o ubuntuzilla, repito, agora é um repositório de pacotes Mozilla:

sudo apt-get update

sudo apt-get install firefox-mozilla-build

sudo apt-get install thunderbird-mozilla-build

sudo apt-get install seamonkey-mozilla-build

:: Linux Registered User nº 439378 ::

Offline Hjik

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #79 Online: 10 de Novembro de 2010, 18:24 »
Fiz todo o processo, mas apareceu isso
Citar
E: Impossível achar pacote firefox-mozilla-build

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #80 Online: 12 de Novembro de 2010, 00:23 »
Poste o resultado de

cat /etc/apt/sources.list | grep ubuntuzilla
:: Linux Registered User nº 439378 ::

Offline Lady in Pijama

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #81 Online: 23 de Julho de 2011, 21:23 »
Consegui instalar o Ubuntuzilla 4.8.4 e, através dele, o Mozilla Firefox 5, e o Thunderbird 5, mas ambos em inglês, pois durante a instalação não tenho a opção de selecionar o idioma. Somente se quero instalar ou não. Segui todas as dicas daqui e do site oficial, inclusive desinstalando e reinstalando. Para o Firefox consegui tradução instalando pacote de idioma pt-BR e o add-on Locale Switcher. Ficou perfeito, como se o tivesse instalado originalmente em português. Mas para o Thunderbird nem o pacote nem o add-on são compatíveis, e este ficou em inglês. Então a pergunta é: a falta de opção para escolha de idioma no Ubuntuzilla é defeito desta versão, ou eu fiz algo errado? Alguém já testou esta versão do Ubuntuzilla? Uso o Linux Mint 10.
Resolvido também no Thunderbird: baixar o pt-BR.xpi em http://releases.mozillaonline.com/pub/mozilla.org/thunderbird/releases/latest/linux-i686/xpi/ e o complemento Quick Locale Switcher, selecionando o idioma do pacote baixado.
Muito obrigada pelas dicas tão detalhadas, pinduvoz!
« Última modificação: 23 de Julho de 2011, 23:44 por Lady in Pijama »

Offline marcosaulima

  • Usuário Ubuntu
  • *
  • Mensagens: 34
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #82 Online: 03 de Agosto de 2011, 16:21 »
Executei este comando
gksudo firefox

e não aparece a opção de "procurar por atualização"
o que devo fazer?

Offline simon_drummer

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #83 Online: 18 de Agosto de 2011, 14:35 »
Gente, ao tentar executar o no terminal tal atualização do FF apareceu o seguinte:

simon@simon-laptop:~$ ubuntuzilla.py -a install -p firefox

Welcome to the Ubuntuzilla Firefox script version 4.8.4

Ubuntuzilla is built only for Ubuntu Linux and other distributions derived from Ubuntu (such as Linux Mint, e.g.)

This script will now install the latest release of the official Mozilla build of Firefox on your Linux system. If you run into any problems using this script, or have feature requests, suggestions, or general comments, please visit our website at http://ubuntuzilla.sourceforge.net/

Retrieving the version of the latest release of Firefox from the Mozilla website...
Traceback (most recent call last):
  File "/usr/local/bin/ubuntuzilla.py", line 1331, in <module>
    bs.start()
  File "/usr/local/bin/ubuntuzilla.py", line 311, in start
    fi.start()
  File "/usr/local/bin/ubuntuzilla.py", line 354, in start
    self.install()
  File "/usr/local/bin/ubuntuzilla.py", line 764, in install
    self.getLatestVersion()
  File "/usr/local/bin/ubuntuzilla.py", line 956, in getLatestVersion
    self.releaseVersion = re.search(r'firefox\-(([0-9]+\.)+[0-9]+)',self.releaseVersion).group(1)
AttributeError: 'NoneType' object has no attribute 'group

Já tenho instalado o Ubuntuzilla normalmente, a instalação ocorreu normal e sem erros. Já tentei reinstalar varias vezes e nada
O que posso fazer agora pra tentar resolver tal problema???

Desde já agradeço a atenção de todos.   

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #84 Online: 09 de Setembro de 2011, 17:11 »
O Ubuntuzilla é do tempo em que não existiam os PPAs.

Atualmente, quem quer programas atualizados recorre aos PPAs.

Para o Firefox, por exemplo:

https://launchpad.net/~mozillateam/+archive/firefox-stable

Instale assim:

sudo add-apt-repository ppa:mozillateam/firefox-stable
sudo apt-get update
sudo apt-get dist-upgrade
« Última modificação: 09 de Setembro de 2011, 17:17 por pinduvoz »
:: Linux Registered User nº 439378 ::

Offline byrogerio

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #85 Online: 04 de Novembro de 2011, 18:50 »
O Ubuntuzilla é do tempo em que não existiam os PPAs.

Atualmente, quem quer programas atualizados recorre aos PPAs.

Para o Firefox, por exemplo:

https://launchpad.net/~mozillateam/+archive/firefox-stable

Instale assim:

sudo add-apt-repository ppa:mozillateam/firefox-stable
sudo apt-get update
sudo apt-get dist-upgrade


Ae era isso mesmo que eu nao conseguia fazer agora com essas dicas deu... obrigado abraço