Autor Tópico: Tutorial | vivo zap™ e vivo Flash™ no Ubuntu passo-a-passo  (Lida 99857 vezes)

Offline vampire_thunder

  • Usuário Ubuntu
  • *
  • Mensagens: 735
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #60 Online: 28 de Abril de 2008, 11:09 »

Muito obrigado pelo apoio vampire_thunder :)
E muito obrigado pela contribuição com os Links :)
Assim que eu obtiver uma resposta do diego_maciel se o tuto externo que passei de celular funfa ou não com, eu vou incluir o tuto de celular aqui também.
Cara, eu poderia incluir o seu tuto aqui no meu tópico e no meu Blog? O crédito do tuto do PDA vai ser seu obviamente. Eu queria deixar este tópico e o artigo no meu Blog o quanto mais abrangente possível :)


Sem problema nenhum!  :)

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #61 Online: 28 de Abril de 2008, 12:11 »

Muito obrigado pelo apoio vampire_thunder :)
E muito obrigado pela contribuição com os Links :)
Assim que eu obtiver uma resposta do diego_maciel se o tuto externo que passei de celular funfa ou não com, eu vou incluir o tuto de celular aqui também.
Cara, eu poderia incluir o seu tuto aqui no meu tópico e no meu Blog? O crédito do tuto do PDA vai ser seu obviamente. Eu queria deixar este tópico e o artigo no meu Blog o quanto mais abrangente possível :)


Sem problema nenhum!  :)

Obrigado :)
Eu tomei a liberdade de utilizar aquela imagen-link do Ubuntu do seu Blog, tudo bem? Eu criei um código HTML pra linkar ao Ubuntu BR Org
 
http://kernelscript.wordpress.com/2008/04/28/vivozap-do-moto-q%E2%84%A2-no-ubuntu/

Offline ThiagoBS

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #62 Online: 28 de Abril de 2008, 13:46 »
Olá para todos, boa tarde.

Eu também tenho um modem AIKO 76-E, como alguns daqui, também tive problemas ao utiliza-lo.

Usando as dicas que vi neste forum, cheguei a compilar até mesmo o airprime.c adicionando a descrição do modem.

Pra mim a conexão funciona (até agora testei as distros: CentOS 5, Big Linux 4.04 Beta3, Ubuntu 8.04, kubuntu 6.06 e Kurumin 7) apenas no Kurumin 7 consegui uma conexão sem quedas, porém com a chateação de ter de reconectar o hardware sempre que eu realizava uma desconexão. No CentOS consegui conectar mais fica instável depois de 5 minutos.

No Kurumin tanto o usbserial quanto o airprime (que pelo que pude entender até agora usa de alguma forma o usbserial, mesmo que ele não esteja relacionado no /etc/modules.conf) funcionaram e a conexão não ficou caindo, o meu problema real é a velocidade, muito lenta. Na área onde resido é rede 1X, mesmo no Windows fica lento, mas sexta-feira testei em uma área EVDO e mesmo usando o módulo airprime, alcancei somente 128kbps (fonte www.speedtest.net), ou seja a mesma velocidade da rede 1X, não foi nem 1/4 da velocidade apresentada em uma maquina Windows no mesmo local. Reclamei por 1 hora com a vivo e eles nada podem fazer, reclamei também com o pessoal da AIKO para ver se eles podem produzir um modulo ideal para esse hardware (estão para me dar resposta). Cheguei a tentar utilizar o programa ndiswrapper, que para que não conhece tem a fantástica capacidade de utilizar arquivos .inf e .sys de drives para placas de rede (principalmente wireless) de Windows, para gerar módulos que funcionam no Linux. Apesar do ndiswrapper ter informado que conseguiu instalar o driver corretamente e o do modulo ndiswrapper ter sido carregado com sucesso, ele não está conseguindo criar os dispositivos ttyUSB.

Alguém pode relatar uma experiência vivida com esse modem em velocidade EVDO? E se possível dizer o que fez para conseguir.


Abraços.

Thiago Santana

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #63 Online: 28 de Abril de 2008, 14:52 »
Olá ThiagoBS, seja bem vindo ao fórum :)
Sobre o problema para criar os ttyUSB, tente o seguinte pelo Terminal/Konsole, mas tome cuidado, pois pode te dar mais dor de cabeça, analise tudo, só depois faça, caso acredite que vá da certo:

Citar
sudo mknod /dev/ttyUSB0 c 1xxxx 0

sudo rmmod usbserial ; modprobe usbserial vendor=xxxx product=xxxx

sudo rm -rf /dev/ttyUSB0 c 1xxxx 0

sudo rm -rf usbserial ; modprobe usbserial vendor=xxxx product=xxxx

sudo mknod /dev/ttyUSB0 c 1xxxx 0

sudo rmmod usbserial ; modprobe usbserial

Substitua os xxxx pelo modelo da sua placa/modem, lembrando que em mknod /dev/ttyUSB0 c 1xxx 0 somente coloque os números, sem as letras.

E troque o usbserial por airprime em sudo rmmod usbserial ; modprobe usbserial caso o utilize, no caso, sem a necessidade de declarar o vendor nem product.

Veja um exemplo:

Citar
mknod /dev/ttyUSB0 c 1893 0

rmmod usbserial ; modprobe usbserial vendor=0xeab product=0xc893

rm -rf /dev/ttyUSB0 c 1893 0

rm -rf usbserial ; modprobe usbserial vendor=0xeab product=0xc893

mknod /dev/ttyUSB0 c 1893 0

rmmod usbserial ; modprobe usbserial
« Última modificação: 28 de Abril de 2008, 14:54 por kErNeL_sCrIpT »

Offline vampire_thunder

  • Usuário Ubuntu
  • *
  • Mensagens: 735
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #64 Online: 28 de Abril de 2008, 16:27 »

Muito obrigado pelo apoio vampire_thunder :)
E muito obrigado pela contribuição com os Links :)
Assim que eu obtiver uma resposta do diego_maciel se o tuto externo que passei de celular funfa ou não com, eu vou incluir o tuto de celular aqui também.
Cara, eu poderia incluir o seu tuto aqui no meu tópico e no meu Blog? O crédito do tuto do PDA vai ser seu obviamente. Eu queria deixar este tópico e o artigo no meu Blog o quanto mais abrangente possível :)


Sem problema nenhum!  :)

Obrigado :)
Eu tomei a liberdade de utilizar aquela imagen-link do Ubuntu do seu Blog, tudo bem? Eu criei um código HTML pra linkar ao Ubuntu BR Org
 
http://kernelscript.wordpress.com/2008/04/28/vivozap-do-moto-q%E2%84%A2-no-ubuntu/

Tudo bem, aquela imagem eu busquei no Google  ;D

Muito bom o seu blog, parabéns! Vou dar uma olhada mais com calma depois. Só vi a primeira página e gostei muito. ;)

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #65 Online: 28 de Abril de 2008, 17:17 »

Muito obrigado pelo apoio vampire_thunder :)
E muito obrigado pela contribuição com os Links :)
Assim que eu obtiver uma resposta do diego_maciel se o tuto externo que passei de celular funfa ou não com, eu vou incluir o tuto de celular aqui também.
Cara, eu poderia incluir o seu tuto aqui no meu tópico e no meu Blog? O crédito do tuto do PDA vai ser seu obviamente. Eu queria deixar este tópico e o artigo no meu Blog o quanto mais abrangente possível :)


Sem problema nenhum!  :)

Obrigado :)
Eu tomei a liberdade de utilizar aquela imagen-link do Ubuntu do seu Blog, tudo bem? Eu criei um código HTML pra linkar ao Ubuntu BR Org
 
http://kernelscript.wordpress.com/2008/04/28/vivozap-do-moto-q%E2%84%A2-no-ubuntu/

Tudo bem, aquela imagem eu busquei no Google  ;D

Muito bom o seu blog, parabéns! Vou dar uma olhada mais com calma depois. Só vi a primeira página e gostei muito. ;)

Muito obrigado :)
Também gostei muito do seu, qualquer coisa, se quiser, coloque o seu aqui:

http://ubuntuforum-br.org/index.php/topic,30895.msg182022.html#msg182022

Offline ThiagoBS

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #66 Online: 28 de Abril de 2008, 18:33 »
Olá ThiagoBS, seja bem vindo ao fórum :)
Sobre o problema para criar os ttyUSB, tente o seguinte pelo Terminal/Konsole, mas tome cuidado, pois pode te dar mais dor de cabeça, analise tudo, só depois faça, caso acredite que vá da certo:

Citar
sudo mknod /dev/ttyUSB0 c 1xxxx 0

sudo rmmod usbserial ; modprobe usbserial vendor=xxxx product=xxxx

sudo rm -rf /dev/ttyUSB0 c 1xxxx 0

sudo rm -rf usbserial ; modprobe usbserial vendor=xxxx product=xxxx

sudo mknod /dev/ttyUSB0 c 1xxxx 0

sudo rmmod usbserial ; modprobe usbserial

Substitua os xxxx pelo modelo da sua placa/modem, lembrando que em mknod /dev/ttyUSB0 c 1xxx 0 somente coloque os números, sem as letras.

E troque o usbserial por airprime em sudo rmmod usbserial ; modprobe usbserial caso o utilize, no caso, sem a necessidade de declarar o vendor nem product.

Veja um exemplo:

Citar
mknod /dev/ttyUSB0 c 1893 0

rmmod usbserial ; modprobe usbserial vendor=0xeab product=0xc893

rm -rf /dev/ttyUSB0 c 1893 0

rm -rf usbserial ; modprobe usbserial vendor=0xeab product=0xc893

mknod /dev/ttyUSB0 c 1893 0

rmmod usbserial ; modprobe usbserial

Olá kErNeL_sCrIpT, eu entendi, mas como eu disse, tudo o que você me explicou acima eu já havia feito através do que li aqui mesmo neste fórum. Os problemas que eu tive de não aparece o device /dev/ttyUSB0, 1 e 2 foi quando usei o modulo ndiswrapper (que eu instalei usando os próprios arquivos .inf e .sys do driver para Windows). Agora quando uso tanto o módulo usbserial quanto com airprime (recompilado com a descrição do meu AIKO), os dispositivos são criados sem problemas. Eu tentei o artifício da ndiswrapper no intuito de obter velocidade EVDO.

Bem minha pergunta inicial ainda está no ar.

Thiago Santana
« Última modificação: 28 de Abril de 2008, 18:37 por ThiagoBS »

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #67 Online: 28 de Abril de 2008, 19:16 »
Olá kErNeL_sCrIpT, eu entendi, mas como eu disse, tudo o que você me explicou acima eu já havia feito através do que li aqui mesmo neste fórum. Os problemas que eu tive de não aparece o device /dev/ttyUSB0, 1 e 2 foi quando usei o modulo ndiswrapper (que eu instalei usando os próprios arquivos .inf e .sys do driver para Windows). Agora quando uso tanto o módulo usbserial quanto com airprime (recompilado com a descrição do meu AIKO), os dispositivos são criados sem problemas. Eu tentei o artifício da ndiswrapper no intuito de obter velocidade EVDO.

Bem minha pergunta inicial ainda está no ar.

Thiago Santana

Ha, beleza então, é por que eu fiquei curioso com esse ndiswrapper e pensei que talvez funcionasse melhor do que o usbserial ou airprime.
Não sei como ajuda-lo com a velocidade (Acredito que já tenha tentado mudar a velocidade nas configs do KPPP [Onde você escolhe a velocidade de operação da linha]), mas desejo-lhe boa sorte.
« Última modificação: 28 de Abril de 2008, 19:18 por kErNeL_sCrIpT »

Offline dosv01

  • Usuário Ubuntu
  • *
  • Mensagens: 24
  • Ubuntu... beauty!
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #68 Online: 29 de Abril de 2008, 00:13 »
Oi gente, olha eu aqui denovo.

Antes de mais nada gostaria de mandar um abraço pro meu novo amigo kErNeL_sCrIpT (Vou lhe convidar pro meu casamento, pois voce é o cara - se eu tivesse "comprado" o suporte da Canonnical não teria sido tão bom)

Bom,

Este post não é tããão novo, mas é apenas para incrementar o post principal.
Instalei hj o Ubuntu 8.04, o Hardy Heron hoje e como tinha me batido para realizar a configuração do modem Yiso S893v, Vivo Flash, resolvi fazê-la diferente para "me bater" mais um pouco e aprender mais. Ao invés de instalar o kppp e suas libs, eu resolvi fazer o seguinte:

Digitei sudo lsusb para verificar se o modem estava constando na lista de dispositivos usb;

Entao eu  digitei:
sudo modprobe usbserial vendor=0xeab product=0xc893 para carregar o modulo do modem;
e sudo echo "usbserial vendor=0xeab product=0xc893"  /etc/modules para iniciar no boot. Todos os comandos devidamente "sudados" para que não haja erro. (cuidado iniciantes como eu, para nao usar o terminal como root de maneira equivocada).

Depois disso fui em Sistema -> Administração/ Rede e configurei uma conexao Ponto a Ponto colocando aquelas mesmas informações constantes neste belíssimo tutorial de kErNeL_sCrIpT (#777 - numero_do_tel@vivozap.com.br - etc)

E não é que funcionou? Já tinha visto isso em outros tópicos mas não tinha tentado ainda. Para aqueles que nao estão fazendo o kppp funcionar de jeito nenhum, segue aí uma dica. Espero que esteja ajudando o pessoal, por que sei como é chato nao conseguir conectar e sei como é bom seguir uma dica e conseguir! (como eu segui a dica aqui e consegui via kppp no Ubuntu 7.04 instalado anteriormente).

Update
Conforme solicitado por kErNeL_sCrIpT, segue thumbs do passo a passo para configurar o modem.
http://img512.imageshack.us/img512/5889/capturadatelajb9.gif
Abrimos as Configurações de Rede do Ubuntu

http://img516.imageshack.us/img516/5914/capturadatela2ha9.gif
Acessamos as propriedades da Conexão ponto a ponto e selecionamos a opção Habilitar esta Conexão, depois selecionamos Modem Serial (Acredito que já está selecionado, não lembro, depois colocamos o telefone (#777), o login (1111111111@vivozap.com.br) e senha (vivo).

http://img206.imageshack.us/img206/6497/capturadatela3xu6.gif
Na Aba Modems temos que escrever o caminho do modem (/dev/ttyUSB0) pois não tem como padrão, o resto deixa como está mesmo.

http://img228.imageshack.us/img228/5786/capturadatela4cj3.gif
E na última Aba, a aba Opções, marque os três checkboxes, pois por padrão eles ficam desmarcados.

Vale lembrar que algumas vezes eu não consegui conectar (mistéééŕio) e fui pelo kppp mesmo. Mas na maioria dos casos ele conecta sem você nem ver!


Um abraço a todos e até a próxima.


DoS

-----------------------------------------------
update (29/04 01:06)

To fazendo download do Skype a 70-100kbps. Deu a louca na vivo? Que é isso!? Até entao aqui era 1x rs
« Última modificação: 30 de Abril de 2008, 20:18 por dosv01 »
==========================
dosv01

"Ubuntu is a community developed, Linux-based operating system that is perfect for laptops, desktops and servers..."

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #69 Online: 29 de Abril de 2008, 17:14 »
Oi gente, olha eu aqui denovo.

Antes de mais nada gostaria de mandar um abraço pro meu novo amigo kErNeL_sCrIpT (Vou lhe convidar pro meu casamento, pois voce é o cara - se eu tivesse "comprado" o suporte da Canonnical não teria sido tão bom)

Bom,

Este post não é tããão novo, mas é apenas para incrementar o post principal.
Instalei hj o Ubuntu 8.04, o Hardy Heron hoje e como tinha me batido para realizar a configuração do modem Yiso S893v, Vivo Flash, resolvi fazê-la diferente para "me bater" mais um pouco e aprender mais. Ao invés de instalar o kppp e suas libs, eu resolvi fazer o seguinte:

Digitei sudo lsusb para verificar se o modem estava constando na lista de dispositivos usb;

Entao eu  digitei:
sudo modprobe usbserial vendor=0xeab product=0xc893 para carregar o modulo do modem;
e sudo echo "usbserial vendor=0xeab product=0xc893"  /etc/modules para iniciar no boot. Todos os comandos devidamente "sudados" para que não haja erro. (cuidado iniciantes como eu, para nao usar o terminal como root de maneira equivocada).

Depois disso fui em Sistema -> Administração/ Rede e configurei uma conexao Ponto a Ponto colocando aquelas mesmas informações constantes neste belíssimo tutorial de kErNeL_sCrIpT (#777 - numero_do_tel@vivozap.com.br - etc)

E não é que funcionou? Já tinha visto isso em outros tópicos mas não tinha tentado ainda. Para aqueles que nao estão fazendo o kppp funcionar de jeito nenhum, segue aí uma dica. Espero que esteja ajudando o pessoal, por que sei como é chato nao conseguir conectar e sei como é bom seguir uma dica e conseguir! (como eu segui a dica aqui e consegui via kppp no Ubuntu 7.04 instalado anteriormente).

Um abraço a todos e até a próxima.


DoS

-----------------------------------------------
update (29/04 01:06)

To fazendo download do Skype a 70-100kbps. Deu a louca na vivo? Que é isso!? Até entao aqui era 1x rs

Muito obrigado pelos elogios e pelo apoio dosv01! :D
Fico muito feliz em ajudar de alguma forma :)
E este tópico cada vez fica mais rico graças a pessoas, como você, que ajudam a entender e solucionar as dificuldades da nossa net, e também provendo tutoriais.
Aliás, gostaria de adicionar o seu à primeira mensagem deste tópico e ao meu Blog, posso? Te darei crédito obviamente, assim como outro usuário que também postou um tuto parecido com o seu aqui, como o seu é o segundo, vou postar a dica, já que acredito que pode ser a solução para muitas pessoas.
Eu gostaria muito que isso funcionasse comigo :(
Já tentei uma vez com o tuto que falei de outro colega daqui, mas sem resultados :(
Vou tentar assim que possível pelo LiveCD do meu Hardy para ver se vai, quem sabe eu fico livre, pela primeira vez, de aplicações KDE :D
« Última modificação: 29 de Abril de 2008, 17:18 por kErNeL_sCrIpT »

Offline dosv01

  • Usuário Ubuntu
  • *
  • Mensagens: 24
  • Ubuntu... beauty!
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #70 Online: 29 de Abril de 2008, 23:18 »
Claro que pode postar! Não precisa nem pedir, o que eu posto aqui é da comunidade, estou procurando resolver "problemas" como este a todo momento :)
Espero que como nós apareçam mais 10 milhões e assim possamos nos desvincular de vez do "janelas", já que ainda tenho uma versao instalado no meu pc por alguns motivos.

Abraço a todos


Ps.: Amanhã irei ceder mais uma cópia de um cd do ubuntu! Cativando usuarios!!!! :)

==========================
dosv01

"Ubuntu is a community developed, Linux-based operating system that is perfect for laptops, desktops and servers..."

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #71 Online: 30 de Abril de 2008, 11:40 »
Claro que pode postar! Não precisa nem pedir, o que eu posto aqui é da comunidade, estou procurando resolver "problemas" como este a todo momento :)
Espero que como nós apareçam mais 10 milhões e assim possamos nos desvincular de vez do "janelas", já que ainda tenho uma versao instalado no meu pc por alguns motivos.

Abraço a todos


Ps.: Amanhã irei ceder mais uma cópia de um cd do ubuntu! Cativando usuarios!!!! :)



Opa, valeu dosv01 :)
Mas cara, queria pedir um favor, será que tem como você fazer um passo-a-passo detalhado do que você fez com o Network Manager? Eu tentei mas não consegui como sempre, e talvez seja que deixei de fazer alguma coisa, queria muito que isso funcionasse :-\

Divulgar o Ubuntu é o que há :D

Abraço e até mais.

Offline dosv01

  • Usuário Ubuntu
  • *
  • Mensagens: 24
  • Ubuntu... beauty!
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #72 Online: 30 de Abril de 2008, 16:36 »
Pronto, Editei o Post, ta cheio de prints já, mas é tao fácil que acho que você não esqueceu de nada não, cara.


Abraços a todos
==========================
dosv01

"Ubuntu is a community developed, Linux-based operating system that is perfect for laptops, desktops and servers..."

kErNeL_sCrIpT

  • Visitante
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #73 Online: 30 de Abril de 2008, 16:50 »
Pronto, Editei o Post, ta cheio de prints já, mas é tao fácil que acho que você não esqueceu de nada não, cara.


Abraços a todos

Hmmm, é como eu pensei :-\
Fiz tudo certo, vou tentar mais algumas vezes. Ha, o Modem você teve que digitar /dev/ttyUSB0 ou reconheceu normal?
No mais, vou postar seu tudo assim que possível, independente de eu ter sucesso na conexão ou não, muito obrigado pela paciência e por me antender com a atualização no tudo :)

Abraço e até mais.

Offline dosv01

  • Usuário Ubuntu
  • *
  • Mensagens: 24
  • Ubuntu... beauty!
    • Ver perfil
Re: vivo zap™ e vivo Flash™ no Ubuntu
« Resposta #74 Online: 30 de Abril de 2008, 17:12 »
Tive que digitar mesmo, pois o caminho /dev/ttyUSB0 não consta na lista padrão (deve ser por que é um modem "novo", sem muita saída, que a vivo inventou pra gente :)
==========================
dosv01

"Ubuntu is a community developed, Linux-based operating system that is perfect for laptops, desktops and servers..."