Autor Tópico: Problemas com Mplayer + RealPlayer + Totem (rmvb ainda)  (Lida 12290 vezes)

Offline dgo08

  • Usuário Ubuntu
  • *
  • Mensagens: 112
    • Ver perfil
Problemas com Mplayer + RealPlayer + Totem (rmvb ainda)
« Online: 13 de MAR?O de 2007, 02:33 »
EDITADO
Voltei a ter problema com rmvb,pra não criar outro tópico usei esse mesmo,e não mudei o conteudo original para futuras consultas se necessário.
Quem ja leu esse primeiro conteúdo,favor ler a partir do meu 3º post nesse tópico onde falo do "novo problema".

----------------------------------------------------------------------------------------------

To com um problema muito chato aqui,estou tendo problema com quase todos meus vídeos  :(
Eu instalei o Edgy hoje,antes tudo funcionava com o Dapper,agora só consigo usar o Totem,e nem pra tudo ele serve,eu entrei no tópico "Multimedia no Edgy",e instalei todos codecs listados manualmente pelo apt-get.

Vou começar falando do MPlayer.
Ele simplesmente não funciona.Seja pra qualquer tipo de video,ainda não experimentei DVD,mas o erro que da é sempre esse indepentende do formato do arquivo:
Citar

Fatal Error!
Error Opening/Initializing the selected video_out (-vo) device.
[/b]
O Totem:
.avi e .mpg = Ele ta rodando perfeitamente
.rmvb = Ele só reproduz o áudio,nada de vídeo.
.mkv = ele reproduz imagem e audio,porém durante a reprodução o video da uns slows,e em seguida acelera para alcançar o time normal do video,com isso a reprodução varia entre o time normal,a hora do slow,e a acelerada para chegar ao time normal

O RealPlayer:
.rmvb = Esse só foi instalado pra rodar .rmvb,e nem pra isso ta prestando.Ele reproduz o som sem problema,mas o vídeo,ele fica dando uma pausa de pouco mais de um segundo e volta em seguida ao time normal do video,e enquanto o video fica dando essas travadas o audio rola normalmente sem interrupção,e embora tenham essas pausas quando o video volta ele volta no time certo do audio.
Ele faz parecido com o Totem com o .mkv,só que pior,o totem da um slow,e o RealPlayer para o vídeo.

Alguem tem alguma solução para esses problemas ???
Desse jeito eu to perdido,pq não vou conseguir assistir os animes e séries que pego,que atualmente é tudo .rmvb
No Dapper eu usava o MPlayer pra todos formatos de vídeo e DVD,se alguem souber resolver o problema que tenho com ele,acho que acabaria com todos,se bem que no Dapper eu não tinha esse problema com o RealPlayer tambem.
Obrigado.
« Última modificação: 18 de MAR?O de 2007, 01:44 por dgo08 »

Offline glaubergoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 511
  • Ubuntu User # 10537
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem +(rmvb,mkv) no Edgy
« Resposta #1 Online: 13 de MAR?O de 2007, 09:10 »
   Olá dgo08. Quanto ao problema do Mplayer, acho que já teve aqui um tópico falando sobre isso, mas no momento não consigo encontrar. Abre o Mplayer, clica com o botão direito nele e vai em Preferences, na aba Video, seleciona a opção xv X11/Xv. E na aba Codecs & Demuxer, acho que é uma boa selecionar tanto pra Audio quanto pra Video a opção FFmpeg, de repente pode testar isso também. Tenta e vê o que acontece!

Offline dgo08

  • Usuário Ubuntu
  • *
  • Mensagens: 112
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem +(rmvb,mkv) no Edgy
« Resposta #2 Online: 13 de MAR?O de 2007, 11:11 »
Obrigado  glaubergoncalves,os problemas acabaram!
Não imaginei que seria tão fácil,por sorte o MPlayer ta dando conta até de .rmvb,que é mais de 50% dos meus vídeos.
Flw

Offline glaubergoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 511
  • Ubuntu User # 10537
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem (RESOLVIDO)
« Resposta #3 Online: 13 de MAR?O de 2007, 22:02 »
   Legal que deu certo. Se tu quiser ampliar ainda mais a capacidade de reprodução de vídeo do Mplayer, também pode instalar via Synaptic o pacote w32codecs, que tem alguns formatos que não são suportados nativamente, é bem interessante. Por aqui, com todos os plugins que tenho instalados no Totem-gstreamer mais todos esses do Mplayer, é difícil eu bater com um vídeo que não consiga reproduzir!

Offline dgo08

  • Usuário Ubuntu
  • *
  • Mensagens: 112
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem (RESOLVIDO)
« Resposta #4 Online: 18 de MAR?O de 2007, 01:41 »
Pessoal,to tendo problema de novo aqui com rmvb  ::)
Quando disse que tava tudo funcionando,testei episódios de Bleach e da série Jericho em rmvb,funcionou perfeitamente,e ainda funcionam.Mas agora peguei um anime chamado Death Note,e quando vou iniciar o video da a mensagem Could not open/initialize audio device -> No Sound.
Eu tentei mudar os codecs lá como havia feito anteriormente,passei por todos e nenhum deu audio  >:( pensei até que o Real Audio codec fosse resolver,mas nada adiantou.
Eu pensei em abrir o RealPlayer e o MPlayer ao mesmo tempo,daí assitia com o MPlayer e o audio ficava pelo RealPlayer,só que ao abrir o video com o RealPlayer e depois abrir o MPlayer ele diz que não consegue carregar/iniciar o dispositivo de video,se abrir primeiro o MPlayer e depois o RealPlayer o real fica sem o audio também.
Tentar outros players também nem rola,o Totem diz que não consegue abrir,a droga do RealPlayer ta reproduzindo só o som agora e nada do video.
E eu já tenho instalado o w32codecs,instalei todos do tópico do sobre multimedia no Edgy daqui do forum.

Offline glaubergoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 511
  • Ubuntu User # 10537
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem (rmvb ainda)
« Resposta #5 Online: 18 de MAR?O de 2007, 02:10 »
   Bah, já tava saindo aqui quando vi o aviso da tua mensagem no meu email... ;D Admito que não tenho certeza do que pode ser isso, se for falta de codecs provavelmente vai ter que sair à cata dos que te faltam... mas se teu problema é só de som, quem sabe dá uma checada na aba de áudio nas preferências, vai testando os drivers que tem por ali pra ver se muda alguma coisa... outra possibilidade é que o Mplayer pode estar em "conflito" com outra aplicação que esteja usando o som... pode tentar fechar tudo e deixar só o Mplayer aberto pra ver se recupera o áudio, nesse caso é até bom reiniciar o sistema pra limpar com certeza qualquer aplicação que possa estar usando o áudio, daí é abrir o Mplayer por primeiro depois da reinicialização e ver o que acontece...

Offline glaubergoncalves

  • Usuário Ubuntu
  • *
  • Mensagens: 511
  • Ubuntu User # 10537
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem (rmvb ainda)
« Resposta #6 Online: 28 de MAR?O de 2007, 00:52 »
   dgo08, chegou a resolver o teu problema com os rmvb que postou por último? Li um tópico agora a pouco e lembrei na mesma hora deste aqui, então tô colocando o link, caso tu ainda tenha interesse é só conferir: http://ubuntuforum-pt.org/index.php?topic=17759.msg95941#msg95941

Offline Daniel Neves

  • Usuário Ubuntu
  • *
  • Mensagens: 116
  • hardy :)
    • Ver perfil
    • last.fm
Re: Problemas com Mplayer + RealPlayer + Totem (rmvb ainda)
« Resposta #7 Online: 28 de MAR?O de 2007, 01:15 »
« Última modificação: 05 de Maio de 2007, 14:38 por Daniel Neves »

Offline rapha

  • Usuário Ubuntu
  • *
  • Mensagens: 30
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem +(rmvb,mkv) no Edgy
« Resposta #8 Online: 17 de Maio de 2007, 17:35 »
   Olá dgo08. Quanto ao problema do Mplayer, acho que já teve aqui um tópico falando sobre isso, mas no momento não consigo encontrar. Abre o Mplayer, clica com o botão direito nele e vai em Preferences, na aba Video, seleciona a opção xv X11/Xv. E na aba Codecs & Demuxer, acho que é uma boa selecionar tanto pra Audio quanto pra Video a opção FFmpeg, de repente pode testar isso também. Tenta e vê o que acontece!

valeu mesmo.. era um sonho rodar rmvb no mplayer.. =)



Offline JPGA

  • Usuário Ubuntu
  • *
  • Mensagens: 79
    • Ver perfil
Re: Problemas com Mplayer + RealPlayer + Totem +(rmvb,mkv) no Edgy
« Resposta #9 Online: 27 de Julho de 2008, 22:28 »
CARAS,

Se alguém estiver com problema em executar rmvb, é só instalar o KMplayer...é batata. O engraçado é que o meu Mplayer não roda rmvb, no máximo rm e se eu renomear o arquivo ele não lê, mas seu executar o Kmplayer o Mplayer executa. Que coisa estranha?
J.P.G.A.