Autor Tópico: Ajuda para o novo Super Tux,ajudem o colega Don Raphael!Olhem a última resposata  (Lida 13949 vezes)

Offline Neynder

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Sempre dependemos de algo ou alguem para crescer
    • Ver perfil
Galera recorro ao forum mais uma vez. Eu instalei o Seper Tux conforme explicado pelo o site do ubuntugames, mas ta muito lento, não dá pra jogar, ta muito ruim.
Essa é minha primeiro experiência com jogos no linux, como posso concertar isso?
A configuração do meu pc é:
> Processador Semprom 2.4 +
> Placa de Vídeo GeForce FX 5200 com acelerador 3D de 128 de memória
> Memória Ram de 512
> Placa Mãe ASUS A7N8X-X

podem me ajudar? Estou usando o Ubuntu 6.10 (Edgy)
« Última modificação: 26 de Janeiro de 2007, 13:28 por Neynder »

Offline ppfb

  • Usuário Ubuntu
  • *
  • Mensagens: 337
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #1 Online: 24 de Janeiro de 2007, 02:32 »
Poste para agente seu xorg.conf (o endereço é /etc/X11/xorg.conf) e, dê um
Citar
glxinfo | grep rendering
, verifique se você está com direct rendering "yes" ou "no".

Talvez você não esteja com o driver da nvidia instalado na sua máquina e o genérico não está suprindo suas necessidades.

Manda ai que agente vê o resultado, se for isso é facil de resolver. Se não for agente da uma olhada no que é.

Abraços

Offline Neynder

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Sempre dependemos de algo ou alguem para crescer
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #2 Online: 24 de Janeiro de 2007, 09:27 »
Kra eu agora estou no trabalho, mais tarde vou pra casa, lá por volta das 17:30, aí eu vou postar o arquivo! Como eu sei se o meu drive da placa de vidio estar instalada ou não?
Obrigado pela a atenção e vou precisar de muita ajuda.

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #3 Online: 24 de Janeiro de 2007, 09:35 »
Citar
Kra eu agora estou no trabalho, mais tarde vou pra casa, lá por volta das 17:30, aí eu vou postar o arquivo! Como eu sei se o meu drive da placa de vidio estar instalada ou não?
Por defeito o Ubuntu instala um driver que não suporta aceleração gráfico, ou seja, certamente o seu problema é a falta do driver da NVidia.
Pode ler como instalar o driver NVidia em:
http://ubuntuguide.org/wiki/Ubuntu_dapper_pt#Como_instalar_o_programa_de_controlo_gr.C3.A1fico_.28Driver_Nvidia.29.3F
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Offline Neynder

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Sempre dependemos de algo ou alguem para crescer
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #4 Online: 24 de Janeiro de 2007, 19:36 »
E ae galera!
Olha eu fiz os comandos solicita lá do link que o Lamengo postou. Quando eu fiz o seguinte comando
Código: [Selecionar]
sudo apt-get install nvidia-glx nvidia-kernel-commonocorreu tudo certo, mas quando eu realizei:
Código: [Selecionar]
sudo nvidia-glx-config enableapresentou o seguinte erro:
Citar
neylor@neylor:/etc/X11$ sudo nvidia-glx-config enable
Error: unable to load nvidia kernel driver! Be sure to have installed
the nvidia driver for your running kernel.

O que eu devo fazer, ah! O xorg.conf que estar no meu Ubuntu 6.10 é esse:
Citar
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   FontPath   "/usr/share/fonts/X11/misc"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV34 [GeForce FX 5200]"
   Driver      "nv"
   BusID      "PCI:2:0:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-51
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV34 [GeForce FX 5200]"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Ah! Fora que o super tux nem abre agora.

e ae galera o que faço? e por favor me expliquem para que eu aprenda.
Muito Grato!
« Última modificação: 24 de Janeiro de 2007, 19:40 por Neynder »

Offline ppfb

  • Usuário Ubuntu
  • *
  • Mensagens: 337
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #5 Online: 25 de Janeiro de 2007, 01:08 »
Citar
Driver      "nv"

seu driver é o genérico......

use o seguinte comando:

Citar
nvidia-xconfig

e se não me engano funcionará. verifique depois se seu driver mudou de nv para nvidia.

Não se esqueça de fazer um backup do seu xorg.conf. se seu X não abrir mais, copie o backup de volta para o normal e depois poste aqui para ajudarmos

abraço

Offline Neynder

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Sempre dependemos de algo ou alguem para crescer
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #6 Online: 26 de Janeiro de 2007, 00:14 »
Valeu galera! RESOLVIDO!

Offline ppfb

  • Usuário Ubuntu
  • *
  • Mensagens: 337
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #7 Online: 26 de Janeiro de 2007, 01:42 »
que bom

agora coloque do lado do assunto do tópico [resolvido] =)

abraços

Offline Don Raphael

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Super Tux muito lento, não dá para jogar, me ajudem por favor!
« Resposta #8 Online: 26 de Janeiro de 2007, 12:43 »
Vou aproveitar o embalo é fazer um questionamento,
Estou jogando o Supertx, esse novo que saiu a pouco tempo.
E estou no segundo mundo(mundo da floresta), fiz quase todas as fases é gostaria de saber como que vai para a ultima fase...
essa ultima fase tá numa ilha só que eu não sei chegar lá, alguem pode me dar uma luz?

Valeu pela edição no título do tópico.
Agora é só aguardar, mas eu acho que vai demorar.
« Última modificação: 26 de Janeiro de 2007, 18:07 por Don Raphael »
"Quanto mais aumenta nosso conhecimento, mais evidente fica nossa ignorância."
(John Kennedy)
 "Ninguém é tão grande que não possa aprender, nem tão pequeno que não possa ensinar."
"O talento educa-se na calma, o caráter no túmulo da vida."(Göethe)

Offline jaypee

  • Usuário Ubuntu
  • *
  • Mensagens: 121
    • Ver perfil
    • Meu Site
Re: Ajuda para o novo Super Tux,ajudem o colega Don Raphael!Olhem a última respo
« Resposta #9 Online: 01 de Fevereiro de 2007, 15:11 »
i Cara,eu to no mundo 2 tambem,quando eu chegar nessa faze que nao dar para chegar (se eu conseguir chegar) eu te digo  ;)

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
Re: Ajuda para o novo Super Tux,ajudem o colega Don Raphael!Olhem a última respo
« Resposta #10 Online: 02 de Fevereiro de 2007, 04:27 »
Cara, eu também pastei pra achar o caminho... rs. Ta meio escondido!

Saca só... tu tem de ir nessa fase aqui:


Daí, aperta pra esquerda e você será teleportado até a última fase! Olha ai ela:


Abraços!

Offline Don Raphael

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Ajuda para o novo Super Tux,ajudem o colega Don Raphael!Olhem a última respo
« Resposta #11 Online: 02 de Fevereiro de 2007, 11:48 »
Cara, eu também pastei pra achar o caminho... rs. Ta meio escondido!

Saca só... tu tem de ir nessa fase aqui:


Daí, aperta pra esquerda e você será teleportado até a última fase! Olha ai ela:


Abraços!
A ta beleza já achei, Obrigado cara.
Tem mais alguma fase depois dessa?
Aliais que fase hardcore eim.. muito difícil.
Esse negócio de ficar transportando luz é muito difícil.
Pode colocar resolvido ae no tópico, já consegui o que queria.
Passei a fase, realmente só tem mais essa fase.
tô só esperando a atualização do jogo agora.
Obrigado a todos.
« Última modificação: 02 de Fevereiro de 2007, 21:17 por Don Raphael »
"Quanto mais aumenta nosso conhecimento, mais evidente fica nossa ignorância."
(John Kennedy)
 "Ninguém é tão grande que não possa aprender, nem tão pequeno que não possa ensinar."
"O talento educa-se na calma, o caráter no túmulo da vida."(Göethe)