Autor Tópico: Programa temperamental, como assim?  (Lida 383 vezes)

Offline wguedes

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Programa temperamental, como assim?
« Online: 05 de MAR?O de 2022, 11:11 »
Adquiri um ACER NITRO 5 AN515-44-R4C8, pois já não aguentava mais aquele ASUS 32 bits. Ocorre que meu LIBRECAD, que lá rodava aos trancos e barrancos, ficou lá e continua querendo rodar. E eu que não tenho coragem?
Pois o fato é que não consigo instalar o tal Librecad no Acer, que já veio com SO Endless e responde sempre a mesma coisa, para qualquer instalação tentada, após a irredutibilidade do DPKG: "Use as opções da Central de Aplicativos.". NÃO! Já tenho muita coisa salva no Librecad e no Blender, das quais não posso abrir mão: fazer tudo, de novo, é impraticável!
Vejam:

@endless:~$ sudo apt-get install librecad

Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
The following additional packages will be installed:
libdouble-conversion3 libmd4c0 libmuparser2v5 libpcre2-16-0 libqt5core5a
libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5 libqt5svg5
libqt5widgets5 librecad-data libxcb-icccm4 libxcb-image0 libxcb-keysyms1
libxcb-render-util0 libxcb-shape0 libxcb-xinerama0 libxcb-xinput0
qt5-gtk-platformtheme qttranslations5-l10n
Pacotes sugeridos:
qt5-image-formats-plugins qtwayland5
Os NOVOS pacotes a seguir serão instalados:
libdouble-conversion3 libmd4c0 libmuparser2v5 libpcre2-16-0 libqt5core5a
libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5 libqt5svg5
libqt5widgets5 librecad librecad-data libxcb-icccm4 libxcb-image0
libxcb-keysyms1 libxcb-render-util0 libxcb-shape0 libxcb-xinerama0
libxcb-xinput0 qt5-gtk-platformtheme qttranslations5-l10n
0 pacotes atualizados, 22 pacotes novos instalados, 0 a serem removidos e 94 não atualizados.
É preciso baixar 0 B/22,6 MB de arquivos.
Depois desta operação, 161 MB adicionais de espaço em disco serão usados.
W: Não usando travamento para arquivo de trava somente leitura /var/lib/dpkg/lock-frontend
W: Não usando travamento para arquivo de trava somente leitura /var/lib/dpkg/lock
Você quer continuar? [S/n] s
dpkg: erro: não foi possível aceder ao directório /var/lib/dpkg da base de dados do dpkg: Sistema de arquivos somente para leitura
E: Sub-process /usr/bin/dpkg returned an error code (2)

A questão é: há a possibilidade de fazer o dpkg ceder aos meus anseios (me deixar instalar o que eu quiser - que seja compatível). No Mundo Livre LINUX, não cabe tamanha ditadura. No Ubuntu eu podia fazer o que quisesse, sem nem sacar muito de comandos. Agora o SO não me deixa instalar nada e não consigo erradicá-lo. Vou acabar formatando.

Agradeço qualquer força que me puderem dar.

Guedes

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.186
  • O negócio não tem alma
    • Ver perfil
Re:Programa temperamental, como assim?
« Resposta #1 Online: 13 de MAR?O de 2022, 18:23 »
Boa tarde

Então... vou aceitar que o Endless é ao menos parcialmente derivado do Ubuntu e não vou trancar a postagem.

Me elucide uma coisa... você quer instalar softwares no Endless usando apt-get, é isso mesmo?

Pelo que eu saiba o Endless só aceita Flatpak.

Logo, se pretende usar versões empacotadas em .deb, não vai rolar, até onde eu sei. Não sei se agora já está rolando diferente.
Me perdoe se eu estiver errado e já tiverem mudado isso no Endless, mas creio que não mudou.

Recomendo que use Ubuntu, ou a distribuição derivada do Debian que mais gostar se pretende usar empacotamento normal de debians em geral
Debian 11 Bullseye KDE + Kernel Liquorix