Autor Tópico: Erro na instalação do JAVA [Resolvido]  (Lida 713 vezes)

Offline paulorltenorio

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Erro na instalação do JAVA [Resolvido]
« Online: 22 de Dezembro de 2020, 14:30 »
Instalei o JAVA 11 no meu Ubuntu 20.04 LTS, usando:

$ sudo apt install openjdk-11-jre-headless

Pois precisp para usar o GEPHI, pois estou estudando pós graduação em Análise de Dados. Mas não consegui abrir o GEPHI, depois vi no forum que o GEPHI não estava abrindo em versões superiores ao JAVA 8.

Como diz em https://github.com/gephi/gephi/issues/1962, "Please make sure to run Gephi with Java 8. Newer versions are not supported yet."

Então instalei o JAVA 8, usando:

$ sudo apt install openjdk-8-jre-headless

Mas mesmo assim não abriu. Então removi tudo que havia em /usr/lib/jvm, usando:

$ sudo rm -r

Removi um por um, o que havia na pasta jvm, usando o comando acima, e depois instalei novamente o JAVA 8.

Mesmo contendo o java-8-openjdk-amd64 em /usr/lib/jvm, quando faço no terminal:

$ java -version

Diz: Comando 'java' não encontrado...

E com isto quando faço:

$ ./Downloads/gephi-0.9.2-linux/gephi-0.9.2/bin/gephi

Aparece o seguinte:

Cannot find java. Please use the --jdkhome switch.


Alguém pode me ajudar?
« Última modificação: 08 de Janeiro de 2021, 21:27 por paulorltenorio »

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
    • CHANGAN Auto
Re:Erro na instalação do JAVA
« Resposta #1 Online: 22 de Dezembro de 2020, 18:16 »
Por favor leia este comentário e os seguintes: https://github.com/gephi/gephi/issues/1962#issuecomment-539982080
Leia também https://askubuntu.com/questions/1133216/downgrading-java-11-to-java-8 antes de fazer mais asneira. Não tem que desinstalar nada!

Offline paulorltenorio

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #2 Online: 23 de Dezembro de 2020, 13:36 »
Sim, entendi o que deveria fazer. Mas como solucionar o que fiz?

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 617
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #3 Online: 24 de Dezembro de 2020, 13:57 »
Acho que você precisa do openjdk-8-jdk para rodar esse gephi.

Se você rodar um sudo apt install openjdk-8-jdk o que acontece?

Você também disse que instalou o pacote openjdk-11-jre-headless e depois removeu a pasta dele em /usr/lib/jvm, isso mesmo? O melhor é removê-lo usando um sudo apt remove openjdk-11-jre-headless.

Offline paulorltenorio

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #4 Online: 01 de Janeiro de 2021, 13:57 »
Sim, mas como removi da forma que disse, parece que está atrapalhando em algo. Já instalei o 8 e nada.

Preciso de ajuda.

Offline paulorltenorio

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #5 Online: 01 de Janeiro de 2021, 14:03 »
Acho que você precisa do openjdk-8-jdk para rodar esse gephi.

Se você rodar um sudo apt install openjdk-8-jdk o que acontece?

Veja o que aconteceu:

Código: [Selecionar]
$ sudo apt install openjdk-8-jdk
[sudo] senha para paulo:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
openjdk-8-jdk is already the newest version (8u275-b01-0ubuntu1~20.04).
O seguinte pacote foi instalado automaticamente e já não é necessário:
  libfprint-2-tod1
Utilize 'sudo apt autoremove' para o remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Infelizmente apaguei a pasta /usr/lib/jvm, foi errado, não usei o comando
Código: [Selecionar]
sudo apt remove openjdk-11-jre-headless.
Não sei se este erro que cometi está provocando erro na instalação de novas versões.

Preciso muito usar este programa Gelphi para continuar meu estudo na pós-graduação.

Me ajudem por favor.

Offline paulorltenorio

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #6 Online: 01 de Janeiro de 2021, 15:01 »
Consegui resolver. Usei o seguinte:

Usei a orientação desse site: https://www.edivaldobrito.com.br/instalar-java-no-linux-veja-como-fazer-isso-manualmente/, até o passo 4.

Depois segui a orientação do site: https://translate.google.com/translate?hl=&sl=en&tl=pt&u=https%3A%2F%2Fgithub.com%2Fgephi%2Fgephi%2Fissues%2F1962%23issuecomment-539982080, onde diz:

Eu adicionei jdkhome="/usr/lib/jvm/java-8-openjdk-amd64"em gephi.conf e lançou apenas com ./bin/gephi. (traduzido).

Mas no meu gephi.conf já possuia a linha jdkhome="/usr/lib/jvm/java-8-openjdk-amd64", e mesmo assim a execução ./bin/gephi não funcionava.

Foi então que notei que a pasta /usr/lib/jvm/ o java não está com nome java-8-openjdk-amd64, e sim java-oracle. Então alterei no gephi.conf a linha jdkhome="/usr/lib/jvm/java-8-openjdk-amd64 para jdkhome="/usr/lib/jvm/java-oracle.

Com isto rodou o comando ./gephi.

Foi emocionante resolver e aprender mais o linux. Obrigado para quem tentou me ajudar.

Abraços a todos!

Offline paulorltenorio

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #7 Online: 01 de Janeiro de 2021, 15:07 »
Agora não sei onde coloco que o tópico está resolvido.

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 617
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #8 Online: 01 de Janeiro de 2021, 15:07 »
Ótimo que agora consegue executar o programa que você precisa.  Será que tem que ser o oracle java para funcionar?

Eu estava escrevendo quando você postou. Iria pedir para você as saídas dos comandos:

Código: [Selecionar]
ls -l /usr/lib/jvm
Código: [Selecionar]
dpkg -l openjdk*
Mas como funciona agora, está tudo certo.
« Última modificação: 01 de Janeiro de 2021, 15:15 por Anderson_Coelho »

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 617
    • Ver perfil
Re:Erro na instalação do JAVA
« Resposta #9 Online: 01 de Janeiro de 2021, 15:08 »
Agora não sei onde coloco que o tópico está resolvido.

Edite o título da primeira mensagem colocando um Resolvido.